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WatchGuard XCS Overview

About the WatchGuard XCS
The WatchGuard XCS is the industry’s first consolidated messaging security platform delivering
integrated protection, control, and management for email and web content.

Firewall-level Network and System Security
The WatchGuard XCS delivers the most complete security available for messaging systems. The
system runs on a customized and hardened Unix operating system, and does not allow uncontrolled
access to the system. There is no command line access and the WatchGuard XCS runs as a closed
system, preventing accidental or deliberate misconfiguration by administrators, which is a common
cause of security vulnerabilities.

Message Delivery Security
The WatchGuard XCS content security features provide instant-on data loss prevention, encryption
and content filtering with integrated threat prevention for viruses, spam, spyware, phishing, and
malware attacks, all in a secured appliance. In addition, the WatchGuard XCS protects outbound
content against unintentional or malicious data loss, privacy discrepancies and non-compliance with
regulations and company policies.
The WatchGuard XCS utilizes a sophisticated message delivery system with several security features
and benefits to make sure that the identifying information about your company’s messaging
infrastructure remains private.
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Web Security
The WatchGuard XCS incorporates a Web Proxy that allows the system to proxy web traffic and
control access to external web sites. The system can scan web traffic using many of the same content
scanners that examine email messages to inspect the content of web traffic and downloaded files. The
Web Proxy can also scan encrypted HTTPS traffic and FTP traffic over HTTP using the same
scanners as the HTTP proxy.
Policy features apply specific web access policies to different users, groups, IP addresses, and
domains, and you can customize notifications for blocked connections or files and send them to the
administrator and recipient.
The Web Traffic Accelerator solution provides critical Web traffic enhancements, for example, disk
caching and streaming media support, that reduce bandwidth consumption, server loads, and latency
to improve network performance.
URL Categorization allows or blocks web sites based on a list of blocked web site content categories.
Web Reputation allows you to block web site domains that have a bad reputation for hosting viruses
and malware.

Content Controls
The WatchGuard XCS implements attachment control, content scanning, and content filtering based
on pattern and text matching. The content controls prevent these issues:
n
n
n
n

Breaches of confidentiality
Legal liability from offensive content
Personal abuse of company resources
Breaches of compliance policies

Content Control features include:
n

n

n

n

n

n

n

2

Attachment Control – Blocks message attachments based on their file extension and MIME
content type.
Objectionable Content Filter – Defines a list of key words that cause a message to be
blocked if any of those words appear in the message.
Content Scanning – Message text and document attachments, for example, Adobe® PDFs or
Microsoft® Word documents, are analyzed for words or phrases that match a pattern filter or
compliance dictionary.
Content Rules – Allows you to create customized rule conditions for examining email message
content and perform customized actions based on the search criteria.
Pattern Filters – Create simple rules that can take actions on messages based on text found in
a specific message part.
Document Fingerprinting – Document Fingerprinting scans trusted, outbound email
messages and their attachments, and allows or blocks the delivery of these messages as
required by comparing them to an uploaded training set of allowed and forbidden documents.
Data Loss Prevention Wizard — Guides you through the configuration of DLP rules for
inbound and outbound email and web traffic. You can block credit cards, SSN/SIN numbers, or
use a compliance dictionary to scan for specific words.
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Virus and Spyware Scanning
The WatchGuard XCS features a virus scanning engine based on Kaspersky® Anti-Virus. You can
scan email messages and web requests in both inbound and outbound directions for viruses and
spyware. The high performance scanning provides a vital layer of protection against viruses for your
entire organization. Automatic pattern file updates make sure that the system can detect the latest
viruses and spyware.
McAfee® Anti-Virus is also available as an add-on subscription for customers who want to enable
multi-layered Anti-Virus protection.

Outbreak Control
The Outbreak Control feature provides customers with zero-day protection against early virus
outbreaks. For most virus attacks, it can be several hours from the moment the virus is released to the
time a pattern file is available to protect against the virus. During this period, mail recipients are
vulnerable to potential threats. The Outbreak Control feature detects and takes action against early
virus outbreaks to contain the virus threat.

Malformed Message Protection
Similar to malformed data packets used to subvert networks, malformed messages allow viruses and
other attacks to avoid detection, crash systems, and lock up mail servers. The WatchGuard XCS
makes sure that only correctly formatted messages are allowed into your mail systems. Message
integrity checking protects your mail servers and clients and improves the effectiveness of existing
virus scanning implementations.

Intercept Anti-Spam
The WatchGuard XCS provides a complete set of Anti-Spam features specifically designed to protect
against the full spectrum of current and evolving spam threats. Intercept combines the results of
several Anti-Spam components to provide a better informed decision on whether a message is spam or
legitimate, mail while minimizing false positives. These features include:
n

n

n

n

n

Spam Words – Filters messages based on a dictionary of typical spam words and phrases that
are matched against a message.
Spam Rules – Uses dynamic content rules generated by WatchGuard to help detect new types
of spam messages that are not easily detected by other Intercept Anti-Spam features.
Mail Anomalies – Checks various aspects of the incoming message for issues, for example,
unauthorized SMTP pipelining, missing headers, and mismatched identification fields.
DNS Block List (DNSBL) – Detects spam using domain-based lists of hosts with a bad
reputation. Messages can also be rejected immediately regardless of the results of other AntiSpam processing if the client is listed on a DNSBL. A configurable threshold allows you to
specify how many DNSBLs must trigger to consider the sender as unreliable.
URL Block List – Examines the URLs in a message and queries a SURBL (Spam URI Realtime Block Lists) server to determine if this URL has been used previously in spam messages.

User Guide

3

WatchGuard XCS Overview
n

n

n

n

n

n

Reputation Enabled Defense (RED) – The Reputation Enabled Defense feature helps to
identify spam by reporting a collection of metrics about the sender of a message. This includes
their overall reputation, whether the sender is a dial-up, and whether the sender appears to be
virus-infected, based on information collected from installed customer products and global DNS
Block Lists. This information is used by Intercept to reject the message, or contributes to the
overall Anti-Spam score for the message. Reputation Whitelists allow you to train on messages
from known legitimate sources based on their reputation.
Token Analysis – Detects spam based on advanced content analysis using databases of known
spam and valid mail. This feature is also specially engineered to effectively detect image spam.
Backscatter Detection – Detects spam based on signature verification of the Envelope Sender
to prevent spam bounce emails to forged sender addresses.
Sender Policy Framework (SPF) – Performs a check of a sending host’s SPF DNS records to
identify the source of a message.
DKIM/DomainKeys Authentication – Performs a check of a sending host’s DKIM
(DomainKeys Identified Mail) and DomainKeys DNS records to identify the source of a
message.
Brightmail – Symantec Brightmail™ Anti-Spam is an add-on subscription for customers who
want to enable multi-layered Anti-Spam engines. Brightmail integrates into the overall Intercept
spam score, or you can run Brightmail independently.

Outbound Anti-Spam
Outbound Anti-Spam controls are used to prevent trusted internal users from sending spam outside of
your organization. You can use the Spam Rules, Spam Words, and URL Block List Anti-Spam
features to scan outbound mail for spam messages. The Mail Surge Detection feature identifies
internal mail users who are sending an unusually large amount of mail messages which can indicate
spam activity. Outbound Anti-Spam features are configurable within policies to define actions and
notifications for different users, groups, and domains.

Reputation Enabled Defense (RED)
The Reputation Enabled Defense (RED) feature helps to identify spam by reporting behavioral
information about the sender of a message. This includes their overall reputation, whether the sender is
a dial-up, and whether the sender appears to be virus-infected or sends large amounts of spam
messages, based on information collected from installed customer products and global DNS Block
Lists. Domain and Sender Reputation increases the effectiveness of RED by examining not only the
IP reputation of a sender, but also the domain name and envelope sender information from that IP
address. This information is used by the WatchGuard XCS to reject the message immediately or
contribute to the Intercept score if a message is detected from a source with a bad reputation.
If you enable Reputation checks, the WatchGuard XCS queries the statistics on the RED domain
service for the sender IP address of each message received, excluding those addresses from trusted
and known networks. Web Reputation is also available to block access to web sites that have a bad
reputation for hosting viruses and malware.
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Using the information returned from RED, the WatchGuard XCS makes a decision about whether a
message is spam or legitimate mail. A reputation closer to 0 indicates the sender is extremely reliable
and rarely sends spam or viruses. A reputation closer to 100 indicates the sender is extremely
unreliable and often sends spam or viruses. An IP address with no previous information from any
source is assigned an initial neutral value of 50.

Trusted and Blocked Senders Lists
End users can create their own personal Trusted and Blocked Senders Lists based on a sender’s email
address. The Trusted email addresses are exempt from Anti-Spam scanning, allowing users to trust
legitimate senders, while email addresses on the Blocked Senders List are prevented from sending
mail to that user through this WatchGuard XCS.

Spam Quarantine
The Spam Quarantine redirects spam mail into a local storage area for each individual user. Users can
connect to the WatchGuard XCS directly or through a summary email to view and manage their own
quarantined spam. Users can delete messages, or move them to the user’s local mail folders. You can
send automatic notifications to end users notifying them of the existence of messages in their personal
quarantine area.
The integrated Spam Quarantine feature on the WatchGuard XCS supports a single end-user
notification domain. End users can have multiple email addresses, but the notification system supports
only a single, primary email domain. For large enterprises, a dedicated Quarantine Management Server
(QMS) is available that supports up to 100,000 quarantine users from multiple domains, and supports
clustering for redundancy.

WatchGuard XCS Outlook Add-in
The WatchGuard XCS Outlook Add-in places special Spam and Not Spam buttons on your Microsoft
Outlook client toolbar. This tool allows you to report any spam messages that bypassed the spam
filters and were delivered to their inbox, and also report false positives where legitimate messages
were classified as spam.

Threat Prevention
Threat Prevention allows organizations to detect and block real-time incoming threats. You can monitor
and record threat types to track client IP behavior and reputation. By examining message flow
patterns, the WatchGuard XCS detects whether a sending host is behaving maliciously by sending out
viruses, spam, or attempting denial-of-service (DoS) attacks. By instantly recognizing these types of
patterns, Threat Prevention presents an effective solution against immediate, real-time attacks. The
Threat Prevention feature blocks or throttles inbound connections before the content is processed to
lessen the impact of a large number of inbound messages.
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Secure WebMail
Secure WebMail provides remote access support to internal mail servers. With Secure WebMail, users
can access their mailboxes with email web clients, for example, Outlook® Web Access, Lotus iNotes,
or the WatchGuard XCS web mail client. The WatchGuard XCS addresses the security issues that
prevent deployment of web mail services with these features:
n
n
n

Strong authentication (includes integration with Active Directory)
Encrypted sessions
Advanced session control to prevent information leaks on workstations

Authentication
The WatchGuard XCS supports these authentication methods for administrators, WebMail users,
Trusted/Blocked Senders List, and Spam Quarantine features:
n
n
n

User ID and Password
LDAP
RADIUS

Integrated and External Message Encryption
TheWatchGuard XCSprovides anintegrated messageencryption optionand alsoincludes integration
withexternal encryptionservers toprovide emailencryption anddecryption functionality.Email encryption
allows users toencrypt individualmessages by the integratedencryption serviceor througha separate
encryptionserver beforethe messages are deliveredto theirdestination by the WatchGuardXCS.
Incoming encrypted messages are sent to the encryption server to be decrypted before the
WatchGuard XCS accepts the message and delivers it to the intended recipient. This integration
allows organizations to make sure that encrypted messages are still processed for security issues, for
example, viruses, malformed mail, and content filtering and scanning.

Mail Delivery Encryption
You can encrypt all messages delivered to and from the WatchGuard XCS with TLS (Transport Layer
Security). This includes connections to remote systems, local internal mail systems, or internal mail
clients. Encrypted messages are delivered to local and remote destinations with complete
confidentiality.
Use TLS encryption for:
n

n

n
n
n
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Secure mail delivery on the Internet to prevent anyone from viewing email messages while in
transit
Secure mail delivery across a LAN to prevent malicious users from viewing email messages
other than their own
Create policies for secure mail delivery to branch offices, remote users and business partners
Supports TLS/SSL encryption for all user and administrative sessions.
Use TLS/SSL to encrypt SMTP sessions that prevents eavesdropping and interception
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Policies
Policy-based controls allow settings for the WatchGuard XCS security features, for example,
Annotations, Anti-Spam, Anti-Virus, and Attachment Control, to be customized and applied based on
the group membership, domain membership, IP address, or email address of the recipient.
You can import user group membership information from an LDAP-based directory, and then create
policies to apply customized settings to these groups. For example, you can set up an Attachment
Control Policy to allow your Development group to accept and send executable files (.exe). You can
then customize your Attachment Control settings for all your other departments to block this file type
and prevent the spread of viruses among the general users.
In addition, you can add an effective time period to apply to any policy, based on the current time and
day of the week.

Directory Services
The WatchGuard XCS integrates with LDAP (Lightweight Directory Access Protocol) directory
services, for example, Active Directory, OpenLDAP, and iPlanet, to utilize these features:
n

n

n

n
n

LDAP lookup prior to internal delivery – The WatchGuard XCS can check for the existence
of an internal user through LDAP before delivering a message. This feature allows you to reject
mail to unknown addresses in relay domains, reducing the number of attempted deliveries of
spam messages for non-existent local addresses. This check is performed directly to an LDAP
server or to a cached directory stored locally on the system.
Group/User Imports – An LDAP lookup determines the group membership of a user when
applying policy-based controls. You can also import LDAP users and mirror their accounts on
the WatchGuard XCS to use for features like the User Spam Quarantine.
Authentication – You can use LDAP for authenticating Web Proxy access, IMAP access, user
mailbox, and WebMail logins.
SMTP Relay Authentication – You can use LDAP for authenticating clients for SMTP Relay.
Mail Routing – You can use LDAP to lookup mail route information for a domain to deliver mail
to its destination server.

System Management
The WatchGuard XCS provides a complete range of monitoring and diagnostics tools to monitor the
system and troubleshoot mail delivery issues. Admin sessions are encrypted for additional security,
while comprehensive logs record all message and admin activity.
n

n

Web Browser-based management – The web browser management interface displays a live
view of system activity and traffic flows. You can configure the management interface to
display information for a single system or many systems in a local cluster or in a centralized
management configuration.
Frequent Tasks — Appears as the default page when you log in to the WatchGuard XCS and
provides direct links to the most frequent tasks you can perform to configure and manage the
WatchGuard XCS.
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n

n

n

n

Dashboard – The WatchGuard XCS system Dashboard provides administrators with a brief
statistical and graphical summary of current inbound and outbound email and web activity. This
allows rapid assessment of the current status of the WatchGuard XCS.
Enterprise integration with SNMP – With SNMP (Simple Network Management Protocol),
the system can generate both information and traps to be used by SNMP monitoring tools. This
extends your view of the WatchGuard XCS and provides you with notification of significant
system events, for example, excessive traffic flows and system failures.
Alarms – The system generates system alarms that automatically notify you through email and
Dashboard alerts of a system condition that requires attention.
Archiving – Archiving support allows organizations to define additional mail handling controls
for inbound and outbound mail. These features are especially important for organizations that
must archive certain types of mail for regulatory compliance or for corporate security policies.

Clustering
The WatchGuard XCS clustering feature provides a highly scalable, redundant messaging security
infrastructure that enables two or more XCS devices to act as a single logical unit for processing
messages while providing redundancy and high availability benefits. There is no theoretical limit to the
size of the cluster, and you can easily add devices to the cluster to increase processing and highavailability capabilities. Clustering makes sure that the flow of traffic is not interrupted due to individual
system failures. You can manage a cluster from any single device in the cluster without the need for a
separate management console, and all devices in the cluster can process messages. Any
configuration changes, for example, Anti-Spam and Policies, are propagated to all devices in the
cluster.

Reports
WatchGuard XCS reports provide a comprehensive range of detailed reporting information that can be
generated in PDF (Adobe Portable Document Format), CSV, and HTML format on demand and at
scheduled times. The reports are derived from information written to the systems and message logs
that are stored in the message database. Up to a month's reporting data can be stored and viewed
online depending on message loads for a particular environment. Reports are stored on the system for
online viewing, and can also be emailed automatically to the administrator.
In clustered environments, reports aggregate information for the entire cluster. System and resource
reports display information for each system in the cluster.
For organizations that support multiple domains, you can add per domain information to the reports
providing you with statistics for each hosted domain. You can also enable Hosted domain reports that
create separate reports for a specific domain and can be emailed to the administrators of each hosted
domain.

Security Connection
The Security Connection provides an automated software update service that polls WatchGuard’s
support servers for new updates, security alerts, and Anti-Spam database updates. You can be notified
when new software updates are available for installation.

8
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Internationalization
The WatchGuard XCS supports internationalization for annotations, notification messages, and
message database views. For example, if a message is sent to someone who is on vacation and the
message used character set ISO-2022-JP (Japanese), the vacation notification sent back is in the
same character set.
You can view the message history database (such as the message history, message details, logs and
reports), with international character sets.
The WatchGuard XCS supports the ISO-8859-1 (Western European Languages) character set and
non-Western international character sets for dictionary-based content filtering with the Content
Scanning, Objectionable Content Filter, and Spam Words features. For more detailed information on
supported character sets, see Dictionaries.

About IPv6 Support
The WatchGuard XCS supports the IPv6 protocol. You can assign an IPv6 address to any network
interface, and most XCS features support the use of IPv6 addresses in their configuration.
n
n
n

n

Static IPv6 addresses can be assigned to a network interface.
IPv6 static routes can be configured.
The WatchGuard XCS supports Dual Stack Mode where network interfaces can have both IPv4
and IPv6 addresses and both IPv4 and IPv6 connections can be made simultaneously. By
default, IPv6 connections are used in preference over IPv4. You can modify this behavior in the
advanced network settings.
At least one interface must be designated as IPv4 or IPv4 and IPV6 interface mode.

IPv6 Support Notes
n
n
n
n

Auto-configuration of IPv6 addresses from compatible IPv6 routers is not supported.
Cluster IP configuration is local to the cluster network, and uses only IPv4.
IPv6 configuration is not available on the system console.
IPv6 to IPv4 tunneling is not supported.

These XCS features and third-party services currently do not support IPv6:
n
n
n
n
n
n
n

Anti-virus software pattern updates
Brightmail Anti-Spam updates
Communications with the SecureMail email encryption server
URL Categorization IP address checking
Threat Prevention static lists and push to an F5 device
Web Proxy Single Sign-on Agent
WatchGuard Security Connection for XCS software updates
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WatchGuard XCSv
The WatchGuard XCSv is a version of the WatchGuard XCS security appliance that runs as a virtual
machine on a VMware or Microsoft Hyper-V host. You can use the WatchGuard XCS web admin UI to
manage an XCSv device, just as you manage any other WatchGuard XCS device.

XCSv Licensing
XCSv devices are licensed in several different editions that provide different levels of scalability and
performance:
n
n
n
n

Small Office Edition
Medium Office Edition
Large Office Edition
Large Office XC Edition

When you activate your XCSv device, you receive a feature key that enables the WatchGuard XCS
capabilities for the XCSv edition you have licensed. You can upgrade from one XCSv edition to
another.

Installation Prerequisites for VMware
You must install the XCSv virtual device in a VMware environment that meets these requirements.
VMware
n

n

n

To install an XCSv virtual device, you must have a VMware vSphere/ESXi v4.1 Update 2 (or
later version) host installed on any supported server hardware. Make sure your vSphere/ESXi
software is updated to the latest patch level.
You must also install the VMware vSphere Client 4.1 (or later version) on a supported Windows
computer.
VMware Tools is installed by default with the XCSv virtual device. VMware Tools is a suite of
utilities that enhances and improves the performance and management of the virtual machine,
and includes the ability to cleanly power off or reset the guest operating system software from
the host system.

Hardware
n

n

n
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The hardware requirements for XCSv are the same as the hardware requirements for VMware
vSphere/ESXi.
For information about VMware hardware compatibility, see the VMware Compatibility Guide at:
http://www.vmware.com/resources/compatibility/search.php
WatchGuard XCSv requires that your host hardware supports Intel Virtualization Technology
(Intel VT) or AMD Virtualization (AMD-V) and has these options enabled in the host system BIOS.
n For more information about Intel VT compatibility, see the Intel Virtualization Technology
List at: http://ark.intel.com/VTList.aspx
n AMD-V is supported in all K8 AMD (Athlon 64) processors from revision F, and all newer
processors support AMD-V technology.
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Installation Prerequisites for Microsoft Hyper-V
You must install the XCSv virtual device in a Hyper-V environment that meets these requirements.
Hyper-V
n

n
n

Hyper-V role on Windows Server 2008 R2 or Windows Server 2012, or stand-alone version of
Hyper-V Server 2008 R2 or Hyper-V Server 2012.
Make sure your Windows Server or Hyper-V Server software is updated to the latest patch level.
You can use the Hyper-V Manager on Windows Server 2012 to deploy, configure , and provision
the XCSv virtual machine in the Hyper-V environment. You can also use System Center Virtual
Machine Manager (VMM) interface, or a Hyper-V role on a client computer instead of Hyper-V
Manager.

Hardware
n

The hardware requirements for XCSv are the same as the hardware requirements for Hyper-V
on Windows Server 2008 R2 or Windows Server 2012.

Network
n

You can configure a maximum of 8 interfaces.

XCSv Device Installation Overview
For VMware, WatchGuard distributes XCSv as an OVF template file. To complete initial installation on
VMware, you must perform these procedures:
1. In the VMware vSphere client, deploy the XCSv OVF template file to the VMware host.
2. Perform any resource allocation (CPU, memory, disk) modifications on the VMware host based
on your XCSv edition.
3. Power on the XCSv virtual machine.
4. Connect to the XCSv device to run the Setup Wizard.
For Hyper-V, WatchGuard distributes XCSv as a virtual hard disk (.vhd) file. To deploy an XCSv virtual
hard disk in a Hyper-V environment:
1. In Hyper-V, create your virtual machine for the XCSv software.
2. Perform any resource allocation (Processors, memory, disk, network) modifications on the
Hyper-V host based on your XCSv edition.
3. Power on the XCSv virtual machine.
4. Connect to the XCSv virtual machine to run the Setup Wizard.
For detailed steps to set up an XCSv device, see the WatchGuard XCSv Setup Guide available at
http://www.watchguard.com/help/documentation.

Features Not Supported with WatchGuard XCSv
These features are not supported for use with WatchGuard XCSv:
General
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n
n

Network storage disks for the virtual host.
XCSv console options:
n Serial console — This feature is redundant with the physical host system serial console.
n UPS configuration — UPS communications must be configured on the physical host
system.

VMware
n
n

vMotion for virtual device migration between VMware hosts.
You cannot set the SMBIOS.reflectHost setting in VMware. This interferes with product
identification and licensing.

Hyper-V
n
n
n
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XCSv does not support the dynamic memory setting on Hyper-V.
The Data Exchange and Volume Backup features are not supported.
Time synchronization is not supported. We recommend you use an NTP server in the XCSv
network configuration.
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WatchGuard XCS Deployments
The WatchGuard XCS is designed to be situated between internal email servers and clients, and
external servers on the Internet so that there are no direct connections between external and internal
systems.
The WatchGuard XCS is installed in one of these locations:
n
n
n

On the DMZ (Demilitarized Zone) of a network firewall
In parallel with a network firewall
Behind the existing firewall on the internal network

Messaging traffic is redirected from either the external interface of the network firewall or from the
external router to the WatchGuard XCS. When the WatchGuard XCS accepts and processes a
message, the device initiates a connection to the internal mail servers to deliver the messages.

WatchGuard XCS on the DMZ of a Network Firewall
The most common deployment strategy for the WatchGuard XCS is to be situated on the DMZ of a
network firewall. This type of deployment prevents any direct connections from the Internet to the
internal mail servers, and makes sure the WatchGuard XCS is located on a secure network behind the
firewall.
This deployment uses a single network interface connected to the DMZ network of the network
firewall.
The Installation Wizard helps you install the WatchGuard XCS in this deployment configuration.
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WatchGuard XCS in Parallel with a Network Firewall
You can deploy the WatchGuard XCS in parallel with an existing network firewall. The device’s firewall
security architecture eliminates the risk associated with deploying an appliance on the perimeter of a
network. This parallel deployment eliminates any messaging traffic on the network firewall and
decreases its overall processing load.
A second network interface must be configured to connect to the Internet-facing network.
Note This deployment is not recommended for WatchGuard XCSv devices installed on a
virtual host machine.

14
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WatchGuard XCS on the Internal Network
The WatchGuard XCS can also be deployed on the internal network. Although this configuration allows
a direct connection from the Internet to the internal network, it is a legitimate configuration when
required by existing network resources.
This deployment uses a single network interface connected to the DMZ network of the network
firewall.
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Web Deployments
You can install the Web Proxy in these types of deployments:

Full Proxy Parallel Deployment
You can deploy the Web Proxy in parallel with an existing network firewall using two network
interfaces.
In this configuration, you must manually configure web clients to use the WatchGuard XCS as the web
proxy. You can also use proxy auto-discovery methods to automatically configure the client with the
address of the XCS device. The network firewall must block HTTP traffic (for example, TCP port 80) to
prevent circumvention of the proxy by network clients.
We recommend this configuration as the primary Web Proxy deployment model.

Advantages
n

n
n
n
n

Requires no additional performance overhead on the Web Proxy because it only processes web
traffic.
Simple to deploy and troubleshoot connection issues.
Appliance is located securely outside of the internal network.
Appliance can be clustered with another WatchGuard XCS that processes web or email.
Automated failover with no network downtime.

Disadvantages
n

Must set up proxy auto-discovery using PAC Files or WPAD to point to the WatchGuard XCS.

Internal Network Deployment
You can deploy the Web Proxy on the internal network connected with one network interface. The
network firewall must block HTTP traffic (for example, TCP port 80) to prevent circumvention of the
proxy by network clients. HTTP port access must be allowed for the Web Proxy only.
You must manually configure web clients to use the WatchGuard XCS as their web proxy. You can
also use proxy auto-discovery to automatically assign the web proxy address.

16
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Advantages
n
n

Requires no additional performance overhead on the system.
Simple to deploy and troubleshoot connection issues.

Disadvantages
n

Must set up proxy auto-discovery using PAC Files or WPAD to point to the WatchGuard XCS.

Transparent Mode Deployment
The Web Proxy offers a Transparent Mode deployment option to integrate the system into existing
environments with minimal network reconfiguration. This method requires no network reconfiguration
and the implementation is transparent to clients.
In a typical Transparent Mode implementation, the Web Proxy system is installed between the primary
internal switch or router and an existing network firewall to act as a bridge for all non-local traffic,
except selected web traffic that is examined by the Web Proxy. The system listens for web traffic on
TCP port 80 and any specific HTTP requests are processed by the Web Proxy for security threat
processing and content filtering before it allows the request through.
Note When Transparent Mode is enabled, the HTTP Proxy port must use TCP port 80.
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You must specify two network interfaces for bridging, and the single IP address that is shared for the
bridge. One of these interfaces (Bridge In) connects to the primary internal router or switch (LAN side),
and the other interface (Bridge Out) connects to the network firewall.
Traffic that is bridged through the Web Proxy is not examined or modified. Traffic examined by the Web
Proxy is modified to appear to originate from the local IP address of the Web Proxy. With this method,
returning traffic is recognized and correctly processed for security threats and content filtering.

Advantages
n

Offers a simple and seamless deployment. No network or client system reconfiguration is
required.

Disadvantages
n

n

n
n
n

n

All network traffic is sent through the Web Proxy, which may not be preferable depending on the
network environment.
Packet inspection is performed on all traffic to determine if data should be proxied or bridged,
which can add additional performance overhead on the Web Proxy.
The default port for HTTP traffic (TCP port 80) cannot be modified in Transparent Mode.
Only IP-based Proxy or Portal authentication can be used in Transparent Mode.
Clustering with other Web Proxy systems is not supported in Transparent Mode. A Web Proxy
that runs in Transparent Mode can be clustered with a non-Web Proxy system, for example, a
WatchGuard XCS system that process email.
If the system fails, all network traffic is stopped.

This diagram illustrates the most basic Transparent Mode implementation in which the Web Proxy is
installed between the primary internal router and the network firewall.
n

n

n

n
n
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The NIC 1 interface is designated the Bridge In interface and connects to the LAN side internal
router. This interface must have an IP address assigned and have HTTP/HTTPS Proxy access
enabled. This interface IP address is the address for the entire bridge.
The NIC 2 interface is designated the Bridge Out interface and connects to the network firewall.
This interface does not require any IP address configuration, and is automatically configured for
use with the bridge.
The NIC 3 interface is designated for administrative access to secure access to the system and
prevent administrative access through the bridge interfaces. The Bridge In interface can be
used for administrative access if required.
The network gateway for the Web Proxy is the address of the network firewall.
You must create static routes on the Web Proxy that point to your internal router networks. This
is required as the web traffic uses the IP addresses on the bridge interfaces when it proxies
traffic. The interface requires the network addresses to be able to route the traffic back to the
internal subnetworks.
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How Messages are Processed
These sections describe the sequence in which the WatchGuard XCS security features are applied to
any inbound and outbound messages and how these settings affect their delivery.

Trusted Messages
The system only processes messages through the spam filters when a message originates from an
untrusted source. Messages from trusted sources bypass the spam controls. By default, messages
that arrive on a particular network interface from the same subnet are trusted.
There are two ways to control how message sources are identified and trusted:
n
n

The network interface the message arrives on
A specified IP address (or address block), or server or domain name

See Trusted and Untrusted Mail Sources for information on how the WatchGuard XCS determines the
source of a message.

Inbound and Outbound Scanning
For features that scan both inbound and outbound messages, these rules apply:
n
n
n
n

Mail from trusted source to local recipient – Inbound
Mail from trusted source to non-local recipient – Outbound
Mail from untrusted source to local recipient – Inbound
Mail from untrusted source to non-local recipient – Inbound

SMTP Connection
An SMTP connection request is issued from a sending server. The WatchGuard XCS accepts the
connection request unless one of these checks (if enabled) triggers:
n

n

n

n
n

n

n
n

20

Reject on Threat Prevention – Rejects mail when the client is rejected by the Threat
Prevention feature.
Reject on missing addresses – Rejects mail when no recipients in the To: field, or no senders
in the From: field are specified in the message headers.
Maximum number of recipients – Rejects mail if the number of recipients exceeds the
specified maximum (default is 1000).
Maximum message size – Rejects mail if the message size exceeds the maximum.
Reject on unauthorized SMTP pipelining – Rejects mail when the client sends SMTP
commands ahead of time without knowing that the mail server actually supports SMTP
command pipelining. This stops messages from bulk mail software that improperly use SMTP
command pipelining to speed up deliveries.
Specific Access Pattern and Pattern Based Message Filter (Reject) – Rejects mail based
on Specific Access Patterns and Pattern Filters for the HELO, Envelope-To, Envelope-From,
and Client IP fields.
Connection Rules Reject – Rejects mail based on any configured Connection Rules.
Reject on DNS Block list – Rejects mail if the sender is on a DNSBL and the system is set to
reject on DNSBL.
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n

Reject on Reputation Enabled Defense (Reputation, Infected, Dial-up) – Rejects mail
based on statistics provided by the Reputation Enabled Defense service.
Note To make sure a trusted client is not rejected by DNS Block Lists or Reputation
checks, add a Specific Access Pattern to "Trust" messages from that client.
You can also use Pattern Filters set to "Bypass" (also bypasses Anti-Spam and
content checks), "Trust" (also accepts and trains as valid mail) or "Accept" (just
accept without training) the message, however, this may interfere with later message
processing and using Specific Access Patterns is recommended.

At this point, trusted or local networks skip any further Reject checks.
n

n

n

n

n

n

Reject on Backscatter Detection – Rejects mail when the message fails the Backscatter
signature verification.
Reject on unknown sender domain – Rejects mail when the sender mail address has no
DNS A or MX record.
Reject on missing reverse DNS – Rejects mail from hosts if the host IP address has no PTR
(address to name) record in DNS, or when the PTR record does not have a matching A (name to
address) record. This setting is rarely used because many servers on the Internet do not have
valid reverse DNS records, and enabling this feature can result in rejecting mail from legitimate
sources.
Reject on missing sender MX – Rejects mail when the sender’s mail address is missing a
DNS MX record.
Reject on non-FQDN sender – Rejects mail when the address in the client MAIL FROM
command is not in the form of a fully-qualified domain name (FQDN).
Reject on Unknown Recipient (Recipient Verification) – Rejects mail if the specified
recipient does not exist. The WatchGuard XCS can perform recipient verification through an
LDAP lookup for the recipient address, or by an SMTP probe to the mail server.

Virus and Spyware Checking
Messages are scanned for viruses and spyware. If there is a virus or spyware program detected, the
system can perform a variety of actions, for example, reject or quarantine.

Malformed Message Checking
The WatchGuard XCS analyzes each message with extensive integrity checks. Malformed messages
(which could be hidden viruses or attempts at a denial-of-service attack) can be quarantined, rejected,
or discarded if they cannot be processed.

Attachment Size Limits
The size of all attachments are checked to make sure they do not exceed the attachment size limit
threshold.
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Attachment Control
Message attachments are scanned for blocked content. If there is a problem, the system can perform a
variety of actions, for example, sending the message to the quarantine area. Attachments can also be
stripped, and then the message continues other security processing.

Outbreak Control
Messages are scanned by Outbreak Control to look for virus-like behavior. These messages can be
quarantined until updated anti-virus pattern files are available to rescan them.
If Malformed Mail or the Attachment Control feature rejects or discards a message, the Outbreak
Control feature takes precedence, and the Malformed or Attachment Control action is applied when the
message is released by Outbreak Control.

OCF (Objectionable Content Filter)
Messages are scanned for objectionable content with a pre-defined dictionary of words. A configurable
action is performed on the message if any content matches words or phrases in the dictionary.

Pattern Filters and Specific Access Patterns
The messages are scanned to see if they match any existing Pattern Filters and Specific Access
Patterns set to Trust or Allow Relaying.

Trusted and Blocked Senders List
If a sender is on a user’s Trusted Senders List, the message skips all remaining checks. If the sender
is on a user’s Blocked Senders List, the message is rejected or discarded.

Content Scanning
Deep scanning is performed on message content and attachments (for example, Microsoft Word or
Adobe PDF files) to check for blocked words and phrases.

Document Fingerprinting
Messages are checked by the Document Fingerprinting feature to examine message attachments
against an uploaded training set of allowed and forbidden documents.

Content Rules
If enabled, any defined Content Rules (including any defined Spam Rules) are applied to the message.

Encryption
If enabled, outbound messages are encrypted before being delivered.
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Anti-Spam Processing
If the message arrives from an untrusted source, it is processed for spam by the Intercept Anti-Spam
engine. All Intercept components that are enabled contribute to the final spam score of a message.

Mail Mappings
The message is accepted for processing and these actions occur:
n

n

If the recipient address is not for a domain or sub-domain for which the system is configured to
accept mail (either as an inbound mail route or a virtual domain), then the message is rejected.
If the recipient address is mapped in the Mail Mappings table, then the To: field in the message
header is modified as required.

Virtual Mappings
The message is examined for a match in the Virtual Mapping table. If a mapping is found, the envelopeheader recipient field is modified as required. LDAP virtual mappings is then processed. Virtual
mappings are useful for these situations:
Acting as a wildcard mail mapping. For example, any message for a user at example.com goes to
exchange.example.com. You can create exceptions to this rule in the mail mappings for particular users.
ISPs that need to accept mail for several domains and the envelope-header recipient field needs to be
rewritten for further delivery.
To deliver to internal servers, define a mail route in Configuration > Mail > Routing.

Relocated Users
When mail is sent to an address that is listed in the relocated user table, the message is bounced back
with a message informing the sender of the relocated user’s new contact information.

Mail Aliases
When mail needs to be delivered locally, the local delivery agent runs each local recipient name
through the aliases database. An alias results in the creation of a new mail message for the named
address or addresses. This mail message is then processed again by the system to be mapped and
routed. This process also occurs with local user accounts that have a forwarder address configured.
Local user accounts are treated like aliases in this case.
Local aliases are typically used to implement distribution lists or to direct mail for standard aliases, for
example, mail directed to the postmaster account. LDAP aliases are then processed. LDAP
functionality can be used to search for mail aliases on directory services, for example, Active
Directory.

Mail Routing
During the mail routing process, there is no modification made to the mail header or the envelope.
A mail route specifies this information:
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n
n

The email domains for which the WatchGuard XCS accepts mail (other than itself)
The hosts to which to deliver the mail

Message Delivery
The message has passed all security and content processing, and is delivered to its destination.

Message Processing Order Summary
This list summarizes the full order in which incoming messages are processed by the WatchGuard XCS:

SMTP Connection Checks
n
n
n
n
n
n
n
n
n
n

Reject on Threat Prevention
Reject on missing addresses
Reject if number of recipients exceeds maximum
Reject if message size exceeds maximum
Reject on unauth SMTP pipelining
Reject on Specific Access Pattern and Pattern Filter HELO
Reject on Specific Access Pattern and Pattern Filter Envelope-To
Reject on Specific Access Pattern and Pattern Filter Envelope-From
Reject on Specific Access Pattern and Pattern Filter Client IP
Connection Rules
Note Specific Access Pattern "Trust" and Pattern Filters set to "Bypass", "Trust", or
"Accept" can be used to skip DNSBL and Reputation connection rejects.

n
n
n
n

Reject on DNS Block List (DNSBL)
Reject on Reputation Enabled Defense reputation
Reject on Reputation Enabled Defense infected
Reject on Reputation Enabled Defense dial-up

At this point, local and trusted networks (this includes Specific Access Pattern Trust), skip any
remaining Reject checks.
n
n
n
n
n
n

Reject on Backscatter Detection
Reject on unknown sender domain
Reject on missing reverse DNS
Reject on missing sender MX
Reject on non-FQDN sender
Reject on unknown recipient (Recipient verification)

Message Checks
n
n
n
n
n
n
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Very Malformed
Anti-Virus
Spyware detection
Pattern Filter Bypass (This action skips remaining checks)
Attachment Size Limits
Malformed messages
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n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n

Attachment Control (Block)
Attachment Control (Strip: message continues to be processed for other checks)
Outbreak Control
Objectionable Content Filtering
Pattern Filter (High priority)
Pattern Filter (Medium priority)
Trusted Senders List (Skips remaining checks)
Blocked Senders List
Pattern Filter (Low priority)
Content Scanning
Document Fingerprinting
Content Rules / Spam Rules
Specific Access Patterns (Trusted bypasses Anti-Spam and allows mail relay)
Message Encryption (Trusted Only)
Trusted Network (Skips remaining checks)
Brightmail (Only if the Brightmail mode is set to “Perform Brightmail Actions”.

Intercept Anti-Spam Processing
n
n
n
n
n
n
n
n
n
n
n

SPF (Sender Policy Framework)
DKIM/DomainKeys
DNS Block Lists
Mail Anomalies
Spam Words
Reputation Enabled Defense Reputation
Reputation Enabled Defense Dial-up
Token Analysis
Backscatter Detection
Brightmail (if configured to integrate with Intercept)
URL Block Lists

Message Mappings and Routing
n
n
n
n
n
n

Mail Mappings
Virtual Mappings
Relocated Users
Mail Aliases
Mail Routing
Message delivery to its final destination
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Before You Begin
Before you begin the installation process, make sure you do the tasks described in the subsequent
sections.

Verify Basic Components
Make sure that you have:
n
n
n
n

A computer with an Ethernet network interface card and a web browser installed
A WatchGuard XCS device or XCSv virtual host system
Ethernet cables
Power cables

You can also attach an optional monitor and keyboard (USB or PS/2) to get access to the WatchGuard
XCS console.

Hardware Installation
For detailed instructions on how to install the WatchGuard XCS device in an equipment rack, see the
Hardware Guide. For the XCSv, see the XCSv Setup Guide for detailed information on hardware
requirements and how to set up your virtual host system.

Physical Location
To safely install your WatchGuard XCS device or XCSv virtual host system, we recommend you
select a physical location that meets these specifications:
n

Install the device in a secure location, for example, in a locked equipment rack or a secure
server room.
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n

n

n

Make sure that the network connections are secure, and the network hubs and switches are in
the same secure location. Any network patch cables should be of the appropriate length (as
short as possible).
If a monitor and keyboard are attached to the device for console use, make sure that keystroke
logging devices cannot be added to the keyboard connection. Connect the monitor and
keyboard directly to the device.
Use the Web UI only in a secure location at a trusted workstation. Do not use the Web UI in any
location where the administrative session can be monitored physically or electronically.

Connect the Network Interfaces
Before installation, make sure that you physically connect at least one of the network interfaces to the
network.
When you install your device, we recommend you use the first onboard Ethernet network interface at
the left of the device (NIC 1) to connect to your network. This is the first default interface assigned by
the WatchGuard XCS. After you complete the installation, you can configure additional network
interfaces.
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Get a Feature Key from LiveSecurity
A feature key is a license that enables you to activate your purchased feature set on your WatchGuard
XCS. You must register the device serial number on the WatchGuard LiveSecurity web site and
retrieve your feature key before adding it to the WatchGuard XCS.To retrieve a feature key from the
LiveSecurity web site:
Note Make sure you can access the Internet if the device is installed behind a network
firewall, or connects through an external proxy server.
1. Open a web browser and go to https://www.watchguard.com/activate.
2. If you have not already logged in to LiveSecurity.
The LiveSecurity Log In page appears.

3. Enter your LiveSecurity user name and password.
The Activate Products page appears.

4. Enter the serial number for the product as it appears on your hardware device, including the
hyphens.
5. Click Continue.
The Choose Product to Upgrade page appears.

6. In the drop-down list, select the WatchGuard XCS device.
7. Click Activate.
The Retrieve Feature Key page appears.

8. Copy the full feature key to a text file and save it on your computer.
9. Click Finish.

Gather Network Addresses
Before you start the installation, make sure you have this information about your network:
Hostname
The hostname assigned to the WatchGuard XCS. For example, if the FQDN (Fully Qualified
Domain Name) is hostname.example.com, use hostname .
Domain Name
The domain name associated with the assigned hostname. This is the domain to which
messages are sent. For example, example.com .
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Internal IP Address
Select an IP address for the internal network interface. You use this address to connect
remotely to the XCS device with a web browser.
External IP Address
Select an IP address for the external network interface (if required). This is the external interface
that connects to a public network, such as the Internet.
Subnet Mask
The subnet mask for the IP addresses you selected.
Gateway Address
The default gateway for the XCS device. This is usually your network router.
Mail Domains
The mail domains for which the WatchGuard XCS processes messages.
Optional Network Cards
The IP address, Subnet Mask, and Gateway Address for any additional network cards required
by your deployment.
DNS Servers
The addresses of your DNS (Domain Name Service) name servers. We recommend that you
include both a primary and a secondary server.
NTP Servers
The addresses of your NTP (Network Time Protocol) servers for time synchronization. We
recommend that you include both a primary and a secondary server.
Table 1: Basic Network Settings

Example

Hostname

hostname
_____________________

Domain Name

example.com
_____________________

Internal IP Address

10.0.0.1
_____._____._____._____

Subnet Mask

255.255.255.0
_____._____._____._____

External IP Address

100.100.100.10
_____._____._____._____

Subnet Mask
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Table 1: Basic Network Settings

Example

_____._____._____._____
Gateway Address

10.0.0.2
_____._____._____._____

_____________________
example.com
Mail Domains
_____________________

example1.com

_____________________

_____._____._____._____
10.0.2.25
Internal Mail Servers
_____._____._____._____

10.0.3.25

_____._____._____._____

_____._____._____._____
Optional Network Cards

10.0.5.10
_____._____._____._____

_____._____._____._____

10.0.2.53

DNS Servers
10.0.3.53
_____._____._____._____

_____._____._____._____

10.0.2.123

NTP Servers
10.0.3.123
_____._____._____._____
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DNS Configuration for Mail Routing
DNS services are used to route mail messages from the Internet to the WatchGuard XCS. DNS
configurations can be complex and are dependant on your specific networking environment.
These instructions represent the minimum changes required to facilitate mail routing.
Add an MX (mail exchanger) record to your DNS configuration to forward incoming messages to the
WatchGuard XCS:
example.com. IN MX 0 hostname.example.com

Add an A record to resolve the domain name to an IP address:
hostname.example.com. IN A 10.0.0.1

Add a PTR record to allow reverse look-ups to succeed and prevent messages sent from the
WatchGuard XCS from being marked as suspected spam:
1.0.0.10.in-addr.arpa. IN PTR hostname.example.com

Consider keeping an MX record with a higher preference pointed at your current mail server during the
integration phase. If the WatchGuard XCS is taken out of service, the messages automatically routes
directly to the mail server. This entry should be deleted before you move to a production environment
because spammers could find this alternate route and bypass the WatchGuard XCS.
example.com. IN MX 10 mailserver.example.com
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Network Firewall Configuration
To enable the WatchGuard XCS to effectively process messages when it is located behind a network
firewall, you must correctly configure the network ports on your network firewall.
This table describes the ports required for each feature. If you do not use a feature in the table, you do
not have to open the port for that feature:
From
From
To
Internal
Internet Internet
Network

To
Internal
Network

Protocol

Port

Description

21

FTP for System Backups

X

TCP

22

SCP (Backup or Offload)

X

TCP

25

SMTP (standard port for sending
and receiving of mail)

X

TCP

53

DNS and RED Queries

X

X

TCP/UDP

80

Anti-Virus Updates (also requires
port 443)

X

TCP

80

URL Categorization Updates

X

TCP

80

Web Mail Access (OWA, iNotes,
etc.) See port 443 for Secure
WebMail access.

X

X

TCP

110

POP3

X

X

TCP

123

Network Time Protocol (NTP)

143

IMAP Proxy

161

SNMP

162

SNMP trap

X

UDP

389

LDAP

X

TCP

443

Software Updates

X

TCP

443

Anti-Virus Updates (also requires
port 80)

X

TCP

443

Secure Web Mail Access

X

X

TCP

443

Web UI connections

X

X

TCP

443

SecureMail Email Encryption

X

TCP

443

RED Statistics Sharing

X

TCP

443

Brightmail updates

X

TCP
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X
X

X

UDP

X

TCP

X

UDP
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To
Internal
Network

Protocol

Syslog

X

UDP

636

LDAPS

X

TCP

993

Secure IMAP

X

X

TCP

995

Secure POP3

X

X

TCP

1812

RADIUS Server

X

UDP

5500

RSA Secure ID ACE Server

X

UDP

Port

Description

514

10101 Support Access

X

X

10106 Centralized Management

X

X

10108 Web Reputation
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Modify Mail Servers for Outbound Mail Routing
Changes are required to your existing mail servers to route outbound mail through the WatchGuard
XCS. You must configure your mail servers to use the hostname or IP address of the XCS device for
SMTP delivery of outbound mail. The procedure depends on the type of mail server you use. See the
instructions for your specific mail server to route outgoing mail through the WatchGuard XCS.
The instructions below are for a Microsoft® Exchange mail server.

Exchange 2000 and 2003
To add the WatchGuard XCS to the outbound configuration on an Exchange 2000 or Exchange 2003
server:
1.
2.
3.
4.
5.

Open Exchange System Manager.
Select Connectors.
Go to the Internet Mail SMTP Connector.
Select the Forward all mail through this connector to the following smart hosts: option.
Type the IP address of your WatchGuard XCS system in square brackets.
For example, [10.0.1.25]
To add multiple systems, separate them with commas.
For example, [10.0.1.25],[10.0.2.25]

6. Click OK.

Multiple Exchange Server Configuration
In an environment with multiple Microsoft Exchange servers (not in a clustered configuration), you
must configure each system to route outbound mail through the WatchGuard XCS. This can be
performed on a per-server basis with the SMTP connector configuration on each server.
To provide a more efficient configuration, add an SMTP Connector to the Exchange Routing Groups
configuration instead of the Servers configuration item. The Routing Group configuration applies to all
your Exchange servers.
To configure the SMTP Connector in a routing group of Exchange servers:
1.
2.
3.
4.
5.
6.

Open the Exchange System Manager.
Select Routing Groups.
Select the First Routing Group.
Select Add.
Select SMTP Connector.
Type a name for the SMTP Connector.
For example, XCSConnector .

7. Select the Forward all mail through this connector to the following smart hosts: option.
8. Type the IP address of your WatchGuard XCS system in square brackets.
For example, [10.0.1.25]
To add multiple systems, separate them with commas.
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For example, [10.0.1.25],[10.0.2.25]
9. In the Local bridgeheads section, click Add.
10. Add each Exchange server that must send mail through the WatchGuard XCS to the list.
Make sure you add all servers and not just the primary Bridgehead server.

11. Select the Address Space configuration tab.
12. Use the default values of Type: SMTP, Address: *, and Cost: 1.
13. Click OK.

Exchange 2007 and 2010
To add the WatchGuard XCS to the outbound configuration on an Exchange 2007 or Exchange 2010
server:
1.
2.
3.
4.
5.
6.
7.
8.
9.
10.

Open the Exchange Management Console.
Expand the Organization Configuration option.
Select Hub Transport.
Select the Send Connectors tab.
Right-click on the existing Send Connector.
Select Properties.
Go to the Network tab.
Select Route mail through the following smart hosts:.
Click Add.
Type the IP address of the WatchGuard XCS system to forward outbound mail to, such as:
10.0.1.25
Repeat this procedure to add the addresses of all of your WatchGuard XCS systems.

11. Click OK.
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Connect the WatchGuard XCS
To connect the WatchGuard XCS:
1. Unpack the device, cables, and documentation from the shipping carton.
2. Connect the power cable to the system and a power source, preferably a UPS (Uninterruptible
Power Supply).
3. Connect the first onboard Ethernet network interface on the back of the device (NIC 1) to the
network.
For the initial installation, you only need to connect the internal network interface to be able to
connect to the device with a web browser. You can configure additional network interfaces after the
installation.

4. Use one of these methods to get access to the Web UI Installation Wizard:
n

n

User Guide

Connect your computer to the same network as the WatchGuard XCS through a network
switch.
Connect the WatchGuard XCS to the network switch using the first onboard Ethernet
connector (NIC 1) on the back panel.
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5. Connect your computer directly to the WatchGuard XCS with a cross-over Ethernet cable
connected to the first onboard Ethernet connector (NIC 1) on the back panel.

Default Network Settings
The default network settings for the WatchGuard XCS are:
n
n
n

IP address: 10.0.0.1
Netmask: 255.255.255.0
Gateway: 10.0.0.2

To connect to the WatchGuard XCS Web UI, we recommend you configure your computer to use the
IP address 10.0.0.2.
The WatchGuard XCS supports these web browsers:
n
n

Internet Explorer 8, 9 (Windows XP, Windows 2000, Windows 2003, Windows Vista, Windows 7)
Firefox 3 and greater (Windows, Linux, Mac)

Use a minimum screen resolution of 1024x768.
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Start the Installation Wizard
1. Power on your device.
Wait at least 5 minutes for the system to initialize before you try to connect to the WatchGuard
XCS with a web browser. Ping is enabled on the configured network interface. You can ping the
default address 10.0.0.1 to check connectivity before you connect with a web browser.
2. Launch a web browser on your computer and type the IP address of the WatchGuard XCS as
the URL in the location bar.
For example, https://10.0.0.1
The login page appears.

Note A security certificate notification appears in the browser because the system uses a
self-signed certificate. It is safe to ignore the warning (Internet Explorer) or to add a
certificate exception (Mozilla Firefox).
3. Type the default Username and Password.
When you access the system for the first time after installation, the default settings are admin
for the username, and admin for the password.
4. The Installation Wizard introduction page appears. Click Continue to start the installation.
Make sure you register your device serial number with the WatchGuard® LiveSecurity® web
site and receive a feature key before you continue with installation.
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5. In the Regional Settings page, configure these options:
n

n
n

Time Settings – Type the current Time and Date. For the time, use 24-hour format
hh:mm:ss.
For the date, use this format: YYYY-MM-DD.
Time Zone – Select the closest city to your location and time zone.
Keyboard – Select the keyboard layout for your location. You can attach a keyboard and
monitor to the WatchGuard XCS to get access to the console.

6. Click Continue.
7. On the Networks Settings page, configure the first network interface.
This is the first onboard Ethernet connector (NIC 1) at the left side of the back panel of your
device.
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You can configure these options:
n

n

n

n

n

n

n

n

n

User Guide

Hostname – Type the hostname for the device.
For example, if your fully qualified domain name is hostname.example.com, type
hostname .
Domain – Type your domain.
For example, type example.com .
Gateway – Type the gateway (typically the router) for your network.
For example, type 10.0.0.2 .
DNS Server 1– Type the IP address of your DNS Name Server.
For example, type 10.0.2.53 .
DNS Server 2 – Type the IP address of a secondary DNS name server.
For example, type 10.0.3.53 .
NTP Server – Type the IP address or hostname of your NTP server.
For example, type 10.0.2.123 .
IP Address – Type IP address for this interface.
For example, type 10.0.0.1 .
Netmask – Type the netmask.
For example, type 255.255.255.0 .
External Proxy Server – If your network uses a proxy server to access the Internet, you
must set this option to Enabled and enter your external proxy server configuration. The
WatchGuard XCS requires access to the Internet through the proxy server to retrieve
license information and software updates. If you do not use an external proxy server, keep
this option set to Disabled.
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n
n

n

n

Server Address – Type the IP address of your external proxy server.
Server Port – Type the server port used by the external proxy server. The default is
TCP port 80.
User Name – If your proxy server requires authentication, type the user name to log
in to the proxy server.
Password – Type and confirm a password.

8. Click Continue.
If you make any network changes, you must restart the device and reconnect to the
WatchGuard XCS with the new IP address you assigned to the network interface.
Note Make sure your computer is configured to get access to the new IP address settings
on the WatchGuard XCS.
9. On the Customer Information page, type the Organization Name and Server Admin Email.
Device alerts and notifications are sent to the Server Admin Email address.

10. Click Continue.
11. On the Admin Password page, type and confirm a new admin password.
We recommend that you choose a secure password of at least 8 characters in length and include a
mixture of upper and lowercase letters, numbers, and special characters.
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12. Click Continue.
13. If you are installing WatchGuard XCSv, enter your Serial Number.
This page does not appear for WatchGuard XCS installations.

14. On the Feature Key page, select one of these options to add your feature key:
n

n

n

Click Download to automatically download and apply your feature key from the
WatchGuard LiveSecurity service. This option requires an Internet connection and an
existing LiveSecurity account. Make sure you can get access to the Internet if the device is
installed behind a network firewall, or connects through an external proxy server.
Click Manual Update to manually add a feature key. Paste your feature key into the text
box and click Apply.
Click Enter Feature Key Later to manually add the feature key after installation. To enter the
feature key manually, from the Web UI, select Administration > System > Feature Key.

Note If you do not enter a valid feature key in this step, the Mail Configuration and Start
Processing steps of the wizard are not displayed.

If you see errors when you add your feature key, try this:
For automatic download:
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n

n
n

Make sure you have a valid LiveSecurity account and that you have registered your device
serial number.
You must have an Internet connection to retrieve your feature key.
Make sure communications are not blocked by a network firewall.

For manual update:
n
n
n

Make sure you cut and paste the entire feature key text.
The first line must be “Serial Number: B0xxxxxxxxxxx”.
The last line is a long line that starts with “Signature: “.

14. On the Mail Configuration page, type your mail domain and server details, and select the initial
status of the WatchGuard XCS security scanning features.
Note If you have purchased a Web Scanning-only subscription, the Mail Configuration
screen will be skipped and you can proceed to the next step.

n

n

In the Email Domain text box, type the domain for which the WatchGuard XCS processes
messages. For example, example.com .
In the Internal Mail Server text box, type the IP address of the internal mail server that
receives and sends mail through the WatchGuard XCS.

The WatchGuard XCS automatically configures a mail route for the domain and internal mail
server you enter on this page. To configure additional domains for mail routing after the
installation is complete, from the Web UI, select Configuration > Mail > Routing.
The WatchGuard XCS also automatically configures a Specific Access Pattern to trust your
internal mail server address to allow the mail server to relay mail outbound through the
WatchGuard XCS. Mail that originates from the internal mail server is also trusted for AntiSpam processing. To configure Specific Access Patterns after the installation is complete, from
the Web UI, select Configuration > Mail > Access.
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In the Security Settings section of the Mail Configuration page, you can enable or disable
Intercept Anti-Spam, Anti-Virus, and the Attachment Control features. If you enable these
features in the Installation Wizard, mail scanning is active when the installation is complete and
mail processing is started. See Intercept Anti-Spam Overview for details on the Intercept AntiSpam default settings.
15. Click Continue.
16. If you have purchased the Web Scanning option, a Web Configuration page appears.

n
n

From the HTTP/HTTPS drop-down list, enable or disable HTTP/HTTPS scanning.
In the Internal Mail Server text box, type the address of your internal mail server that will
receive notification messages.

Note The Internal Mail Server field only appears if you did not configure a mail server in the
previous step.
n

In the Security Settings section of the Web Configuration page, you can enable or
disable URL Categorization, Reputation Enabled Defense, and the Anti-Virus
features.

If you enable these features in the Installation Wizard, web scanning is active when the
installation is complete and message processing is started.
If you enable URL Categorization, the feature will not be enabled until after the initial control list
is downloaded.
17. Click Continue.
18. From the Messaging System drop-down list, select Enabled to start message traffic
processing after the installation is complete.
Note Do not enable message processing if you need to perform a restore of a previous
configuration, or you require additional system configuration before you start
processing messages.
If you select Disabled, you can start message processing manually from Activity > Status >
Utilities after the installation is complete.
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19. Click Continue.
20. Click Done to complete the installation.
This process can take up to a minute to complete.
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Post-Installation Tasks

Add a Feature Key
A feature key is a license that enables you to activate your purchased feature set on your WatchGuard
XCS. You must register the device serial number on the WatchGuard LiveSecurity web site and
retrieve your feature key before adding it to the WatchGuard XCS.
Note Make sure you can access the Internet if the device is installed behind a network
firewall, or connects through an external proxy server.
To install a new feature key:
1. Select Administration > System > Feature Key.
The Feature Key page appears.

2. Click Manual Update.
The Update Feature Key page appears.
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3. Copy the text of the feature key file and paste it in the text box.
4. Click Update Key.
The Feature Key page appears with the new feature key information.
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Update a Feature Key
If you already have a LiveSecurity login and your WatchGuard device serial number is registered, you
can update your feature key automatically from the LiveSecurity site.
To update a feature key:
1. Select Administration > System > Feature Key.
The Feature Key page appears.

2. Click Download.
Your feature key is downloaded from the LiveSecurity site and automatically updated on your device.

Feature Key Synchronization
Select the Enable automatic feature key synchronization option to always keep your feature key
synchronized with your WatchGuard LiveSecurity account. If you purchase new feature options or
renew your product, your feature key will be automatically updated on the XCS device.

Troubleshoot Feature Key Updates
If you encounter errors when you add your feature key:
For manual update:
n
n
n

Make sure that you cut and paste the entire feature key text.
The first line of the feature key must be “Serial Number: B0Exxxxxxxxxx”.
The last line of the feature key is a long line of characters starting with “Signature: “.
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For automatic download:
n

n
n

Make sure you have a valid LiveSecurity account and you have registered your device serial
number.
You must have an Internet connection to retrieve your feature key.
Make sure communications are not blocked by a network firewall.

Remove a Feature Key
You may need to remove a feature key after an XCS device evaluation or to troubleshoot license
issues.
Note If you remove a feature key, you disable all security features and the system stops
processing messages.
To remove an existing feature key:
1. Select Administration > System > Feature Key.
The Feature Key page appears.

2. Click Remove.
A confirmation dialog box appears.

3. Click OK to confirm.

Feature Key Expiration
The WatchGuard XCS sends notifications to the administrator at 90, 60, 30, 7, 2, and 1 days before a
feature key expires. To make sure your XCS operates with full functionality, update your feature key
before the expiration date.
When a feature key expires on the WatchGuard XCS, the device continues to process and deliver
mail, but expired features do not scan or perform actions on messages. Also, you will not receive
software and Anti-Spam updates from Security Connection.
For example, if the Anti-Virus scanning feature key expires, the WatchGuard XCS continues to
process mail, but the messages are not scanned for viruses.
These features do not have associated expiration periods because they are required for normal system
operations and management:
n
n
n
n
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Security Connection
Security Connection is a service that polls WatchGuard’s support servers for new updates, security
alerts, and Anti-Spam database updates. The WatchGuard XCS sends a notification to the
administrator when new information and updates are available.
The Security Connection service is enabled by default after you install the WatchGuard XCS to make
sure you automatically receive notifications for the latest software updates. After the initial installation,
Security Connection immediately checks for new available updates. The Security Connection
downloads any available updates for your system, but does not automatically install them.
To install software updates, from the Web UI, select Administration > Software Updates >
Updates. See Software Updates for more detailed information on Software Updates.
Note For security purposes, all Security Connection files are encrypted and contain an
MD5-based digital signature that is verified after the file is decrypted.
To configure Security Connection:
1. Select Administration > Software Updates > Security Connection.

2. Select the Enabled check box.
3. From the Frequency drop-down list, select how often to run the Security Connection service:
daily, weekly, or monthly.
4. To enable software updates to be downloaded automatically, select the Auto Download check
box.
Updates are automatically downloaded, but not automatically installed. You must use Software
Updates to manually install the updates.

5. To enable Security Connection alert messages to appear on the system console, select the
Display Alerts check box.
6. To send an email to the address specified in the Send Emails To text box, select the Send
Email check box.
7. In the Send Emails To text box, type the email address to receive notifications.
8. Click Apply.
9. Click Connect Now to run Security Connection and check for new software updates.
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Software Updates
To make sure your device software is up to date with the latest patches and upgrades, you must install
any updates released for your version of software.
After the installation of the WatchGuard XCS, Security Connection immediately checks for new
software and automatically downloads any available updates. The Security Connection does not
automatically install these updates. You must manually install them on the Software Updates page.
Updates appear in two sections: Available Updates (on the device, but not yet installed) and Installed
Updates (installed and active). You can install an available update, or delete an installed update.
Software updates downloaded from Security Connection appear in the Available Updates section.
You can also perform full system upgrades from the Software Updates page. If you upload a full
system software upgrade, it appears in the System Upgrades section.
Note We recommend that you back up the current system before you perform a software
update. See Backup and Restore from Backup for detailed information on the backup
and restore procedure.

Install a Software Update
To install software updates:
1. Select Administration > Software Updates > Updates.
The Software Updates page appears.

2. If you manually downloaded your software update:
n
n

Click Browse and select the software update.
Click Upload.
The software update appears in the Available Updates section.

3. In the Available Updates section, select the software updates you want to install.
You can install multiple software updates at the same time. The WatchGuard XCS determines
any software dependency issues and installs the updates in the proper order. You will receive a
warning if you are missing a software dependency.
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4. Click Install.
After you install updates, you must restart the device.
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Delete a Software Update
To delete software updates:
1. Select Administration > Software Updates > Updates.
The Software Updates page appears.

2. In the Installed Updates section, select the software updates to delete.
You can delete multiple software updates at the same time. The WatchGuard XCS determines
any software dependency issues and deletes the updates in the proper order.
3. Click Delete.
After you delete updates, you must restart the device.

Install a System Upgrade
You can install a full system upgrade from the Software Updates page. The upgrade is distributed as a
.pf file just like a software update. When you upload a full system software upgrade, it appears in the
System Upgrades section.
WarningIf you install a full system upgrade, your current configuration and data will be
deleted. Make sure you perform a backup of your system before you perform a
full system upgrade. See Backup and Restore from Backup for detailed
information on how to back up and restore your system configuration.
When you perform a system upgrade, the system will retain its original IP address and Feature Key
information. When you system reboots, you can connect to the system using its original IP address.
You can then perform a restore of your configuration from backup.

Upgrade Notes
n
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This upgrade method requires that you have at least 2 GB free space in the System Data
Storage disk area. To check your free disk space, select Activity > Dashboard > System
Summary > Disk Usage.
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Any network interface specific features that you enabled before the upgrade (for example: Large
MTU, Respond to Ping, Trusted Subnet, Admin & Web User Login, WebMail, SNMP Agent,
Centralized Management, HTTP/HTTPS Proxy, Queue Replication, Bridging etc.) will be reset
to their default value. You must re-enable these options after the upgrade is complete.
Cluster status is preserved, but the system will restart in Standalone mode after the upgrade.
You must manually change the run mode to the system's previous mode, such as Primary,
Secondary, or Client.

To install a full system software upgrade:
1. Select Administration > Backup/Restore > Backup & Restore, and perform a backup of
your system.
2. Select Administration > Software Updates > Updates.
The Software Updates page appears.

3. Click Browse and select the software upgrade.
4. Click Upload.
The software update appears in the System Upgrades section.

5. In the System Upgrades section, select the software upgrade you want to install.
6. Click Upgrade.
The system will prompt you to perform a backup of the current system configuration. After you install
the software upgrade, you must restart the device.

7. Log in to the system as the primary admin user after the device restarts.
8. Select Administration > Backup/Restore > Backup & Restore, and perform a restore of
your configuration.

Update Anti-Virus Pattern Files
If licensed, the Anti-Virus service is automatically enabled and started. After the initial installation of
the WatchGuard XCS, it may take up to the default of one hour to update your Anti-Virus pattern files to
the most recent version. We recommend you update your pattern files immediately after installation.
Note If you access the Internet through a proxy server, you must enter its hostname and
port number in the external proxy configuration in Configuration > Network >
External Proxy Server for pattern file updates to succeed.
To update your pattern files:
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1. Select Security > Anti-Virus > Anti-Virus.

2. Go to the Virus Pattern Files section.
3. Click Get Pattern Now.
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Mail Routing
If you configured a primary email domain and an internal mail server during the initial installation of the
WatchGuard XCS, a mail route is automatically set up for that mail server.
Use the Mail Routing page to configure additional domains to accept mail for and identify the
destination mail servers to route the messages to.
You can perform these actions:
n
n
n

n

n

Add — Add a mail route.
Delete — Select one or multiple mail routes, then click Delete to delete the routes.
Download File — Download a list of mail routes. You can download a text list of mail routes
and edit the text file.
Upload File — Upload a list of mail routes. You can upload a list of mail routes in a text file. We
recommend you download the existing mail routes first and edit this file for upload.
LDAP Routing — Define mail routes using an LDAP directory server. This is the preferred mail
routing method for organizations with a large amount of domains.

Search Mail Routes
You can use the search box to search for specific mail routes and filter the display. Type a text string to
search on the Domain, Route-to, and Port fields.

Sort Mail Routes
You can click on the any column to sort the display by ascending or descending order.

Add or Edit Mail Routes
To add and configure mail routes:
1. Select Configuration > Mail > Routing.

2. Click Add to add a mail route, or click on an existing mail route to edit its settings.
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3. In the Domain text box, type the domain for which mail is accepted.
For example, example.com .
4. In the Route-to text box, type the IP address or host name for the mail server to which mail is
delivered.
For example, 10.0.2.25 or mail.example.com .
Note If this XCS device is acting as the local mail server, leave the Route-to field blank and
do not enter the IP address of the XCS device.
When you click Add the route will appear as "LOCAL".
5. In the Port text box, type the port on which to deliver mail to this server.
The default is SMTP port 25.

6. To accept and relay mail for subdomains of the specified domain, select the Accept
Subdomains option.
7. If you need to look up the mail routes in DNS before delivery, select the MX Lookup option.
If this option is disabled, MX records are ignored. You do not need to select this item unless you
are using multiple mail server DNS entries for load balancing and failover purposes. By
checking the MX record, DNS sends the request to the next mail server in the list.
8. Select the Keep Open option to make sure that each mail message to the domain is not
removed from the active queue until the WatchGuard XCS attempts delivery, even if the
preceding mail failed or was deferred.
This setting makes sure that local mail servers receive high priority.

Note The KeepOpen option should only be used for domains that are usually very reliable. If
the domain is unavailable, it can cause system performance problems because of
excessive error conditions and deferred mail.
9. Click Apply.
10. Repeat the procedure for any additional domains and mail servers.

Upload Mail Routes
You can upload a list of mail routes in a text file. The file must contain comma separated entries with
one entry per line. We recommend you download the existing mail routes first and edit this file for
upload.
Use this format:
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[domain],[route],[port],[ignore_mx],[subdomains_too],[keepopen]

For example:
example.com,10.0.2.25,25,on,off,off

To upload a list of mail routes:
1. Click Upload File.
2. Click Browse and select the file to upload.
3. Select an upload option:

n
n
n

Delete – Delete the mail routes listed in the upload file.
Replace – Delete all existing mail routes and add new mail routes from the upload file.
Upload – Append the entries in the upload file to the existing mail routes and update any
existing entries.

4. Click Upload.
The Upload Mail Routes page appears.

5. Select the Ignore First Line check box if your file contains a header line that you want to ignore
during the import.
6. Choose the fields that represent each data column in your file:
n
n
n
n
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(Ignore) – Ignores the specified field.
Domain – The domain for which mail is accepted.
Route – The IP address for the mail server to which mail is delivered.
Port – The port on which to deliver mail to this server.
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n
n

Ignore MX – If this option is disabled, MX records are ignored. You do not need to select
this item unless you are using multiple mail server DNS entries for load balancing and
failover purposes. By checking the MX record, DNS sends the request to the next mail
server in the list.
Subdomains – Accept and relay mail for subdomains of the specified domain.
Keep Open – Make sure that each mail message to the domain is not removed from the
active queue until the system attempts delivery, even if the preceding mail failed or was
deferred.

7. Click Continue.

Subdomain Routing with MX Lookup
The WatchGuard XCS can route and deliver messages to subdomains based upon an MX record
lookup using the domain portion of the RCPT TO: field of a message.
In the Mail Routing configuration, you can specify “any” or “ANY” in the Route-to field. The
WatchGuard XCS performs an MX lookup on the specified subdomain, and then the message is
delivered based on a DNS A record lookup for the destination host.
When you define the Route-to field as “any” or “ANY”, these default values are used, and changing
them in the user interface has no effect.
n
n
n

The default Port is 25
The MX Lookup option is enabled
The Keep Open option is disabled

Subdomain Routing and DNS Caching
If DNS caching is enabled, a cached DNS entry can cause a message to be delivered to an incorrect
host if the DNS entry is modified. We recommend that you disable the Enable DNS Cache option
(from Configuration > Network > Interfaces) if you use DNS MX lookups for subdomain routing.
This can cause a slight decrease in performance of DNS lookups, but makes sure the correct route is
used if you change a DNS record.

LDAP Routing
Click the LDAP Routing button to define mail routes using an LDAP directory server. This is the
preferred mail routing method for organizations with a large amount of domains. See LDAP Routing for
more detailed information on using LDAP for mail routing.

60

WatchGuard XCS

Post-Installation Tasks

Trust Mail Servers
To allow your mail servers to relay mail outbound through this WatchGuard XCS, a Specific Access
Pattern must be set up for the system. A Specific Access Pattern makes sure that your mail servers
and their messaging traffic is trusted and not processed for spam.
1. Select Configuration > Mail > Access.
2. Click the Add Pattern button.

3.
4.
5.
6.

In the Pattern text box, type the IP address of the client.
Select the Client Access check box.
From the If pattern matches drop-down list, select Trust.
Click Apply.
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Start Messaging Services
When you have configured the WatchGuard XCS with your required networking information and mail
routes, you can start the messaging system and start to process messages.
To start the messaging system:
1. Select Activity > Status > Utilities.

2. In the Messaging System Control section, click Start.
The status message changes from “Messaging System is stopped” to “Messaging System is
running”.
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Connect to the WatchGuard XCS
You can use these web browsers to connect to the Web UI:
n
n

Internet Explorer 8, 9 (Windows XP, Windows 2000, Windows 2003, Windows Vista, Windows 7)
Firefox 3 and greater (Windows, Linux, Mac)

Make sure your screen resolution is set to a minimum of 1024x768.
To administer the WatchGuard XCS with the Web UI:
1. Open a web browser and go to the IP address of the WatchGuard XCS.
For example, https://10.0.0.1
The login page appears.

Note A security certificate notification appears in the browser because the system uses a
self-signed certificate. You can safely ignore the warning (Internet Explorer) or add a
certificate exception (Mozilla Firefox).
2. Type the default Username and Password.
When you connect to the device for the first time after installation, the default settings are:
n
n
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Username — admin
Password — admin
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When you log in, the Frequent Tasks page appears.

If you want to display the Dashboard monitoring page after you login instead of the Frequent
Tasks page, deselect the Display at Login check box.
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Navigate the Main Menu
The main menu has these main categories:

Note Depending on your device model and feature package, not all menu configuration
items are displayed.

Activity
The Activity menu provides a variety of information on system status and activity. This includes the
Dashboard, message history, mail queue and quarantine management, and reports and logs. This
menu includes these features:
Status
n
n
n
n
n
n
n
n

Dashboard
Alarms
Cluster Alarms (if in a Cluster)
Cluster Activity (if in a Cluster)
CM Activity (on a CM Manager only)
Threat Prevention
Utilities
Frequent Tasks

History
n
n
n
n

Message History
Saved Searches
System History
Connection History

Queue/Quarantine
n
n
n

Mail Queue
Message Quarantine
Custom Quarantines

Reports
n
n
n

Schedule
View
Centralized Management (on a CM Manager only)
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Logs
n
n
n
n
n

Mail
Web
System
Previous Searches
All

Security
Use the Security menu to configure the system’s powerful security and content control features.
This menu includes these features:
Anti-Spam
Use the Anti-Spam menu to configure the components of the Intercept Anti-Spam features.
n
n
n
n
n
n

Anti-Spam
Outbound Anti-Spam
Connection Control
Threat Prevention
Reputation Enabled Defense
Brightmail (if licensed)

Anti-Virus
The Anti-Virus menu includes message security scanning features, for example, Anti-Virus,
Spyware, Outbreak Control, and Malformed Mail scanning:
n
n
n
n

Anti-Virus
Spyware
Outbreak Control
Malformed Mail

Encryption
Use the Encryption menu to configure message and delivery encryption features.
n
n
n

SecureMail
External
TLS

Content Control
Use the Content Control menu to configure the system’s powerful content control features.
This includes Attachment Control, Content Scanning, and other content filters.
n
n
n
n
n
n
n
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Attachment Control
Attachment Size Limits
Content Scanning
Objectionable Content
Document Fingerprinting
Content Rules
Pattern Filters
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n

Dictionaries
DLP Wizard
Custom Actions

Policies
Use the Policies menu to configure system policies for access control and compliance.
n
n
n
n
n
n
n

Policies
User Policy
Group Policy
Domain Policy
IP Policy
Default Time Policy
Diagnostics

Configuration
Use the Configuration menu to configure device network and mail settings.
This menu includes these items:
Network
Use the Network menu to configure options related to the device’s networking features.
n
n
n
n
n
n
n

Interfaces
Virtual Interfaces
Performance
Static Routes
Web Server
External Proxy Server
SNMP

LDAP
Use the LDAP menu to configure your Directory Services features that rely on LDAP.
n
n
n
n
n
n
n
n

Directory Servers
Directory Users
Web Users
Aliases
Mappings
Recipients
Relay
Routing

Mail
Use the Mail menu to configure features related to mail processing and delivery.
n
n
n
n

Access
Delivery
Routing
Aliases
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n
n
n
n
n

Mapping
Virtual Mapping
Archiving
DKIM/DomainKeys
Annotation
POP3 and IMAP

WebMail
Use the WebMail menu to configure the Secure WebMail and its related features that use the
WebMail client.
n
n
n

WebMail
Trusted/Block Senders
User Spam Quarantine

Web
Use the Web menu to configure features specific to the Web Proxy.
n
n
n
n
n
n
n
n

HTTP/S Proxy
HTTPS Deep Inspection
Traffic Accelerator
Reputation Enabled Defense
User Reporting
URL Categorization
Proxy Auto Configuration
URL Block Lists

Miscellaneous
Use the Miscellaneous menu to configure the general settings of several features.
n
n
n
n
n

Logs
Reports
Customization
Alarms
Feature Display

Administration
Use the Administration menu to manage the device. This includes user account administration,
backup and restore, software updates, and feature key management.
This menu includes these features:
Accounts
Use the User Accounts menu to configure local user accounts and authentication.
n
n
n
n
n
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Administrator
Local Accounts (or Tiered Admin if in a cluster)
Mirror Accounts
Delegated Domains
Relocated Users
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n

Vacations
Remote Authentication
SecurID

Backup/Restore
Use the Backup/Restore menu to backup and restore the device configuration and data.
n
n

Backup & Restore
Daily Backup

Software Updates
Use the Software Updates menu to manage device software updates and the Security
Connection.
n
n

Updates
Security Connection

Multi-System Management
Use the Multi-System Management menu to configure multi-system features, for example,
Centralized Management and mail queue replication.
n
n
n
n
n

Centralized Management
Configuration Set (if on a CM Manager)
Entities (if on a CM Manager)
Entity Status (if on a CM Entity)
Queue Replication

System
Use the System menu to configure system administrative settings, for example, feature keys
and certificates.
n
n
n
n

Feature Key
SSL Certificates
Regional Settings
Reboot & Shutdown

Support
Use the Support menu to obtain additional support for the product.
This menu includes these features:
n
n
n
n
n
n

Technical Support
Problem Reporting
Reputation Enabled Defense
Online Access (main WatchGuard web site)
Online Manual
Microsoft Outlook Add-ins
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Language Display
You can select the language in which to display the WatchGuard XCS menu system, the Dashboard
page, and the Frequent Tasks page. Each Tiered Admin user can have their own specific language
settings. The WatchGuard XCS currently supports English, French, Spanish, and Chinese
(Simplified).
From the Web UI, select a language from the drop-down list in the top-left corner of the page. Choose
Auto-Select to automatically detect the language based on the current browser settings.
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Frequent Tasks
The Frequent Tasks page appears as the default page when you log in to the WatchGuard XCS. This
page provide direct links to the most common tasks you can perform to configure and manage the
WatchGuard XCS.
Some tasks are important to run immediately after installation, such as importing LDAP users,
updating your software, or adding additional email routing domains.
Note Depending on your feature key and product feature activations, only tasks for licensed
features will appear.

If you want to display the Dashboard monitoring page after you login instead of the Frequent Tasks
page, uncheck the Display at Login check box.
To access the Frequent Tasks page from the Web UI, select Activity > Status > Frequent Tasks.
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Task Descriptions
Accept email for additional domains
Configure additional email domains for which you accept mail.
Make sure you also add a specific access pattern to trust the internal mail server you specify for
the mail route.
Import users/groups from directory services
Configure a directory server to import user/group information for use with LDAP features.
Make sure you import Directory Users after you configure a directory server.
QMS Integration Wizard
This wizard guides you through the required configuration to integrate the WatchGuard XCS
with the WatchGuard QMS (Quarantine Management Server).
This allows you to redirect spam messages from the WatchGuard XCS to the quarantine area
on the WatchGuard QMS where users can manage their quarantined spam.
Make sure your WatchGuard QMS is configured and running before starting the wizard.
Block or allow email using pattern filters
Pattern filters allow you to block or allow email messages based on message characteristics
including the message header, sender, recipient, subject, attachment content, and message
body text.
Block or allow attachment types
Attachment controls allows you to block, allow, or strip email attachments based on their file
extension, MIME type, or attachment content.
Enable email encryption
SecureMail email encryption allows you to protect the confidentiality of messages by encrypting
the message before it is delivered to the recipient.
Data Loss Prevention Wizard
The Data Loss Prevention (DLP) wizard guides you through the configuration of DLP content
controls and rules for inbound and outbound email and web traffic. You can select specific tasks
such as blocking credit card or national identification numbers, or use a compliance dictionary to
scan for specific words and phrases in email and web traffic.
Create and schedule backup
Schedule a backup using the local disk, or FTP/SCP to a remote server. You can back up the
system configuration, quarantined items, mail queues, user mail directories, uploaded user
lists, SSL certificates, feature keys, and reporting data.
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Update your software
Keep your system software up-to-date by installing any software updates or software upgrades
available for your WatchGuard device.
Add an administrator account
Add additional administrator accounts for managing your WatchGuard device.
Create and schedule a report
The WatchGuard XCS reports provide a comprehensive range of detailed information about
your system. You can create a report on demand or schedule a recurring report.
View a report
View your generated reports in HTML, PDF, and CSV formats.
Search message history
Search the message history database to see how specific messages were processed and the
final action performed on a message.

User Guide

73

Administration

WatchGuard XCS Console
The WatchGuard XCS console supports a limited subset of administrative tasks and should only be
used for troubleshooting or for a custom installation. We recommend you perform all routine
administration through the Web UI.
When you access the console for the first time after installation, the default login credentials are admin
for the UserID, and admin for the Password. The password can be changed from the Web UI
administration interface.

Console Activity Page
The console activity page provides you with basic activity and statistics information for this device.
Press any key to log in to the console with your admin login credentials.

Admin Menu
The Admin menu contains these options:
n
n

n

n
n
n
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Exit – Exits the console.
Hardware Information – Displays the processor type, available memory, and network
interface information.
Configure Interfaces – Allows you to modify the host and domain name, IP address, Gateway,
DNS and NTP servers for all network interfaces.
Security Connection – Enables automatic software updates.
Shutdown – Shuts down the device.
Reboot – Shuts down and restarts the device.
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Diagnostics Menu
The Diagnostics menu contains these options:
n
n
n
n

n
n

Activity Display – Displays CPU usage, network traffic and mail message activity.
Ping – Allows you to test network connectivity to other systems with the ping utility.
Traceroute – Displays the routing steps between the device and a destination host.
Reset Network Interface – Resets network interfaces. This function is useful to correct
connection issues.
Display Disk Usage – Displays the amount of used and available disk space.
Display System Processes – Displays information about processes running on the system.

Repair Menu
The Repair menu contains these options:
n

Reset SSL Certificates – Sets certificate information back to the factory defaults. Any existing
certificates or private keys are deleted.

Misc Menu
The Misc menu contains these options:
n
n
n

n

Set Time and Date – Sets the time and date for the system.
Set Time Zone – Sets your local time zone settings.
Configure UPS – Allows you to configure the link to an Uninterruptible Power Supply (UPS) for
automatic shutdown in the event of a power failure. A UPS keeps a device running for several
minutes after a power outage. This allows you to shut down the device gracefully. The signal is
sent with the serial COM port on the WatchGuard XCS that is connected to the UPS.
UPS Protocol – Select the protocol to communicate with the UPS.
Note The system only supports APC type UPS systems.

n

Enable UPS Monitor – Select Yes to enable the UPS monitor.
When you enable monitoring, the WatchGuard XCS detects alarms from the UPS that it is
running on battery power, and starts a graceful shutdown of the WatchGuard XCS. If this option
is set to No, the system does not automatically shut down, and you must perform a manual
shut down before the UPS battery power is exhausted.

n

n

n

UPS Interface Port – Select the serial COM port on the WatchGuard XCS that is connected to
the UPS.
Shutdown Interval – Type the number of minutes (0-30) to wait before automatically shutting
down the WatchGuard XCS.
Configure Web Admin – Modify the ports used to access the system web browser
administration interface.
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Configure Serial Console – Allows you to configure a serial port for using the device console
with a serial connection. To use the serial console, you must set your terminal program to these
values:
o VT100 Emulation
o Baud Rate: 9600
o Data Bits: 8
o Parity: None
o Stop Bits: 1
o Flow Control: Hardware
Note The Serial Console and UPS settings are not supported with WatchGuard XCSv
because these features are configured directly on the virtual host system.
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Configure the Admin User
The WatchGuard XCS creates the primary admin account during the initial installation. To modify the
settings for the admin user:
1. Select Administration > Accounts > Administrator.
2. In the User ID text box, you can view and modify the current admin user name.
You cannot delete the admin user name, but you can modify the account name. This helps
prevent attempts to compromise the primary admin user name by allowing you to use a nonstandard user name. We recommended that you create additional admin users and use those
accounts to manage the WatchGuard XCS instead of the primary admin account. Record the
primary admin account password and store it in a safe place.
3. In the Forward email to: text box, type an optional email address to which to forward mail from
this account.

4. In the Password text box, type and confirm a password for the admin user.
5. In the IP Access Control List (ACL) section, click Edit to type a list of IP addresses or
networks that are allowed admin access to this WatchGuard XCS.
n

n
n

Type a specific IP address, for example, 192.168.1.250 . To type a network address, use
192.168.1.0 for the entire 192.168.1.0/24 network.
Click Add.
You must also enable Admin access on a network interface (from Configuration >
Network >Interfaces), in addition to the ACL access. Leave the IP access list undefined to
limit admin access only through the network interface option.

4. From the Password Enforcement drop-down list, select a method to strengthen the security of
the admin and user accounts.
n

n
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Unrestricted – Allow any type of password for the admin account and user accounts. This
is the default setting used after the initial installation.
Strong – Require that passwords for both admin accounts and user accounts be at least 6
characters in length and include a mix of alphabetic and non-alphabetic characters.
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Note After you enable this option, any existing user accounts and passwords that do not
have a strong password do not have the restrictions enforced until the next time you
modify the passwords.
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Add Admin Users
There is only one primary admin user account, but you can add additional administrative users with
Tiered Administration. This feature allows you to configure another user with full admin rights or with
granular permissions that only give administrative rights to certain options.
For example, you can add a user who has permissions to administer reports or vacation notifications,
but does not have any other administrative access.
Granting full or partial admin access to one or more user accounts allows you to log actions performed
by administrators because they have an identifiable user ID that can be tracked by the system.
Note AuserwithFullAdminprivileges cannotmodify theprofileofthedefaultadminuser.They
can,however,editothers userswithFullAdminprivileges.

To add an administrative user:
1. Select Administration > Accounts > Local Accounts.
2. Click Add Admin User.

3. In the User ID text box, type a user name.
4. In the Forward email to: text box, type an optional email address to which to forward
messages from this account.
5. In the Password text box, type and confirm a password for this user.
6. In the Administrator Privileges section, select the required administrative access for the user:
Full Admin
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The user has administrative privileges equivalent to the admin user.
Delegated Domain Admin
The user has administrative privileges to a specific domain. No tiered admin permissions
are available when this is enabled.
Administer Aliases
The user can add, edit, remove, upload, and download aliases (except for LDAP aliases.)
Administer Filter Patterns
The user can add, edit, remove, upload, and download Pattern Filters and Specific Access
Patterns.
Administer Mail Queue
The user can administer mail queues.
Administer Quarantine
The user can view, delete, and release quarantined files.
Administer Reports
The user can view, configure, and generate reports, and view system activity.
Administer Users
The user can add, edit, and relocate user mailboxes (except the Full Admin users). This
includes the ability to upload and download user lists. The user can also configure User
vacation notifications.
Administer Vacations
The user can edit local user’s vacation notification settings and other global vacation
parameters.
Message History
The user can view the message history database and perform quick searches of the recent
Mail and Web activity on the Dashboard.
View Dashboard
The user can view the Dashboard page. Tiered admins can only perform a quick search of
the recent mail and web activity if Message History is also enabled.
View Alarms
The user can view the alarms in the alarms indicator and the local alarms page, but cannot
acknowledge them.
View System Logs
The user can view all system logs.
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7. Click Create.
8. Select Configuration > Network > Interfaces.
9. Select the Admin & Web User Login and WebMail check boxes for the network interface to
be used by tiered administration users.
See Tiered Administration for more information on configuring tiered admin access.

Admin User Automatic Logout and Lockout
As a security precaution, the WatchGuard XCS automatically logs the admin user out of the Web UI if
they are logged in for 30 minutes without any activity.
If login credentials for an admin user are not properly entered after five times in a row, the account is
locked out for 30 minutes. Reboot the device to reset the lockout.
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Web Server
The Web Server page defines the settings used to connect to the WatchGuard XCS with the Web UI.
By default, the web server uses TCP port 80 for HTTP requests and TCP port 443 for HTTPS
requests. For secure WebMail and administration sessions, we recommend that you leave the default
SSL encryption enabled to force a connecting web browser to use HTTPS.
To configure your web server settings:
1. Select Configuration > Network > Web Server.

You can configure these options:
Admin HTTP Port
Indicates the default port 80 for HTTP requests.
Admin HTTPS Port
Indicates the default port 443 for HTTPS requests.
Note You can only modify the HTTP/HTTPS ports on the WatchGuard XCS console.
Require SSL encryption
Requires SSL encryption for all user and administrator web sessions.
Allow low-grade encryption
Allow the use of low-grade encryption, for example, DES ciphers with a key length of 64
bits, for encrypted user and administrator web sessions.
Enable SSL version 2
Enables SSL version 2 protocol. Note that SSL version 2 contains known security
vulnerabilities.
Enable SSL version 3
Enable SSL version 3 protocol. This is the default setting.
Enable TLS version 1
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Enable TLS version 1 protocol. This is the default setting.
Character set encoding
Select the type of character encoding used to display HTML data. Change the encoding if
you view and manage dictionaries that use different encodings, for example, ISO-8859-1.
WarningIf you modify the character set encoding from the default UTF-8, the system
may display unreadable characters depending on your language display
settings.
2. Click Apply.
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External Proxy Server
A proxy server is used to cache and proxy requests to systems external to your network. If you use
features that must connect to the Internet for updates, and your network uses a proxy server, the proxy
server must be configured on the WatchGuard XCS. If you do not use an external proxy server, keep
this option disabled.
The WatchGuard XCS requires access to the Internet through the proxy server for these features:
n
n
n
n
n
n
n
n

Kaspersky and McAfee Anti-Virus pattern updates
Message encryption with a public key server
Reputation Enabled Defense sharing uploads
URL Categorization control list downloads
Security Connection features and software
Intercept Anti-Spam database and Brightmail updates
SecureMail encryption connection
Feature key updates

To configure an external proxy server:
1. Select Configuration > Network > External Proxy Server.

2.
3.
4.
5.

Select the Use External Proxy Server check box.
In the Server Address text box, type the IP address or host name of the proxy server.
In the Server Port text box, type the Server Port number used by the proxy server.
In the User Name text box, type a user name used to log in to the proxy server if authentication
is required.
6. Type and confirm a Password for the user name on the proxy server.
7. Click Update.
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Customize the Web UI Interface
The WatchGuard XCS interface logos can be easily customized. You can replace the system logo with
your own custom logo.
You can modify these logos:
n
n
n

Login page logo
Administration page logo (also appears on generated reports)
Spam digest logo

To customize a logo:
1. Select Configuration > Miscellaneous > Customization.

2. In the Title text box, type optional text for the title bar of the login page.
3. For the logo you want to customize, click Browse to choose a file, and then click Next to upload
the file.
Most graphic formats are supported (GIF, JPEG, PNG, BMP), but we recommend that you use
graphics suitable for web pages, for example, GIF and JPEG. The maximum file size is 32k
with a recommended height of 40 pixels.
Select the Reset this Logo to the Default link to revert to the default logo.
4. Click Finished.

User Guide

85

Administration

End-User Agreement
The End-User Agreement option allows you to display a disclaimer on the WatchGuard XCS login
page that a user must accept before they can log in. This option applies to logins by administrators,
tiered administrators, Spam Quarantine/Trusted Senders, and WebMail users.
You can customize the default End-User Agreement text to reflect the specific acceptable use and
legal policies of your organization.

Customize the HTTP Proxy End-User Agreement
You can customize the HTTP Proxy End-User Agreement text that appears to users when they log in
through the Web Portal. The Web Portal login page appears to end users when IP Address Portal
Authentication is enabled as the authentication method in the HTTP Proxy configuration.
The user must accept this agreement and successfully authenticate before they are allowed to browse
the web through the Web Proxy.
Note The logo that appears on the Web Portal page is the Administration page logo.
To customize the agreement:
1. Select Configuration > Miscellaneous > Customization.

2. In the End-User Agreement text box, customize the End-User Agreement text as required.
3. Click Finished.
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Feature Display
You can choose to display or hide specific feature configuration entries in the main menu, the
Dashboard, and policy configuration.
For example, if you do not use the Centralized Management feature, you can prevent any Centralized
Management options from appearing in the menus.
1. To configure feature display:
2. Select Configuration > Miscellaneous > Feature Display.

3. Select the Display Centralized Management check box to show configuration options for this
feature in the menu.
Clear the check box to prevent the display of any Centralized Management options.
4. Click Finished.
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Regional Settings
Your regional settings (time and date, time zone, and keyboard layout settings) are configured during
the initial installation process.
To modify your regional settings:
1. Select Administration > System > Regional Settings.

2. In the Time Settings section, set the current date and time.
n
n

In the Time text box, type the current time. Use 24-hour format HH:MM:SS.
In the Date text box, type the current date. Use the format YYYY-MM-DD.

Note You can configure an NTP Time Server in the Network Settings to make sure the
system time is always synchronized.
3. In the Time Zone section, from the Region, Country, and City drop-down lists, select the
closest city to your location and time zone.
4. In the Keyboard section, from the Layout drop-down list, select the keyboard layout for your
location.
The keyboard is used to access the system console.
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Network Configuration
When you complete the initial installation process for your WatchGuard XCS, you configure the basic
network information for your device. From the Network Configuration page, you can configure other
network interfaces and advanced network settings.
You can modify these configuration items:
n
n
n
n
n
n
n
n

Hostname and Domain information
Default Gateway
Syslog Host
DNS and NTP servers
Network interface IP Address and feature access settings
Clustering and Queue Replication interface configuration
Web Proxy Bridging and Transparent Mode
Support Access settings
Note If you make any modifications to your network settings, you must reboot the system.
The system prompts you to restart after you apply the configuration.

To configure your network settings:
1. Select Configuration > Network > Interfaces.
The Network Configuration page appears.
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2. The Hostname, Domain, and Gateway are configured during the initial installation and can be
modified on this page.
3. In the Hostname text box, type the hostname (not the Fully Qualified Domain Name) of this
device.
For example, if your Fully Qualified Domain Name is hostname.example.com, type hostname .
4. In the Domain text box, type the domain name for your device.
For this example, type example.com .
5. In the Gateway text box, type the IP address of the default route for this device.
This is usually the external router connected to the Internet or the network firewall’s interface if the
system is located on the DMZ network.

6. In the DNS Servers text boxes, type the name of your primary and secondary DNS servers.
At least one DNS (Domain Name Service) name server must be configured for hostname resolution.
We recommend that you specify at least one secondary DNS server to use when the primary DNS
server is unavailable.

7. To enable DNS caching, select the Enable DNS Cache check box.
This option is enabled by default and provides the best performance in most cases. When this
option is enabled, the system determines which of the configured DNS servers sends the
fastest response, and caches the result.
Clear the Enable DNS Cache check box to:
n
n

90

Use the configured DNS servers in the order they appear
Use your ISP DNS servers as failover servers
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8. To make sure private reserved IP addresses are not used in a reverse lookup to a DNS server,
select the Block Reserved Reverse Lookups check box.
This option is enabled by default.
Clear the Block Reserved Reverse Lookups check box if you use your ISP DNS servers, and
reverse lookups for reserved addresses are required in your network environment.
9. In the NTP Server text boxes, type the IP address or hostname for your primary time server and
any secondary time servers.
We recommend that you specify secondary NTP servers to use if the primary NTP server is
unavailable.

10. If you use a syslog host on your network, in the Syslog Server text box, type the IP address of
your syslog host.
A syslog host collects and stores log files from many sources.

Network Interface Configuration
For each network interface, you can set these options:
1. From the Interface Mode drop-down list, select the mode for this network interface.
n
n
n
n

n

Disabled — Disables the selected network interface.
IPv4 Only — The network interface only supports IPv4.
IPv6 Only — The network interface only supports IPv6.
IPv4 and IPv6 — The network interface can have both IPv4 and IPv6 addresses and both
IPv4 and IPv6 connections can be made simultaneously.
Cluster — Used exclusively for the cluster network. An IP address is automatically
configured for use with clustering.

Note You must configure at least one interface to support IPv4, or both IPv4 and IPv6.
2. For IPv4, type an IP Address and Netmask for this interface. For example, type 10.0.0.1 and
255.255.255.0 .
For IPv6, type a static IP address and Prefix Length. For example, type a123:b123::c123
and 64 .
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3. Select the Media type for the network card.
For automatic configuration, select Auto select.

4. There are several additional options that you can enable on a network interface.
Some of the following options will not be displayed unless the related feature is enabled.

Large MTU
Sets the MTU (Maximum Transfer Unit) to 1500 bytes. The regular MTU size is 576 bytes.
Large MTU can improve performance connecting to servers on the local network. You must
enable Large MTU if you are using the Web Proxy. This option is enabled by default, and
should only be disabled if required and in consultation with a Technical Support
representative.
Respond to Ping and ICMP Redirect
Allows ICMP ping requests to this interface. This allows you to perform network
connectivity tests to this interface, but makes this interface more susceptible to denial of
service ping attacks. This option is enabled by default on a configured interface.
Trusted Subnet
Consider all hosts on this subnet trusted for mail relaying, and exclude them from AntiSpam processing.
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Admin and Web User Login
Allows admin access (including Tiered Admins) and access for Web users who log in to the
Web Proxy. This option is enabled by default on a configured interface.
WebMail
Allows access to WebMail through this interface. This includes the WebMail client, Secure
WebMail, Tiered Admin, User Spam Quarantine, and Trusted/Blocked Senders List
access.
Message Submission (if enabled)
Enables Message Submission via SMTP port 587 on this interface.
IMAPS Server (if enabled)
Allows secure access to the internal IMAP server through this interface.
IMAP Server (if enabled)
Allows access to the internal IMAP server through this interface.
POP3S Server (if enabled)
Allows secure access to the internal POP3 server through this interface.
POP3 Server (if enabled)
Allows access to the internal POP3 server through this interface.
SNMP Agent
Allows access to the SNMP (Simple Network Management Protocol) agent through this
network interface. You should only enable access to the SNMP agent on an internal
interface.
Centralized Management
Enables Centralized Management on this interface.
HTTP/HTTPS Proxy
Enables access to the HTTP proxy on this interface.
5. Click Apply.
You must restart the device.
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Advanced Parameters
Click Show Advanced Options to display advanced networking options.

Enable RFC 1323
Enable RFC 1323 TCP extensions to improve performance and to provide reliable operations of
high-speed paths. This option is enabled by default. Disable this option if you experience
networking issues with certain hosts.
Path MTU Discovery (RFC 1191)
Path MTU is enabled by default. Disable this option to resolve delivery problems when
interconnecting between specific firewalls and SMTP proxies.
Prefer IPv4 over IPv6
Select this option to set priority to IPv4 when you have both IPv4 and IPv6 interfaces
configured. Enable this option if you experience connectivity issues with IPv4 networks.
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Queue Replication
The Queue Replication feature enables mail queue replication and failover between two XCS devices.
In the event that the primary owner of a mail queue is unavailable, the mirror system can take
ownership of the mirrored mail queue for delivery. See Queue Replication for more detailed information.
n
n

n

n

Enable Replication — Select the check box to enable the Queue Replication feature.
Replication Host — Type the IP address of the host that is backing up mail for this system. If
you configure Queue Replication in a cluster, you can use the interface connected to the cluster
network for replication. Specify the hostname of the host cluster system, for example, SystemA ,
in the address SystemA.example.com .
Replication Client — Type the IP address of the client that is backing up its mail queue to this
system. If you configure Queue Replication in a cluster, you can use the interface connected to
the cluster network for replication. Specify the hostname of the host cluster system, for
example, SystemB , in the address SystemB.example.com .
Replication Interface — From the drop-down list, select the network interface to use for Queue
Replication.
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Transparent Mode and Bridging
The Web Proxy feature offers a Transparent Mode to integrate the Web Proxy more easily into existing
environments with minimal network configuration. In a typical Transparent Mode implementation, the
Web Proxy system sits inline between the primary internal switch or router and an existing network
firewall.
This enables the Web Proxy to act as a bridge for all non-local traffic, except selected HTTP traffic that
is proxied. Packet inspection is performed on all traffic to determine if data is proxied or bridged. See
Transparent Mode for more detailed information.
To configure Transparent Mode bridging for the Web Proxy:
1. Select Configuration > Network > Interfaces.
2. Go to the Bridging and Transparent Mode sections.

3. Select the Enable Bridging check box.
This option is required for Transparent Web Proxy mode. When you enable bridging, you must
select two network interfaces for the bridge.
4. Select a network interface to use as the Bridge In Interface in Transparent Mode.
For greater security and performance, make sure this interface is on a dedicated, non-routable
subnet. You must assign an IP address and select the HTTP/HTTPS Proxy access and Large
MTU check boxes before you select the interface as the Bridge In interface. This IP address is
used as the address for the entire bridge interface.
5. Select a network interface to use as the Bridge Out Interface in Transparent Mode.
For greater security and performance, make sure this interface is on a dedicated, non-routable
subnet. Configure the selected network interface to be disabled, with Large MTU enabled.
6. Select the Enable Transparent Mode check box.
7. Click Apply.
You must restart the system.

Clustering
See Configure Clustering for more detailed information on clustering.
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To enable clustering on an interface:
1.
2.
3.
4.

Select Configuration > Network > Interfaces.
Select the interface connected to the cluster network.
From the Interface Mode drop-down list, select Cluster.
Click Apply.
You must restart the system.

Support Access
Support Access enables technical support to connect to this system from the specified IP address.
This setting is usually not enabled during normal use, and should only be enabled if requested by
technical support.
For security reasons, Support Access communications use SSH (Secure Shell) to establish a secure
connection based on PKI (Public Key Infrastructure) encryption on a non-standard network port.
Support Access only allows a connection from WatchGuard networks.
Note You must open up TCP port 10101 on your firewall to enable support access to work
behind a network firewall.
To install and enable Support Access:
1. Select Administration > Software Updates > Updates.

2. Select the support_access update check box.
3. Click Install.
The system reboots.

4. Select Configuration > Network > Interfaces.
5. Go to the Support Access section.
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6. To enable Support Access on this system, select the Support Access check box.
Support access is allowed to originate from the specified Support Access IP Address.

7. From the Support Access Interface drop-down list, select the network interface for which you
want to enable Support Access.
8. Click Apply.
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Static Routes
Static routes are required if the messaging servers to which messages must be relayed are located on
another network, for example, behind an internal router, firewall, or accessed through a VPN. You can
add static routes for both IPv4 and IPv6 networks.
To add a static route:
1. Select Configuration > Network > Static Routes.

2. In the Network text box, type a network address. For example, 10.10.0.0 for IPv4 or a123::
for IPv6.
3. In the Mask text box (or Prefix Length text box for IPv6), type a corresponding value.
For example, 255.255.0.0 for IPv4 or 64 for IPv6.
4. In the Gateway text box, type a gateway route for the network.
For example, 10.10.0.1 for IPv4 or a123:b123::c123 for IPv6.
5. Click Add.
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Virtual Interfaces
Virtual Interfaces are additional interfaces and IP addresses used to send and receive mail for specific
domains. These virtual interfaces are associated with the existing physical network interfaces on the
WatchGuard XCS. Multiple domains can share the same virtual interface IP address.
The system sends all outbound email for a specific domain using its specified IP address in the Virtual
Interfaces configuration. The WatchGuard XCS selects the virtual interface to use for outgoing mail by
matching the sender's domain to the domains associated with the configured virtual interfaces. If no
virtual interface domains match the domain of the sender, or if using the virtual interface results in a
non-network connection, the system sends the mail through its normal outbound interface.
The WatchGuard XCS accepts inbound email arriving through this virtual interface's IP address. When
a mail server connects to SMTP port 25 on a virtual interface, the customized banner for that interface
appears. If no banner is specified, the default system banner is used. To configure the banner, select
Configuration > Mail > Access.
Only TCP port 25 is used for sending and receiving mail on a virtual interface. Virtual interfaces can be
pinged if ping is enabled on the corresponding physical network interface. Because of their nature,
virtual interfaces cannot be pinged from the Utilities page, and cannot be used when the Web Proxy is
in Transparent Mode. You can only configure virtual interfaces on up to five different physical network
interfaces.
Domains that use virtual interfaces are used with Domain-based policies to provide flexibility in
creating security and content policies for specific domains.
The WatchGuard XCS supports up to 175 Virtual Interfaces. This feature does not currently support
IDN (Internationalized Domain Names).

Network Routing of Virtual Interfaces
Virtual interfaces are routed through:
n
n
n

A physical interface that shares the same subnet as the Virtual Interface.
The physical interface that reaches a host specified through a static route.
The current default route (through the physical interface that connects to the default router.)

If your system has these settings:
n
n
n

Interface 1: 192.168.1.10/24
Interface 2: 172.16.1.10/16
Default Gateway/Router: 172.16.1.1

Adding a virtual interface of 192.168.1.20 routes through Interface 1.
Adding a virtual interface of 172.16.1.20 routes through Interface 2.
Adding a virtual interface of 10.10.1.20 routes through Interface 2 through the default gateway.
If the virtual interface has no corresponding physical interface displayed, there is no valid route through
any physical interface, and the virtual interface is disabled.
To configure virtual interfaces:
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1. Select Configuration > Network > Virtual Interfaces.
2. Upload a virtual interface list in CSV format that contains comma or tab separated entries.
Use this format:
[domain],[IP Address],[Banner message]

For example,
example1.com,192.168.1.20,example1.com ESMTP
example2.com,172.16.1.20,example2.com ESMTP

or for multiple domains that share IP addresses,
domain1.example.com,192.168.1.20,domain1.example.com ESMTP
domain2.example.com,192.168.1.20,domain2.example.com ESMTP
domain3.example.com,172.16.1.20,domain3.example.com ESMTP
domain4.example.com,172.16.1.20,domain4.example.com ESMTP

Note A standards-compliant banner should, at minimum, contain the domain name and the
keyword ESMTP, for example, “example.com ESMTP”. Extra informational text after
the ESMTP keyword is optional, for example, “example.com ESMTP Authorized
Users Only”.
The banner displayed to a connecting client corresponds to the last entry uploaded for
a shared IP address of the virtual interface.
You must use a text editor to create the file vip.csv.
To update a virtual interface file:
1.
2.
3.
4.

To download the virtual interface list from the WatchGuard XCS, click Download File.
Open the file and update the virtual interface list.
Click Upload File and upload the edited file to the WatchGuard XCS.
For each domain that to be used with Virtual Interfaces, select Configuration > Mail >
Routing to define a mail route to a destination mail server.
Virtual mappings can also be used for mail routing.

You must publish DNS MX records for any virtual interfaces. You must also configure local network
devices, for example, the default external router to route traffic to and from the virtual interfaces.
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Virtual Interfaces and Trusts
Email arriving through a virtual interface is considered untrusted for Anti-Spam and security
processing.
To configure a client as trusted, use a Specific Access Pattern or Pattern Filter to trust the client that
connects on that virtual interface.
To trust a client with a Specific Access Pattern:
1. Select Configuration > Mail > Access.
2. Click the Add Pattern button.

3.
4.
5.
6.
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In the Pattern field, type the IP address of the client.
Select the Client Access check box.
From the If pattern matches drop-down list, select Trust.
Click Apply.
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Mail Routing
If you configured a primary email domain and an internal mail server during the initial installation of the
WatchGuard XCS, a mail route is automatically set up for that mail server.
Use the Mail Routing page to configure additional domains to accept mail for and identify the
destination mail servers to route the messages to.
You can perform these actions:
n
n
n

n

n

Add — Add a mail route.
Delete — Select one or multiple mail routes, then click Delete to delete the routes.
Download File — Download a list of mail routes. You can download a text list of mail routes
and edit the text file.
Upload File — Upload a list of mail routes. You can upload a list of mail routes in a text file. We
recommend you download the existing mail routes first and edit this file for upload.
LDAP Routing — Define mail routes using an LDAP directory server. This is the preferred mail
routing method for organizations with a large amount of domains.

Search Mail Routes
You can use the search box to search for specific mail routes and filter the display. Type a text string to
search on the Domain, Route-to, and Port fields.

Sort Mail Routes
You can click on the any column to sort the display by ascending or descending order.

Add or Edit Mail Routes
To add and configure mail routes:
1. Select Configuration > Mail > Routing.

2. Click Add to add a mail route, or click on an existing mail route to edit its settings.
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3. In the Domain text box, type the domain for which mail is accepted.
For example, example.com .
4. In the Route-to text box, type the IP address or host name for the mail server to which mail is
delivered.
For example, 10.0.2.25 or mail.example.com .
Note If this XCS device is acting as the local mail server, leave the Route-to field blank and
do not enter the IP address of the XCS device.
When you click Add the route will appear as "LOCAL".
5. In the Port text box, type the port on which to deliver mail to this server.
The default is SMTP port 25.

6. To accept and relay mail for subdomains of the specified domain, select the Accept
Subdomains option.
7. If you need to look up the mail routes in DNS before delivery, select the MX Lookup option.
If this option is disabled, MX records are ignored. You do not need to select this item unless you
are using multiple mail server DNS entries for load balancing and failover purposes. By
checking the MX record, DNS sends the request to the next mail server in the list.
8. Select the Keep Open option to make sure that each mail message to the domain is not
removed from the active queue until the WatchGuard XCS attempts delivery, even if the
preceding mail failed or was deferred.
This setting makes sure that local mail servers receive high priority.

Note The KeepOpen option should only be used for domains that are usually very reliable. If
the domain is unavailable, it can cause system performance problems because of
excessive error conditions and deferred mail.
9. Click Apply.
10. Repeat the procedure for any additional domains and mail servers.

Upload Mail Routes
You can upload a list of mail routes in a text file. The file must contain comma separated entries with
one entry per line. We recommend you download the existing mail routes first and edit this file for
upload.
Use this format:
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[domain],[route],[port],[ignore_mx],[subdomains_too],[keepopen]

For example:
example.com,10.0.2.25,25,on,off,off

To upload a list of mail routes:
1. Click Upload File.
2. Click Browse and select the file to upload.
3. Select an upload option:

n
n
n

Delete – Delete the mail routes listed in the upload file.
Replace – Delete all existing mail routes and add new mail routes from the upload file.
Upload – Append the entries in the upload file to the existing mail routes and update any
existing entries.

4. Click Upload.
The Upload Mail Routes page appears.

5. Select the Ignore First Line check box if your file contains a header line that you want to ignore
during the import.
6. Choose the fields that represent each data column in your file:
n
n
n
n
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(Ignore) – Ignores the specified field.
Domain – The domain for which mail is accepted.
Route – The IP address for the mail server to which mail is delivered.
Port – The port on which to deliver mail to this server.
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n
n

Ignore MX – If this option is disabled, MX records are ignored. You do not need to select
this item unless you are using multiple mail server DNS entries for load balancing and
failover purposes. By checking the MX record, DNS sends the request to the next mail
server in the list.
Subdomains – Accept and relay mail for subdomains of the specified domain.
Keep Open – Make sure that each mail message to the domain is not removed from the
active queue until the system attempts delivery, even if the preceding mail failed or was
deferred.

7. Click Continue.

Subdomain Routing with MX Lookup
The WatchGuard XCS can route and deliver messages to subdomains based upon an MX record
lookup using the domain portion of the RCPT TO: field of a message.
In the Mail Routing configuration, you can specify “any” or “ANY” in the Route-to field. The
WatchGuard XCS performs an MX lookup on the specified subdomain, and then the message is
delivered based on a DNS A record lookup for the destination host.
When you define the Route-to field as “any” or “ANY”, these default values are used, and changing
them in the user interface has no effect.
n
n
n

The default Port is 25
The MX Lookup option is enabled
The Keep Open option is disabled

Subdomain Routing and DNS Caching
If DNS caching is enabled, a cached DNS entry can cause a message to be delivered to an incorrect
host if the DNS entry is modified. We recommend that you disable the Enable DNS Cache option
(from Configuration > Network > Interfaces) if you use DNS MX lookups for subdomain routing.
This can cause a slight decrease in performance of DNS lookups, but makes sure the correct route is
used if you change a DNS record.

LDAP Routing
Click the LDAP Routing button to define mail routes using an LDAP directory server. This is the
preferred mail routing method for organizations with a large amount of domains. See LDAP Routing for
more detailed information on using LDAP for mail routing.
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Mail Delivery Settings
Use the Mail Delivery Settings page to configure parameters related to accepting, relaying, and
delivering mail messages.
To configure your mail delivery settings, select Configuration > Mail > Delivery.

Delivery Settings
Maximum time in mail queue
Type the number of days for a message to stay in the queue before it is returned to the sender
as “undeliverable”. The default is 5 days.
Maximum time in queue for bounces
Type the number of days a system-generated bounce message (from MAILER-DAEMON) is
queued before it is considered undeliverable. Default is 5 days. Set this value to 0 to attempt
delivery of bounce messages only once.
Maximum original message text in bounces
Type the maximum amount (in bytes) of original message text that is sent in a non-delivery
notification. Range is 10 to 1000000000. If this field is left blank, the default is set to 5000 bytes.
Time before delay warning
Number of hours before issuing the sender a notification that mail is delayed. Set to “0” to
disable this option. The default is 4 hours.
Time to retain undeliverable notice mail
The number of hours to keep undeliverable notice mail addressed to the external mail server’s
MAILER-DAEMON. These messages are typically notifications sent to mail servers with
invalid return addresses and can be safely purged. Leave this value blank for no special
processing.
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Deliver mail to local users
Disable this option to prevent mail delivery to local accounts configured on the WatchGuard
XCS. The postmaster (admin) account is not affected by this setting.
Allow “-” as the first character
Allows a recipient address to have a “-” character as the first character in the address, for
example,
“-test@example.com”.

Gateway Features
Masquerade Addresses
Masquerades internal host names by rewriting headers to only include the address of this
system.
Strip Received Headers
Strips all Received headers from outgoing messages.

Default Mail Relay
Relay To
(Optional) Type an optional hostname or IP address of a mail server (not this system) to which
to relay mail for all email with unspecified destinations. A recipient’s email domain is checked
against the mail routing table. If the destination is not specified, the email is sent to the Default
Mail Relay server for delivery. Use this option when the WatchGuard XCS cannot deliver email
directly to remote mail servers. If you are setting up this system as a dedicated WebMail
system, and all mail originating from this system should be forwarded to another mail server for
delivery, then specify the destination mail server here.
WarningDo not enter the name of your system because this causes a relay loop.
SMTP Port
Type the SMTP port used to deliver mail to the relay. The default is 25.
Ignore MX record
Enable this option to prevent an MX record lookup for this host to force relay settings.
Enable Client Authentication
Enable client SMTP authentication for relaying mail to another mail server. This option is only
used in conjunction with the Default Mail Relay feature. This allows the WatchGuard XCS to
authenticate to a server that it is using to relay mail. With this configuration, connections to the
default mail relay are authenticated, while connections to other mail routes are not.
User ID
Type a User ID to login to the relay mail server.
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Password
Type and confirm a password for the specified User ID.

Failback Mail Relay
Relay To
Enter an optional hostname or IP address of a mail server (not this system) to be used as the
failback server. In the event the default mail relay is unavailable, the failback server relays mail
for all email with unspecified destinations.
SMTP Port
Type the SMTP port to use to deliver mail to the relay. The default is 25.
Ignore MX record
Enable this option to prevent an MX record lookup for this host to force relay settings.

BCC (Blind carbon copy) All Mail
The WatchGuard XCS offers an archiving feature for organizations that require storage of all email that
passes through their corporate mail servers. This option sends a blind carbon copy (BCC) of each
message that passes through the system to the specified address. This address can be local or on any
other system. Once copied, the mail can be effectively managed and archived from this account. You
must also specify an address that receives error messages if there are problems delivering the BCC
messages.

Delivery Notifications
You can customize Delivery Failure Notification, Delivery Delay Warning, and Delivery Success
Notification messages. To enable or disable Delivery Status Notifications (DSN) usage, go to the
Configuration > Mail > Access page.
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Hide Internal Relays in Notifications
You can exclude the host names and IP addresses of internal relays from Delivery Status Notifications
(including success, failure, and delivery delay notifications). An internal relay includes any system for
which the XCS has a configured mail route or virtual mapping, such as a local mail server.
To exclude host names and IP addresses from notifications, select Configuration > Mail > Delivery
> Advanced, and then select the Hide internal relays in notifications check box.
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Advanced Mail Delivery Options
Click the Advanced button to reveal additional options for Advanced SMTP Settings, SMTP
notifications, and the Received Header.

Advanced SMTP Settings
You can configure these advanced SMTP settings:
SMTP Pipelining
Select the check box to disable SMTP Pipelining when delivering mail. Some mail servers may
experience problems with SMTP command pipelining. You may have to disable this feature if
required.
ESMTP
Select the check box to disable ESMTP (Extended SMTP) when delivering mail. Some mail
servers may not support ESMTP. You may have to disable this option if experiencing problems.
WarningDisabling ESMTP disables TLS encryption on outgoing connections.
ESMTP with Cisco PIX
Select the check box to disable ESMTP if the WatchGuard XCS detects that a Cisco PIX is in
front of the destination MTA. Older Cisco PIX firewalls only allow basic SMTP commands when
you use the "smtp fixup" or Mail Guard feature, and any attempt to use ESMTP commands,
including those used in the TLS setup, are rejected as an unrecognized command.
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HELO required
Enable this option to require clients to initiate their SMTP session with a standard HELO/EHLO
sequence. It is recommended that you leave this feature enabled. It should only be disabled
when experiencing problems with sending hosts that do not use a standard HELO message.
Content Reject Message
This is the text part of the SMTP 552 error message that is reported to clients when message
content is rejected because the maximum message size has been exceeded.
Multiple Recipient Reject Mode
Indicates the reject handling of messages with multiple recipients. This option only applies to
features with reject actions, for example, Malformed and Very Malformed Mail, Attachment
Control, Content Scanning, Pattern Filters, OCF, Anti-Virus, and Intercept Anti-Spam features.
This includes features defined in a policy.
n

n
n

All – Reject the message if all recipients reject the message. If some but not all of the
recipients reject the message, the message is discarded without notification to the sender
for those recipients that rejected the message.
Any – Reject the message if any recipient rejects the message.
Never – The message is never rejected, regardless of any configured reject actions. For
recipients that rejected the message, the message is discarded without notification to the
sender.

Send EHLO
Always send EHLO when communicating with another server, even if their banner does not
include ESMTP. Disable EHLO if you are experiencing communications problems with specific
SMTP servers.
WarningDisabling EHLO disables TLS encryption on outgoing connections.
Hide internal relays in notifications
Select this option to exclude the host names and IP addresses of internal relays from Delivery
Status Notifications (including success, failure, and delivery delay notifications). An internal
relay includes any system for which the XCS has a configured mail route or virtual mapping,
such as a local mail server.

SMTP Notification
Administrators can select the type of notifications that are sent to the postmaster account. Serious
problems, for example, resource or software issues, are selected by default for notification.
Resource
Mail not delivered due to resource problems, for example, queue file write errors.
Software
Mail not delivered due to software problems.
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Bounce
Send postmaster copies of undeliverable mail. If mail is undeliverable, a single bounce
message is sent to the postmaster with a copy of the message that was not delivered. For
privacy reasons, the postmaster copy is truncated after the original message headers. If a
single bounce message is undeliverable, the postmaster receives a double bounce message
with a copy of the entire single bounce message.
Delay
Inform the postmaster of delayed mail. In this case, the postmaster only receives message
headers.
Policy
Inform the postmaster of client requests that are rejected because of policy restrictions.
The postmaster receives a transcript of the entire SMTP session.
Protocol
Inform the postmaster of protocol errors (client or server), or attempts by a client to execute
unimplemented commands. The postmaster receives a transcript of the entire SMTP session.
Double Bounce
Send double bounced messages to the postmaster.

Received Header
The Received Header is the mail server information displayed in the Received: mail header of a
message. You can modify the default WatchGuard XCS name to a generic identifier to prevent
attackers from knowing the server details.
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Annotations
You can enable and customize plain text and HTML annotations that are appended to all outbound
messages. The annotation is a global option that you can use to append legal and policy notices,
disclaimers, or a custom mail footer to all messages leaving your organization. You can also use
policies to enable separate annotations for different users, domains, and groups.
To enable and configure annotations:
1. Select Configuration > Mail > More > Annotation.
2. Select the Enable Annotation check box.
3. In the Plain Text Annotation text box, type the text for the annotation.
This text is appended as an annotation to all plain-text (text/plain) messages.

4. In the HTML Text Annotation text box, type the text for the HTML annotation.
This text can include HTML markup characters. This text is appended as an annotation to all HTML
messages (text/html).

5. Click Apply.

To configure annotations in a policy:
1.
2.
3.
4.
5.
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Select Security > Policies > Policies.
Select a policy to configure or create a new policy.
Edit the Email settings of the policy.
Inthe Annotationssection, enableor disableannotations forthe policy and editthe annotationtext.
Click Apply.
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System Variables for Notifications
System variables are system and message settings that are automatically substituted at the time a
notification message is sent. For example, you can insert the system hostname and sender/recipient
fields of a message into a notification generated by Anti-Virus and Content Control features, and also
delivery status notifications.
Note Not all variables work with all notification features. None of these system variables
can be used with the SMTP Banner or SMTP Content Reject message.
These system-wide variables are available:
Variable

Description

Example

%PROGRAM% or
%PRODUCT%

Product name

WatchGuard XCS

%HOSTNAME%

Hostname entered on the Network
mail.example.com
Settings page.

%POSTMASTER_MAIL_
ADDR%

Email address of the admin user.

%DISPN%

Disposition or Action for a
message. Applicable only to
notifications for message content
security and management
quarantined
features, for example, Anti-Virus,
Attachment Control, OCF,
Content Scanning, and Malformed
Mail.

%QUEUEID%

The Queue ID of a mail message.
This ID is used to track the
message when being processed
by the system.

admin@example.com

CE9D0C23183D8E2B

You can only use this variable in
Annotations.

%SUBJECT%

116

The Subject header field of the
original message.

"Meeting Minutes"

WatchGuard XCS

Configure Mail Delivery

Variable

Description

Example

%DELAY_WARN_TIME%

Time before Delay Warning. Only
applicable in Configuration >
Mail > Delivery in the Delivery
Delay Warning section.

4 hours

%MAX_QUEUE_TIME%

Maximum Time in Mail Queue.
Only applicable in Configuration
> Mail > Delivery in the Delivery
Delay Warning section.

5 days

%S_YOU% (%SENDER%)

The Mail address of the sender.
Applicable only to notifications for
message content security and
management features, for
example, Anti-Virus, Attachment
Control, Malformed Mail, etc.
Cannot be used in Delivery failure
notifications.

sender@example.com

The Mail address of the recipient.
Applicable only to notifications for
message content security and
management features, for
%R_YOU% (%RECIPIENT%)
example, Anti-Virus, Attachment
Control, Malformed Mail, etc.
Cannot be used in Delivery failure
notifications.

recipient@example.com

%SPAM_FOLDER%

The name of the spam folder for
the user spam quarantine. Only
applicable to the User Spam
Quarantine feature.

spam_quarantine

%SPAM_EXPIRY%

The number of days before
quarantined spam is expired. Only
applicable to the User Spam
Quarantine feature.

30

%SPAM_MESSAGES%

The information for a spam
message (Date, From, Subject).
Only applicable to the User Spam
Quarantine.

05/27/09, joe@example.com,
File for you

%WEBMAIL_URL%

The URL of the configured
WebMail server. Only applicable
to the User Spam Quarantine and
other features that use WebMail.

http://hostname.example.com/

%NUMSPAM%

Number of spam messages in the

20
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Variable

Description

Example

spam folder. This information is
sent in a spam summary digest
and is only applicable to the User
Spam Quarantine.

%NUMSPAMSTAT%

Number of spam messages and
bytes used in the spam folder.
This information is sent in a spam
summary digest and is only
applicable to the User Spam
Quarantine.

20,10000

From and Subject Headers in Notification Messages
You can specify the From: and Subject: header fields in email notification messages sent from the
WatchGuard XCS, such as delivery notification messages and scanning feature notifications.
Note Attachment stripping does not allow any header fields in the notification template.
The From: header can include the mail address part and mail name part. For example, you can specify
From: Admin <admin@example.com> , where "admin@example.com" is the mail address and "Admin"
is the mail name.
You can specify the From: header as:
n
n
n

User name <user@example.com>
<user@example.com>
user@example.com

The Subject: header is the subject line for the notification message. Both the From: and Subject:
headers are limited to 256 characters. If you specify both a From: and Subject: header, they must be
followed by a blank line. Any of the system variables can be used with the Subject header field, for
example, %SUBJECT% and %DISPN%.
For example, the notification for an Attachment Control policy violation can be specified as:
From: Admin <admin@example.com>
Subject: Attachment Control Policy Violation in message %SUBJECT%
This is an automated message from the %PROGRAM% at host %HOSTNAME%.
A mail from %S_YOU%(%SENDER%) to %R_YOU%(%RECIPIENT%) was stopped
and %DISPN% because it contains one or more forbidden attachments.

Note Non-US ASCII text found in the Subject: or From: header name part will be
automatically converted to RFC 2047 compliant UTF-8 quoted-printable format.
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Mail Aliases
When mail is delivered locally, the delivery agent runs each local recipient name through the aliases
database. If an alias exists, a new mail message is created for the named address or addresses. This
mail message is returned to the delivery process to be mapped and routed. This process also occurs
for local user accounts with a specified forwarder address. Local user accounts are treated as aliases
in this case.
Local aliases are typically used to implement distribution lists, or to direct mail for standard aliases.
For example, the alias postmaster can resolve to the local mailboxes admin1@example.com, and
admin2@example.com. For distribution lists, an alias called sales@example.com can be created that
points to all members of the sales organization of a company.
To add a mail aliases:
1. Select Configuration > Mail > Aliases.
2. Click Add Address.

3.
4.
5.
6.

In the Alias Name text box, enter a descriptive alias name.
In the Address text box, type the corresponding mail addresses for the alias.
Click Add More Addresses button to add multiple addresses for this alias.
Click Apply.

Upload Alias Lists
You can upload a list of aliases in a text file. The file must contain comma or tab separated entries.
Use this format:
[alias],[mail_address]

For example:
sales,fred@example.cominfo,mary@example.com

You must use a text editor to create the file alias.csv.
To update an alias file:
1. To download the alias list from the WatchGuard XCS, click Download File.
2. Open the file and update the alias list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
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LDAP Aliases
Click LDAP Aliases to configure and search for aliases with LDAP. This allows you to search LDAPenabled directories, for example, Active Directory, for mail aliases. See LDAP Aliases for more
detailed information.
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Mail Mappings
Mail Mappings map an external address to an internal address and vice versa. This is useful for hiding
internal mail server addresses from external users. For mail originating externally, the mail mapping
translates the address in the To: and CC: mail header field into a corresponding internal address that is
delivered to a specific internal mailbox.
For example, you can redirect mail addressed to joe@example.com to the internal mail address
joe@chicago.example.com. This delivers the message to the user’s preferred mailbox.
Mail originating internally has the address in the From:, Reply-To:, and Sender: header modified by a
mail mapping to appear to come from the preferred external form of the mail address,
joe@example.com.
To add a mail mapping:
1. Click Configuration > Mail > Mapping.
2. Click Add.

3. In the External mail address text box, type the email address that you want to convert to the
specified internal email address for incoming mail.
The specified internal address is converted to this external address for outgoing mail.

4. In the Internal mail address text box, type the mapped address for the specified external
address for incoming mail.
The internal address is converted to the specified external address for outgoing mail.

5. In the New text box, type any additional internal mappings that are included in the outgoing mail
conversion.
Click Add for each entry.
6. Click Apply.

Upload Mapping Lists
You can upload a mappings list in a text file. The file must contain comma or tab separated entries.
Use this format:
[type ("sender" or "recipient")],[map_in],[map_out],[value ("on" or "off")]

For example:
sender,joe@chicago.example.com,joe@example.com,on

You must use a text editor to create the file mailmapping.csv.
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To update a mapping file:
1. To download the mapping list from the WatchGuard XCS, click Download File.
2. Open the file and update the mapping list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.

Mail Mapping as Access Control
You can block all incoming and outgoing mail messages that do not match a configured mail mapping.
This feature makes sure that all incoming and outgoing mail matches a legitimate user as the
destination or source of a message.
To configure access control:
1. Click Preferences.
2. Select the Enable Mail Mapping Access Control check box.
3. Click Apply.
Note these issues when you enable Mail Mapping as Access Control:
n
n
n
n

n
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Any users that send or receive mail require a mail mapping
The mailer-daemon address bypasses the access control list and does not require a mapping
The postmaster address bypasses the access control list and does not require a mapping
These addresses must be added as mail mappings to make sure system-related messages can
be sent out and received:
o The admin user, for example, admin@example.com
o Users configured to receive emailed reports
o The user specified as the recipient in the Problem Reporting feature
If you enable access control, all incoming and outgoing mail is blocked unless the user has a
mapping listed in the mail mappings table.
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Virtual Mappings
Virtual Mappings redirect mail addressed for one domain to a different domain. This process is
performed without modifying the To: and From: headers in the mail, because virtual mappings modify
the envelope-recipient address.
For example, you can accept mail for the domain @example.com and deliver it to
@sales.example.com. This allows the system to distribute mail to multiple internal servers based on
the Recipient: address of the incoming mail.
Virtual mappings are useful for acting as a wildcard mail mapping, for example, mail for example.com
is sent to exchange.example.com. Virtual mappings are also useful for ISPs who need to accept mail
for several domains, and situations where the envelope-recipient header must be rewritten for further
delivery.
You should review the use of mail routes before you create virtual mappings because they are more
appropriate for delivering mail to internal mail servers.
Note When you use Virtual Mappings, the Reject on Unknown Recipient and LDAP
Recipient lookups are not performed for these mapped addresses. These email
addresses are not rejected because the virtual mappings do not exist in an LDAP
directory.
To configure virtual mappings:
1. Select Configuration > Mail > Virtual Mapping.
2. Click Add Virtual Mapping.

3. In the Input text box, type the domain or address to which incoming mail is directed.
For example, @example.com .
4. In the Output text box, type the domain or address to which mail is redirected.
For example, @sales.example.com
Note The domain that is virtually mapped or redirected must be defined in an "internal" DNS
MX record to connect to this WatchGuard XCS.

Upload Virtual Mapping Lists
You can upload a list of virtual mappings in a text file. The file must contain comma or tab separated
entries.
Use this format:
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[map_in],[map_out]

For example:
user@example.com,user
user@example.com,user@sales.example.com
@example.com,@sales.example.com

You must use a text editor to create the file virtmap.csv.
To update a mapping file:
1. To download the mapping list from the WatchGuard XCS, click Download File.
2. Open the file and update the mapping list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.

LDAP Virtual Mappings
Click LDAP Virtual Mappings to configure and search for virtual mappings with LDAP. This allows
you to search LDAP-enabled directories, for example, Active Directory, for virtual mappings.
See LDAP Virtual Mappings for more detailed information.
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Queue Replication
The Queue Replication feature enables mail queue replication and failover between two WatchGuard
XCS devices. In the event that the primary owner of a mail queue is unavailable, the mirror system can
take ownership of the mirrored mail queue for delivery.
Queue replication actively copies any queued mail to the mirror system, ensuring that if one system
should fail or be taken offline, the mirror system can take ownership of the queued mail and deliver it. If
the source system successfully delivers the message, the copy of the message on the mirror server is
automatically removed.
Without queue replication, a system with received and queued messages that have not been delivered
can result in lost mail if that system suddenly fails. In large environments, this could translate into
hundreds or thousands of messages.
In this diagram, System A and System B are configured to be mirrors of each other’s mail queues.

When a message is received by System A, it is queued locally and a copy of the message is also
immediately sent over the failover connection to the mirror queue on System B.
If System A fails, administrators can login to System B and take ownership of the queued mail to
deliver it. Messages are exchanged between the systems to make sure that the mirrored mail queues
are properly synchronized, which prevents duplicate messages from being delivered when a failed
system comes back online.
To configure Queue Replication:
1. Select Administration > Multi-System Management > Queue Replication.
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2.
3.
4.
5.

Select the Enable Queue Replication check box.
Click Apply.
Select Configuration > Network > Interfaces.
Go to the Queue Replication section.
These options only appear in the Network settings page after you enable Queue Replication.

6. Select the Enable Replication check box.
7. In the Replication Host text box, type the IP address of the host that is backing up mail for this
WatchGuard XCS.
If you configure Queue Replication in a cluster, you can use the interface connected to the
cluster network for replication. Specify the hostname of the host cluster system, for example,
SystemA , in the address SystemA.example.com.
8. In the Replication Client text box, type the IP address of the client that is backing up its mail
queue to this WatchGuard XCS.
If you configure Queue Replication in a cluster, you can use the interface connected to the
cluster network for replication. Specify the hostname of the host cluster system, for example,
SystemB , in the address SystemB.example.com.
9. From the Replication I/F drop-down list, select the network interface to use for queue
replication.
This network interface must be connected to a secure network. We recommend that queue
replication and clustering functions be run together on their own dedicated subnet.
10. Click Apply.
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Import and Process Mirrored Messages
If you have two WatchGuard XCS devices that are mirroring each other’s mail queues, and one of
those devices fails, you must go to the mirror server and import the mirrored mail to make sure that it is
processed and delivered. To import the mirrored messages:
1. Make sure that the host system is unavailable.
Before you import any mirrored mail, you must make sure that the host system is not
processing mail. If you import and process the mirrored mail on the mirror system, this can
result in duplicate messages if the host system starts to function again.
2. On the mirror device, select Administration > Multi-System Management > Queue
Replication.
The Queue Replication page appears.

The Mirrored Messages value indicates the current amount of queued mail that is mirrored on
this WatchGuard XCS.
3. Click the Review Mirrored Messages button to review any mail in the local queue that is
mirrored from the source device.
4. To take ownership and process the mail that is mirrored for the source device, click Deliver
Mirrored Messages.
WarningDo not click the Deliver Mirrored Messages button unless you are certain
that the source system is unable to deliver mail.
You can also perform these functions from the Queue Replication page:
n

n

n

In the Replication Timeout text box, type the time interval, in seconds, to contact the host
system before timing out. The default is 5 seconds.
Click Replicate to Host to replicate the queue to the mirror host system immediately. The mail
queues are automatically updated when a message is first received, and the queues are also
synchronized at regular intervals.
Click the Purge Mirrored Messages button to delete any mail messages in the local mirror
queue. These are the files that are mirrored for another host device.
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Message Archiving
Archiving support allows organizations to define additional mail handling controls for inbound and
outbound mail. These features are especially important for organizations that must archive certain
types of mail for regulatory compliance or other corporate security policies.
Mail is categorized and selectively archived for different levels of importance. By providing the ability to
classify and archive messages at different levels, mail of high importance or compliance classification
can be archived, while you can configure different actions for mail of lower importance. These features
also prevent the waste of unnecessary resources by ignoring spam messages and other types of
unwanted mail when archiving messages.
The WatchGuard XCS integrates with third-party archiving servers to archive email messages with
pattern filters that classify messages and route them to the appropriate archiving server or an archive
email address, while still delivering the email to the original recipients. Mail headers added to an
archived message by the WatchGuard XCS allow you to customize archiving services for efficient
retrieval of archived messages.

You can use archiving with Pattern Filters, the Objectionable Content Filter, and Content Scanning.
When the WatchGuard XCS receives a message, these features search for text within a message and
its attachments. When this text is found, an action is performed to classify the message for archiving
into one of three categories: Archive High, Archive Medium, and Archive Low.
The WatchGuard XCS then applies the archiving action for each category. For example, messages
categorized as Archive High can have an action of Archive copy to, with the action data identifying
the archiving email address or the mail route to which to archive mail to.

Configure Message Archiving
To configure Message Archiving:
1. Select Configuration > Mail > Archiving.
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Configuration fields for three classifications of archiving appear for High, Medium, and Low
Importance archiving actions.

2. Select the Active check box.
3. In the Action Name text box, type a name to display as the archiving action for the Pattern
Filter, Objectionable Content, and Content Scanning features.
4. From the Action drop-down list, select Archive copy to to send the message to an archive
server.
5. In the Action Data text box, type an email address or the name of the mail route for the
destination archiving server.
If you enter an email address, this is a mailbox that contains all archived messages. Your
archiving server can pull its data for the archived messages from this mailbox.
To use a mail route to route mail to the archiving server, set the Action Data to archive_high_
reroute, archive_medium_reroute, or archive_low_reroute as required.
You must create a corresponding mail route on the Configuration > Mail > Routing page. Mail
routes are not required if you archive to an email address.
6. To add an archive header to the message when it is sent to the destination archive server,
select the Add header Enabled check box.
This allows the archiving server to store that message according to its classification in the
header and allow for more efficient retrieval of the message.
7. In the Header data text box, enter the header that is added to the message header.
For example, X-Archive: high
8. To send a notification to when a message is archived, select Notify Recipients, Notify
Sender, or Notify Administrator.
9. Click Apply.
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Define Mail Routes for Archiving
When you use the mail routing method for archiving messages, you must define mail routes to the
archiving server to make sure that the WatchGuard XCS knows where to send messages for the
appropriate message archiving classification.
For each archiving classification, a corresponding mail route must created:
For archive_high_reroute, use: .archive_high_reroute
For archive_medium_reroute, use: .archive_medium_reroute
For archive_low_reroute, use: .archive_low_reroute
To set up mail routes for archiving:
1. Select Configuration > Mail > Routing.
2. Type the domain, for example,.archive_high_reroute , and type the destination address of
the archiving server.
3. Click Add.
Note Mail routes are not required when you archive to an email address.

Configure Content Control Filters for Archiving
To classify messages for archiving, you must configure the content control features, for example,
Pattern Filters, Objectionable Content filtering, and Content Scanning, to search for text in a message
or its attachment. The corresponding action is the archive classification, for example, “Archive High”.

Configuring Pattern Filters for archiving
1. Select Security > Content Control > Pattern Filters.
2. Click Add.
3. Create a pattern filter for the required specific text.
For example, search for an inbound message subject that starts with the word “Compliance”.
4. Set the Action to the appropriate archive action, for example, Archive High.
5. Click Apply.

Configuring OCF for Archiving
The Objectionable Content Filter can be used to classify and archive messages. You can create
custom dictionaries for content specific to your organization. When the OCF feature finds a word from
these dictionaries, an archive action is applied.
1.
2.
3.
4.
5.
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Select Security > Content Control > Objectionable Content.
Enable the OCF feature.
Select your customized dictionary file, for example, “Archive”.
Set the Action to the appropriate archive action for this dictionary file, for example, Archive Low.
Click Apply.
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Configure Policies for Archiving
You can use policies to customize archive actions for different domains or groups of users. When you
create a policy, the Content Scanning feature provides actions for archiving when specific text is found
in an attachment. The Content Scanning feature requires a dictionary file to match against the
attachment content, and a corresponding archiving action to perform.
1.
2.
3.
4.
5.

To configure a policy definition:
Enable Content Scanning globally from Security > Content Control > Content Scanning.
Select Security > Policies.
Select the Content Control tab.
In the Content Scanning section for inbound messages, select the Compliance Dictionary to
use for matching text, for example, “Archive”.
6. Set the Action to the appropriate archive action for this dictionary file, for example, Archive
Medium.

Customize Archive Headers with Policies
For each policy definition, you can customize the Archive Header for each archiving classification.
This is configured in the Email policy tab.
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LDAP and Directory Services

LDAP Overview
The WatchGuard XCS utilizes LDAP (Lightweight Directory Access Protocol) services for accessing
directory services for user and group information. LDAP can be used with the WatchGuard XCS for
mail routing, group membership lookups for policies, user lookups for mail delivery, alias and virtual
mappings, and remote authentication.
LDAP is designed to provide a standard for efficient access to directory services using simple data
queries. Most major directory services, for example, Active Directory, support LDAP but each differs in
their interpretation and naming convention syntax. Other types of supported LDAP services include
OpenLDAP and iPlanet.

Naming Conventions
The method for which data is arranged in the directory service hierarchy is a unique Distinguished
Name.
This diagram is an example of a Distinguished Name in Active Directory:
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cn=jsmith,dc=example,dc=com

In this example, “cn” represents the Common Name, and “dc” is the Domain Component. The user
jsmith is in the users container. The domain component is analogous to the FQDN domain name, in
this example, example.com.
Note For all LDAP Directory features, you must make sure you enter values specific to your
LDAP environment and schema.
Common names are not always unique. Another way to reference user objects is by their login name
that is a unique identifier within an organization. Another DN for John Smith is:
UID=jsmith,CN=Canada,DC=example,DC=com

This second DN is different from the first example, but points to the same user object, and uses a
different RDN name to identify the local entry. The root of the directory is called the base DN. The base
DN is typically set to closely match the DNS name for the server. The base DN uses the Domain
Components (dc) attribute to distinguish its DNS zones. The administrator may want to make the
directory structure different than the DNS structure to have more flexibility in its design. Similar to
DNS, the TLD is one zone with the registered name of the domain is another zone.
DNS name: example.com
Base DN: dc=example, dc=com

The objectClass attribute defines the entry rules. The objectClass attribute is mandatory for all entries
in the directory. It describes the content of the entry by specifying which other attributes are
mandatory, and which are optional. An entry is assigned multiple objectClass attribute pairs. The
schema of the directory determines which objectClasses are available. Some examples of common
objectClasses are:
objectClass group
objectClass computer
objectClass user
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objectClass container

LDAP Schema
The directory schema defines the rules the directory can use when to save and store the data. The
schema governs what types of objects are populated, which attributes are allowed, the structure of
those attributes, and what the valid compare operators are. “Greater than”, “less than”, and “equal to”
are common compare operators. The minimum set of schema objects required by LDAP allows us to
browse the directory structure. A directory schema can be extended beyond its default design to
conform to the data requirements of an organization. Most directories have a single schema that is
shared throughout the entire directory. Others directories can have different schemas for different
sections of the directory.

LDAP Components
LDAP is a term commonly used in the technology field to describe a group of functions. There are
several different components that encompass LDAP technology.

Clients
The LDAP client used to query a directory can be a stand-alone piece of software, or can it can be
integrated into other applications. When integrated, LDAP works seamlessly, and its functions are
unknown to the user or administrator. LDAP is used by large organizations because of its flexibility
between the client and the server, and its ease of client integration with existing software. Because the
naming conventions are the same for directory servers, LDAP clients can support many different
LDAP implementations from different vendors.

Protocol
LDAP uses TCP/IP for its interface to the network and its hosts. For LDAP to communicate with a
directory server, it must establish a TCP session. The LDAP protocol encodes the attribute value data
that passes between the server and client. Any LDAP client can speak to any LDAP enabled server
because of the standard application programming interface (API). The LDAP protocol also supports the
use of Unicode UTF-8 to support non-English languages.

Operations
LDAP has very few operations available to lower the complexity of the protocol for the client programs.
These are categories of the operations and their functions:
Category

LDAP Operations

Client Session

Bind, unbind, abandon

Query and Retrieval

Search and compare

Modification

Add, modify, modifyRDN, delete

Extended

Extended
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Client Session Operations
Session operations control access to the directory server using the bind, unbind, and abandon
operations. When a client binds to the directory server, its identity can be used to decide the level of
permissions the client has when accessing the objects. The bind operation is similar to a login. Any
other operation you use to interact with the server requires a successful bind to the directory. To
perform this operation requires a user name and password, or you can use an anonymous bind.
Note For most LDAP servers, binding anonymously to the server does not allow you
access to all the information you would be able to obtain if you had used an actual
login and password.
The unbind operation closes the LDAP session to the server, and the abandon operation allows the
client to cancel an outstanding operation request.

Query Operations
The query operations are used the when applications are integrating with a directory server. These
operations search and retrieve the information from the directory server. The “search” operation is most
frequently used because you typically do not know the location of the information you want to obtain.
Through the use of string parameters, an LDAP client can perform sophisticated queries to search for
data within the directory. The “compare” operation can take a value and verify it against a directory
object or attribute. The LDAP client sends the values of the attribute pair, and the server responds with
a “success” if it matches, or a failure if it does not match.
You can use filter operations in LDAP queries to help narrow down or widen the scope of the search.
You can use these boolean operators when you perform a query:
LDAP Filter
Character

Boolean Operator

&

AND

|

OR

!

NOT

These operators precede the filter they modify. A normal search string to find all user objects is:
(objectCategory=person)

A search string to find a specific user object is:
(&(objectCategory=person)(name=John Smith))

A search string to return all user objects except for those in the admin group “admins” is:
(objectCategory=person)(!(&(objectCategory=person)(memberOf=admins)))
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Modification Operations
Modification operations allow changes to be made to the data within the directory. Operations, for
example, “add”, “modify”, and “delete”, are standard and self-explanatory. The modifyRDN operation
allows the client to change the name of an entry and to move the entry to a different container.
Depending on the access permissions (determined when binding to the directory), some modifications
are not allowed. For example, a read-only branch of the directory does not allow any of the modification
operations to be processed.

Extended Operations
Extended operations are unique for each directory server and client. They are used as a placeholder for
custom protocol expansions but still defines the syntax to be used.

Security
The LDAP protocol supports the use of SSL (Secure Sockets Layer) for its data encryption privacy.
Encrypting the session between the client and the directory server makes sure that computers sniffing
the traffic in the network cannot read any of the data within the session. Authentication is handled by
the client bind operation. After a successful bind to the directory server, the authorization dictates
which objects are available to the user. This can also include an anonymous user situation where no
bind operation was performed before a query.
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Directory Servers
The WatchGuard XCS uses the directory servers you specify for all LDAP functions. This includes
user and group membership confirmation, authentication, and mail routing.
To configure Directory Servers:
1. Select Configuration > LDAP > Directory Servers.
The Directory Server page appears.

2. To configure a new directory server, click Add.
To modify an existing server, click Edit.

3. In the Server URI text box, type the URI (Uniform Resource Identifier) address for the server.
For example, ldap://10.0.2.120 .
If you use SSL with the LDAP server directory, type ldaps instead of ldap .
If you use a port other than the default 389 for LDAP or 636 for LDAPS, append the URI with a
colon and the port number.
For example, ldap://10.0.2.120:80 .
To query an Active Directory global catalog, add the port number 3268 to the server URI.
For example, ldap://10.0.2.120:3268 .
For IPv6, make sure the address is enclosed in square brackets.
For example, ldap://[a123:b123::c123] or ldap://[a123:b123::c123]:80
4. In the Label text box, type a name or alias for the LDAP server.
5. From the Type drop-down list, select the type of LDAP server you specified.
If you use an OpenLDAP or iPlanet server, select Others.
6. Select the Bind check box.
7. In the Bind DN text box, type the DN (Distinguished Name) for your directory server.
For example, for Active Directory, type: cn=Administrator,cn=users,dc=example,dc=com
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Older Windows login names, for example, DOMAIN\Administrator , are also supported. Make
sure that you select a bind DN specific to your environment.
In Active Directory, if you use an account other than Administrator to bind to the LDAP server,
the name must be specified as the full name, not the account name. For example, use “John
Smith” instead of “jsmith”.
8. In the Bind Password text box, type the password to use for the LDAP server.
9. In the Search Base text box, type the default search base for account lookups.
For example, dc=example,dc=com .
10. In the Timeout text box, type the maximum amount of time, in seconds, to wait for the search
to complete.
You can set the timeout value to between 1 and 100 seconds.

11. From the Dereference Aliases drop-down list, select the method to use for to dereference
aliases in a directory search:
n
n

n
n

Never – Aliases are never dereferenced.
Searching – Aliases are dereferenced in subordinates of the base object, but not when the
base object of the search is found.
Finding – Aliases are only dereferenced when the base object of the search is found.
Always–Aliasesaredereferencedwhenthebaseobjectofthesearchissearchedforandfound.

12. To enable paging support for an Active Directory server, select the Paged check box.
When a query is sent to an LDAP server, the amount of information returned could contain
thousands of entries and sub-entries. Paging enables the information from the LDAP server to
be retrieved in more manageable sections to control the rate of data return.
13. In the Page Size text box, type the maximum number of entries to be returned in a query to the
Active Directory server. The default setting is 1000.
If you do not type a new setting, the default value of 1000 is used. The setting you select must
match the size configured in the LDAP query policy for the Active Directory server.
14. Click Test.
A test query is sent to the LDAP server to test your LDAP settings.

15. Click Apply.
Note If you delete an LDAP server, this removes all additional configuration items based on
that server, for example, Directory Users, Groups, and Aliases.
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Test LDAP Servers
To test your LDAP server configuration:
1. Select Configuration > LDAP > Directory Servers.
The Directory Server page appears.

2. Click Test.
The LDAP Debugging page appears.

3. Click Submit LDAP Query.
If the remote server does not respond, this error message appears:
ldap_bind: Can't contact LDAP server (81)

If the user you used to bind to the LDAP tree does not have enough permissions, this message
appears:
ldap_bind: Invalid credentials (49)
additional info: 80090308: LdapErr: DSID-0C09030B, comment:
AcceptSecurityContext error, data 525, v893

This is typically caused by a wrong user name or password.
If the search base you specify does not exist, this message appears:
# extended LDIF
#
# LDAPv3
# base with scope sub
# filter: (objectClass=*)
# requesting: ALL
#
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# search result
search: 2
result: 32 No such object
matchedDN: DC=example,DC=com
text: 0000208D: NameErr: DSID-031001BD, problem 2001
(NO_OBJECT), data 0, best match of:
'DC=example,DC=com'
# numResponses: 1

Search the LDAP Tree
You can choose a specific type of object to find in the LDAP query field. For example, if you want to
search for users, use the filter: (ObjectCategory=person) . This displays all users within the specified
search base.
If you specify a search filter in the LDAP Query field, this displays every single record with all the
attributes associated with the selected search filter.
To narrow the search results, you can specify LDAP attributes to format the display so that only certain
attributes are displayed for each returned object. In addition, there is an attribute called ObjectClass
and the value is also equal to “user” in each user object, but (ObjectClass=user) returns a computer
object as well.
To search for all user objects (this includes group information) with the email domain example.com,
and display the mail attribute of each object in the result, use this query:
(mail=*example.com)

The results of the query are similar to this message:
# extended LDIF

# LDAPv3
# base with scope sub
# filter: (mail=*@example.com)
# requesting: mail
#

# techsupport, users, example.com
dn: CN=techsupport,OU=users,DC=example,DC=com
mail: techsupport@example.com

# sales, users, example.com
dn: CN=sales,OU=users,DC=example,DC=com
mail: sales@example.com
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# Joe TS. Smith, users, example.com
dn: CN=Joe TS. Smith,OU=users,DC=example,DC=com
mail: jsmith@example.com

# Ken R. Simon, users, example.com
dn: CN=Ken R. Simon,OU=users,DC=example,DC=com
mail: ksimon@example.com

# Andrew Y. Roberts, users, example.com
dn: CN=Andrew Y. Roberts,OU=users,DC=example,DC=com
mail: aroberts@example.com

# Kathy J. Norman, users, example.com
dn: CN=Kathy J. Norman,OU=users,DC=example,DC=com
mail: knorman@example.com

# search result
search: 2
result: 0 Success

# numResponses: 7
# numEntries: 6

If you want to search for users only, use this LDAP Query: (&(ObjectCategory=user)
(mail=*example.com))

If you want to display the login name for each object returned, use sAMAccountName as the LDAP
attribute instead of mail .
The results of the query are similar to this message:
# techsupport, users, example.com
dn: CN=techsupport,OU=users,DC=example,DC=com
sAMAccountName: techsupport
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Directory Users
Use the Directory Users feature to import user account and group membership data from LDAP-based
directory servers. This information is used by the Intercept Anti-Spam Reject on Unknown Recipient
feature to provide LDAP lookups for valid email addresses and to import group membership information
for policies.
Note Only groups that the imported users belong to are imported. Group Policy must be
enabled before you import users and groups if you use the information for Group
policies.
You can create local mirror accounts to allow directory-based users to view and manage quarantined
mail for the Spam Quarantine feature.
To configure Directory Users:
1. Select Configuration > LDAP > Directory Users.
The Directory User page appears.

2. Click Add.

3. From the Directory Server drop-down list, select a server to perform the search.
4. In the Search Base text box, type a Search Base string with information specific to your LDAP
hierarchy.
For example: cn=users,dc=example,dc=com .
5. From the Scope drop-down list, select the scope of the search.
n
n
n

Base – Searches the base object only.
One Level – Searches objects beneath the base object, but excludes the base object.
Subtree – Searches the entire subtree of which the base distinguished name is the
topmost object, and includes the base object.

6. In the Query Filter text box, type a filter to return the user account information.
For example, for Active Directory, type:
(|(objectCategory=group)(objectCategory=person)(objectCategory=publicFolder))
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This query filter includes mail-enabled Exchange public folders to prevent them from being
rejected if Reject on Unknown Recipient is enabled.
For iPlanet and OpenLDAP, type:(objectClass=person)
7. In the Timeout text box, type the maximum interval, in seconds, to wait for the search to
complete.
You can enter values from 1 to 100 seconds.

8. In the Email attribute text box, type the attribute that identifies the user’s email address.
For Active Directory, iPlanet, and OpenLDAP, type: mail .
9. In the Email alias attribute text box, type the attribute that identifies the user’s alternate email
addresses.
For Active Directory, type: proxyAddresses .
For iPlanet, type: Email .
For OpenLDAP, leave this field blank.
10. In the Member Of text box, type the attribute that identifies the groups that the user belongs to
for group policy resolution.
For Active Directory, type: memberOf .
For iPlanet, type: Member .
For OpenLDAP, leave this field blank.
11. In the Account Name Attribute text box, type the attribute that identifies a user’s account
name for login.
For Active Directory, type: sAMAccountName .
For iPlanet, type: uid .
For OpenLDAP, type: cn .
12. Click the Test button to test your LDAP settings.
13. Click Apply.
When the import is complete, you can click Download Imported Users to download a list of users
imported to the XCS via LDAP. You can use the downloaded list to examine the email addresses of
imported and mirrored users to verify the stored information.

Import Settings
You can automatically import LDAP user data on a scheduled basis to stay synchronized with the
LDAP directory.
To import LDAP users and groups:
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1. Select Configuration > LDAP > Directory Users.
The Import Settings: LDAP User page appears.

2. Click Import Settings.

3. To enable automatic import of LDAP user data, select the Import User Data check box.
Automatic import makes sure that your imported LDAP data remains current with the
information on the LDAP directory server.
4. In the Frequency drop-down list, select the frequency of LDAP imports.
n
n
n
n
n

Hourly
Every 3 Hours
Daily
Weekly
Monthly

5. In the Start Time text box, type the start time for the import in the format hh:mm.
For example, to schedule an import at midnight, type: 00:00 .
6. Click Apply.
7. Click Import Now to immediately begin the import of users.
To view the progress of LDAP imports, select Activity > Logs > System.
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Mirror LDAP Accounts
To provide local account access, you can mirror existing LDAP accounts, which creates a local
account on the WatchGuard XCS for each imported user.
This allows directory-based users to view and manage quarantined messages for the Spam Quarantine
and the Trusted/Blocked Senders List features.
Note You cannot use mirror accounts as local mail accounts.
To configure mirror users:
1. Select the Mirror accounts check box.
2. From the Expiry period drop-down list, select an expiration period for mirrored accounts.
If the user no longer exists in the LDAP directory for the specified period of time, the local
mirrored account is deleted. This option only applies to a mirrored account, not accounts used
for the Reject on Unknown Recipients feature.
3. Click Apply.
4. Click Import Now to immediately begin the import of users and create mirrored accounts.
To view the progress of LDAP imports, select Activity > Logs > System.
To view mirrored accounts, select Administration > Accounts > Mirrored Accounts.

Test Directory Users
There are four main attributes specific to Active Directory that the WatchGuard XCS uses for mail
processing:
n
n
n
n

mail
proxyAddresses
memberOf
sAMAccountName

To make sure that the information imported is properly accepted by the WatchGuard XCS, test the
LDAP query and attributes before you import LDAP users.
1. Select Configuration > LDAP > Directory Users.
The Directory User page appears.

2. Click Test.
The LDAP Debugging page appears.
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3. Test the mail attribute with this query:
n

n

For LDAP Query, use the default value: (|(objectCategory=group)
(objectCategory=person)) .
For the LDAP attributes text box, use the mail attribute.

4. Click Submit LDAP Query.
The results display the requested attribute (mail). The WatchGuard XCS uses this as the account
name to create mirrored accounts. There is only one email address returned for each user even though
a user can have multiple messages in an Active Directory/Exchange environment.
To view or modify the primary user in Active Directory:
1. Open Active Directory Users and Computers.
2. Double click on the user.
3. Click the Email Addresses tab.
The Primary account is the one highlighted with type SMTP.

4. To change the Primary email account, select the address you want to make primary and click
Set As Primary.
5. Test the proxyAddresses attribute with this query:
n
n

For LDAP Query, type: (|(objectCategory=group)(objectCategory=person))
For the LDAP attributes field, type: proxyAddresses

6. Click Submit LDAP Query.
The SMTP item in uppercase letters is the primary address (the same as the mail attribute).
The proxyAddresses attribute is used to implement the Reject on Unknown Recipients feature.
The WatchGuard XCS uses this attribute for the mail attributes and to process any additional email
addresses (this includes aliases) associated with the users and groups.
Test the memberOf attribute with this query:
1. For LDAP Query, type:(|(objectCategory=group)(objectCategory=person))
2. For the LDAP attributes text box, type: memberOf
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3. Click Submit LDAP Query.
The sAMAccountName attribute is used as the login name by the WatchGuard XCS when it
authenticates with the Active Directory server. This attribute is not necessarily equivalent to the email
name. To locate the sAMAccountName attribute in Active Directory:
1. Go to user properties in Active Directory Users and Computers.
2. Click the Account tab.
3. The sAMAccountName corresponds to the User Login Name.
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LDAP Aliases
Use LDAP Aliases to search LDAP-enabled directories for user mail aliases. If an alias exists, a new
mail message is created for the named address or addresses. This mail message is returned to the
delivery process and mapped, routed, and processed.
Note LDAP Aliases have only been tested with Active Directory, and the examples shown
are for Active Directory LDAP implementations. In most cases, Active Directory
already performs its own internal alias translations and configuring LDAP Aliases is
not required.
See Mail Aliases for more detailed information on Mail Aliases.
To configure LDAP Aliases:
1. Select Configuration > LDAP > Aliases.
The LDAP Alias page appears.

2. Click Add.

3. From the Directory Server drop-down list, select a server to perform the search.
4. In the Search Base text box, type a Search Base string with information specific to your LDAP
hierarchy.
For example: cn=users,dc=example,dc=com .
5. From the Scope drop-down list, select the scope of the search.
n
n
n

Base – Searches the base object only.
One Level – Searches objects beneath the base object, but excludes the base object.
Subtree – Searches the entire subtree of which the base distinguished name is the
topmost object, and includes the base object.

6. In the Alias Attribute text box, type the attribute that defines the alias mail addresses for a user.
For example, for Active Directory, type: (proxyAddresses=smtp:%s@*)
7. In the Email attribute text box, type the attribute that returns the user’s email address.
8. For example, for Active Directory, type: mail
9. In the Timeout text box, type the maximum interval, in seconds, to wait for the search to
complete.
You can enter values from 1 to 100 seconds.
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10. Click the Test button to perform a test of the LDAP Aliases configuration.
11. Click Apply.

LDAP Web Users
The LDAP Web Users feature allows LDAP-authenticated clients to utilize the system’s Web Proxy
feature.
These clients must use a login and password to authenticate to an LDAP server before they can use
the Web Proxy. LDAP Authentication allows the WatchGuard XCS to authenticate the user directly to
an LDAP directory server without the need to create a local account.
When a user successfully authenticates with the LDAP server, the information is saved in an LDAP
authentication cache on the system for 300 seconds. Any subsequent LDAP requests go to the cache
instead of the LDAP server. This enables a faster response and prevents the LDAP server from being
overloaded with authentication requests. After 300 seconds, the Web Proxy authenticates directly to
the LDAP server again and caches the results if the authentication is successful.
To configure LDAP authentication for web users:
1. Select Configuration > LDAP > Web Users.
The LDAP Authenticated Sessions page appears.

2. Select a method, and then click Add to add an entry.
You can only use one method, Bind or Query Direct, for all defined LDAP servers. You cannot use
both at the same time.

Note The Bind method only works with Active Directory and iPlanet implementations. The
Query Direct method only works with OpenLDAP.
n

n

Bind – The Bind method uses the User ID and password to authenticate on a successful
bind.
The Query Filter must specify the User ID with a %s variable. For example, for Active
Directory, use (sAMAccountName=%s) for the Query Filter. Use mail for the Result
Attribute. For iPlanet, use uid=%s for the Query Filter, and mail for the Result Attribute.
Query Directly – The Query Direct method queries the LDAP server directly to
authenticate a user ID and password. The Query Filter must specify the user ID, and the
Result Attribute must specify the password. For OpenLDAP, use (&
(ObjectClass=inetOrgPerson)(cn=%s)) for the Query Filter, and userPassword for the
Result Attribute.

Note For either method, access is refused if the LDAP server direct query or bind attempt
fails for any reason, for example, an invalid user name or password, bad query, or if
the LDAP server is not responding.
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3. From the Directory Server drop-down list, select a server to perform the search.
4. In the Search Base text box, type a Search Base string with information specific to your LDAP
hierarchy.
For example: cn=users,dc=example,dc=com .
5. From the Scope drop-down list, select the scope of the search.
n
n
n

Base – Searches the base object only.
One Level – Searches objects beneath the base object, but excludes the base object.
Subtree – Searches the entire subtree of which the base distinguished name is the
topmost object, and includes the base object.

6. In the Query Filter text box, type the filter for the LDAP lookup.
For example, for Active Directory, type:(sAMAccountName=%s) .
For OpenLDAP, type: (&(ObjectClass=inetOrgPerson)(cn=%s)) . For iPlanet, type: uid=%s .
7. In the Result Attribute text box, type the attribute that returns the user’s account.
For example, for Active Directory, type: mail .
For OpenLDAP, type: userPassword . For iPlanet, type: mail .
If your organization has multiple LDAP domains, or if the domain of the WatchGuard XCS is
different than the LDAP domain, then the LDAP authentication Bind method must be used for
Web User authentication.
For example, for Active Directory, the LDAP Query Filter must consist of the user name, for
example, samAccountName=%s , and the Result Attribute should be mail .
For OpenLDAP, use cn=%s and mail .
This makes sure you properly match user, domain, and group policies for this LDAP user.
8. In the Timeout text box, type the maximum interval, in seconds, to wait for the search to
complete.
You can enter values from 1 to 100 seconds.

9. Click the Test button to perform a test of the LDAP Authentication configuration.
10. Click Apply.
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LDAP Virtual Mappings
Use Virtual Mappings to accept mail addressed for one domain and redirect it to a different domain.
This process is performed without modifying the To: and From: headers in the mail. Virtual mappings
only modify the envelope-recipient address.
For example, you can configure the WatchGuard XCS to accept mail for the domain @example.com
and deliver it to @sales.example.com. This allows you to distribute mail to multiple internal servers
based on the Recipient: address of the incoming mail.
You can use LDAP mappings to search LDAP-enabled directories for user virtual mappings. See
Virtual Mappings for more information on Virtual Mappings.
Note LDAP Virtual Mappings have only been tested with Active Directory, and the
examples shown are for Active Directory LDAP implementations. In most cases,
Active Directory already performs its own internal virtual mapping translations so
configuring LDAP Virtual Mappings is not required.
To configure LDAP Virtual Mappings:
1. Select Configuration > LDAP > Mapping.
The LDAP Virtual Mapping page appears.

2. Click Add.

3. From the Directory Server drop-down list, select a server to perform the search.
4. In the Search Base text box, type a Search Base string with information specific to your LDAP
hierarchy.
For example: cn=users,dc=example,dc=com .
5. From the Scope drop-down list, select the scope of the search.
n
n
n

Base – Searches the base object only.
One Level – Searches objects beneath the base object, but excludes the base object.
Subtree – Searches the entire subtree of which the base distinguished name is the
topmost object, and includes the base object.

6. In the Incoming Address text box, type the attribute that defines the virtual mapping for a user.
For example, for Active Directory, type:(proxyAddresses=smtp:%s)
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7. In the Email text box, type the attribute that returns the user’s email address.
For example, for Active Directory, type: mail
8. In the Timeout text box, type the maximum interval, in seconds, to wait for the search to
complete.
You can enter values from 1 to 100 seconds.

9. Click the Test button to perform a test of the LDAP mappings configuration.
10. Click Apply.
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LDAP Recipients
The LDAP Recipients feature is used in conjunction with the Intercept Anti-Spam Recipient
Notification (Reject on Unknown Recipient) feature. Recipient Notification must be enabled for LDAP
Recipients to work properly. When a mail message is received by the system, LDAP Recipients
searches an LDAP directory for the existence of a recipient’s email address. If that user address does
not exist in the LDAP directory, the mail is rejected.
This feature differs from the LDAP Users lookup option, which searches for a user in the imported,
locally-cached LDAP users database. The LDAP Recipients feature performs a direct lookup on a
configured LDAP directory server for each address.
Note If you use an Active Directory server, we recommend that you use the LDAP Users
feature.
If Reject on Unknown Recipient is enabled for both LDAP Users and LDAP Recipients, the system
checks the local and mirrored LDAP Users first, and then sends a direct query to an LDAP server.
To configure LDAP recipient lookups:
1. Select Configuration > LDAP > Recipients.
The LDAP Recipient page appears.

2. Click Add.

3. From the Directory Server drop-down list, select a server to perform the search.
4. In the Search Base text box, type a Search Base string with information specific to your LDAP
hierarchy.
For example: cn=users,dc=example,dc=com .
5. From the Scope drop-down list, select the scope of the search.
n
n
n

Base – Searches the base object only.
One Level – Searches objects beneath the base object, but excludes the base object.
Subtree – Searches the entire subtree of which the base distinguished name is the
topmost object, and includes the base object.

6. In the Query Filter text box, type the filter for the LDAP Recipients lookup.
For example, for Active Directory, type:
(&(objectClass=person)(|(mail=%s)(proxyaddresses=SMTP:%s)))
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For OpenLDAP and iPlanet, type: (&(objectClass=person)(uid=%s))
7. In the Result Attribute text box, type the attribute that returns the user’s email address.
For example, for Active Directory, OpenLDAP, and iPlanet, type: mail
8. In the Timeout text box, type the maximum interval, in seconds, to wait for the search to
complete.
You can enter values from 1 to 100 seconds.

9. Click the Test button to perform a test of the LDAP Recipients configuration.
10. Click Apply.
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LDAP SMTP Authenticated Relay
The LDAP SMTP Authenticated Relay feature allows authenticated clients to use this system as an
external mail relay for sending mail. For example, you may have remote users in your organization that
need to send mail through this WatchGuard XCS.
These client systems must use a login and password to authenticate to the WatchGuard XCS before
they are allowed to relay mail. These accounts can be set up as local accounts, but you can also use
LDAP relay authentication to authenticate the user to an LDAP directory server.
To configure LDAP Authenticated SMTP Relay:
1. Select Configuration > Mail > Mail Access.
The Mail Access page appears.

2. SelectthePermit SMTP Authenticated RelayandtheLDAP Authenticated Relaycheck boxes.

3. Select Configuration > LDAP > Relay.
The LDAP Authenticated Relay page appears.

4. Select a query method for contacting the LDAP server.
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For Active Directory and iPlanet implementations, use the Bind method. For OpenLDAP, use
the Query Direct method.
n

n

Bind – The Bind method uses the User ID and password to authenticate on a successful
bind.
The Query Filter must specify the User ID with a %s variable. For example, for Active
Directory, enter (sAMAccountName=%s) . The Result Attribute must be a User ID, for
example, sAMAccountName .
For iPlanet, use uid=%s for Query Filter, and mail for Result Attribute.
Query Direct – The Query Direct method queries the LDAP server directly to authenticate
a user ID and password. The Query Filter must specify the user ID, and the Result
Attribute must specify the password. For OpenLDAP, use uid=%s for Query Filter, and
userPassword for Result Attribute.

For the Bind or Query Direct method, the relay is refused if the LDAP server direct query or bind
attempt fails for any reason, for example, an invalid user name or password, bad query, or if the
LDAP server is not responding.
5. Click Add.
You can only use one method, Bind or Query Direct, for all defined LDAP servers.

6. From the Directory Server drop-down list, select a server to perform the search.
7. In the Search Base text box, type a Search Base string with information specific to your LDAP
hierarchy.
For example: cn=users,dc=example,dc=com .
8. From the Scope drop-down list, select the scope of the search.
n
n
n

Base – Searches the base object only.
One Level – Searches objects beneath the base object, but excludes the base object.
Subtree – Searches the entire subtree of which the base distinguished name is the
topmost object, and includes the base object.

8. In the Query Filter text box, type a query for the LDAP lookup.
For example, for Active Directory type:(sAMAccountName=%s)
9. In the Result Attribute text box, enter the attribute that returns the user’s account.
For example, for Active Directory type: sAMAccountName
10. In the Timeout text box, type the maximum interval, in seconds, to wait for the search to
complete.
You can enter values from 1 to 100 seconds.

11. Click the Test button to perform a test of the LDAP relay configuration.
12. Click Apply.
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LDAP Routing
LDAP routing allows you to query for a mail route for a recipient on a specified LDAP server. The
destination mail server for that domain is returned and the message is routed to that server. This is the
preferred method for mail routing for organizations with a large amount of domains. Any locally defined
mail routes (in Configuration > Mail > Routing) are resolved before LDAP routing.
Note LDAP routing has only been tested with iPlanet implementations but the examples
provided should also work with OpenLDAP, depending on your LDAP schema.
To configure LDAP routing:
1. Select Configuration > LDAP > Routing.
The LDAP Routing page appears.

2. Click Add.

3. From the Directory Server drop-down list, select a server to perform the search.
4. In the Search Base text box, type a Search Base string with information specific to your LDAP
hierarchy.
For example: cn=users,dc=example,dc=com .
5. From the Scope drop-down list, select the scope of the search.
n
n
n

Base – Searches the base object only.
One Level – Searches objects beneath the base object, but excludes the base object.
Subtree – Searches the entire subtree of which the base distinguished name is the
topmost object, and includes the base object.

6. In the Query Filter text box, type the query filter that searches for the Mail Domain of a
recipient.
For example, for iPlanet type:(&(cn=Transport Map)(uid=%s))
7. In the Result Attribute text box, type the attribute that returns the domain’s mail host.
For example, for iPlanet, type: mailHost
8. In the Timeout text box, type the maximum interval, in seconds, to wait for the search to
complete.
You can enter values from 1 to 100 seconds.
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9. Click the Test button to perform a test of the LDAP routing configuration.
10. Click Apply.

Troubleshoot LDAP Issues
These sections describe several common LDAP problems and procedures for their resolution.

Cannot Contact the LDAP Server
This error is displayed in the logs if LDAP User imports fail:
Nov 16 17:03:13 server root: ldap_bind: Can't contact LDAP server (81)

Examine these items:
n
n
n
n

n

Verify that the LDAP Server is up and running.
In Configuration > LDAP > Directory Servers, verify the address of the LDAP Server.
Make sure that LDAP or LDAPS is used properly in the LDAP server URI.
Make sure nothing is blocking LDAP traffic for the WatchGuard XCS and the LDAP Server. For
example, if the WatchGuard XCS is installed on a network off of the network firewall, make sure
it can connect to the LDAP server on TCP port 389 (LDAP) or 636 (LDAPS).
Test connectivity with the LDAP Server. Telnet to the LDAP Server on TCP port 389 or 636.

LDAP User and Group Imports are Failing
If LDAP Users and Groups are not being imported, check Activity > Logs > System for any of these
errors:
Nov 19 14:14:23 hostname spl: ALARM: LDAP import: serious: Import of users
failed.Nov 19 14:14:23 hostname spl: LDAP import of users failed.Nov 19 14:14:23
hostname root: ldap_bind: Invalid credentials (49)

These messages indicate that the system can contact the LDAP Server, but either the user does not
have the correct credentials to perform a search, or the Bind DN does not exist.
n
n

In Configuration > LDAP > Directory Servers, verify that you specified the correct Bind DN.
Verify the Bind DN is correct. The configured Bind DN user on the system is only used to
search the LDAP Server. In Active Directory, this is any user in the Domain Users Group. In an
Active Directory environment the DN would look like:
cn=User name,cn=users,dc=example,dc=com

For example:
cn=Ken R. Simon,ou=users,dc=example,dc=com
n

Verify that the user can log in to the domain. If this user cannot log in to the domain, verify the
user name and password.
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Mirror Accounts are Not Created
If the system is able to connect to the LDAP Server and import users, but fails to create any or only
some mirrored accounts, examine these items:
n

n

n

n

n

If the system is not creating mirrored users, make sure that Mirror Accounts is enabled in
Configuration > LDAP > Directory Users > Import Settings.
Verify that the search base is correct and is not too restrictive. Try re-importing with a wider
search base.
Make sure that the email attribute is set correctly in Configuration > LDAP > Directory
Users. In most environments it is typically set to mail .
Verify that users have an assigned email address. The system only creates mirrored accounts
for user accounts that have an email address. In Active Directory, make sure the user has a
valid email address.
If a valid email address exists, verify that the system can view it. Click the Test button in
Configuration > LDAP > Directory Users. Specify the user in the LDAP Query Field, for
example, (sAMAccountName=username) and use mail as the attribute for the returned data.
# extended LDIF
#
# LDAPv3
# base with scope sub
# filter: (sAMAccountName=ksimon)
# requesting: mail
#

# Ken R. Simon, users, example.com
dn: CN=Ken R. Simon,OU=users,DC=example,DC=com
mail: ksimon@example.com

In the previous example, the final line indicates the mail attribute returned.

LDAP Authentication Failures
If the system is able to contact the LDAP server, but when trying to login you receive this error
message “Invalid Login”, check the logs to see why the login failed in Activity > Logs > System.
Typically, this type of error message appears:
Nov 22 15:24:49 server login.spl: fail login as 'jsmith' [dom:0]: Invalid
RADIUS/LDAP login [ip:10.10.8.224]

Use the LDAP Test Feature in Configuration > LDAP > Directory Users to verify the user exists.
For the LDAP Query, specify the user name attribute and the user name. For example, for Active
Directory use (sAMAccountName=jsmith) .
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If the LDAP test does not return any results from the search then it is possible that the user name is
incorrect, does not exist, or the search base is too restrictive. Repeat the test with a broader search
base. If the system does not find the user after performing this step, verify that the user name exists by
checking the directory server itself.
If the LDAP test does find the user, the password may be incorrect or the user cannot login because
either the user does not have the required permissions or the account is disabled. Verify that the user
can log in to the domain.
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Mail Access
Use the Mail Access page to configure features that provide security when the WatchGuard XCS is
accepting mail during an SMTP connection.
To configure your SMTP mail access settings:
1. Select Configuration > Mail > Access.
The Mail Access page appears.

Specific Access Patterns
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Use Specific Access Patterns to search for patterns in a message for filtering during the
SMTP connection. See Specific Access Patterns for detailed information on configuring
these filters.
Pattern Based Message Filtering
Use Pattern Filters to reject or accept mail based upon matches in the message envelope,
header, or body. See Pattern Filters for detailed information on configuring Pattern Filters.
Maximum recipients per message
Setthe maximumnumber ofrecipients acceptedper message.A very large amountof
recipients means themessage is more likely to bespam orbulk mail.The defaultis setto 1000.
Maximum recipients reject code
Allows administrators to define other errors to return instead of the default “452 Error: too
many recipients” error, for example, permanently rejecting the connection “554”.
Maximum message size
Set the maximum message size (in bytes) that is accepted by the system. The default is
10240000 bytes. Note that processing large messages decreases mail processing
performance.
The Attachment Size Limit option configured in Security > Content Control >
Attachment Control is also set to 10240000 bytes, and as a result, the threshold is
exceeded if the attachment size is close to the attachment size limit. We recommend that
you set the Maximum Message Size value to at least 1.5 times the value of the
Attachment Size Limit option. When attachments are sent with most email messages,
the message size grows considerably because of the encoding methods. The maximum
message size should be set accordingly to accommodate attachments. Attachments are
sent base64 encoded, not in their binary form. Base64 encoding can increase the size of a
file to up to 140% of its original size. A 9MB attachment is actually 13MB in size, and would
exceed a message size limit of 10MB. You must consider the additional overhead caused
by base64 encoding when configuring a maximum message limit.
Minimum Queue Free Space (Cluster Primary Only)
This option only appears on a Cluster Primary system and allows administrators to set the
minimum amount of free space in kilobytes that is required in the queue file system to
receive messages. If the system has less than the specified free space, messages are
rejected with a “452: Insufficient system storage” error. This value must at minimum be
greater than 1.5 times the specified Maximum message size, and at maximum 50 GB.
The default value is automatically calculated for clusters with all the same hardware, and
this configuration is replicated across all cluster systems. In a cluster that contains
systems of different types of hardware, you must set this value to 20% of the total System
Data Storage Area space available according to the cluster member with the least space.
To view this information, select Activity > Status > Utilities on the cluster member. For
example, if the cluster system with the least amount of System Data Storage Area space
has 10 GB available, then set this value to 2097152 KB (2 GB).
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Note The Minimum Queue Free Space value is not synchronized through Centralized
Management.
Maximum Unknown recipients per message
This value determines how many unknown recipients are allowed in the message before it
is rejected by the system. A high number of unknown recipients indicates the message is
likely spam or a denial of service attempt.
Maximum Unknown recipients reject code
This value indicates the SMTP reject code to use when the maximum unknown recipients
value is exceeded. This option can be set to “421” (temporary reject) or “554” (permanent
reject).
SMTP Authenticated Relay
This feature allows authenticated clients to usethe systemas anexternal mailrelay for
sendingmail. Forexample, youmay haveremote users who needto sendmail throughthis
system.Clients mustuse alogin andpassword toauthenticate tothe systembefore they are
allowedto relay mail. Theseaccounts canbe localor they can beauthenticated throughLDAP.
LDAP SMTP Authentication
SMTP authentication can be performed to an LDAP directory server. Select the check box
to enable LDAP Authenticated Relay, and select the link to configure its options. This
feature can also be configured in Configuration > LDAP > Relay. See LDAP SMTP
Authenticated Relay for detailed information on configuring LDAP Authenticated Relay.
Message Submission
You can enable message submission on SMTP port 587. When message submission is
enabled, the system listens on SMTP port 587 (in addition to port 25) for SMTP
authenticated relay. Message Submission must also be enabled on a specific network
interface on the Configuration > Network > Interfaces page.
SMTP Banner
The SMTP banner is exchanged during the HELO/EHLO session of an SMTP connection.
The banner contains identifying information for your mail server that can be used as
information to launch attacks against it. This option allows you to customize the SMTP
banner. Select Domain only to remove the hostname from the banner.
DSN SMTP Extension
Delivery Status Notifications (DSN) are extensions to the SMTP mail delivery protocol
(RFC 3461) that allow an SMTP client to request that the server (in this case, the
WatchGuard XCS) send notification messages for successful, delayed, or failed message
deliveries. Delivery notifications are very helpful for troubleshooting email delivery issues.
This feature allows the WatchGuard XCS administrator greater control over the conditions
for which notifications are sent to SMTP clients and the notification message content.
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Select Trusted Clients Only to restrict DSN to trusted SMTP clients. A trusted client is
one that is located on one of the WatchGuard XCS trusted networks (configured in
Configuration > Network > Interfaces). The default value is Never which prevents
SMTP clients from controlling which notifications are sent.
Note You cannot use Specific Access Patterns to identify trusted clients for DSN because
Specific Access Patterns are processed after the HELO part of the SMTP connection
where DSN usage is determined.
The WatchGuard XCS inserts the DSN keyword into the EHLO message to communicate
to the mail client that it offers DSN.

Select Configuration > Mail > Delivery to customize the Delivery Failure Notification,
Delivery Delayed Warning, and Delivery Success Notification messages.
Select Configuration > Mail > Delivery > Advanced and select the Hide internal
relays in notifications check box to exclude the host names and IP addresses of internal
relays from Delivery Status Notifications. An internal relay includes any system for which
the XCS has a configured mail route or virtual mapping, such as a local mail server.
Queue Monitoring
The Queue Monitoring feature allows you to modify the system’s behavior depending on the
size of the incoming mail queue. To process the current mail queue faster, you can give a
higher priority to the delivery of queued mail than receiving new mail when a threshold is
reached.
At the maximum threshold, incoming requests are temporarily rejected to allow the queue
to process current messages first.
Select the Monitor Mail Queue Size option to enable incoming queue thresholds.
n

n

n
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Minor Queueing – If the active queue size reaches the minor threshold, the system
slightly increases the priority of mail delivery over mail receiving. A Warning alarm is
generated.
Medium Queueing – If the active queue size reaches the medium threshold, the
system significantly increases priority of mail delivery over mail receiving. A Serious
alarm is generated.
Significant Queueing – If the active queue size reaches the significant threshold,
the system temporarily rejects any new mail and notifies the administrator. A Critical
alarm is generated.
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Deferred Mail Queue Size monitoring
This feature monitors the size of the deferred mail queue and generates a critical alarm if
the deferred queue size threshold is exceeded. Your deferred mail queue can grow in size if
your XCS device experiences issues with outbound mail.
n

n

Monitor Deferred Queue Size – Select the Enable check box to monitor the
deferred mail queue.
Threshold – Indicates the threshold size for the deferred mail queue. A Critical alarm
is generated if this threshold is exceeded. The default is 2000.

2. Click Apply.
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Specific Access Patterns
Specific Access Patterns are enabled by default and can be used to accept or reject mail during an
SMTP connection. Specific Access Patterns occur are processed before any other security or content
processing.
Use access patterns to allow email where it would be otherwise blocked, or to block email when it
would otherwise be allowed. Specific access patterns allow you to respond to these local filtering
requirements:
n
n
n

Allow other systems to relay mail through the system
Reject all messages from specific systems
Allow all messages from specific systems (effectively trusting the server)

When you specify a Specific Access Pattern rule, it can take one of these forms:
n

n

n

IP Address – The system matches the IP address, for example, 192.168.1.10, or you can use
a more general address form, for example, 192.168 that matches anything in that address
space. For the Client Access parameter, you can also use CIDR (Classless Inter-Domain
Routing) format to specify a pattern for a network, for example, 192.168.0.0/24.
Domain Name – The system matches the supplied domain name, for example, example.com,
with any subdomain, for example, mail.example.com, and sales.mail.example.com.
Address – The system matches an exact email address, for example, user@example.com, or
a more general rule, for example, @example.com.

To configure a Specific Access Pattern:
1. Select Configuration > Mail > Access.
The Mail Access page appears.

2. Click Add Pattern.
The New Access Pattern page appears.

3. In the Pattern text box, type a mail address, IP address, hostname, or domain name.
n

n
n
n
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Client Access – Specify a domain, server hostname, or IP address. This item is the most
reliable and can be used to block spam and trust clients.
HELO Access – Specify a domain or server name.
Envelope-From Access – Specify a valid email address.
Envelope-To Access – Specify a valid email address.
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Note Only the Client Access parameter is reliable because spammers can easily forge all
other message properties. These parameters are useful for trusting purposes.
4. From the If pattern matches drop-down list, select an action to perform:
n
n

n

Reject – The connection is rejected.
Allow Relaying – When you specify Allow Relaying:
o Messages from the specified address are accepted for processing by the system
o Messages are checked by all features. This includes Anti-Virus, Content Control,
Anti-Spam, Reputation Enabled Defense, and DNSBL (DNS Block List) features
o Messages are not checked by the Reject on Unknown Recipient feature
o Messages can be relayed externally
Trust – The Trust option treats the server or message as part of the trusted network. When
you specify the Trust action:
o Messages from the specified address are accepted for processing by the system
o Messages are checked by the Anti-Virus and Content Control features
o Messages are not checked by the Anti-Spam features
o Messages are not checked by the Reject on Unknown Recipient feature
o Messages are not checked by the Reputation Enabled Defense and DNSBL (DNS
Block List) features
o Messages can be relayed externally

5. Click Apply.
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Anti-Virus
The Anti-Virus scanning feature scans all messages (inbound and outbound) passing through the
system for viruses. The WatchGuard XCS integrates the Kaspersky Anti-Virus engine which is one of
the highest rated virus scanning technologies in the world. Anti-Virus scanning is tightly integrated with
the message processing engine for maximum efficiency.
You can selectively block viruses based on whether they are found in inbound or outbound messages.
Attachments are recursively disassembled to make sure that viruses cannot be concealed in archive
files.
Note Kaspersky Anti-Virus can scan up to 20 levels of an archive file.
When you receive a virus-infected message, you can reject, discard, or quarantine the message. You
can view, download, or delete quarantined messages from the administrative quarantine area.
By default, if the WatchGuard XCS cannot open and examine message attachments because of
password-protection, the messages are quarantined. This feature prevents password-protected zip
files that contain viruses or worms from passing through the system.
Virus pattern files are automatically downloaded at regular intervals to make sure that they are always
up to date. Notification messages can be sent to the sender, recipient, and administrator when an
infected message is received.
McAfee Anti-Virus is also available as an add-on subscription for customers who want to enable multilayered Anti-Virus protection.

Configure Anti-Virus
To configure Anti-Virus scanning:
1. Select Security > Anti-Virus > Anti-Virus.
The Anti-Virus Configuration page appears.

2. Select the Enable Kaspersky virus scanning check box.
3. In the Treat as a Virus section, you can select these options:
Attachments containing unknown viral code
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The Anti-Virus scanner can detect code that resembles the patterns of a virus. We strongly
recommend that you treat attachments containing suspected viral code as if they contained
viruses.
Corrupt attachments
The Anti-Virus scanner may not be able to scan corrupted attachments which can contain
viruses. We strongly recommend that you treat corrupt attachments as if they contained
viruses.
Password-protected attachments
Attachments protected by a password cannot be opened by the Anti-Virus scanner and
could contain viruses.
Note Disable this option if you use password-protected files and archives in your
organization. You can use the Attachment Control feature to manage how passwordprotected files are processed with the [password protected] special file extension type.
Attachments causing scan errors
Attachments that cause errors while being scanned by the Anti-Virus scanner can contain
viruses. We strongly recommend that you treat attachments that cause scanning errors as
if they contained viruses.
4. For both inbound and outbound mail, from the Email Action drop-down list, select an action to
perform:
n
n
n

n
n

Just log – Log the event and take no further action.
Reject mail – Reject the message with notification to the sending system.
Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message without notification to the sending system.

6. Select the notifications to send when a virus is detected in a message.
You can send notifications to the Sender, Recipient, and Administrator, and customize the
notification text.
Note Variables, for example, %HOSTNAME% are inserted by the system. See System
Variables for Notifications for a full list of system variables that can be used in the
notification.

Update Pattern Files
Virus pattern files must be continuously updated to make sure that you are protected from new virus
threats. The frequency of virus pattern file updates is configured in the Virus Pattern Files section.
The WatchGuard XCS can automatically contact a default update server to update the pattern files at
the specified time.
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Note If you access the Internet through a proxy server, you must enter its hostname and
port number in the external proxy configuration in Configuration > Network >
External Proxy Server for pattern file updates to succeed.
You can also define alternate sites to retrieve the Anti-Virus pattern update files from an internal
location before you obtain them from external sites. You can specify up to two user-defined update
servers.
The primary and alternate user-defined servers are queried in order. If the primary server cannot be
contacted, the system attempts to retrieve the update from the alternate server. If the user-defined fields
are not configured, the system default servers are used to retrieve the updates from external sites.

To configure virus pattern files:
1. In the Kaspersky User-Defined Server text box, type an optional URL that indicates the
hostname and directory of the primary web server hosting the pattern file.
Use this format:
http://<host>/<pathname>

2. In the Kaspersky User-Defined Alternate Server text box, type an optional URL that
indicates the hostname and directory of the alternate web server hosting the pattern file.
We recommend that you use the alternate server as the default system update server.

3. From the Update interval drop-down list, select the interval for how often to check for pattern
file updates.
You can select 30 min, 1 hour, and 3 hours. The default is 1 hour.
4. Click Apply.
5. Click Get Pattern Now to update the pattern files immediately.
The Kaspersky Anti-Virus Status field displays the date and time of the last pattern file
update.

172

WatchGuard XCS

Mail Security

Spyware Detection
The Kaspersky Anti-Virus scanner can detect specific spyware and malware threats in addition to AntiVirus scanning for inbound and outbound email messages and web requests.
You can enable or disable spyware detection globally and through policies. You can configure specific
protocol scanning (email and web), actions, and notifications for spyware detection that are
independent from the configuration of the global Anti-Virus scanner.
Note The Spyware action is performed after any applicable Anti-Virus action.
To configure spyware detection:
1. Make sure Kaspersky Anti-Virus is enabled in Security > Anti-Virus > Anti-Virus.
Spyware cannot be enabled and configured until Kaspersky Anti-Virus is enabled.

2. Select Security > Anti-Virus > Spyware.
The Spyware Configuration page appears.

3. Select the Enable Kaspersky spyware scanning check box.
4. For both inbound and outbound email, from the Email Action drop-down list, select an action to
perform:
n
n
n

n
n

Just log – Log the event and take no further action.
Reject mail – Reject the message with notification to the sending system.
Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message without notification to the sending system.

5. Select the notifications to send when spyware is detected in a message.
You can send notifications to the Sender, Recipient, and Administrator, and customize the
notification text.
Note Spyware actions for web requests must be set in a policy. You can set email spyware
actions globally and within a policy.
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Outbreak Control
The Outbreak Control feature provides you with zero-day protection against early virus outbreaks. For
most virus attacks, it can be several hours from the moment the virus is released to the time a pattern
file is available. During this period, mail recipients are vulnerable to potential threats.
Outbreak Control detects early virus outbreaks and takes immediate action contain the virus threat. If a
message is classified as containing a possible virus, you can quarantine or discard message. When
the WatchGuard XCS receives an updated Anti-Virus pattern file, any quarantined files are re-scanned
automatically. If a virus is detected with the new pattern file, the configured Anti-Virus action is
performed on the message. If the hold period for a message in the quarantine expires and the message
has not been positively identified as a virus during that time, the configured “release” action is
performed.
The WatchGuard XCS examines incoming untrusted messages and looks for these characteristics
when deciding if the message indicates an early virus threat:
n

n

n

The message originates from an IP address that has recently sent viruses and the message
contains an executable or common office document attachment. To detect if the client has
recently sent viruses, you must enable the Mail Anomalies feature and the Recent virus from
Client option.
The message originates from an IP address with a poor reputation and the message contains an
executable or common office document attachment. To detect addresses with a poor
reputation, you must enable the Reputation Enabled Defense feature.
The Anti-Virus scanner detects attachments that resemble a known virus or contain unknown
viral code.

This table lists the types of executable files and common office document formats that are scanned by
Outbreak Control:.
Executable

Common Office Documents

bat

.doc

.chm

.dot

.cmd

.ppt

.com

.wk1

.dll

.wks

.drv

.wp

.exe

.xls

.js
.jse
.nlm
.ovl
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Executable

Common Office Documents

.pif
.scr
.shs
.sys
.vbe
.vbs
.vxd
To configure Outbreak Control:
1. Select Security > Anti-Virus > Outbreak Control.
The Outbreak Control page appears.

2. From the Email Action drop-down list, select an action to perform if a possible virus is
detected.
n
n
n

n
n

Just Log – The message is delivered to its destination and an entry added to the mail log.
Reject mail – Reject the message with notification to the sender.
Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message without notification to the sender.

3. In the Hold Period text box, type the time (in hours) for which to hold the message in the
administrative quarantine area.
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The default hold period is 8 hours. In most cases, the Anti-Virus pattern files are updated within
2-4 hours of the discovery of a new virus. We recommend that you configure enough time to
allow the opportunity for the files to be rescanned with updated Anti-Virus pattern files as they
become available. If the Quarantine expiration period is set to a value less than the Hold
Period, the expiry period takes precedence and the quarantined message is expired.
During the hold period, if a quarantined message is rescanned and determined to have a virus,
the configured Anti-Virus action is performed as set in Security > Anti-Virus > Anti-Virus. If
the hold period expires and the message is determined not to be infected with a virus, the
Release action is performed.
4. Select the notifications to send when a suspicious message is detected by Outbreak Control.
You can send notifications to the Sender, Recipient, and Administrator, and customize the
notification text
5. In the Release section, from the Email Action drop-down list, select an action to perform if the
Hold Period expires for a quarantined message:
n

n

Just Notify – A notification is sent to the specified users that the Hold Period for a
quarantined message has elapsed without the message being classified as a virus. The
message remains in the quarantine until you release the message manually.
Release mail – The message is automatically released from the quarantine and delivered
to the original recipients.

6. Select the notifications to send when a message is released from the quarantine.
You can send notifications to the Sender, Recipient, and Administrator, and customize the
notification text.
Note To search for the disposition of messages caught by Outbreak Control in Activity >
History > Message History, search for a subject that contains “possible virus”.
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Malformed Mail
Many viruses try to elude virus scanners by concealing themselves in malformed messages. The
scanner cannot detect the attachment and passes the complete message through to an internal server.
Some mail clients try to rebuild malformed messages and can rebuild or activate a virus-infected
attachment. Other types of malformed messages are designed to attack mail servers directly. These
types of messages are typically used in denial-of-service (DoS) attacks.
The system analyzes each message with extensive integrity checks. You can quarantine malformed
messages if they cannot be processed.
To configure malformed mail scanning:
1. Select Security > Anti-Virus > Malformed Mail.
The Malformed Mail page appears.

2. Select the Enablemalformed scanning check box.
3. Select the Treat messages with MIME decoding errors as malformed check box to treat
any messages that contain MIME decoding errors as a malformed message.
This option prevents messages from passing through the system when the attachments cannot
be decoded and scanned because of MIME decoding errors. Enabling this option can increase
the number of messages identified as malformed. If you quarantine malformed mail, this can
impact resource usage and increase the amount of quarantined mail that requires management
and review.
4. From the Enable NULL character detect drop-down list, select Enable to consider messages
containing null characters (a byte value of 0) in the raw mail body as a malformed message.
NULL character detect is disabled by default.
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Note The null character detection feature can cause incompatibility with certain mail
servers and we recommend that you disable this feature if issues occur.
5. From the Action drop-down list, select an action to perform when a malformed message is
detected.
n
n
n

n
n

Just log – Log the event and take no further action.
Reject mail – Reject the message with notification to the sending system.
Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message without notification to the sending system.

6. Select the notifications to send when a malformed message is detected.
You can send notifications to the Sender, Recipient, and Administrator, and customize the
notification text
7. From the Very Malformed Mail Action drop-down list, select an action to perform when a very
malformed message is detected.
A very malformed message can cause scanning engine latency.
n
n

n
n

n
n

Just log – Log the event and take no further action.
Quarantine: System – Place the message into the system quarantine area. You can also
choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Temporarily Reject Mail – Return an error to the sending server and do not accept the
mail.
The mail delivery is attempted again at a later time.
Reject mail – Reject the message with notification to the sending system.
Discard mail – Discard the message without notification to the sending system.

8. Select the Notify check box to send notifications according to the malformed notification
settings (configured in Security > Anti-Virus > Malformed Mail) when any action except for
Just Log is performed.
Note Messages that are very malformed are not virus scanned or filtered for attachments
and spam.
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SecureMail Email Encryption
SecureMail Email Encryption allows end users to encrypt outbound messages directly from the
WatchGuard XCS without the need for a local encryption server or additional desktop software.
Messages are secured until they are delivered and decrypted by the recipient of the message.
Recipients open an attachment to the encrypted message that allows them to create an account on the
SecureMail web site and log in to read the message.
When encryption is enabled, you can use these features to scan for specific patterns in email
messages that indicate the message must be encrypted.
n
n
n
n
n

Pattern Filters
Objectionable Content Filter
Content Scanning
Content Rules
Document Fingerprinting

For example, you can create a Pattern Filter to search for the word "[Encrypt]" in the subject field of a
message. An end user can add this phrase to their message subject header to indicate the message
must be encrypted before it is delivered.

How SecureMail Email Encryption Works

1. When a user sends a message, the WatchGuard XCS uses pattern and content filters to
determine if a specific encryption policy applies to the message.
2. The SecureMail engine communicates with the SecureMail service to generate encryption
keys, any branding data, and creates the notification message. SecureMail uses IBE (IdentityBased Encryption) which generates encryption keys based on the sender and recipient email
addresses.
3. The message is encrypted and signed with the sender's public key and delivered to the recipient
as a message attachment.
4. The recipient opens the attachment that allows them to register (if this is the first encrypted
message received) and authenticate their email address to the SecureMail web site.
5. When the recpieint opens the the message, the message contents are posted to the Securemail
web site where they are decrypted. The mail contents are secured with SSL and are never
stored. The SecureMail site uses the recipient's private session key to allow the recipient to
read the unencrypted message.
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Note The WatchGuard XCS uses TCP port 443 (HTTPS) to communicate with the
SecureMail key server. Make sure this port is correctly configured on your network
firewall to allow access from the WatchGuard XCS.

SecureMail Service
The SecureMail service allows you to send secure, encrypted messages directly to a recipient's inbox.
The WatchGuard XCS integrates the encryption engine to allow messages to be encrypted on the
system before it is delivered to the intended recipient. The recipient does not require any additional
software or configuration to decrypt and read the message. The SecureMail architecture allows the
integrated encryption engine software on the WatchGuard XCS to perform the message encryption and
message delivery functions directly on your appliance, while the SecureMail service performs all
encryption key-related services and provisioning.
These features are available when using the SecureMail Email Encryption service:
n

n

n

n

Platform independent – You can open messages encrypted by SecureMail from any email
platform, on any operating system and web browser.
Secure – The secure email is encrypted with the equivalence of a 1024-bit key. Each message
is also signed by the sender to ensure authenticity of the sender and data integrity of the
message. In addition, all decrypted email messages are viewed through your web browser
using an SSL/TLS connection.
Branding – You can use optional SecureMail branding services to display your organization's
logo and branding text on all encrypted messages.
Encrypted replies – Recipients can securely reply to or forward encrypted messages they
receive using the same web-based service that allows them to read the encrypted message.

License and Activate SecureMail
When you purchase SecureMail Email Encryption, you must activate the subscription from the
LiveSecurity activation page. You will be provided with a link to enter this information about your
organization:
n

n

n
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Email Domains – Your organization's email domains from which your users will be sending
encrypted messages.
For example, example.com, example1.com.
Gateway IP addresses – These are the public IP addresses from which your WatchGuard XCS
device is connecting to the SecureMail servers. This is required to authorize only your
organization's IP addresses to establish a connection with the SecureMail service.
Authorization Code – This code authorizes SecureMail Email Encryption for use with your
WatchGuard XCS device. This code is entered in your SecureMail configuration on the
WatchGuard XCS. The Authorization Code must be 15-20 alphanumeric characters in length
and cannot contain symbols or spaces.

WatchGuard XCS

Mail Security

Branding Option
If you have purchased the SecureMail branding option, you can display custom logos and branding text
for your organization on encrypted message envelopes. You can configure a single branding profile, or
use multiple branding profiles that allows you to define a separate branding profile for each mail domain
that you process mail for on a per-policy basis. Your primary branding profile is defined on the main
SecureMail configuration page, and other branding profiles can be defined in the SecureMail policy
configuration located in a policy's Email settings.
When you activate the SecureMail branding option, you must provide these items:
n

n

Logo – You can upload a custom logo that is displayed on encrypted message envelopes. The
logo must be 370 pixels wide and 70 pixels high on a transparent background in gif, jpg or png
format.
Branding Profiles – This value identifies your branding profile (logo and branding text) on the
SecureMail service. The primary branding profile is defined on the WatchGuard XCS
SecureMail configuration page. Other branding profiles can be defined on a per-policy basis. The
branding profile can be up to 20 alphanumeric characters, must start with a letter, and cannot
contain symbols or spaces.

Configure SecureMail on the WatchGuard XCS
To configure SecureMail Email Encryption:
Note Make sure you have an NTP server configured in your network settings. SecureMail
requires that your XCS device clock be properly set to provide accurate timestamps
for the encryption process.
1. Select Security > Encryption > SecureMail.
The SecureMail Encryption page appears.
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2. Select the Enable SecureMail Encryption check box.
3. In the Authorization Code text box, you must type your authorization code to authorize
SecureMail Email Encryption for use with this WatchGuard device.
You must enter an authorization code before you can enable SecureMail Email Encryption.

4. In the Branding Profile text box, type an optional branding profile value that corresponds to
your branding profile configured with the SecureMail service.
If you type an incorrect Branding Profile value, the default WatchGuard branding appears on the
encrypted message envelope.

5. Click Apply.

User Licenses
The User License Count indicates the maximum amount of users allowed with your license.
The WatchGuard XCS is currently governed by an authorized technology license to support the
maximum number of XCS SecureMail Email Encryption licensed users. Should you require additional
user licenses in excess of those previously purchased, please contact WatchGuard or your local
reseller. In accordance with technology licensing, WatchGuard has an obligation to ensure strict
compliance regarding the number of SecureMail users, and therefore reserves the right to perform
required and necessary compliance audits at any time during the subscription period.

Troubleshoot Configuration Issues
When you apply the SecureMail configuration, the WatchGuard XCS connects to the SecureMail
server and tests your configuration.
If you receive an error that the WatchGuard XCS cannot contact the SecureMail server, check the
following:
n

n

The WatchGuard XCS requires an outbound HTTPS connection on port 443 to connect to the
SecureMail server. Make sure this connection is allowed by your network firewall.
The SecureMail service returns an XML-based configuration file. Make sure your network
firewall or content filter allows XML files.

If the connection to the SecureMail server completes, but you receive an error that the Message
Encryption verification test failed, check the following:
n
n

Confirm that you correctly entered your Authorization Code.
Check the gateway IP addresses you activated with SecureMail to make sure you are
connecting from the public IP address of the WatchGuard XCS.
Note SecureMail will only encrypt messages that originate from a trusted network
(outbound mail). Clients that relay mail via the WatchGuard XCS from an untrusted
network and attempt to encrypt messages will be rejected.

Encrypt Messages with Pattern Filters
To support SecureMail and the Outlook SecureMail Add-in, there are two default pattern filters that you
must enable.
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n
n

Outbound Mail Subject: Contains [SecureMail]
Outbound Mail <<Mail Header>> Reg Exp ^X-XCS-SecureMail: 1$

These pattern filters check for both [SecureMail] in the subject header, and the X-XCS-SecureMail text
in the mail header to indicate that a message should be encrypted.
You can create more pattern filters to search for additional text in an outgoing message that identifies it
as a message to be encrypted. For example, you can create a filter to search for the text “Encrypt” in a
subject header to indicate the message must be encrypted before it is sent to its destination.
To configure a Pattern Filter:
1.
2.
3.
4.

Select Security > Content Control > Pattern Filters.
Click Add.
Create an outbound filter that searches for the word “[Encrypt]” in the subject of a message.
From the Action drop-down list, select SecureMail Encrypt.
Any outbound message with the word “[Encrypt]” in the subject is encrypted before delivery.

Note If SecureMail is disabled globally, messages are delivered unencrypted when
triggered by a Pattern Filter. Messages are rejected if you use Content Rules, OCF,
Content Scanning, and Document Fingerprinting and SecureMail is disabled.

Encrypt Messages with Content Rules
You can create Content Rules to search for text in an outgoing message that identifies it as a message
to be encrypted. For example, you can create a rule to search for the text “Encrypt” in a subject header
to indicate the message must be encrypted before it is sent to its destination.
To configure a Content Rule:
1.
2.
3.
4.
5.
6.
7.

Select Security > Content Control > Content Rules.
Select the Enable Content Rules check box.
Click Apply.
Click Outbound Content Rules.
Click Create New Rule.
Create a rule that searches for the word “[Encrypt]” in the subject of a message.
From the Then drop-down list, select SecureMail Encrypt.
Any outbound message with the word “[Encrypt]” in the subject is encrypted before delivery.

8. Click Apply.

Encrypt Messages with OCF
You can use the Objectionable Content Filter (OCF) to create a dictionary of words that is checked
against a message to indicate the message should be encrypted. For example, you may require that
any outgoing messages that contain certain confidential information, for example, credit card
information or medical records, must be encrypted. You can create an OCF dictionary listing the words
to scan for in a message. If any of these words are found in the message, the message is encrypted
before delivery.
1. Select Security > Content Control > Objectionable Content.
2. Select the Enable OCF check box.

User Guide

183

Mail Security

3. In the Outbound OCF section, select the dictionary file that contains a list of words which
indicate a message must be encrypted.
4. In the outbound Email Action drop-down list, select SecureMail Encrypt.
Any outbound message containing words from the OCF dictionary file is encrypted before delivery.

5. Click Apply.

Encrypt Messages with Content Scanning
You can use a compliance dictionary to scan for specific words in the attachment of an outbound
message that indicate a message must be encrypted. For example, your organization may require that
any outgoing message attachments that contain certain confidential information, for example, credit
card information or medical records, must be encrypted. You can create a compliance dictionary listing
the words to scan for in the message attachment. If any of these words are found in the attachment,
the message is encrypted before delivery.
To configure Content Scanning to use encryption:
1. Make sure the Content Scanning feature is enabled globally in Security > Content Control >
Content Scanning.
2. Select Security > Policies > Policies.
3. Select a specific policy.
4. Go to the Content Scanning section.
5. In the Outbound Email Content Scanning section, from the Compliance Dictionaries dropdown list, select the compliance file that contains a list of words which indicate a message
must be encrypted.
6. In the Action field, click Edit, and select the SecureMail Encrypt action.
Any outbound message with an attachment containing words from the compliance dictionary is
encrypted before delivery.

7. Click Apply.
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Read Encrypted Messages
To view an encrypted message:
1. When you receive an encrypted message, it appears similar to this message:

2. Open the message attachment “message_zdm.html”.
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3. Click Read Message.
4. If this is the first encrypted message you receive, you are prompted to register with the
SecureMail service to create an account and establish a password.
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5. You must respond to a verification email message before you can open the encrypted message.
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6. You must type your password to verify your identity.

7. When you have authenticated to SecureMail, the secure message is decrypted and displayed.
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Reply to Encrypted Messages
You can securely reply to or forward encrypted messages within the same web-based service that
allows you to read the encrypted message.
To reply to an encrypted email message on the SecureMail web site:
1. From the encrypted message, click Reply, Reply All, or Forward.
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2. Type your reply.
3. Click Send Secure.
An encrypted reply is sent to the sender of the original encrypted message.

The SecureMail server sends secure replies on behalf of your organization's email domain, and the
email message will appear as originating from a SecureMail domain. In certain cases, your mail
security devices may block these messages because they originate from a different domain than your
own. You must make sure that your mail security devices are configured to allow messages from
SecureMail servers when secure replies are sent back to your email domain.
On the WatchGuard XCS, you can configure Pattern Filters to "Accept" these SecureMail
IP addresses:
Host

IP Address

Notes

mail1.vsn.voltage.com 165.193.228.181,
205.140.196.245*

*This IP will eventually replace the existing
mail1 host address

165.193.228.186,
205.140.196.250*

*This IP will eventually replace the existing
mail2 host address

mail2.vsn.voltage.com

mail3.vsn.voltage.com 165.193.91.245
mail4.vsn.voltage.com
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WatchGuard XCS Outlook SecureMail Add-in
WatchGuard provides an Outlook SecureMail Add-in that integrates the Outlook client with the
SecureMail Email Encryption service on the WatchGuard XCS. The add-in adds a Send SecureMail
button to the Outlook compose new email toolbar in the Add-Ins menu.
The Send SecureMail button performs just like the default Outlook Send button, but adds an X-XCSSecureMail header to the outgoing message to indicate that the message must be encrypted by the
WatchGuard XCS before it is sent to its destination. The header is recognized by a pattern filter on the
WatchGuard XCS that processes the message using SecureMail Email Encryption and then delivers
the encrypted email to its destination.
Note The encryption is performed by the WatchGuard XCS SecureMail feature, and no
encryption is performed on the Outlook client.

Download and Install the Outlook SecureMail Add-in
To download the latest WatchGuard XCS Outlook SecureMail Add-in for your version of Outlook:
1. Select Support > Microsoft Outlook Add-ins from the WatchGuard XCS Web UI, and then
select WatchGuard Portal.
You can also go to http://www.watchguard.com/archive/softwarecenter.asp.
2. Log in to the WatchGuard Portal and click the Articles & Software tab.
3. Select WatchGuard XCS.
4. Search to see all available Software Downloads articles and find the Software Download
content for the WatchGuard XCS Software Downloads.
5. Select the download link for your specific version of Outlook.
Installation instructions are included with the download file.

Note Make sure you install the Outlook SecureMail Add-in for the local user, and not for
'everyone'. The Add-in doesn't support roaming profiles/folder redirection.

Use the Outlook SecureMail Add-in
When installed, the add-in adds a Send SecureMail button to the Outlook compose new email toolbar
in the Add-Ins menu.
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When you have finished editing your message, click the Send SecureMail button to make sure that
the email message is encrypted by the WatchGuard XCS SecureMail feature before it is sent to the
recipient.

Outlook SecureMail Add-in Pattern Filters
To support the Outlook SecureMail Add-in and SecureMail Encryption, there are two default Pattern
Filters that you must enable.
n
n

Outbound Mail Subject: Contains [SecureMail]
Outbound Mail <<Mail Header>> Reg Exp ^X-XCS-SecureMail: 1$

These pattern filters check for:
n

n
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[SecureMail] text in the subject header so that end users can manually enter this text into the
subject field to indicate that a message should be encrypted.
X-XCS-SecureMail text in the mail header from the Outlook Add-in to indicate that the message
should be encrypted.
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External Email Message Encryption
The WatchGuard XCS provides integration with external encryption servers to provide email
encryption and decryption functionality. Email encryption allows individual messages to be encrypted
by a separate encryption server before they are delivered to their destinations. An incoming encrypted
message can also be sent to the encryption server to be decrypted before the system accepts the
message and delivers it to the intended recipient. This integration allows organizations to make sure
that encrypted messages are still processed to detect security, content, and policy issues.

Email encryption provides organizations with the ability to protect the privacy and confidentiality of
their messages and also to conform with any regulatory compliance policies that must make sure that
certain types of data are encrypted before they are sent out across the Internet. Encryption and
decryption is performed for selected email messages with filter rules on the WatchGuard XCS. A
message filter is created for specific email sending addresses, IP addresses and host names of
specific SMTP servers, or for specific words located in the subject of a message, for example,
“Encrypt”.
Because mail is forwarded back and forth between the WatchGuard XCS and the Encryption server, all
mail statistics include this additional delivery information.
To configure external message encryption and decryption:
1.
2.
3.
4.

Configure the encryption server to integrate with the WatchGuard XCS.
Create mail routes to the encryption server on the WatchGuard XCS.
Enable encryption and decryption on the WatchGuard XCS.
Create encryption rules on the WatchGuard XCS to identify messages to encrypt.
Note The Encryption server must be on the same network as the WatchGuard XCS. Use
the ping utility to make sure they are communicating properly and can see each other
on the network.

User Guide

193

Mail Security

Configure the Encryption Server
The existing encryption server must be set up to relay all mail to the WatchGuard XCS. Please see the
documentation provided by your encryption server vendor. Typically, outbound and inbound proxies or
mail routes must be configured on the encryption server to make sure messages are accepted from
and passed back to theWatchGuard XCS after they are encrypted or decrypted.

Define Mail Routes for Encryption and Decryption
You must define Mail routes to the encryption server for both encrypting and decrypting messages. To
make sure the system knows where to route messages for encryption, create a mail route for the
domains .encrypt_reroute and .decrypt_reroute to the address of the encryption server.
Select Configuration > Mail > Routing.
1. In the Domain text box, type.encrypt_reroute
2. In the Route-to text box, type the address of the encryption server.
For example, 10.1.2.200
3. Click Add.
4. In the Domain text box, type.decrypt_reroute
5. In the Route-to text box, type the address of the encryption server.
For example, 10.1.2.200
6. Click Add.

Enable Encryption and Decryption on the WatchGuard XCS
1. Select Security > Encryption > External.
The External Encryption page appears.
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2. Select the Active check box for the Encrypt Action and Decrypt Action section.
3. From the Action drop-down list, select Redirect to.
4. In the Action data text box, type encrypt_reroute or decrypt_reroute for the required
section.
5. Select who to send notifications to when a message is encrypted or decrypted. You can select
Notify Recipient, Notify Sender, or Notify Administrator.
6. Click Apply.

Define Filter Rules for Encryption
You must use a filer rule to identify what types of messages to encrypt. For example, your organization
may use a tag in the subject header, for example, “Encrypt”, which is used to identify an outgoing
message that must be encrypted. You can also define specific email addresses and IP addresses to
make sure certain users or servers have their email encrypted.
You can create encryption rules with Pattern Filters or by using definable dictionaries with the
Objectionable Content and Content Scanning features. The latter features allow you to use dictionaries
with specific keywords and phrases to trigger the encryption rules.
The filter rule examines outbound mail messages for specific patterns to redirect mail for encryption.
This pattern can be a user’s email address or a phrase in the subject header.
To set up an encryption rule with Pattern Filters:
1. Select Security > Content Control > Pattern Filters.
2. Click Add.
3. Create a simple rule that checks all outbound mail for the word “Encrypt” in the subject, and set
the action to Encrypt.
4. Create a rule to match the Client IP field to the address of the Encryption server, for example
10.1.2.200 , and set the action to Relay.
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You must create a separate filter rule to relay messages arriving from the encryption server.
This action allows the system to accept messages back from the encryption server that have
been encrypted and relay these messages to external networks. The filter rule that relays
messages back must be of a higher priority than any encryption rule.
You must create a similar Pattern Filter rule to examine incoming messages that need to be
decrypted before they are delivered to the recipient.
5. Click Apply.
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TLS Mail Delivery Encryption
The WatchGuard XCS offers a simple mechanism to encrypt mail delivery with SSL (Secure Socket
Layer) and TLS (Transport Layer Security) encryption. You can implement a flexible policy to allow
other servers and clients to establish encrypted sessions with the WatchGuard XCS to send and
receive mail.

You can encrypt these types of traffic:
n

n

Server to Server – Creates an email VPN (Virtual Private Network) and protects company
email over the Internet.
Client to Server – Use email clients, for example, Outlook with TLS, to send and receive mail.
This allows email messages to be sent with complete confidentiality from desktop to desktop,
but without the difficulties of implementing other encryption schemes.

You can enforce encryption between servers, for example, you can set up an email VPN between two
WatchGuard XCS systems at remote sites. Encryption can also be optional so that users who are
concerned about the confidentiality of their messages on the internal network can specify encryption in
their mail client when it communicates with the WatchGuard XCS. The WatchGuard XCS supports the
use of certificates to initiate the negotiation of encryption keys. The system can generate its own site
certificates, and can also import Certificate Authority (CA) signed certificates.
See Certificates for more information on importing certificates.
To configure mail delivery encryption:
1. Select Security > Encryption > TLS.
The TLS Encryption page appears.
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2. To allow the use of low-grade encryption ciphers for incoming and outgoing TLS connections,
for example, 64-bit DES, select the Allow low-grade encryption check box.
This option may need to be enabled to support older mail servers, but reduces connection security.

3. Select the Enable SSL version 2 check box to enable SSL version 2 for incoming and outgoing
TLS connections. SSL version 2 is considered insecure, but some older mail systems may still
use SSL v2 when sending mail with TLS.
4. Select the Enable SSL version 3 check box to enable SSL version 3 for incoming and outgoing
TLS connections. SSL version 3 is considered insecure, but some older mail systems may still
use SSL v3 when sending mail with TLS.
5. Select the Enable TLS version 1.0 check box to enable TLS version 1.0 for incoming and
outgoing TLS connections. TLS version 1.0 is considered a less secure protocol than newer
versions of TLS, but some older mail systems may still use TLS v1.0 when sending mail with TLS.
6. Select the Allow SSL renegotiation check box to allow SSL renegotiation after a TLS session
has been established between the XCS and another mail server. This is enabled by default.
You can disable this option to mitigate SSL renegotiation denial-of-service attacks and avoid
issues with standard security scans, but this can cause interoperability issues with some types
of TLS connections. You should allow SSL renegotiation if connection problems with your TLS
sessions occur.
7. Select the Accept TLS check box to accept SSL/TLS for incoming mail connections.
8. To require SSL/TLS when accepting mail for authenticated relay, select Require TLS for
SMTP AUTH.
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9. To log TLS information (this includes protocol, cipher used, client and issuer common name)
into the Received: message header, select the Log TLS info into Received header check
box.
These headers can be modified by intermediate servers and only information recorded at the final
destination is reliable.

10. To offer remote mail servers the option of using SSL/TLS when sending mail, select the Offer
TLS check box.
11. To require the validation of a CA-signed certificate when delivering mail to a remote mail server,
select the Enforce TLS check box.
If the certificate validation fails, the mail delivery connection is denied.
12. Click Apply.

Specific Site Policy
The Specific Site Policy option supports the specification of exceptions to the default settings for
TLS/SSL. For example, you may need to exempt a mail server from using TLS/SSL because of lack of
TLS support or improve performance for internal hosts that do not need to send or receive with TLS.

Search Site Policies
You can use the search box to search for specific site policies and filter the display. Type a text string
to search on the Site field.

Sort Site Policies
You can click on any column to sort the display by ascending or descending order.

Add a Specific Site Policy
You can perform these actions:
n
n
n

Add – Add a TLS site policy.
Delete – Select one or multiple site policies, then click Delete to delete the policy.
Download File – Download a list of site policies. You can download a text list of site policies
and edit the text file.
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n

Upload File – Upload a list of site policies. You can upload a list of site policies in a text file.
We recommend you download the existing site policies first and edit this file for upload.

To add or edit a TLS site policy:
1. Click Add to add a new site policy, or select an existing policy to edit.
2. In the Site text box, type the IP address, FQDN (Fully Qualified Domain Name), or the email
domain of the remote mail server.
3. From the Policy drop-down list, select a TLS option for this site policy.
n
n
n

n

Don’t Use TLS – TLS Mail Delivery is never used with the specified server.
May Use TLS – Use TLS if the specified server supports it.
Enforce TLS – Deliver to the specified server only if a TLS connection with a valid CAsigned certificate can be established.
Loose TLS – Similar to Enforce TLS but accepts a mismatch between the specified
server name and the Common Name in the certificate. Use this option when you use selfsigned certificates.

4. Click Apply.

Upload TLS Policy Sites
You can upload a list of TLS site policies in a text file. The file must contain comma separated entries
with one entry per line. We recommend you download the existing site policies first and edit this file for
upload.
Use this format:
[site],[policy]

For example:
example.com,NONE

To upload a list of TLS site policies:
1. Click Upload File.
The Upload File page appears.

200

WatchGuard XCS

Mail Security

2. Click Browse and select the file to upload.
3. Select an upload option:
n
n
n

Delete – Delete the site policies listed in the upload file.
Replace – Delete all existing site policies and add new site policies from the upload file.
Upload – Append the entries in the upload file to existing sites polices and update any
existing entries.

4. Click Upload.
The Upload TLS Site Policies page appears.

5. Select the Ignore First Line check box if your file contains a header line that you want to ignore
during the import.
6. Choose the fields that represent each data column in your file:
n
n

n
n
n
n
n

(Ignore) – Ignores the specified field.
Site – The site address for the policy. This can be an IP address, FQDN (Fully Qualified
Domain Name), or the email domain of the remote mail server.
Policy – The TLS policy to use for this site.
NONE – Don't Use TLS.
MAY – May Use TLS.
MUST – Enforce TLS.
MUST_NOPEERMATCH – Loose TLS.

7. Click Continue.

TLS and Message History
You can filter the Message History log for SSL/TLS messages in the Activity > History > Message
History > Advanced search menu.
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Certificates
A valid SSL certificate is required to support the encryption services available on the WatchGuard
XCS. The SSL encrypted channel from the server to the web browser (for example, when you use a
URL that begins with HTTPS), requires a valid digital certificate. You can use self-signed certificates
generated by the system, or import certificates purchased from commercial vendors, for example,
VeriSign.
A certificate binds a domain name to an IP address by means of the cryptographic signature of a
trusted party. The web browser warns you of invalid certificates that undermine secure, encrypted
communications with a server. The disadvantage of self-signed certificates is that web browsers
display warnings that the “company” (in this case, the WatchGuard XCS) issuing the certificate is
untrusted. When you purchase a commercial certificate, the browser recognizes the company that
signed the certificate and does not generate these warning messages.
A web server digital certificate can only contain one domain name, for example, server.example.com,
and a limitation in the SSL protocol only allows one certificate per IP address. Some web browsers
display a warning message when trying to connect to any domain on the server that has a different
domain name than the server specified in the single certificate. Digital certificates eventually expire
and are no longer valid after a certain period of time and need to be renewed before the expiration date.
To install a commercial certificate:
1. Select Administration > System > SSL Certificates.
The SSL Certificates page appears.

2. Click Generate a 'self-signed' certificate.
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3. Enter the required information for your organization in the form.
4. Click Apply.
You must restart the system to install the certificate.

After the system restarts, the current certificate and certificate request that was signed by the
on-board Certificate Authority is displayed. To obtain a commercial certificate, send this
certificate request information to the commercial Certificate Authority (CA) of your choice (for
example, VeriSign or Entrust) for signing.
Note Make sure that the certificate is an Apache type of certificate for a mail server.
5. When you receive the certificate from the CA, click the Load site certificate button.

6. Copy and paste the PEM encoded certificate information from the signed SSL certificate
returned by the CA into the SSL Certificate text box.
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7. To use a supplied private key, select the Use this Private Key for SSL Certificate check box.
8. Copy and paste the PEM encoded private key into the Private Key text box.
Do not enable this option and leave the field blank if the certificate was generated by a request from
this WatchGuard XCS.

Note If you generate a new self-signed certificate after you install a commercial certificate,
this action overwrites the private key associated with the installed commercial
certificate and renders it invalid.
9. Some commercial certificates require you to upload an intermediate certificate in addition to the
commercial certificate and the private key. You can enter this information into the Intermediate
Certificate section.

Root CA Certificate Bundle (Advanced)
The Root CA (Certificate Authority) certificate bundle file is used by the system to validate certificates
issued by well-known Root Certificate Authorities. In some cases, secure sites may want to utilize
their own Root CA certificate bundle.
Click Advanced for additional options that allow you to manage the Root CA certificate bundle. To
download a copy of your current Root CA bundle, click Download. To upload a new Root CA bundle
file, click Browse to select your file, then click Upload.

When the file is installed, the new Root CA bundle will take effect for TLS sessions and the use of
certificates with the Web Proxy.

User Guide

205

Mail Security

User Guide

206

Content Control

9

Content Control

Attachment Control
Attachment Control is used to control a wide range of problems originating from both inbound and
outbound attachments in email messages and web requests:
n

n

n

n

Viruses and Spyware – Blocks attachments and downloads carrying viruses, spyware, and
other types of malware.
Offensive Content – Blocks the transfer of images which reduces the possibility that an
offensive picture is transmitted to or from your organization’s messaging and web systems.
Confidentiality – Prevents the transmission of unauthorized documents through the
WatchGuard XCS.
Loss of Productivity – Prevents employee abuse of your organization’s computer resources.

Attachment Control can block, allow, or strip attachments using the file extension or MIME content
type of the file. Attachment Control can scan the file to determine its proper content type regardless of
the file extension to prevent malicious users from evading content controls by renaming attachments.
You can set email attachment control actions globally and within a policy for both inbound and
outbound Attachment Control. In addition, you can define different Attachment Control file extension
and MIME type lists for email and web traffic. Attachment Control actions for web content must be set
in a policy.
Note If you use Attachment Control with web content, setting a “Reject” HTTP action for
blocked image types and other web file types effectively stops many web sites from
working properly because files required for viewing of the web site are blocked.
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Attachment Stripping
The Attachment Control feature can identify and remove attachments from inbound and outbound mail
messages. You can configure a list of specific attachment extensions or MIME types that are stripped
from a message before delivery. A configurable notification text attachment replaces the removed
attachment that indicates to the user that the attachment is stripped and specifies the reason why it
was removed.
Note Attachment Stripping is a global feature, and cannot be configured on a per-policy
basis. Attachment stripping is performed after the DomainKeys signature verification
of inbound messages. This may invalidate DomainKeys message signatures for
further recipients because the system modifies the message body. The WatchGuard
XCS verifies any DomainKeys signatures before stripping attachments, but the
signature is not valid for the final recipient because the message has been altered by
the system to remove the attachments.
The WatchGuard XCS determines the file extension and MIME-type for each MIME part in a message.
If the file extension or MIME type exists in the Attachment Stripping global list, that specific file or
MIME part is stripped from the message and discarded before delivery to the recipient. The attachment
cannot be retrieved after it has been stripped from a message. The WatchGuard XCS also examines
MIME parts contained in archive file types, for example, .zip. If a file to be stripped is found in an
archive file, the entire archive file is stripped.
Note You must enable Kaspersky Anti-Virus to expand and examine archive files for
attachments.
Attachment stripping actions are performed in addition to any other scanning actions on a message, for
example, Anti-Spam or content controls. A message can still be rejected or quarantined by other
message scanners after the attachment is stripped. Any message encryption is performed after the
attachments are stripped.

Configure Attachment Control
To configure Attachment Control, select Security > Content Control > Attachment Control.
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File Types
Select a file type to edit the list:
n
n

n

Email File Extensions – Edit the list of email attachment file extensions, such as .exe.
Email Content Types – Edit the list of email attachment content types, such as application/xdosexec.
Web Content Types – Edit the list of web content types, such as application/x-dosexec.
Actions for blocked web file types are configured in Policies.

See Edit Attachment Types for detailed information.

Inbound Settings
1. Select the Enable check box to enable scanning on inbound attachments.
2. Select Block Unlisted Attachments to block any attachments that are not listed in your email
and web file extension and content types.
3. From the Email Action drop-down list, select the action to perform when Attachment Control
blocks an inbound email attachment.
n
n
n

n
n
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Just log – Log the event and take no further action.
Reject mail – Reject the message and send a notification to the sending system.
Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message and do not send a notification to the sending system.
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4. Click Show Notification Settings to select who to send notifications to when a message is
caught by Attachment Control.
You can select Notify Recipient, Notify Sender, or Notify Administrator, and customize the
notification text.

Outbound Settings
1. Select the Enable check box to enable scanning on outbound attachments.
2. Select Block Unlisted Attachments to block any attachments that are not listed in your email
and web file extension and content types.
3. From the Email Action drop-down list, select the action to perform when Attachment Control
blocks an inbound email attachment.
n
n
n

n
n

Just log – Log the event and take no further action.
Reject mail – Reject the message and send a notification to the sending system.
Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message and do not send a notification to the sending system.

4. Click Show Notification Settings to select who to send notifications to when a message is
caught by Attachment Control.
You can select Notify Recipient, Notify Sender, or Notify Administrator, and customize the
notification text.

Stripped Attachment Text
Attachment stripping removes the attachment and then delivers the message to its final destination.
The attachment cannot be retrieved after it has been stripped from a message. A text notification can
be attached to the message in place of the stripped attachment. The replacement text attachment uses
the content type of “text/plain” and the US-ASCII character set.
Click Show Notification Settings to customize the notification text for stripped attachments.
Note Attachment stripping does not allow any headers, such as From: and Subject:, in the
notification template.

Edit Attachment Types
Attachment Control can block, allow, or strip attachments using the file extension or MIME content
type of the file. Attachment Control can scan the file to determine its proper content type regardless of
the file extension to prevent malicious users from evading content controls by renaming attachments.
Select a file type to edit the list:
n
n

n
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Email File Extensions – Edit the list of email attachment file extensions, such as .exe.
Email Content Types – Edit the list of email attachment content types, such as application/xdosexec.
Web Content Types – Edit the list of web content types, such as application/x-dosexec.
Actions for blocked web file types are configured in Policies.
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Scan Archives
You can deep scan archives such as .zip files for forbidden attachments. If an archive file contains a
file type that is blocked, the archive file will be blocked, even if it is set to "Allow". Disable this option if
you do not want to scan the content of the specific archive file type.
Note You must enable Anti-Virus scanning to decompress archive files and check for
forbidden attachments.

Email File Extensions
You can modify existing actions for listed file extensions, or click Add to add a new file extension to
the list.
You can filter the display results by Action and a Search keyword.

To add a new email file extension:
1. Click Add to add a new file extension to the list.
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2. In the File Extension text box, type the file extension name, such as ".exe".
3. From the Inbound Action drop-down list, select the action to perform when this file extension
is detected.
n
n
n

Block – Block the file extension using the assigned action.
Allow – Allow the specified file extension.
Strip – Strip the attachment from the message while still delivering the message to its
destination. The stripped attachment can be replaced by customized notification text.

4. Select the Check Inbound Archive check box to deep scan archive files, such as .zip files, for
files with this extension.
5. From the Outbound Action drop-down list, select the action to perform when this file extension
is detected.
n
n
n

Block – Block the file extension using the assigned action.
Allow – Allow the specified file extension.
Strip – Strip the attachment from the message while still delivering the message to its
destination. The stripped attachment can be replaced by customized notification text.

6. Select the Check Outbound Archive check box to deep scan archive files, such as .zip files,
for files with this extension.
7. In the Comment text box, enter a description for this file extension.
8. Click Apply.

Special File Extensions
There are two special file extensions that you can configure:
n

n

[no extension] – Allows you to configure an action for any attachment that does not have an
extension. Attachment Control uses the MIME-type of the attachment to determine its file type
for scanning, but you can also configure special processing if the attachment has no file
extension. The most restrictive action takes precedence. For example, if you set this option to
allow the attachment, and the detected MIME-type for the attachment is set to block, the
attachment will be blocked.
[password protected] – Allows you to configure an action for attachments that are passwordprotected. Password-protected attachments cannot be opened by the mail scanner, and can
contain viruses, malware, or objectionable content. In some spam campaigns, viruses and
malware are concealed within a password-protected attachment and the password is given to
the user within the message itself. This feature allows you to block or strip this attachment
before it reaches the end user's mailbox. This feature is useful if you have disabled the "Treat
As Virus - Password-protected attachments" option in the Kaspersky Anti-Virus configuration,
but still want control of how to process password-protected attachments. For more information
on Anti-Virus configuration, see Anti-Virus.
Note You must have Kaspersky Anti-Virus enabled to be able to detect that an attachment
is password-protected. The Kaspersky Anti-Virus "Treat as Virus - Passwordprotected attachments" option, if enabled, takes precedence over Attachment Control
actions.
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Upload and Download File Extensions
You can upload a list of file extensions to the system. The file must contain comma or tab separated
entries.
Use this format:
[name],[inbound_action],[outbound_action],[inbound_archive],[outbound_archive],
[comment]

For example,
.exe,Block,Block,on,on,Windows/Dos executable

We recommend that you download the existing file, edit the file as required, and upload it to the
system.
To update a file extension list:
1. To download the file extensions list from the system, click Download.
2. Open the file and update the file extensions list.
3. Click Upload and upload the edited file to the system.

Email Content Types
You can modify existing actions for listed content types, or click Add to add a new content type to the list.
You can filter the display results by Action and a Search keyword.

To add a new email content type:
1. Click Add to add a new content type to the list.
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2. In the Content Type text box, type the content type name, such as "application/x-dosexec".
3. From the Inbound Action drop-down list, select the action to perform when this content type is
detected.
n
n
n

Block – Block the content type using the assigned action.
Allow – Allow the specified content type.
Strip – Strip the attachment from the message while still delivering the message to its
destination. The stripped attachment can be replaced by customized notification text.

4. From the Outbound Action drop-down list, select the action to perform when this content type
is detected.
n
n
n

Block – Block the content type using the assigned action.
Allow – Allow the specified content type.
Strip – Strip the attachment from the message while still delivering the message to its
destination. The stripped attachment can be replaced by customized notification text.

5. In the Comment text box, enter a description for this content type.
6. Click Apply.

Upload and Download Content Types
You can upload a list of content types to the system. The file must contain comma or tab separated
entries.
Use this format:
[name],[inbound_action],[outbound_action],[inbound_archive],[outbound_archive],
[comment]

For example,
application/x-dosexec,Block,Block,on,on,Windows/Dos executable

Note The inbound_archive and outbound_archive fields are not used and should be defined
as "on".
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We recommend that you download the existing file, edit the file as required, and upload it to the
system.
To update a content types list:
1. To download the content types list from the system, click Download.
2. Open the file and update the content types list.
3. Click Upload and upload the edited file to the system.

Web Content Types
You can modify existing actions for listed content types, or click Add to add a new content type to the list.
You can filter the display results by Action and a Search keyword.

To add a new web content type:
1. Click Add to add a new content type to the list.

2. In the Content Type text box, type the content type name, such as "application/x-dosexec".
3. From the Inbound Action drop-down list, select the action to perform when this content type is
detected.
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n

n

Block – Block the content type using the assigned action. Actions for web attachment
control are defined in Policies.
Allow – Allow the specified content type.

4. From the Outbound Action drop-down list, select the action to perform when this content type
is detected.
n

n

Block – Block the content type using the assigned action. Actions for web attachment
control are defined in Policies.
Allow – Allow the specified content type.

5. In the Comment text box, enter a description for this content type.
6. Click Apply.

Upload and Download Content Types
You can upload a list of content types to the system. The file must contain comma or tab separated
entries.
Use this format:
[name],[inbound_action],[outbound_action],[inbound_archive],[outbound_archive],
[comment]

For example,
application/x-dosexec,Block,Block,on,on,Windows/Dos executable

Note The inbound_archive and outbound_archive fields are not used and should be defined
as "on".
We recommend that you download the existing file, edit the file as required, and upload it to the
system.
To update a content types list:
1. To download the content types list from the system, click Download.
2. Open the file and update the content types list.
3. Click Upload and upload the edited file to the system.

Attachment Size Limits
The Attachment Control feature can filter inbound and outbound mail messages based on the size of
their attachments. You can set a size limit threshold that triggers an action if it is exceeded. If there is
more than one attachment to the message, the attachment sizes are added together.
You can configure attachment size limits globally and through policies.
Note Attachment size limits are checked before any other attachment control function, and
size limit actions take precedence over attachment control actions.
To configure attachment size limits:
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1. Select Security > Content Control > Attachment Size.
2. Go to the Inbound Settingsor Outbound Settings section.

3. Select the Enable check box.
4. In the Limit text box, type the maximum attachment size (in bytes).
Attachments greater than this threshold trigger the Email Action defined in the next step. The
default is 10240000 bytes. Set to 0 to indicate no size limit.
Note The Maximum Message Size configured in Configuration > Mail > Access is also
set to 10240000 bytes, and this threshold is exceeded if the attachment size is close
to the attachment size limit. We recommend that the Maximum Message Size value
be at least 1.5 times the value of the Attachment Size Limit option to make sure that
large attachments do not exceed the Maximum Message Size.
5. From the Email Action drop down list, select an action to perform on an email message when
the attachment size threshold limit is exceeded:
n
n
n

n
n

Just log – Log the event and take no further action.
Reject mail – Reject the message and send a notification to the sending system.
Quarantine: System – Place the message into the system quarantine area. You can also
choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message and do not send a notification to the sending system.
This is the default action.

6. Click Show Notification Settings to select who to send notifications to when an attachment
exceeds the size limit.
You can select Notify Recipient, Notify Sender, or Notify Administrator, and customize the
notification text.
7. Click Apply.
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Content Scanning
Content Scanning performs deep scanning of email and web messages and files, for example, PDF
and Microsoft document files, for patterns of text and phrases. This allows organizations to use filter
rules and policy settings to scan attachments for specific content that could be considered offensive,
private and confidential, or against existing compliance rules.
If you enable Content Scanning globally, no additional message processing occurs until you configure
additional features to use the Content Scanning feature. There are two methods for scanning the
content of messages and attachments:
n

n

Configure a Pattern Filter or Content Rule with the “Content Scanning” message part to search
for text and phrases in a document.
Use a dictionary with a policy to scan extracted message text and attachments for words and
phrases that appear in the dictionary.
Note Content Scanning is also known as Attachment Content Scanning (ACS).
"ACS" appears in many logs and drop-down selections, and refers to the Content
Scanning feature.

Unopenable Attachments
These cases of unopenable documents classifies the attachment as a compliance violation if you
enable the Treat unopenable documents as compliancy violations option.
n
n
n
n

Files larger than 1 GB
File types not recognized by the scanner
Files that take longer than one minute to scan
Malformed or virus-infected attachments

Configuring Content Scanning
To configure Content Scanning:
1. Select Security > Content Control > Content Scanning.
The Content Scanning page appears.
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2. Select the Enable content scanning check box.
3. Select the Enable international document capability check box to perform content scanning
on attachments that use non-Western international Unicode characters sets.
See Dictionaries for more detailed information on dictionary character set support and
internationalized content scanning.
4. To treat unopenable documents as though they were not compliant, select the Treat
unopenable documents as violations check box.
Attachments that are protected by a password or encrypted can contain text that is a compliance
violation.

5. In the Phrase Length text box, type the phrase length to use for pattern-matching checks.
This number of words is passed to the scanning engine to check if it matches any phrases in your
compliance file. The default is 4.

Note Long phrases result in greater processing times. The phrase length of the compliance
dictionary selected for Content Scanning must not be greater than the phrase length
selected in this text box. If you use Content Scanning with the DLP wizard, the
Content Scanning phrase length be a minimum of 4. Depending on the ID number you
search for, you must set the Content Scanning phrase length to an appropriate value
to match that pattern.
See Data Loss Prevention Wizard for more information.
6. From the File Types drop-down list, select the types of files to scan:
n
n

n

All Supported Formats– Scans all file formats supported by the content scanner.
Common Document Formats– Scans only common word processing, spreadsheet,
database, presentation, text, and archive formats. This is the default setting.
Standard Document Formats– Scans only common document formats (word processing,
spreadsheet, database, presentation, text, and archive files). This includes less common
formats, for example, graphics and desktop publishing formats.

6. From the Punctuation Treatment drop-down list, select how to treat punctuation in words and
phrases:
n

n

n

Significant– The punctuation is considered as part of the word or phrase it appears in. This
is the default setting.
Treat as space– The punctuation is treated as a space. For example, the phrase “This, is
classified” is treated as “This is classified”.
Ignore– The punctuation is completely ignored.

7. From the Case Sensitivity drop-down list, select how the scanning engine treats capitalization.
The default is Insensitive. Select Sensitive to take capitalization of letters into account. For
example, the word “Classified” must appear in the phrase compliance file with the first letter
capitalized.
8. Select who to send notifications to when a message is caught by Content Scanning.
You can select Notify Recipient, Notify Sender, or Notify Administrator, and customize the
notification text.
9. Click Apply.
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Use Pattern Filters for Content Scanning
To create a Pattern Filter for use with Content Scanning:
1. Select Security > Content Control > Pattern Filters.
2. Click Add.
3. From the Apply To drop-down list, select whether you want to check Inbound, Outbound, or
All Mail.
4. From the Message Part drop-down list, select Content Scanning.
Note Content Scanning scans the entire email message. This includes the header, body
and any attachment for matching content.
5. In the Pattern text box, enter a text pattern to match against.
6. From the Action drop-down list, select an action to perform on a message that contains the
pattern text, for example, Reject.
7. Click Apply.

Use a Compliance Dictionary for Content Scanning
You can also perform Content scanning with policies by uploading compliance dictionaries. The
compliance dictionaries contain a list of words and phrases that are checked against text in scanned
attachment files and web uploads and downloads.
You can set a weighted threshold for weighted compliance dictionaries. For example, the system can
encrypt an outbound message when the phrase “patient number” and the term “diagnosis” is detected in
the same message content. In the weighted dictionary, these terms can be configured to have a weight
of 50. If the weighted threshold for the compliance dictionary is set to 100, these two terms, or any
number of terms that match or exceed a weight of 100, result in the message being encrypted. In the
specified Content Control policy, select the dictionaries to use with the policy. If required, select a
weighted threshold between 1 and 9999.
To configure a compliance dictionary to use for Content Scanning:
1.
2.
3.
4.
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Select Security > Policies > Policies.
Select an existing policy or add a new policy.
Select Content Control.
In the Email Content Scanning section, from the Compliance Dictionaries drop-down list,
select Define.
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5. Use the arrow buttons to move a dictionary from the Available Dictionaries section to the
Dictionaries in Use section.
To upload custom dictionary files, select Security > Content Control > Dictionaries, or click
Add or Edit to manage your dictionaries.
See Dictionaries for more detailed information on uploading custom dictionary files.
6. From the Weighted Threshold drop-down list, select Define to enter an optional weighted
threshold for the dictionary.
7. In the Action field, click Edit to select the corresponding action to perform for Email and HTTP
traffic, for example, Reject, and select the notifications to send.
8. Click Apply.
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Objectionable Content Filter
The Objectionable Content Filter (OCF) defines a list of key words that cause a message to be blocked
if any of those words appear in the message. The Objectionable Content Filter provides enhanced
content filtering functionality and flexibility, allowing users to restrict objectionable words and phrases,
and offensive content.
The predefined lists provided are configurable and can be updated and customized to meet the specific
needs of any organization. Rules can also be applied to both inbound and outbound email messages
and web uploads and downloads. This prevents unwanted content from entering an organization, and
prohibits the release of sensitive content outside an organization.
OCF words are extracted from messages that disguise the words with certain techniques. For
example, OCF detects the word “spam”, even if it is disguised as “sp@m” or “s_p_a_m” using the
advanced token recognition component of the Token Analysis feature.
Note OCF has a maximum of 35 characters for a word. OCF does not detect plurals of
words. Both plural and singular word forms must be defined in the dictionaries.
To configure OCF:
1. Select Security > Content Control > Objectionable Content.

2. Select the Enable OCF check box.
3. Select the Enable international character support check box to support international
languages when you use the OCF feature to scan messages that use Unicode or other
supported international character sets.
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If you do not require international character support for OCF, we recommend you leave this
option disabled to improve message processing performance. This option also controls
international character support for the Spam Words feature.
4. From the Logging drop-down list, select the type of logging to perform for OCF processing:
n
n
n

No Logging – Do not log OCF actions.
First match only – Log the first word that is matched by the filter.
All matches – Log all words that are matched by the filter.

4. From the Email Action drop-down list, select an action to perform:
n
n
n

n
n
n
n
n
n

Just log – Log the event and take no further action.
Reject mail – Reject the message and send a notification to the sending system.
Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message and do not send a notification to the sending system.
Encrypt – Redirect the message to an encryption server.
Decrypt – Redirect the message to a decryption server.
Archive – Redirect the message to an archive server.
SecureMail Encrypt – Encrypts the message with the integrated SecureMail encryption
engine.

5. In the Weighted Threshold text box, type a threshold for OCF to classify a message as
containing objectionable content. This threshold only applies if you use weighted
dictionaries.You can specify a value between 1 and 9999. The default is 100.
If the aggregate weight of the OCF words found in a message matches or exceeds this
threshold, OCF performs the configured action. If both weighted and unweighted dictionaries
are used, the final action is triggered if the sum of the weights exceeds the configured weighted
threshold, or if a match occurs in an unweighted dictionary.
6. Select the OCF Dictionaries to use with inbound and outbound OCF.
The dictionaries available are listed in the Available Dictionaries section. Use the arrow
buttons to move the dictionaries to the Dictionaries in Use section as required.
The default OCF dictionaries consist of a “Short”, “Medium”, and “Long” list of common
objectionable words and phrases. You can create your own OCF dictionary files in Security >
Content Control > Dictionaries.
Click Add or Edit to manage your dictionaries.
Note The OCF dictionaries contain content that are of a vulgar nature. The pre-defined
dictionaries must be viewed with caution because they contain words and phrases
that are offensive. All dictionaries must be reviewed and modified as required before
you enable them for use with OCF.
7. Select who to send notifications to when objectionable content is detected by OCF.
You can select Notify Recipient, Notify Sender, or Notify Administrator, and customize the
notification text.
8. Click Apply.
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Document Fingerprinting
Document Fingerprinting scans trusted, outbound email messages and their attachments, and allows
or blocks the delivery of these messages as required by comparing them to an uploaded training set of
allowed and forbidden documents.
Note Document Fingerprinting only scans outbound messages relayed from a trusted
source.
An outbound message that matches an “Allow Relaying” Specific Access Pattern is
not scanned by Document Fingerprinting.
Document Fingerprinting extracts text from common office document formats, for example, plain text,
HTML, PDF, and Microsoft Office (Word, Excel, Powerpoint). This text is compared to the existing
document training set uploaded by the administrator. The outbound message is assigned a score
(between 0 and 100) that indicates to which category it belongs. A score closer to 0 indicates an
allowed category. A score closer to 100 indicates the forbidden category.
Note Content Scanning must be enabled to scan common office document file types, for
example, Microsoft Office and PDF formats with Document Fingerprinting.
If the Document Fingerprinting score is greater than the configured threshold, the document is
classified as forbidden, and the specified action is performed on the message. For example, if the
administrator sets the threshold to 90, any scanned message with a Document Fingerprinting score of
90 or greater is considered as forbidden and the configured action is performed on the message.

Upload Training Documents
Before you enable Document Fingerprinting, you must upload at least one allowed and one forbidden
document for training purposes. You can upload documents one at a time, or you can upload an archive
file (of .zip or .gzip format) containing several documents for each category.
The WatchGuard XCS assumes that all data in plain text and HTML message parts belong to the ISO8859-1 character set. Text extracted from other types of documents, for example, Microsoft Office
files, are converted to the ISO-8859-1 character set. Any characters that do not exist in the ISO-8859-1
characters set are converted to the “*” character.
Note You can only upload training documents on a global basis. You cannot upload different
training sets within policies.
To upload training documents:
1. Select Security > Content Control > Dictionaries.
The Dictionaries page appears.
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2. Click Add.
3. Enter or upload your dictionary.
4. From the Character Set drop-down list, select the correct character set for the content.
Choose the BINARY character set if you upload a Microsoft Office, PDF file, or .zip archive of
documents.

5. From the Type drop-down list, select Document Fingerprinting.
6. Click Apply.
7. Select Security > Content Control > Document Fingerprinting.

8.
9.
10.
11.

In the Training Set section, click Add Document Fingerprinting File.
From the file drop-down list, select the existing document file.
From the adjacent drop-down list, select if this file is Allowed or Forbidden.
Click Add.
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Configure Document Fingerprinting
To configure Document Fingerprinting:
1. Select Security > Content Control > Document Fingerprinting.
The Document Fingerprinting page appears.

2. Select the Enable Document Fingerprinting check box.
Note You cannot enable Document Fingerprinting until you upload at least one allowed file
and one forbidden file for training.
3. In the Threshold text box, type a Document Fingerprinting threshold between 0 and 100.
Scores closer to 0 indicate the allowed category. Scores closer to 100 indicate the forbidden
category. The default threshold is 90. Any scanned message with a score of 90 or greater
triggers the specified action.
4. From the Email Action drop-down list, select an action to perform on the message when the
Document Fingerprinting threshold is exceeded.
n
n
n

n
n
n
n
n
n

n

Just log – Log the event and take no further action.
Reject mail – Reject the message and send a notification to the sending system.
Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Discard mail – Discard the message and do not send a notification to the sending system.
BCC – Send a Blind Carbon Copy of the message to the specified email address.
Encrypt – Redirect the message to an encryption server.
Decrypt – Redirect the message to a decryption server.
Archive – Redirect the message to an archive server. Archive priority can be set to Low,
Medium, and High.
SecureMail encrypt – Encrypts the message with the integrated SecureMail encryption
engine.

5. Select who to send notifications to when a message is caught by Document Fingerprinting.
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You can select Notify Recipient, Notify Sender, or Notify Administrator, and customize the
notification text.
6. To include Document Fingerprinting diagnostic headers in the message header, select the
Enable Diagnostic Headers check box.
The Document Fingerprinting message score and highest and lowest token scores are helpful in
troubleshooting message delivery issues.
7. Click Apply.
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Pattern Filters
Pattern Filters are the primary tool for creating filter rules on the WatchGuard XCS. Pattern Filters are
used for:
n
n

Trusting and blocking messages containing certain text or characteristics
Creating content filter rules for managing email messages

An administrator can create filter rules for any aspect of an email message. This includes the message
header, sender, recipient, subject, attachment content, and message body text. For example,
administrators can create a simple text filter that specifies to check messages for the word “spam” in
the subject. This filter rule is helpful in correcting disadvantages in the other spam filters.
Note Specific Access Patterns must be used to trust specific servers because Pattern
Filters can bypass or interfere with certain content filters, for example, Content
Scanning and OCF, that occur later in the processing order.
Note Pattern Filters is also known as Pattern Based Message Filters (PBMF).
"PBMF" appears in many logs and drop-down selections, and refers to the Pattern
Filters feature.
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Email Message Structure
This is an example of a typical mail message:

Message Envelope
The information in the message envelope (HELO, MAIL FROM, and RCPT TO) are parameters not
visible to the user. They are the handshake part of the SMTP protocol. You need to look for these in the
log files or have other knowledge of them.

Message Header
The message header includes these fields:
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Received from
Indicates the final path that the message followed to get to its destination. It arrived from
mail.example.com, which delivered it to server.example.com to be put in the mailbox of
user@server.example.com.
Received by
This indicates a previous hop that the message followed. In this case, the message came
through mail.example.com which accepted the message addressed to user@example.com.
Delivered-To
The user to which to deliver to, in this example, user@example.com.
Received from
This field marks the origin of the message. Note that it is not necessarily the same as the actual
server that sent the message.
Subject
This is a free form field and is displayed by a typical mail client.
To
This is a free form field and is displayed by a typical mail client. It may be different from the
destination address in the Received headers or from the actual recipient.
From
This is a free form field and is displayed by a typical mail client. It may be different from the
From address in the Received headers. It is typically faked by spammers.
Message-ID
This is added by the mail server and is often faked by spammers.
Other header fields include Reply-to, Sender, and others. These fields can be forged by spammers
because they do not affect how the mail is delivered.

Message Body
After the header is the text or content of the message. This content can be formatted or encoded in
many different ways, but in this example, it is displayed as plain text.

Message Attachment
Many emails contain attachments to the main message. The system has the ability to decode
attachments to match text found within an attachment using a filter rule.

Default Pattern Filters
These default Pattern Filters support SecureMail Email Encryption and the Outlook SecureMail Add-in:
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n
n

Outbound Mail Subject: Contains [SecureMail]
Outbound Mail <<Mail Header>> Reg Exp ^X-XCS-SecureMail: 1$

These default Pattern Filters support the user submitted "Spam" and "Not Spam" training feature:
n

n

All Mail Envelope To: matches spam@mailsupport.watchguard.com (trains on user submitted
spam messages)
All Mail Envelope To: matches notspam@mailsupport.watchguard.com (trains on user
submitted not spam messages)

The other predefined default pattern filters are included to make sure that mail is not trained in these
situations:
n
n
n
n
n
n
n
n
n
n
n
n
n

Outbound Mail To: contains @watchguard.com
Outbound Mail To: contains @borderware.com
All Mail Subject: contains [SPAM]
All Mail Subject: contains [MAYBE SPAM]
All Mail Subject: contains Spam summary for
All Mail Subject: contains Delayed Mail
All Mail Subject: contains Delivery Status Notification
All Mail Subject: contains Delivery Failure Notification
All Mail Subject: contains Undelivered Mail Returned to Sender
All Mail Subject: contains AutoReply
All Mail Subject: contains Returned Mail:
All Mail From: contains postmaster@ + domain
All Mail From: contains MAILER-DAEMON@ + domain

These rules help prevent misconfiguration of the Token Analysis database to make sure that forwarded
spam messages, delivery notifications, automatic replies, and system messages are not trained.
Note Spam messages must never be forwarded within an organization because this action
can misconfigure the Token Analysis training database.
Additional postmaster and MAILER-DAEMON Pattern Filters must be created for organizations
supporting multiple domains.
You can edit or remove the default Pattern Filter rules in Security > Content Control > Pattern
Filters.

Credit Card Pattern Filters
To assist you with regulatory compliance for Payment Card Industry (PCI) and other types of Data
Loss Prevention (DLP) digital security standards, the WatchGuard XCS includes predefined regular
expression Pattern Filters that search messages and attachments for specific credit card patterns
using the Content Scanning feature.
For example, any messages or attachments that contain a credit card number can be encrypted before
delivery to protect the data.
Several default credit card types are provided (Diners Club, American Express, Discover, MasterCard,
and Visa) that allow you to search for these patterns in incoming and outgoing messages and
attachments.
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By default, the credit card pattern filters are initially disabled and set to the action of Just Log.
To enable and edit the pattern filters:
1. Select a credit card Pattern Filter to edit.
2. Select the Enabled check box to enable the pattern filter.
3. From the Action drop-down list, select an action to take when this credit card pattern is
detected in a message or attachment.
For example, you can Encrypt a message before it is sent if a credit card pattern is detected.

Content Scanning Phrase Length for Credit Card Pattern Filters
When you enable Credit Card patter filters, you must make sure the Content Scanning phrase length is
at least 4 so that credit card filters are properly scanned.
To modify the content scanning phrase length:
1.
2.
3.
4.

Select Security > Content Control > Content Scanning.
Select the Enable check box.
In the Phrase Length text box, type 4 .
Click Apply.

Validation for Regular Expressions
The WatchGuard XCS provides validation for regular expressions that search for financial, banking,
health care, and other types of data when scanning messages. This validation helps prevent false
positives when you match regular expression patterns during message processing.
For example, you can create a pattern filter or content rule with a regular expression that searches for a
specific credit card pattern. As part of the rule, you can specify "Credit Card" validation to use with the
regular expression. When the message is processed, the system validates the patter filter match to
make sure that it has matched a known credit card number type.
You can specify validation for these types of identification numbers:
National Identification Numbers
n
n
n

SIN – Social Insurance Number (Canada)
SSN – Social Security Number (U.S.)
INSEE – Social Insurance Number (France)

Health Identification Numbers
n
n
n

DEA – Drug Enforcement Administration Number (U.S.)
NPI – National Provider Number (U.S.)
NHS – National Health Service number (U.K.)

Financial Information Numbers
n

n
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Credit Card Number – Includes VISA, MasterCard, American Express, Discover, Diners Club,
or other credit cards.
CUSIP – Committee on Uniform Security Identification Number
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n
n

IBAN – International Bank Account Number
RTN – Routing Transit Number

General Validation
n

Luhn/Mod10 - Luhn algorithm validation

Content Scanning Phrase Length for IBAN and INSEE Numbers
When you create regular expression patter filters for IBAN and INSEE numbers, you must make sure
the Content Scanning phrase length is at least 6 so that IBAN numbers are properly scanned. INSEE
numbers require a minimum phrase length of 7.
To modify the content scanning phrase length:
1.
2.
3.
4.

Select Security > Content Control > Content Scanning.
Select the Enable check box.
In the Phrase Length text box, type the new phrase length, such as 6 .
Click Apply.

Configure Pattern Filters
To configure Pattern Filters:
1. Select Security > Content Control > Pattern Filters.
The Pattern Filters page appears.

2. Click Add.
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3. In the Name text box, type a name for this Pattern Filter.
The name can only consist of letters, numbers, spaces, periods, underscores, and dashes.

4. Select the Enable this filter check box.
5. From the Apply To drop-down list, select the direction of mail for the Pattern Filter rule:
n
n

n

All Mail – Mail destined for any domain.
Inbound – Any mail that is destined to a domain for which the system is configured to
accept mail for. This is any domain listed in the mail routing table in Configuration > Mail
> Routing.
Outbound – Mail destined to any domain for which the system is not configured to accept
mail (every domain other than those configured in Mail Routing).

6. From the Message Part drop-down list, select a message part on which to filter.
These parameters are not visible to the user. They are the handshake part of the SMTP
protocol. You can filter on these parameters.
<<Mail Envelope>>
This parameter allows for a match on any part of the message envelope which includes the
HELO, Client IP, and Client Host.
HELO
This field is easily faked, and is not recommended for use in spam control. It may be useful
in trusting a source of mail. For example: mail.example.com.
Client IP
This field is accurately reported and can be reliably used for both blocking and trusting. It is
the IP address of the system initiating the SMTP connection. For example: 192.168.1.200.
Client Host
This field is accurately reported and can be reliably used for both blocking and trusting.
For example: mail.example.com.
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These envelope parameters (Envelope Addr, Envelope To, and Envelope From) may be visible
if your client supports reading the message source. They can also be found in the transport logs.
Other header fields may be visible as supported by the mail client.
Envelope Addr
This finds matches in either the Envelope To or Envelope From field. These fields are
easily faked, and are not recommended for use in spam control. They may be useful in
trusting a source of mail. For example: fred@example.com.
Envelope To
This field is easily faked, and is not recommended for use in spam control. It may be useful
in trusting a source of mail. For example: fred@example.com.
Envelope From
This field is easily faked, and is not recommended for use in spam control. It may be useful
in trusting a source of mail. For example: fred@example.com.
Message Header Parameters
Spammers typically enter false information into these fields, except for the Subject field, and
they are usually not useful for controlling spam. These fields can be useful in trusting certain
users or legitimate source of email.
Note Mail Header parameters only match on the primary header of a message and not other
multi-part message headers.
<<Mail Header>>
This parameter allows for a match in any part of the message header.
<<Recipient>>
This parameter finds matches in the To: or CC: fields of the message.
CC:
This parameter finds matches in the CC: (Carbon Copy) field of the message.
From:
This parameter finds matches in the From: field of the message.
Message-ID:
This parameter finds matches in the Message-ID: field of the message.
Received:
This parameter finds matches in the Received: field of the message.
Reply-to:
This parameter finds matches in the Reply-to: field of the message.
Sender:
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This parameter finds matches in the Sender: field of the message.
Subject:
This parameter finds matches in the Subject: field of the message.
To:
This parameter finds matches in the To: field of the message.
There are other header fields that are commonly used, for example, List-ID, as well as those
added by local mail systems and clients. You must use Regular Expressions to specify these
parameters.
Message Body Parameters
<<Raw Mail Body>>
This parameter finds matches in any part of the encoded message body. This encoded
content includes Base64, MIME, and HTML. Because messages are not decoded, a
simple text match may not work. Use <<Mail Content>> for text matching on the decoded
content. This parameter also matches in multi-part message parts. You can also set a
Match Threshold that indicates how many times this pattern must appear in the message
before an action is performed.
<<Mail Content>>
This parameter finds matches in the visible decoded message body. You can also set a
Match Threshold that indicates how many times this pattern must appear in the message
before an action is performed.
STA (Token Analysis) Token
Token Analysis tokens can also be selected for pattern based message filters. This allows
you to match patterns for common spam words that can be hidden or disguised with fake or
invisible HTML text comments, that would not be caught by a normal pattern filter. For
example, Token Analysis extracts the token “viagra” from the text “vi<spam>ag<spam>ra”
and “v.i.a.g.r.a.”. You can also set a Match Threshold that indicates how many times this
pattern must appear in the message before an action is performed.
Content Scanning
You can define Pattern Filters to match the content of an entire mail message and its
attachments. This type of Pattern Filter is used with the Content Scanning feature. You can
also set a Match Threshold that indicates how many times this pattern must appear in the
message before an action is performed.
7. From the Pattern drop-down list, select a matching option:
n

n

n

236

Contains – Looks for the text to be contained in a line or field. This allows for spaces or
other characters that can make an exact match fail.
Ends with – Looks for the text at the end of the line or field (no characters, spaces and so
on, between the text and the non-printed end-of-line character.)
Matches – The entire line or field must match the text.
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n

Starts with – Looks for the text at the start of the line or field (no characters between the
text and the start of line.)
Reg Exp – Enter a regular expression to match the text. The WatchGuard XCS supports
Extended POSIX regular expressions.
n Validated By – If you select a regular expression for the pattern, an additional
Validated By field appears. From the Validated By drop-down list, select the type
of validation to use for your regular expression. For example, if you enter a regular
expression to search for a credit card pattern, select "Credit Card". The validation is
applied when a message is processed to reduce the chances of false positives when
detecting specific types of regular expression patterns.

8. In the Pattern text box, type a text pattern (case insensitive) to search for in the message.
You can also use regular expressions that allow you to specify match rules in a more flexible
manner.
For example, to search for a blank message field, use this regular expression:
^subject:[[:blank:]]*$

Note WatchGuard cannot help with devising or debugging Regular Expressions because
the expressions have a wide variety and can be very complex. We recommend you do
not use regular expressions unless you have advanced knowledge of their use.
Regular expressions are based on the Extended POSIX specification.
9. In the Match Threshold text box, type the number of times a pattern must appear in the
message before an action is performed.
This field only appears when you select the Raw Mail Body, Mail Content, STA Token, or
Content Scanning message parts. For example, if you set this field to 3, a pattern must appear
at least 3 times before an action is performed. The default is 1.
10. From the Priority drop-down list, select a priority for the Pattern Filter (High, Medium, Low).
The entire message is read before a decision is made about which filter to use. If a message
matches multiple filters, the filter with the highest priority is used. If more than one matched
filter has the highest priority, the filter with the strongest action is used, in order, from highest
priority to lowest (Bypass, Reject, Discard, Quarantine, Certainly Spam, SecureMail
Encrypt, Archive, Redirect, Trust, Relay, Accept, Just log). Note that Discard, Quarantine,
and Redirect are only available as custom actions.
If more than one matched rule has the highest priority and highest action, then the filter with the
highest rule number is used.
11. From the Action drop-down list, select an action to perform when Pattern Filter is matched:
n
n

User Spam Train – This action is used to train on spam messages submitted by end users.
User Not Spam Train – This action is used to train on legitimate (not spam) messages
submitted by end users.

Note The User Spam Training and User Not Spam Training actions are used with the
default Pattern Filters for user submitted messages.
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n

n

n

Bypass – Allow this message to bypass all Intercept Anti-Spam and Content Control
(Attachment Control, Content Scanning, Malformed Message, and OCF) processing. This
action overrides other Pattern Filter actions for the same priority. This action does not
bypass Anti-Virus scanning.
Trust – This mail is considered trusted and from a legitimate source. This message is not
processed for spam. Mail is trained as legitimate mail.
Reject – Mail is received, then rejected before the close of an SMTP session. Message is
trained for spam if Train is also selected.
Relay – Message can be relayed externally. Message is trained as legitimate mail or spam
as determined by Intercept Anti-Spam if Train is also selected.

Note The Relay or Trust action can only be used with an Envelope message part because
attempted relays must be rejected immediately after the envelope transaction.
n

n

n
n

n

Accept – Mail is accepted and is delivered regardless if the message is considered spam.
Message is trained as legitimate mail if Train is also selected.
Certainly Spam – Mail is received, trained as spam, and then the Intercept action for
Certainly Spam is applied.
Discard – Discards the message and does not send a notification to the sending server.
Just Log – Take no action, but log the occurrence. Just Log can be used to override other
lower priority Pattern Filters to test the effect of Pattern Filters without an action taking place.
SecureMail Encrypt – Encrypts the message with the integrated SecureMail encryption
engine.

Note If SecureMail Email Encryption is disabled globally, messages are delivered
unencrypted when triggered by a Pattern Filter.
n

n

BCC – Send a blind carbon copy mail to the mail address specified in Action Data text box.
This option only appears if you have a BCC email address set up in the Custom Actions page.
Do Not Train – Do not use the message for Token Analysis training.

These actions appear in this list if they are defined in the Custom Actions page:
n

n
n

n
n
n

Quarantine: System – Place the message into the system quarantine area. You can also
choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Redirect to – Redirects the message to the mail address or server specified in the Action
Data field.
Encrypt – Redirects the message to an encryption server.
Decrypt – Redirects the message to a decryption server.
Archive (High, Medium, Low) – Redirects the message to an archiving server.

11. In the Comment text box, enter a description for the Pattern Filter so that you can easily
identify its purpose.
The comment can only consist of letters, numbers, spaces, periods, underscores, and dashes.

12. Click Apply.

Search and Sort Pattern Filters
Use the search controls at the top of the Pattern Filters page to filter the list. You can select a specific
action from the Action drop-down list, or a message part from the Message Part drop-down list.
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To search by keyword or pattern filter number, type specific search text in the Search text box.

To sort the list of Pattern Filters, click on a specific column title. For example, to sort the list by priority,
click the Priority column.

Upload and Download Pattern Filters
You can create a list of Pattern Filters and upload them in a text file. The file must contain comma or
tab separated entries.
Use this format:
[section],[type],[pattern],[action],[sequence(priority)],[rulenumber],[direction
(inbound, outbound, both],[options (on or ‘blank’)]|[validation],[name],[is_enabled
(t or f)],[comments]

For example:
to:,contains,friend@example.com,reject,medium,1,both,on|cc,patternname,t,comment

The Options field is used for the Do-Not-Train option and validation. The training value can be on or
blank. If the field is blank, a Reject action is considered Reject+Train.
For validation, use these values:
n
n
n
n
n
n
n
n
n
n
n

Credit Card - cc
CUSIP – cusip
DEA – dea
Luhn/Mod10 – luhn
IBAN – iban
INSEE – insee
NHS – nhs
NPI – npi
RTN – rtn
SIN – sin
SSN – ssn

You must use a text editor to create the file pbmf.csv.
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To update a Pattern Filter file:
1. To download the Pattern Filter list from the WatchGuard XCS, click Download File.
2. Open the file and update the Pattern Filter list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
Note The default Pattern Filters are not downloaded when you download the Pattern Filter
list. Only user defined Pattern Filters appear in the list.
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Content Rules
Content rules allow you to create customized rule conditions for examining email message content and
perform customized actions based on the search criteria. A rule can contain one or several conditions,
including nested boolean operations, and the specified action is performed on the message if the
conditions in the rule are satisfied. Rules can be ordered in priority as required. You can enable Content
Rules globally, and you can also configure rules in the Content Control section of a policy.
Note Content Rules are processed after Pattern Filters. To prevent issues with rule order
processing, we recommend that you use either one method or the other when creating
rule filters, and do not use both concurrently.
When you use Content Rules in conjunction with Trusted/Blocked Senders Lists, note this behavior:
n

n

Users listed in the Trusted Senders List override any Content Rule action except if the rule
action is Quarantine, Reject, or Discard.
Users listed in the Blocked Senders List override a Content Rule action unless the Content
Rule action is Reject or Discard.

Configure Content Rules
To configure and create Content Rules:
1. Select Security > Content Control > Content Rules.
The Content Rules page appears.

2. Select the Enable Content Rules check box.
Enabling Content Rules also enables Connection Rules that are configured in Security > AntiSpam > Connection Control.
3. Select Inbound Content Rules to create rules for inbound traffic.
Select Outbound Content Rules to create rules for outbound traffic.
4. Click Create New Rule, or select an existing rule to modify its settings.
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5.
6.
7.
8.

In the Name text box, type a name for this content rule.
Select the Enable This Rule check box.
In the Description text box, type a detailed description for the rule.
From the Rule Conditions drop-down list, select the condition type, such as AND, OR, or NOT.
Note If you only have a single condition in your rule, the default operator will appear as "OR"
if you save and then edit the rule to add more conditions.
To add nested conditions, click the “+()” icon. Nested conditions allow you to provide additional
conditions with multiple boolean AND, OR, and NOT condition types.
For example, this rule activates when the word "Spam" is detected in the subject field OR "This
is Spam" in the mail body, and only when the phrase "*Test Message*" does NOT appear in the
mail body.

To delete conditions, click the “x” icon. You can add up to 21 levels of nested conditions.
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9. From the drop-down list, select a Message Part for this rule condition.
n
n

n

n

n

n

n

n

n
n
n
n
n
n
n
n
n
n
n

n

n

n

n
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Trusted – The rule only acts on messages that are considered trusted by the system.
Mail Envelope – This parameter allows for a match in any part of the message envelope
which includes the HELO, Client IP, and Client Host.
HELO – This parameter allows for a match in the HELO part of the message envelope. For
example, mail.example.com.
Client IP – This parameter allows for a match in the IP address of the system initiating the
SMTP connection. For example, 10.1.2.200.
Client Host – This parameter allows for a match in the client host name of the system
initiating the SMTP connection. For example, mail.example.com.
Envelope Addr – This parameter allows for a match in the Envelope To or Envelope From.
For example, fred@example.com.
Envelope To – This parameter allows for a match in the Envelope To field. For example,
user@example.com.
Envelope From – This parameter allows for a match in the Envelope From field. For
example, user@example.com.
Mail Header – This parameter allows for a match in any part of the message header.
Recipient – This parameter allows for a match in the To: or Cc: fields.
Cc – This parameter allows for a match in the Cc: field.
From – This parameter allows for a match in the From: field.
Message-ID – This parameter allows for a match in the Message-ID: field.
Received – This parameter allows for a match in the Received: field.
Reply-to – This parameter allows for a match in the Reply-to: field.
Sender – This parameter allows for a match in the Sender: field.
Subject – This parameter allows for a match in the Subject: field.
To – This parameter allows for a match in the To: field.
Raw Mail Body – This parameter allows for a match in any part of the encoded message
body. This encoded content includes Base64, MIME, and HTML. Because messages are
not decoded, a simple text match may not work. Use Mail Content for text matching on the
decoded content. You can also set a Match Threshold that indicates how many times this
pattern must appear in the message before an action is performed.
Mail Content – This parameter allows for a match on the visible decoded message body.
You can also set a Match Threshold that indicates how many times this pattern must
appear in the message before an action is performed.
STA (Token Analysis) Token – You can select Token Analysis tokens for a rule. This
allows you to match patterns for common spam words that can be hidden or disguised with
fake or invisible HTML text comments, which would not be caught by a normal content rule.
For example, Token Analysis is able to extract the token “viagra” from the text
“vi<spam>ag<spam>ra” and “v.i.a.g.r.a.”. You can also set a Match Threshold that
indicates how many times this pattern must appear in the message before an action is
performed.
Content Scanning – This field is used with the Content Scanning feature and matches the
content of an entire message and its attachments. You can also set a Match Threshold
that indicates how many times this pattern must appear in the message before an action is
performed.
DFP Scanned – The rule only acts on messages that have been scanned by Document
Fingerprinting.
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DFP Metric – This parameter allows for a match in the Document Fingerprinting metric
score, for example, equal to, greater than, and less than.

10. In the corresponding drop-down list, select the Match Option for the search:
n

n

n

n
n

n

Contains – Looks for the text contained in a line or field. This allows for spaces or other
characters that can make an exact match fail.
Starts with – Looks for the text at the start of the line or field (no characters between the
text and the start of line.)
Ends with – Looks for the text at the end of the line or field. No characters, spaces are
allowed between the text and the non-printed end-of-line character.
Matches – The entire line or field must match the text exactly as entered.
Reg Exp – Allows you to enter a regular expression for your search criteria. The
WatchGuard XCS supports Extended POSIX regular expressions. If you select the regular
expression match option, an additional validation field appears. From the drop-down list,
select the type of validation to use for your regular expression. For example, if you enter a
regular expression to search for a credit card pattern, select "Credit Card". The validation is
applied when a message is processed to reduce the chances of false positives when
detecting specific types of regular expression patterns.
In Dictionary – Select a predefined dictionary that is matched against the specified
message part. This option is only available with specific message parts.

11. In the search text box, type the specific text (case insensitive) to search for.
12. In the Match Threshold text box, type the number of times a pattern must appear in the
message before an action is performed.
This field only appears when you select the Raw Mail Body, Mail Content, STA Token, or
Content Scanning message parts. For example, if you set this field to 3, a pattern must appear
at least 3 times before an action is performed. The default is 1.
11. From the Action drop-down list, select an action to perform when the rule statement is true:
Note You can define custom actions for use with Content Rules. See Custom Actions for
Pattern Filters and Content Rules for details.
n

n

n
n
n
n
n
n
n
n
n

n
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Continue – No action is taken and the message continues to be processed by the system.
This is the default selection if no action is specified. BCC actions are still performed.
Quarantine: System – Place the message into the system quarantine area. You can also
choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Just log – Log the event and take no further action.
Reject – Reject the message and send a notification to the sending system.
Discard – Discard the message and do not send a notification to the sending system.
Modify Subject Header – Insert the specified text into the message subject line.
Add Header – The specified “X-” mail header is added to the message headers.
Redirect To – The message is delivered to the specified mail address or server.
Accept – Mail is accepted and is delivered regardless if the message is considered spam.
SecureMail encrypt – Encrypts the message with the integrated SecureMail encryption
engine.
PBMF Action – Use a custom pattern filter action as defined in the Pattern Filter
configuration.
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n

n

Encrypt – Redirects the message to the encryption server specified in the Configuration
> Mail > Encryption > External Encryption menu.
Decrypt – Redirects the message to the decryption server specified in the Configuration
> Mail > Encryption > External Encryption menu.
Archive – Redirects the message to an archive server specified in the Configuration >
Mail > Archiving menu. Archive priority can be set to Low, Medium, and High.

13. In the BCC text box, type an optional email address to send a blind carbon copy of the message
to if the rule is matched.
14. From the Train drop-down list, select the training options for this rule if it is matched.
n

n
n
n

Intercept decides – The Intercept Anti-Spam engine decides whether to train the message
as spam or legitimate mail based on its scanning results.
Do not train – The message is not be trained.
Train as ham – The message is trained as a legitimate (ham) message.
Train as spam – The message is trained as a spam message.

15. Select the corresponding check box to send a notification message to the Sender, Recipient,
and Administrator.
16. In the Notification text box, customize the notification text that is sent when a Content Rule is
triggered.
17. Click Apply.

Rule Ordering
The rules are processed in the displayed order. To reorder rules, select a specific rule and drag it to the
desired location. Click Save Rule Order to save the updated order of your rules when you are finished.

Download and Upload Content Rules
You can create a list of Content Rules and upload them in a text file. The file must contain comma or
tab separated entries.
Use this format:
[Policy],[Stage],[Rank],[Name],[Description],[Enabled],[Condition],[Final Action],
[Final Action Text],[BCC Address],[Train Action][Notify Recipients][Notify Sender]
[Notify Admin][Notify Message]

For example:
0,1,50,Rule_10,This_is_Rule_10,1,pbmf_match
(sender:,contains,”spammer”,"",1),subject_rewrite,[Spam],admin@example.com,do_not_
train, 1,1,0,Notification text

You must use a text editor to create the file contentrules.csv.
To update a Content Rules file:
1. To download the Content Rules list from the WatchGuard XCS, click Download File.
2. Open the file and update the Content Rules list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
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Note If you upload a list of content rules, all previous rules are overwritten by the new
uploaded list. It can take several minutes to process long lists of content rules
uploaded in a file. An alarm will be generated when the Content Rule processing is
complete.
This table describes the fields for the rules file:
Field

Description

Policy

Policy ID of the rule. This is 0 for a connection rule.

Stage

This is 1 if the rule is an inbound content rule, 2 if the rule is an
outbound content rule, and 0 if a connection rule.

Rank

The ordering of the rule in the given policy and stage. 1 is the
highest priority, 2 is next highest priority, and so on.

Name

The rule name.

Description

Description of the rule.

Enabled

This value is 1 if the rule is enabled, and 0 if it is disabled.
Rule condition statement:
- trusted
- !trusted (not trusted)
- in_dict(messagepart,dictionaryID).
For example, in_dict(client_hostname,83)
[Note: If you upload a list of rules with content scanning
dictionaries defined, the rule will initially be disabled. You must
review your rules, select the dictionary, and enable the rule
before it can be used.]

Condition

- pbmf_match(messagepart, ptype, text, regex validation,match
threshold).
For example, pbmf_match(sender:,contains,”spammer”,"",1) in
the previous example.
messagepart: “env”, “helo”, “ip”, “client”, “env-addr”, “env-to”,
“env-from”, “body”, “content”, “token”, “acs”, “hdr”, “recipient”,
“cc:”, “from:”, “received:”, “reply-to:”, “sender:”, “subject:”, “to:”,
“message-id”.
ptype : “contains”, “ends”, “starts”, “match”, “regex”.
text: The specified text string.
regex validation: cc, ssn, sin, insee, iban, npi, dea, nhs, cusip,
rtn, luhn
Boolean operators:
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Field

Description

&& - AND, || - OR, ! - NOT
For example, trusted&&in_dict(sender_address,83)||pbmf_match
(subject:,contains,”spam”)

Indicates the final rule action. This includes: “movem”
(Quarantine), “log”, “trash” (Discard), “reject”, “subject_rewrite”,
“add_header”, “redirect”, "sm_encrypt" (Encrypt), “trust”, “relay”,
“whitelist” (Accept), “continue”.
Final action
Custom Pattern Filter actions. This includes external Encryption
and Archiving if enabled: “actiona”, “actionb”, “actionc”, “actiond”,
“actione”, “action1”, “action2”, “action3”, “action4”, “action5”, and
“action6”.
Final action data

Indicates any additional data for the action, for example, the text
for a modified subject or header, for example, “[Spam]” in the
previous example.

BCC address

Contains a blind carbon email address, for example,
user@example.com. This is blank if no address is specified.

Train action

This field is blank if set to the default “Intercept decides”. Other
values include: “do_not_train”, “train_spam”, and “train_ham”.

Notify Recipients

This value is 1 if enabled, and 0 if it is disabled.

Notify Sender

This value is 1 if enabled, and 0 if it is disabled.

Notify Admin

This value is 1 if enabled, and 0 if it is disabled.

Notify Message

The text of the notification message.
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Custom Actions for Pattern Filters and Content
Rules
You can create additional custom actions that you can use with Pattern Filters and Content Rules.
For example, you can only use the Quarantine, Discard, and Redirect actions for a Pattern Filter
when defined as a custom action.
To create custom Pattern Filter or Content Rule actions and notifications:
1. Click Security > Content Control > Custom Actions.

2. Click on a specific custom action to define its options.
You can define up to six custom actions.
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3. In the Name text box, type a description for the action.
4. From the Action drop-down list, select a custom action to perform:
n
n
n

n
n

n

n
n

Reject – Rejects the message and sends a notification to the sending server.
Discard – Discards the message and does not send a notification to the sending server.
Quarantine: System – Place the message into the system quarantine area. You can also
choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Certainly Spam – Mail is received, trained as spam, and then the Intercept action for
Certainly Spam is applied.
Redirect to – Redirects the message to the mail address or server specified in the Action
Data field.
Accept – Accepts and delivers the message.
BCC – The message is copied to the email address specified in the Action Data field.

5. In the Action Data text box, type the action data for the specified Action.
For the Redirect To action, send the message to a mailbox, for example,
spam@example.com. You can also specify a domain, for example, spam.example.com. For a
BCC action, type an email address to which to send a blind carbon copy of the message.
6. Select the Do Not Train option to make sure that when this action is performed, the message
is not trained for spam.
7. In the Notification section, select the users that receive a notification when the custom action
is applied.
n
n
n

Notify Sender – Sends a notification to the sender of the message.
Notify Recipient – Sends a notification to the recipients of the message.
Notify Administrator – Sends a notification to the WatchGuard XCS administrator.

8. Click Apply.
9. In the Notification Message text box, type a custom notification message for the action.
10. In the PBMF BCC Email Address text box, type an email address to use in conjunction with
the BCC action to specify the email address to which to send a blind carbon copy message.
11. Click Apply.

User Reported Spam and Not Spam
End users can utilize a Microsoft Outlook Add-in from WatchGuard that places special Spam and Not
Spam buttons on their Outlook client toolbar. This tool allows the user to report any spam messages
that bypassed the spam filters and were delivered to their inbox, and also report false positives where
legitimate messages were classified as spam.
See WatchGuard XCS Outlook Add-in for more detailed information on installing and configuring the
Outlook Add-in.

User Reported Spam
Select your options for spam reported from end users:
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n
n

n

Training – Enables training on user submitted spam messages.
Add to Blocked Senders – When a user submits messages as spam, the sender is
automatically added to their personal Blocked Senders List.
Relay to WatchGuard – Allows user submitted spam messages to be relayed to WatchGuard
servers for training. Disable this option to use training messages for your device only and not
share them with WatchGuard.

User Reported Not Spam
Select your options for legitimate mail (Not Spam) reported from end users:
n
n

n

Training – Enables training on user submitted legitimate (Not Spam) messages.
Add to Trusted Senders – When a user submits messages as legitimate mail (Not Spam), the
sender is automatically added to their personal Trusted Senders List.
Relay to WatchGuard – Allows user submitted legitimate messages (Not Spam) to be relayed
to WatchGuard servers for training. Disable this option to use training messages for your device
only and not share them with WatchGuard.
WarningIf you import Trusted/Blocked Senders Lists from a WatchGuard QMS
(Quarantine Management Server), the import will overwrite any entries created
by user submitted spam and legitimate mail from the WatchGuard XCS
Outlook Add-in.

Reroute Mail with Pattern Filters
You can use custom Pattern Filters to redirect mail to another mail server, while preserving the
message properties (for example, Envelope To and Deliver To). This feature is similar to the redirect
actions and reroute mail routes used in Archiving and External Encryption to redirect mail to an
archiving or encryption server.
In your mail routing configuration (configured in Configuration > Mail > Routing), create a mail route
that begins with a “.” period character, (for example, .mail_reroute ) and enter the destination mail
server as the address for your mail route.
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When you create a custom Pattern Filter, set the Action to Redirect To, and in the Action Data field,
type the name of the corresponding mail route, for example, mail_reroute .
When a pattern filter is matched, it reroutes the message to the corresponding mail server.
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Connection Rules
Connection Rules allow the administrator to create customized rule conditions for examining incoming
and outgoing message connections, to perform customized actions based on the search criteria. A rule
can contain one or several conditions. The specified action is performed on the message if the
conditions in the rule are satisfied. Rules can be ordered in priority as required.
Note Connection Rules are processed after Specific Access Patterns and Pattern Filters.
To prevent issues with rule order processing, do not use both methods concurrently.
To configure Connection Rules:
1. To enable Connection Rules, you must first enable the Content Rules feature in Security >
Content Control > Content Rules.
2. Select the Enable Content Rules check box.
3. Click Apply.

4. Select Security > Anti-Spam > Connection Control.
5. Select Connection Rules.
6. Click Create New Rule, or select an existing rule to modify its settings.
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7.
8.
9.
10.

In the Name text box, type a descriptive name for this rule.
Select the Enable This Rule check box.
In the Description text box, type a detailed description for the rule.
From the If drop-down list, select all if all conditions in this content rule must be true to trigger an
action, or select any to trigger an action if any condition in the content rule is true.
To add multiple conditions, click the “+” icon. To delete conditions, click the “x” icon. You can only
have a maximum of 10 conditions per rule.

11. From the drop-down list, select a Message Part for this rule condition.
n
n

n

n

n

n

n

n

Trusted – The rule acts only on messages that are considered trusted by the system.
Mail Envelope – This parameter allows for a match on any part of the message envelope
which includes the HELO, Client IP, and Client Host.
HELO – This parameter allows for a match on the HELO part of the message envelope.
For example, mail.example.com.
Client IP – This parameter allows for a match on the IP address of the system initiating the
SMTP connection. For example, 10.1.2.200.
Client Host – This parameter allows for a match on the client host name of the system
initiating the SMTP connection. For example, mail.example.com.
Envelope Addr – This parameter allows for a match on the Envelope To or Envelope
From. For example, fred@example.com.
Envelope To – This parameter allows for a match on the Envelope To field.
For example, fred@example.com.
Envelope From – This parameter allows for a match on the Envelope From field.
For example, fred@example.com.

12. In the drop-down list, select the Match Option for the search:
n

n

n

n
n

n

Contains – Looks for the text contained in a line or field. This allows for spaces or other
characters that may make an exact match fail.
Starts with – Looks for the text at the start of the line or field (no characters between the
text and the start of line.)
Ends with – Looks for the text at the end of the line or field. No characters, spaces, are
allowed between the text and the non-printed, end-of-line character.
Matches – The entire line or field must match the text exactly as entered.
Reg Exp – Allows you to enter a regular expression for your search criteria. If you select
the regular expression match option, an additional validation field appears. From the dropdown list, select the type of validation to use for your regular expression. The validation is
applied when a message is processed to reduce the chances of false positives when
detecting specific types of regular expression patterns.
In Dictionary – Select a predefined dictionary that is matched against the specified
message part.

13. In the search text box, type the specific text to search for.
14. From the Then drop-down list, select an action to perform when the rule statement is true:
n

n

n
n
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Continue – No action is taken and the message continues to be processed by the system.
This is the default selection if no action is specified. BCC actions are still performed.
Quarantine: System – Place the message into the system quarantine area. You can also
choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Just log – Log the event and take no further action.

253

Content Control
n
n
n
n
n
n
n

n

n
n

n
n

Reject – Reject the message and send a notification to the sending system.
Discard – Discard the message and do not send a notification to the sending system.
Modify Subject Header – Insert the specified text into the message subject line.
Add Header – Add the specified “X-” mail header to the message headers.
Redirect To – The message is delivered to the specified mail address or server.
Accept – Mail is accepted and is delivered regardless if the message is considered spam.
SecureMail encrypt – Encrypts the message with the integrated SecureMail encryption
engine.
Trust – This mail is considered trusted and from a legitimate source. This message is not
processed for spam.
Relay – Allows the message to be relayed externally.
PBMF Action – Use a custom pattern filter action, as defined in the Pattern Filter
configuration.
Encrypt – Redirects the message to an encryption server.
Decrypt – Redirects the message to a decryption server.

15. In the BCC text box, type an optional email address to send a blind carbon copy of the message
to if the rule is matched.
16. From the Train drop-down list, select the training options for this rule if it is matched.
n

n
n
n

Intercept decides – The Intercept Anti-Spam engine decides whether to train the message
as spam or legitimate mail based on its scanning results.
Do not train – The message is not be trained.
Train as ham – The message is trained as a legitimate (ham) message.
Train as spam – The message is trained as a spam message.

17. Click Apply.

Rule Ordering
The rules are processed in the displayed order. To reorder rules, select a specific rule and drag it to its
desired location. Click Save Rule Order to save the updated order of your rules when you are finished.
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Dictionaries
The Dictionaries feature contains default and custom word and phrase dictionaries that you can use
with the Objectionable Content Filter, Spam Dictionaries, and Content Scanning features. You can
also create lists of IP addresses, domains, and email addresses to use with other WatchGuard XCS
features.
Each dictionary is a simple word or phrase text file (in Unix format) with one word or phrase per line:
Compliance Classified Top Secret This is Confidential

The maximum word length is 35 characters. You can upload words or phrases greater than 35
characters, but they are truncated for matching purposes. Both plural and singular word forms must be
defined in the dictionaries. In policies, the phrase length of the compliance dictionary selected should
not be greater than the phrase length configured in the content scanning configuration.

Character Set Support
The WatchGuard XCS supports several characters sets for dictionary-based message scanning. This
allows you to upload dictionaries in a variety of character set encodings and use these dictionaries with
the Objectionable Content Filter, Spam Words, and Content Scanning features when scanning email
and web content.
When you upload a dictionary, the contents are displayed in UTF-8 format on the Dictionaries page.
When you download the dictionary, it is saved in the original character encoding format with which it
was uploaded. Your web browser may need to be configured to display the UTF-8 character set to view
the contents of the dictionary file. In addition, make sure the web server configuration (in
Configuration > Network > Web Server), accurately reflects the encoding you require.
These character set encodings are supported for use in dictionaries:
n
n
n
n

ASCII
Unicode
UTF-8, UTF-16, UTF-32
ISO-8859-1 (Western European Languages). These languages are supported by the ISO-8859-1
character set:
o Afrikaans
o Albanian
o Basque
o Breton
o Danish
o Dutch (missing IJ, ij but these should always be represented as IJ or ij in electronic form)
o English (US and modern British)
o Estonian (missing Š, š, Ž, for loan words)
o Faroese
o Finnish (missing Š, š, Ž, for loan words)
o French (missing Œ, œ and the very rare Ÿ; they are generally replaced by “OE” and “oe”
without the normally required ligature, and “Y” without the diaeresis)
o Galician
o German
o Icelandic
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o
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o
o
o

Irish (new orthography)
Italian
Latin (basic classical orthography)
Luxembourgish (basic classical orthography)
Norwegian (Bokmål and Nynorsk)
Occitan
Portuguese (European and Brazilian)
Rhaeto-Romanic
Scottish Gaelic
Spanish
Swahili
Swedish
Walloon
Welsh (missing these circumflex accented characters W, w, Y, y)

Internationalized Scanning
In the Content Scanning, Spam Words, and Objectionable Content Filter configuration, you can enable
the Enable international document capability option that allows you to use these features to scan
messages and files that use non-Western international character sets.
Internationalized scanning supports these character sets:
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
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Thai, Windows-874
Japanese Shift-JIS, Windows-932
Chinese simplified GBK, GB2312, GB18030, Windows-936
Korean, EUC-KR, Windows-949
Chinese Traditional, Big5, Windows-950
Central Europe, Windows-1250
Cyrillic, Windows-1251
Latin 1, Windows-1252
Greek, Windows-1253
Turkish, Windows-1254
Hebrew, Windows-1255
Arabic, Windows-1256
Baltic, Windows-1257
Russian, KOI8-R
Japanese EUC, ISO-2022-jp
Latin 1, ISO-8859-1
Latin 2, ISO-8859-2
Latin 3, ISO-8859-3
Baltic, ISO-8859-4
Cyrillic, ISO-8859-5
Latin/Arabic, ISO-8859-6
Greek, ISO-8859-7
Latin/Hebrew, ISO-8859-8
Turkish, ISO-8859-9
Latin/Thai, ISO-8859-11
Latin 7, ISO-8859-13
Latin 9, ISO-8859-15
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Dictionary
To add a new dictionary to the system:
1. Select Security > Content Control > Dictionaries.

2. Click Add.

3. In the Name text box, type a descriptive name for the dictionary.
4. From the Type drop-down list, select the type of dictionary you are adding:
n auto-detect – Automatically detect the type of dictionary.
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n

n

n
n
n

n

Phrase List – This file type of words and phrases is used with the policy-based Content
Scanning, OCF, and Spam Words features, and can also be used for any type of general
dictionary.
Document Fingerprinting – This file type of words and phrases is used with the
Document Fingerprinting feature.
IP – A list of IP addresses. For example, 192.168.1.128 or a123:b123::c123 for IPv6.
Email – A list of email addresses. For example, user@example.com .
Domain – A list of domains. For example, example.com. Domain lists can also include IP
addresses. For example, 192.168.1.10 or a123:b123::c123 for IPv6.
Domain & Email – A list of domains and email addresses. For example,
example.com,admin@example.com . This type is used for the Hosted Domains reporting
feature.

Note When you configure a specific feature that uses dictionaries, the system will only
display dictionary types applicable to that feature.
5. In the Comment text box, type a descriptive comment for this dictionary to identify its contents
to other administrators.
6. From the Weight drop-down list, select if the dictionary is weighted or not.
Select auto-detect to automatically detect if the dictionary is weighted. See Weighted
Dictionaries for more detailed information.
7. From the Create From drop-down list, select if you are entering a Text dictionary, or using an
Uploaded File.
n

n

n

If you are entering text, type your words or phrases for the dictionary using one entry per
line. You can enter a maximum of 1 MB of text.
If you are entering a weighted dictionary, make sure that the first line is match,weight or
weight,match based on the contents.
If you are uploading a file, click Browse to select a file to upload.

8. From the Character set drop-down list, select the encoding used in the uploaded file.
Select auto-detect to automatically detect the character set of your dictionary.
9. Click Apply.
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Clone a Dictionary
To copy the contents of an existing dictionary to a new dictionary:
1. Select Security > Content Control > Dictionaries.

2. Select the check box for a dictionary.
3. Click Clone.
A new dictionary is created prefixed with the title "Clone of [dictionary name]".

Search for a Dictionary
To filter the dictionary display or search for a dictionary:
1. Select Security > Content Control > Dictionaries.

2. From the Filters Type drop-down list, select a dictionary type to filter the displayed dictionary list.
3. In the Search text box, enter search text to find a dictionary by its ID, Name, or Comment.
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Financial and Medical Dictionaries
The WatchGuard XCS includes predefined dictionaries that contain industry-specific terms for medical
and financial organizations to assist you with regulatory compliance configurations. You can
customize these dictionaries to comply with specific regulations regarding the communications and
storage of message data. The dictionaries are used with the Content Scanning feature to allow the
system to check the dictionary for matched words and phrases in incoming and outgoing messages
and attachments. You can use policies to define specific Content Scanning actions when dictionary
terms are detected.
Note If you use the Financial and Medical dictionaries when content scanning email
messages and web requests, you must review these dictionaries and customize them
as appropriate for your organization to prevent legitimate messages from being
blocked because of words and phrases in these dictionaries.
To enable a dictionary for use in a Content Scanning policy:
1. Select Security Policies > Content Control > Content Scanning.
2. Select the Enable check box.

3. In the Phrase length text box, type a phrase length for your specific dictionaries.
The Content Scanning feature has a default Phrase length of 3, indicating that the system only
scans up to 3 words of a dictionary phrase. If longer phrases appear in your Financial or Medical
dictionaries, the Phrase length must be increased to 4 or more as required. Longer phrase
lengths require additional system processing.
4.
5.
6.
7.
8.
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Click Apply.
Select Policies.
Select a policy to configure, for example, the Default Policy or another policy.
Select the Edit link in the Content Control section.
In the Content Scanning section, enable Content Scanning and select the required dictionary
(for example, Medical Terms) from the Compliance Dictionaries drop-down list.
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9. From the Action field, click Edit to select the actions to perform for email messages and HTTP
requests when a dictionary term is detected in a message or its attachments.
Note By default, the medical and financial dictionaries are configured with no weights. You
can modify and customize the dictionaries as required with weights for each word or
phrase.

Weighted Dictionaries
You can assign a configurable weight to dictionary words and phrases to provide more intelligent and
flexible decisions for dictionary scanner components and compliance policies.
With a weighted dictionary, you can perform an action if the aggregate weight of several matched
dictionary terms exceeds a configurable threshold. You can set a weight to a dictionary word or phrase
so that it is a compliance violation if any two terms from a dictionary appear in a message or
attachment. The weight of these two terms is added together, and if they exceed the threshold for that
policy, an action is performed.
For example, the WatchGuard XCS can encrypt an outbound message when the phrase “patient
number” and the term “diagnosis” are detected in the same message content. In the weighted
dictionary, these terms can be configured to have a weight of 50. If the weighted threshold for the
compliance dictionary is set to 100, these two terms, or any number of terms that match or exceed a
weight of 100, cause the message to be encrypted.
Note If the same word appears more than once in a message (this includes text and HTML
portions of a message), each instance is included in the total weight.
When a dictionary is configured as a weighted dictionary, use this format:
match,weight

or
weight,match

For example,
patient,30
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or
50,diagnosis

The first line of the weighted dictionary must contain the heading match,weight, or weight,match
depending on the configuration of your file.
For example,
match,weight patient,30 diagnosis,50

Negative Dictionary Weights
You can apply negative weights to specific words or phrases in a weighted dictionary that, on their
own, may not constitute a match in an objectionable content or compliance dictionary. For example, a
weighted dictionary entry can be entered as “junk,-25”. This indicates that if the word “junk” appears on
its own in the text of a message, the weight threshold is lowered by 25. Another phrase entry can be
entered as “junk message,50” that indicates that the phrase “junk message” raises the weight by 50.
This helps to prevent weighted thresholds from being exceeded by words that may not be objectionable
or classified for compliance, when they are not used in conjunction with other words or phrases.
When a dictionary is configured as a weighted dictionary, use this format:
match,weight

or
weight,match

For example,
patient,-30

or
50,diagnosis

The first line of the weighted dictionary must contain the heading match,weight, or weight,match
depending on the configuration of your file.
For example,
match,weight patient,-30 diagnosis,50

Use Weighted Dictionaries
Weighted dictionaries can be used with Spam Words, Content Scanning, and the Objectionable
Content Filter.
Create a dictionary with spam words and phrases and their assigned weights that are checked by the
Spam Words scanning feature.
match,weight spam,40 hot stocks,40 viagra,50 stock tips,40
stock,-50
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To upload a dictionary:
1.
2.
3.
4.
5.
6.

Select Security > Content Control > Dictionaries.
In the Type drop-down list, select Phrase List.
From the Weighted drop-down list, select Yes.
Enter or upload your dictionary.
Click Apply.
Select Security > Anti-Spam > Anti-Spam > Spam Words.
The Spam Words page appears.

7. Select the Enable Spam Words check box.
8. In the Weighted Threshold text box, type the weighted threshold if you use weighted
dictionaries with Spam Words
This threshold can be any positive integer from 1 to 9999. In this example, the default threshold
is 100. If the number of spam words in a message have an aggregate weight of 100 or more, the
message is considered spam.
9. Select the weighted dictionary created in the first step.
10. Click Apply.
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Data Loss Prevention Wizard
The Data Loss Prevention (DLP) wizard guides you through the configuration of DLP content controls
and rules for inbound and outbound email and web traffic. You can perform these tasks using the
DLP Wizard:
n

n

n

n

Block financial identification numbers – Creates Content Rules in the Default Policy to
block financial identification numbers such as credit card and bank account numbers in email
messages. This includes these identification numbers.
n Credit Cards (Visa, MasterCard, American Express, Diners Club, Discover, and other
credit cards)
n Credit Card Magnetic Track 1 - International Air Transport Association (IATA). This track is
sometimes used by airlines when securing reservations with a credit card.
n Credit Card Magnetic Track 2 - American Banking Association (ABA). This track is read by
ATMs and credit card verification systems.
n National Securities Identification Number (CUSIP)
n International Bank Account Number (IBAN)
n Routing Transit Number (RTN)
Block national identification numbers – Creates Content Rules in the Default Policy to
block national identification numbers. This includes these identification numbers:
n Social Security Number (USA)
n Social Insurance Number (Canada)
n Social Insurance Number (UK)
n Social Insurance Number - INSEE (France)
n National Identification Number (Brazil)
n National identification numbers (Denmark)
n Social Insurance Number (Germany)
n Personal Public Service numbers (Ireland)
n Fiscal code numbers (Italy)
n Fiscal identification numbers (Spain)
n National identity card (Hong Kong)
n Permanent account numbers (India)
n National registration identity card (Singapore)
Block healthcare identification numbers – Creates Content Rules in the Default Policy to
block national identification numbers. This includes these identification numbers:
n Drug Enforcement Administration Number – DEA (USA)
n National Provider Identifier – NPI (USA)
n National Health Service – NHS (UK)
Block based on compliance terms
n Email – Creates Content Rules in the Default Policy to content scan email messages
based on the selected dictionary, such as Medical, Financial, or a custom dictionary.
n Web – Configures Content Scanning in the Default Policy to content scan web content
based on the selected dictionary, such as Medical, Financial, or a custom dictionary.

When you use the DLP wizard, any previous settings (configured through a previous wizard session or
configured manually) will be displayed and maintained unless you modify the configuration.

264

WatchGuard XCS

Content Control

Content Scanning Settings for DLP
The Data Loss Prevention Wizard requires that the Content Scanning phrase length be a minimum of
4. Depending on the ID number you search for, you must set the Content Scanning phrase length to an
appropriate value to match that pattern.
These types of ID numbers require a longer minimum phrase length:
n
n
n
n

IBAN (International Bank Account Number) – 7
INSEE (Social Insurance Number - France) – 7
National Identification Number (Brazil) – 8
Social Insurance Number (UK) – 5

These are the minimum lengths required for other ID numbers:
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n

Credit Cards – 4
Credit Card Magnetic Track 1 – 4
Credit Card Magnetic Track 2 – 1
National Securities Identification Number (CUSIP) – 1
Routing Transit Number (RTN) – 1
Social Security Number (USA) – 3
Social Insurance Number (Canada) – 3
National identity card (Hong Kong) – 1
National registration identity card (Singapore) – 1
Permanent account numbers (India) – 1
Personal Public Service numbers (Ireland) – 1
National identification numbers (Denmark) – 4
Fiscal code numbers (Italy) – 1
Fiscal identification numbers (Spain) – 3
Social Insurance Number (Germany) – 1
Drug Enforcement Administration Number DEA (USA) – 1
National Provider Identifier NPI (USA) – 1
National Health Service NHS (UK) – 3

The File Types should also be set to "Common Office Documents", and the Punctuation Treatment set
to "Significant".
See Content Scanning for more detailed information on configuring the Content Scanning feature.

Notifications
Notifications are not configured using the wizard. After completing the wizard you can manually
examine any content rules created by the wizard and modify the notification settings in the Default
Policy.

Run the DLP Wizard
You can access the DLP Wizard on the Frequent Tasks page, or select Security > Content Control
> DLP Wizard on the menu.
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1. From the Frequent Tasks page, select Data Loss Prevention Wizard.
2. Select which message traffic types you want to scan: Email, Web, or Any.

3. Click Continue.
4. On the Tasks page, select the DLP tasks you want to perform.
5. Click Continue.
6. On the Block Financial Identification Numbers page, select which types of credit patterns
and financial numbers to scan for, the message direction, and the action to take on the message
if a credit card pattern is detected in email messages.
The Other credit cards option is able to detect the patterns of other credit card types that are
not listed.

7. Click Continue.
8. On the Block National Identification Numbers page, select the identification numbers to
scan for, the message direction, and the action to take on a message if these numbers are
detected in email messages.
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9. Click Continue.
10. On the Block Healthcare Identification Numbers page, select the identification numbers to
scan for, the message direction, and the action to take on a message if these numbers are
detected in email messages.

11. On the Block Email Based on Compliance Terms page, select the types of terms to scan for
in email traffic, the message direction, and the action to take on a message if a term is detected.
Select Custom to choose a custom dictionary.
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12. Click Continue.
13. On the Block Web Traffic Based on Compliance Terms page, select the types of terms to
scan for in web traffic, the message direction, and the action to take on a message if a term is
detected.
Note Web options only appear if the system is licensed for Web Scanning.
Select Custom to choose a custom dictionary.

14. Click Continue.
15. The Done page describes the rules that will be configured based on your selections.
Click Done to complete the initialization.

Content Rules Configured by the DLP Wizard
To view and edit the resulting Content Rules configured by the wizard:
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1.
2.
3.
4.

Select Security > Policies > Policies.
Configure the Default Policy.
Select Content Control.
Select Inbound Content Rules or Outbound Content Rules as required.

Note Web configuration settings added by the wizard appear in the Content Scanning
section of the Default Policy.
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Intercept Anti-Spam

Intercept Anti-Spam Overview
The Intercept Anti-Spam features take advantage of the extensive message control features of the
WatchGuard XCS to provide a solutions-based approach where each anti-spam component, when
enabled, provides input to the final spam score of a message. Information retrieved by all of the
enabled Anti-Spam components results in a more informed decision on whether a message is spam or
legitimate mail.
You can set thresholds to take appropriate action on a message based on its score and classification,
for example, Certainly Spam, Probably Spam, and Maybe Spam. You can set a different action for
each threshold, for example, “Reject” for messages that are classified as Certainly Spam, or “Modify
Subject Header” for messages that are classified as Maybe Spam.
WatchGuard has engineered the default Intercept configuration to provide maximum protection against
spam without additional configuration, but you can modify the Intercept options to provide more
granular control over each Anti-Spam Intercept component for your environment.

Outbound Anti-Spam
Outbound Anti-Spam controls are used to prevent trusted internal users from sending spam outside of
your organization. You can use the Spam Rules, Spam Words, and URL Block List Anti-Spam
features to scan outbound mail for spam messages. The Mail Surge Detection feature identifies
internal mail users who are sending an unusually large amount of mail messages which can indicate
spam activity. Outbound Anti-Spam features are configurable within policies to define actions and
notifications for different users, groups, and domains.

Intercept Components
The Intercept Anti-Spam engine includes these components:
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Spam Words
Filters messages based on a dictionary of typical spam words and phrases that are matched
against the message. Spam Words can also be used for outbound Anti-Spam checks.
Spam Rules
Uses dynamic content rules generated by WatchGuard to help detect new types of spam
messages that are not easily detected by other Intercept Anti-Spam features. Spam Rules can
also be used for outbound Anti-Spam checks.
Mail Anomalies
Checks various aspects of the incoming message for issues, for example, unauthorized SMTP
pipelining, missing headers, and mismatched identification fields.
DNS Block List (DNSBL)
Detects spam using domain-based lists of hosts that have a poor reputation. Messages can
also be rejected immediately, regardless of the results of other Anti-Spam processing, if the
client is listed on a DNSBL. A configurable threshold allows you to specify how many DNSBLs
must be triggered to consider the sender as unreliable.
URL Block List
URL Block Lists contain a list of domains and IP addresses of URLs that have appeared
previously in spam messages. This feature examines any URLs contained in the body of a
message to see if they appear on a block list. URL Block Lists can also be used for outbound
Anti-Spam checks.
Reputation Enabled Defense
The Reputation Enabled Defense service helps to identify spam by reporting behavioral
information about the sender of a mail message, based on information collected from installed
products and global DNS Block Lists. The statistics it collects include the sender's overall
reputation, where the sender is a dial-up, and whether the sender appears to be virus-infected or
sends large amounts of spam messages. The Intercept engine uses this information to reject
the message, or uses it as part of the overall anti-spam decision. Reputation Whitelists allow
you to train on messages from known legitimate sources based on their reputation.
Token Analysis
Detects spam basedon advancedcontent analysis using databases of knownspam andvalid mail.
Backscatter Detection
Detects spam based on signature verification of the Envelope Sender to prevent spam bounce
emails to forged sender addresses.
Sender Policy Framework (SPF)
Performs a check of a sending host’s SPF DNS records to identify and validate the source of a
message to determine whether a message was spoofed.
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DKIM/DomainKeys Authentication
Performs a check of a sending host’s DKIM (DomainKeys Identified Mail) or DomainKeys DNS
records to identify and validate the source of a message to determine whether a message was
spoofed.
Brightmail
You can utilize the Symantec Brightmail Anti-Spam™ engine as a cost-option. Brightmail
integrates into the overall Intercept spam score, or you can run Brightmail independently.

Default Intercept Configuration
The following tables describe the default settings for Intercept Anti-Spam and Connection Control.

Intercept Anti-Spam
This table describes the default Intercept Anti-Spam settings when you enable the Anti-Spam
feature.
Intercept Option

Default Setting

Certainly Spam

Reject
(Threshold: 99)

Probably Spam

Modify Subject
Header
(Threshold: 90)

Maybe Spam

Just Log
(Threshold: 60)

Decision Strategy

Adaptive

Spam Words

Enabled

Spam Rules

Enabled

Mail Anomalies

Enabled

DNS/URL Block List

Enabled

Reputation Enabled Defense

Enabled

Token Analysis

Enabled

SPF

Enabled

DomainKeys

Enabled

DKIM

Enabled

Backscatter

Disabled
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Intercept Connection Control
This table describes the default Intercept Connection Control settings when you enable Connection
Control.
Feature

Default Setting

Reject on Reputation (Reputation Enabled Defense)

Enabled
(Threshold: 90)

Reject on infection (Reputation Enabled Defense)

Enabled

Reject connections from dial-ups (Reputation Enabled
Defense)

Off

Reject on DNSBL

Off

Threat Prevention

Enabled

Recipient Verification (Reject on unknown recipient)

Off

Reject on unknown sender domain

Enabled

Reject on missing sender MX

Off

Reject on non FQDN sender

Enabled

Reject on unauth pipelining

Enabled

Reject on missing addresses

Off

Reject on missing reverse DNS

Off
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Trusted and Untrusted Mail Sources
You must configure the WatchGuard XCS to properly interact with local and remote mail servers. The
XCS device only processes mail through the spam filters when a message originates from an
untrusted source.
Mail from trusted sources bypass the spam controls.
There are two ways to control how sources of mail are identified and trusted:
n
n

Trusted Subnet – All mail from a specific network interface is considered trusted.
Specific Access Pattern – An IP address (or address block), server, or domain name is
identified as trusted by a specific access pattern rule.

Trusted Subnet
To specify a network interface as trusted or untrusted:
1. Select Configuration > Network > Interfaces.
2. Enable or disable the Trusted Subnet check box for the required interface.
Do not enable the Trusted Subnet option if the device is deployed internally or behind a network
firewall.
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Trust Servers with Specific Access Patterns
To trust a server with a Specific Access Pattern:
1. Select Configuration > Mail > Access.
2. In the Specific Access Patterns section, click Add Pattern.

3. In the Pattern text box, type the IP address or hostname of the server.
4. Select the Client Access check box.
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5. From the If pattern matches drop-down list, select Trust.
6. Click Apply.
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Intercept Connection Control
You can configure Intercept connection control settings to reject messages before the SMTP mail
connection is completed based on several identifying factors about the connection.
To configure Connection Control settings:
1. Select Security > Anti-Spam > Connection Control.
The Intercept Connection Control page appears.

Reject on unknown sender domain
Rejects mail when the sender’s mail address does not appear in the DNS as an A or MX
record.
This option only applies to untrusted mail.
Reject on missing sender MX
Rejects mail when the sender’s mail address has no DNS MX record.
Reject on non FQDN sender
Rejects mail when the client MAIL FROM command is not in the form of an FQDN (Fully
Qualified Domain Name), for example, mail.example.com. This option only applies to
untrusted mail.
Reject on unauth pipelining
Rejects mail when SMTP commands are sent ahead of the message even though the
SMTP server supports pipelining. This option blocks mail from bulk mail software that uses
SMTP command pipelining improperly to speed up deliveries.
Reject on missing addresses
Reject mail when no recipients (To:) or sender (From:) were specified in the message
headers. These fields are the optional To: and From: fields, not the corresponding Envelope
fields.
Reject on missing reverse DNS
Reject mail from a host when the host IP address has no PTR (address to name) record in
the DNS, or when the PTR record does not have a matching A (name to address) record.
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WarningMany servers on the Internet do not have valid Reverse DNS records. If you
set this option, it can result in rejected mail from legitimate sources. We
recommend that you do not enable this option.
2. Click Apply.

Recipient Verification
The Reject on Unknown Recipient feature rejects inbound mail messages based on recipient address
checks to an LDAP server or a recipient address SMTP probe to the nearest MTA to ensure that the
recipient address is verified to be deliverable.
If you use LDAP in your organization, we recommend that you use LDAP with Reject On Unknown
Recipient for the most efficient and accurate method of recipient verification because your LDAP
server contains the most complete and up-to-date list of local recipient addresses.
Use the SMTP method of verification if your users are not listed in an LDAP directory. For example,
some or all of your domains that you manage may not have users listed in an LDAP directory service.

LDAP Recipient Verification
If you select the LDAP method of verification, you must also configure the Directory Users or the
LDAP Recipients feature.
The XCS device performs these LDAP checks:
n

n

Checks to see if the user is in the local database of imported Directory Users (Recommended
for Active Directory)
Performs a direct lookup on an LDAP user directory with the LDAP Recipients feature

See Directory Users for more information on how to import LDAP users for user lookups.
See LDAP Recipients for information on configuring the LDAP Recipients feature.

SMTP Recipient Verification
SMTP Recipient Verification rejects mail messages based on a recipient address probe to the nearest
MTA (Mail Transfer Agent) to ensure that the recipient address is verified to be deliverable. When
SMTP Recipient Verification is enabled, the WatchGuard XCS initiates an SMTP probe to the mail
server to check that the recipient address exists without delivering the mail message. If the address
does not exist, the message is rejected. This verification is only applied to untrusted sources, and the
results of the address verification are cached to prevent additional probes for the same recipient
address. SMTP verification results for non-existent users are cached for 3 hours. Results for existing
users are cached for 7 days.
Make sure that the email service you route mail to does not use rate limiting features and performs a
permanent reject (500) for non-existent users.
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Note In its default configuration, Microsoft Exchange does not support SMTP recipient
verification. To use SMTP recipient verification with Exchange, you must enable the
Recipient Filtering feature on the Edge Transport server, or you must use the LDAP
method of verification instead. For more detailed information, see the SMTP Recipient
Verification and Microsoft Exchange article in the WatchGuard Knowledge Base.

Enable Recipient Verification
To enable recipient verification:
1. Select Security > Anti-Spam > Connection Control.
The Intercept Connection Control page appears.

2. In the Recipient Verification section, select the Reject on unknown recipient check box.
3. From the Verification method drop-list, select SMTP, LDAP, or Disabled.
4. If you select the SMTP method, in the SMTP probe reject code text box, type the reject code
to use when an SMTP recipient check fails. You can enter 450 (temporary), or 550
(permanent).
5. In the Address verification timeout text box, type the number of seconds (1-10) before an
SMTP recipient verification probe times out when attempting to contact the SMTP server.
Do not change the default values for address verification timeout and retries unless you
experience problems with rejected messages resulting from delayed connections to the SMTP
server. If this issue occurs, increase the timeout and retry values to allow more time for the
SMTP probe to connect with the SMTP server.
6. In the Address verification retries text box, type the total number of retry attempts (1-10) to
poll an SMTP server for recipient verification.
We recommend you do not use "1" for the number of retries because the initial verification only
checks the recipient cache before sending an SMTP probe. If the recipient is not verified in the
cache check, the first message from the recipient will be rejected. If the recipient is verified by
the SMTP probe, subsequent messages are allowed.
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Per-domain Recipient Verification
You can also configure how to perform recipient verification based on the domain of the recipient. For
each domain, you can disable recipient verification, or choose between the LDAP or SMTP verification
methods. If a domain is not configured, the default recipient verification method is used.

1. In the Domain field, type a domain name, such as example.com .
2. From the Verification Method drop-down list, select LDAP, SMTP, or Disabled.
3. Click Add.
You can also upload a list of domains and verification settings as a file. We recommend you click
Download to save the current file, edit the file as required, then click Upload to upload the file to the
system. The file must contain comma separated entries with one entry per line.
Use this format:
domain,method

For example:
example.com,LDAP
example2.com,SMTP
example3.com,Disable

Reputation Enabled Defense, DNSBL, and Backscatter Rejects
You can also configure Reputation Enabled Defense, DNS Block Lists, and Backscatter rejects from
this page.
These features are discussed in more detail later in this section.
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Connection Control Components
You can enable or disable each Connection Control component depending on your requirements.
To configure the settings for each feature:
1. Select the Enable check box for a specific feature.

2. Select the feature link to review or customize the default settings.
3. When finished, click the Apply button to save the configuration.

Mail Relays
To trust friendly local networks or addresses of known mail servers in their environment that relay mail
through this system, click the internal hosts and friendly mail relays link.
You can add specific networks and servers to the relays IP Address list in the Threat Prevention
configuration page to prevent them from being blocked by Threat Prevention and RED, as well as
make sure that reputation statistics for these addresses are not reported to RED.
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Configure Intercept Anti-Spam
Select Security > Anti-Spam > Anti-Spam to enable and configure the Intercept Anti-Spam features.

Intercept Anti-Spam Actions
In the Intercept Anti-Spam Actions section, you can assign actions for three levels of spam score
thresholds.
Certainly Spam
Any message with a score over this threshold (Default: 99) is Certainly Spam. These types of
messages require a strong action, for example, Reject Mail or Redirect To.
Probably Spam
Any message with a score over this threshold (Default: 90) is probably spam. This threshold
indicates a message with a very high spam score, but not high enough to be Certainly Spam.
You should treat these messages with a lighter action than Certainly Spam, for example,
Redirect To or Modify Subject Header. You should not reject Probably Spam messages.
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Maybe Spam (Advanced setting)
Any message with a score over this threshold (Default: 60) might be spam but should be treated
with caution to prevent false positives. This threshold indicates messages that could be spam,
but could also be legitimate mail. We recommend that you use a light action, for example,
Modify Subject Header.
For each category you can set these fields and actions:
n

n
n
n

n
n
n
n
n

n

n
n
n

n

n

Threshold (advanced view only) – Set the threshold spam score (between 1 and 99) for this
category. We recommend that you leave these values at their defaults.
Email Action – Specify one of these actions to take when the threshold is exceeded:
Just log – Log the occurrence, and take no other action.
Modify Subject Header – Insert the specified text in the Email Action Data text box into the
message subject line.
Add header – Add an “X-” mail header as specified in the Email Action Data text box.
Redirect to – Deliver to the mail address or server specified in the Email Action Data text box.
Discard mail – Discard the message and do not send a notification to the sender.
Reject mail – Reject the message and send a notification to the sender.
BCC – Send a blind carbon copy of the message to the mail address specified in the Action
Email Data text box.
Quarantine: System – Place the message into the system quarantine area. You can also
choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.
Email Action Data – Select the Email Action Data depending on the specified Email Action:
Modify Subject Header – Insert the specified text into the subject line, for example, [SPAM]. If
this field is left blank, [SPAM] is the default modifier.
Redirect to – Send the message to a mailbox, for example, spam@example.com. You can
redirect the message to a spam quarantine, for example, spam.example.com.
Add header – Add an “X-” message header with the specified text, for example, “X-Reject:
spam”. The header action data must start with “X-” and must contain a colon followed by a
space. If this is not specified, the phrase “X-Reject” is added as a prefix to the header. For
example, if you enter “spam”, the full header is “X-Reject: spam”. If enter a header with a colon,
for example, “Reason:spam”, the full header is “X-Reason:spam”.
Leave this field blank to add a default header used by the Intercept Plug-in for Exchange:
For the Certainly Spam action, add the header: X-BTI-AntiSpamCode: certainly
For the Probably Spam action, add the header: X-BTI-AntiSpamCode: probably
For the Maybe Spam action, add the header: X-BTI-AntiSpamCode: maybe
For no classification, add the header: X-BTI-AntiSpamCode: none

Configure Intercept Anti-Spam Components
You can enable or disable each component of the Intercept Anti-Spam engine depending on your
requirements. To configure the settings for each feature:
1. Select Security > Anti-Spam > Anti-Spam.

User Guide

285

Intercept Anti-Spam

2. Select the Enable check box for a specific feature.
3. Select the spam feature link to review or customize the default settings.
4. When finished, click the Apply button to save the configuration.

Automatic Intercept Configuration
Select the Update Intercept Settings Automatically check box to allow advanced Intercept settings
to be updated automatically by WatchGuard. If you use this option, WatchGuard will update your
advanced Intercept settings on a periodic basis to make sure you always use the most up-to-date and
recommended configuration. Your Intercept actions, thresholds, and component settings are not
modified with this option.
Note Automatic Intercept configuration requires that Security Connection be enabled and
running.
This option configures these advanced settings:
n
n
n
n
n
n
n
n
n
n
n
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Reputation/UBL/DNSBL domains and timeout settings
Advanced Token Analysis options
Enable Image Analysis
Enable PDF Analysis
Analyze PDF text
Analyze PDF images
Enable RTF Analysis
Legitimate mail and Spam training sources
Legitimate mail and Spam limits and thresholds
Adaptive decision strategy training thresholds
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n
n

Dictionary spam count
Reputation Whitelist
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Advanced Intercept Options
Click the Show Advanced Options link to display additional advanced Intercept configuration
options.

Anti-Spam Header
You can add an Anti-Spam header to a message for diagnostic purposes. The Anti-Spam header
contains data on all spam processing applied to the message.
X-BTI-AntiSpam:
score:60,sta:22/031,dnsbl:off,sw:passed,bsn:none,spf:none,bsctr:off,dk:passed,
pbmf:none, ipr:0/3,trusted:no,ts:no,bs:no,ubl:passed,spamrules:passed

Note You must enable the Anti-Spam header to use the Intercept Plug-in for Exchange.
The Anti-Spam header output can contain these items:
Item

Description

score

Overall Intercept score

sta

Token Analysis score

dnsbl

DNS Block List check

sw

Spam Words

spamrules

Spam Rules

bsn

Reputation Enabled Defense reputation

spf

SPF results

brightmail

Brightmail scanning result

dk

DomainKeys results

pbmf

Pattern Based Message Filters

ipr

Mail Anomalies checks

trusted

Trusted or non-trusted

ts

Trusted Senders List

bs

Blocked Senders List

ubl

URL Block List check

bsctr

Backscatter Detection

dfp

Document Fingerprinting
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Intercept Decision Strategy
The Intercept Decision Strategy allows administrators to alter the way in which Intercept processes
messages for spam.

Highest Score
The Highest Score method uses the maximum score derived from all the scans that are
processed.
For example, if Mail Anomalies, and DNS Block List are enabled, and DNS Block List results in
the highest contributing score for all the scans, then that score is used.
Sum of Weights
The message is initially classified by the Token Analysis and Brightmail scores, and then the
weight of any other enabled components with a spam score are added.
Note The component weights should be adjusted to be lower than their default settings
when you use the Sum of Weights decision strategy.
Heuristic 1
Components are divided into objective and subjective categories. Objective components are
DNS Block List, URL Block List, Mail Anomalies, RED Dial-up, Backscatter, SPF, and
DomainKeys. Subjective components are Spam Words, Token Analysis, Brightmail, and RED
reputation. The message is classified initially by combining the subjective scores and the
classification is then adjusted by combining the objective scores. A baseline is established with
a subjective filter. If Token Analysis scores a message at 60, a baseline of Maybe Spam is
established. An additional objective filter that triggers categorizes the message as Probably
Spam. Two objective filters increases the level to Certainly Spam.
Heuristic 2
This strategy is similar to the Heuristic 1 strategy except that the subjective component scores
are weighted more heavily in the final decision than in Heuristic 1. In environments where there
is no Token Analysis training on outbound legitimate mail (for example, some evaluation
scenarios), or for new installations, Heuristic 2 can result in an increase in false positives. In
this case, you should use the Heuristic 1 strategy, which is identical to Heuristic 2 except that
Token Analysis is de-emphasized and additional Anti-Spam features must be triggered for a
message to be considered Probably Spam or Certainly Spam. When using Intercept for this first
time, we recommend that you use Heuristic 1 until a suitable amount of training has been
accumulated before you switch to Heuristic 2.
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Adaptive (Default Strategy)
The Adaptive strategy combines the strengths of both Heuristic 1 and Heuristic 2 by initially
processing messages similar to the Heuristic 1 strategy. The anti-spam scanning engine
automatically adjusts its aggressiveness based on the amount of messages that have been
trained. When a suitable amount of spam and legitimate mail have been trained, the scanning
aggressiveness switches to a strategy similar to Heuristic 2.
Statistical
Scans are processed independently and the resulting score represents the probability that a
message is spam based on statistical computation of the results.
Bayesian
Scans are processed independently and the resulting score represents the probability that a
message is spam based on Bayesian computation of the results.
Note Statistical and Bayesian strategies are experimental, and you should only use these
strategies in a test environment.

Training Period
Depending on the amount of mail sent and received in your environment, it can take several days of
mail processing and training to properly adjust the default training database for the content of your
organization’s mail flow.
When the initial training period is complete, you can modify the Intercept Anti-Spam decision strategy
from the default Heuristic 1 to Heuristic 2. The Heuristics 2 decision strategy puts more emphasis
on your trained mail to help identify spam messages and to prevent false positives (legitimate mail
classified as spam).

Recommended Strategy
We recommend that you select the Adaptive decision strategy. This strategy is very effective for most
environments and provides an excellent spam catch rate with a very low chance of false positives. The
Adaptive strategy combines the abilities of Heuristic 1 and Heuristic 2 and monitors the initial
message training period. When the system has trained a suitable amount of spam and legitimate mail,
it adjusts its internal aggressiveness strategy accordingly to utilize the trained mail.
WarningChoosing the wrong strategy for your environment could result in false
positives and a lower spam capture rate.

Intercept Component Weights
To customize the Intercept engine, configure the weights for each Intercept component that help
determine the final spam score for a message. These values represent the scores used if that
component triggers. For example, if a mail message triggers a DNS Block List, the spam score
contribution for that message is the defined weight, for example, 100.
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The final result of these scores is decided by your selected Decision Strategy. Valid weights for each
component are from 0 to 100. Set the weight to 0 if you want that feature to have no bearing on the final
spam score of a message. Set this value to 100 if you want this component to have a strong weight on
the final spam score of a message.
WarningWe recommend you do not modify the default component weights. Weight
misconfiguration can cause a degradation in your Anti-Spam capture rate.
To configure Anti-Spam component weights:
1. Select Security > Anti-Spam > Anti-Spam.

2. Set the weight for each component.
A value of 0 means that the component is a completely unreliable indicator of spam. A value of 100
means that this component is a completely reliable indicator of spam.

3. Click Apply.

Reputation/DNSBL/UBL Timeout Setting
Reputation Enabled Defense, DNS Blocks lists, and URL Block Lists, if enabled, perform their own
separate checks per message when they scan messages for spam. In the event that one or more of
the specified services are unavailable, the query to the service domain times out.
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These options allow you to configure the timeout and retry settings for each lookup query. We
recommend that you use the system defaults. If a query for Reputation Enabled Defense, DNS Blocks
Lists, or URL Block Lists exceeds the timeout and retry threshold, the checks for this message are
skipped for that feature.

n

n

Timeout – The delay (in seconds) between each retry in the event of a Reputation/DNSBL/UBL
lookup failure for a message. The default is 5 seconds.
Retries – The number of retries to perform in the event of a Reputation/DNSBL/UBL lookup
failure for a message. The default is 1 retry.

Intercept Plug-in for Exchange
The Intercept plug-in is installed on a Microsoft Exchange 2003 server to assign processed messages
from the WatchGuard XCS an SCL (Spam Confidence Level) rating. The SCL rating is used by
Exchange to classify messages in terms of how likely they are to be spam. The rating is based on a
scale from 0 to 9, where 9 indicates the message is most likely spam, and 0 indicates a legitimate
message. Each Intercept feature provides information (via the Anti-Spam header) to the Intercept plugin running on the Exchange server and maps the Intercept Anti-Spam score values to an equivalent
SCL rating. When the SCL rating for a message is determined, a configurable action is performed
depending on the thresholds set in the plug-in.
You can set a Gateway Blocking Threshold to perform an action on a message before it is delivered
to a user’s inbox on their Outlook client. You can discard (with no notification) or reject (with
notification) the message, or take no action. This allows you to stop the delivery of messages with very
high SCL ratings.
We recommend that you do not reject mail at the Exchange level. You should set the action for the
Gateway Blocking Threshold to be No Action, and then set an appropriate Store Threshold to
allow the end users to manage their spam and legitimate mail with the Outlook mail client’s Junk Email
Folder. You should reject messages with very high spam scores at the WatchGuard XCS level.
You can configure a separate Store Threshold that sets a specific SCL rating value where messages
equal to or above this rating are automatically delivered to a user’s Junk Email folder instead of the
inbox on their Outlook client. Also, user’s of the Outlook and OWA 2003 client can define Safe Senders
and Blocked Senders to trust and block email addresses and domains.
You can download the Intercept Plug-in for Exchange from the link on the main Intercept Anti-Spam
page. You can also obtain the Plug-in from the WatchGuard support site.
The Intercept Plug-in for Exchange requires these versions of software:
n
n
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Microsoft Windows 2000 (or greater) Server
Microsoft Exchange 2003 (SP1 or SP2. The plug-in should be installed on the Front End or
Bridge Head server, not a back end server). Please see the Intercept Plug-in for Exchange
Installation and User Guide for detailed instructions on how to install and configure the plug-in.
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For Microsoft Exchange 2007 or greater, see the WatchGuard Knowledge base for information on how
to use Exchange Transport Rules with the WatchGuard XCS.

Outbound Anti-Spam
Outbound Anti-Spam controls are used to prevent trusted internal users from sending spam outside of
your organization.
You can use the Spam Rules, Spam Words, and URL Block List Anti-Spam features to scan outbound
mail for spam messages. You can also use the Mail Surge Detection feature to identify internal mail
users who are sending an unusually large amount of mail messages which can indicate spam activity.
You can use Outbound Anti-Spam features within policies to define actions and notifications for
different users, groups, and domains.

Configure Outbound Anti-Spam
To enable and configure Outbound Anti-Spam:
1. Select Security > Anti-Spam > Outbound Anti-Spam from the menu.
2. Select the Enable Outbound Anti-Spam check box to enable Outbound Anti-Spam checks.
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3. From the Email Action drop-down list, select the action to take on outbound mail messages
identified as spam.
n
n
n
n

Just log — Log the event and take no further action.
Reject — Reject the message and send a notification to the sending system.
Discard — Discard the message and do not send a notification to the sending system.
Quarantine — Place the message into the specified quarantine area.

4. Select who to send notifications to when outbound spam is detected.
You can select Notify Recipient, Notify Sender, or Notify Administrator, and customize the
notification text.
5. Select the Anti-Spam components to use to scan outbound mail:
n

n

n
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Spam Rules — A list of content rules generated by WatchGuard that detects new types of
spam messages that are not easily detected by other Intercept Anti-Spam features.
Spam Words — Scans all inbound messages passing through the system for spam words
and phrases that appear in a spam words dictionary.
URL Block List — Lists of domains and IP addresses that have appeared previously in
URLs in spam messages.
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6. Click Apply.

Mail Surge Detection
The Mail Surge Detection feature identifies internal mail users who are sending an unusually large
amount of mail messages which can indicate spam activity. When a mail surge is detected, you can set
a hold period that prevents the user from sending further emails for the duration of the specified time.
Note If you have legitimate users that often send large amounts of messages, such as mail
lists, we recommend you create a policy for the user where the Email Action for Mail
Surge Detection is set to "Just Log".
To configure mail surge detection:
1. Select the Enable Surge Detection check box to enable the feature.
2. In the Surge Threshold text box, type the number of messages for the surge threshold. If the
user exceeds this amount of sent messages per hour, they will be prevented from sending
further messages during the specified hold period. The default is 1000.
3. In the Hold Period text box, type the number of hours for the hold period. The specified action is
taken if the user tries to send messages during the hold period duration. The default is 4 hours.
4. From the Email Action drop-down list, select an action to perform on outbound messages
during the hold period time after a user has exceeded the mail surge threshold.
n
n

n
n
n

Just log — Log the event and take no further action.
Reject — Permanently reject the message (code 550) and send a notification to the
sending system.
Discard — Discard the message and do not send a notification to the sending system.
Temporary Reject — Reject the message with a temporary reject (code 450).
Quarantine — Place the message into the specified quarantine area.

5. Select who to send notifications to when a mail surge is detected.
You can select Notify Recipient, Notify Sender, or Notify Administrator, and customize the
notification text.
6. Click Apply.
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Spam Words
The WatchGuard XCS provides a Spam Words dictionary filter. When enabled, all inbound messages
passing through the XCS device are scanned for words and phrases that appear in the spam words
dictionary. Messages with words or phrases in their subject or body that match the phrase list are more
likely to be spam. The Intercept Anti-Spam engine uses this information to help decide if the message
is spam or legitimate mail.
The WatchGuard XCS includes a basic pre-configured spam words list for message filtering.
WatchGuard’s default list includes basic words most commonly found in spam, for example,
“prescription” and “viagra”. You can view and modify the full default list. You can use this list to build
and upload your own custom spam word list.
Note We recommend that you review this default spam words list to make sure any
included words are not part of their organizations functions. For example, remove the
word “prescription” if your organization is involved with the pharmaceutical industry.
To configure Spam Words:
1. Select Security > Anti-Spam > Anti-Spam.
2. Select Spam Words.
The Spam Words page appears.

3. Select the Enable Spam Words check box.
4. Select the Enable Outbound Spam Words text box to scan outbound mail with the Spam
Words feature.
5. Select the Enable international character support check box to support international
languages when you use the Spam Words feature to scan messages that use Unicode or other
supported international character sets.
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If you do not require international character support for Spam Words, we recommend you leave
this option disabled to improve message processing performance. This option also controls
international character support for the OCF feature.
6. From the Logging drop-down list, select the method to log messages that contain matched
spam words and phrases.
The logging information appears in the Mail Logs:
n
n
n

No logging – Perform no logging.
First match only – Display only the first matching word.
All matches – Display all matched words.

5. In the Weighted Threshold text box, type the threshold for weighted spam words dictionaries.
If you use a weighted spam dictionary, the terms and their weight in the dictionary must match
or exceed this threshold to classify a message as spam. If you use both weighted and
unweighted dictionaries, the final action is performed if the sum of the weights exceeds the
configured weighted threshold, or if a match occurs in an unweighted dictionary. See
Dictionaries for more details on weighted dictionaries.
6. In the Spam Words Dictionaries section, select the dictionaries to use for Anti-Spam checks.
The dictionaries available are listed in the Available Dictionaries list. Use the arrow buttons to
move the dictionaries to the Dictionaries in Use list as required. You can use the Default
Spam Words list provided by WatchGuard, or you can upload a custom list. Click Add or Edit
to manage your dictionaries, or upload a dictionary on the Security > Content Control >
Dictionaries page.
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Add a Spam Words Dictionary
To add a Spam Words dictionary:
1. Select Security > Content Control > Dictionaries.
The Dictionaries page appears.

2. Select the Default Spam Words list.
The default list contains a list of common words that are typically seen in spam messages.

3. Click Download to save and view the text file of spam words.
The list contains one word or phrase per line.
For example,
free pic free pics free picz meds medz

You can edit this base list to create your own dictionary of spam words, and delete default
words that are not required.
4.
5.
6.
7.
8.

Select Security > Content Control > Dictionaries.
Click Add.
Enter or upload your dictionary.
From the Type drop-down list, select Phrase List.
Click Apply.
The new dictionary appears in the list and you can select it when you use Spam Words.
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Spam Rules
Spam Rules are a list of content rules created and maintained by WatchGuard to help detect new types
of spam messages that are not easily detected by other Intercept Anti-Spam features. For example,
DNS and URL Block Lists do not protect your system from new types of spam if the sending email
server or URL links within the message are not currently listed on these public services.
Spam Rules are regularly updated by WatchGuard via Security Connection to make sure you are
always protected from the latest variants of spam messages. We recommend that you enable this
feature.

Spam Rules Examples
These are the basic categories of rules from the current Spam Rules list. The list is dynamic and is
continually updated by WatchGuard based on new spam campaigns.
n
n

n
n
n

n

Email claiming to originate from Twitter and other social media sites that contain forged links
Email claiming to originate from popular financial companies with suspicious links,
attachments, or phrases
Emails that use phishing techniques to solicit webmail or other online account information
Email containing suspicious links and commonly sold products seen in spam
Short email messages containing suspicious links and common obfuscations of drug names
seem in spam
Email from suspicious senders, or email with suspicious email addresses in the mail body or
reply-to header

Configure Spam Rules
To enable Spam Rules:
1. Select Security > Anti-Spam > Anti-Spam.
2. Select Spam Rules.
The Spam Rules configuration page appears.
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3. Select the Enable Spam Rules check box.
4. Select the Enable Outbound Spam Rules text box to scan outbound mail with the Spam
Rules feature.
5. Click Apply.
The Spam Rules status indicates:
n
n
n

Ruleset ID – The ID number of the current ruleset.
Ruleset date – The release date of the current ruleset.
Rules count – A count of the number of spam rules currently defined.

When Spam Rules takes action on a message, the log files and message details display the applicable
rule number and ruleset ID.
For example,
spamrules:matched/73/7777
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Mail Anomalies
The Mail Anomalies feature performs checks on incoming messages to help determine whether the
message is coming from a known source of spam or is legitimate mail. Servers that send spam have
certain characteristics that can give away the nature of the sending system. Many spammers deploy
scripts and use spoofed or false information when they send mail. The WatchGuard XCS can check
incoming connections for patterns of these behaviors to help determine whether mail from an incoming
server is legitimate or spam.
The Mail Anomalies feature checks messages for a variety of information that can reveal
discrepancies between the message’s sending host and the host listed in the message envelope and
contents, and information about messages recently sent by the sending host. A message must fail four
or more checks to be considered spam.
To configure Mail Anomalies:
1. Select Security > Anti-Spam > Anti-Spam > Mail Anomalies.
The Mail Anomalies page appears.

2. The WatchGuard XCS can detect these types of anomalies:
These checks relate to issues with DNS record lookups for the sending host:
n

n

User Guide

Missing client reverse DNS – Checks to see if the sending host has a PTR (address to
name) record and the PTR record has a matching A (name to address) record.
Missing sender MX – Checks to see if the sender mail address has a DNS MX record.
This check is more restrictive than the check for Unknown sender domain. If Unknown
sender domain fails then this check also fails. We recommend that you only use one of the
two checks at the same time.
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n

n

Unknown sender domain – Checks to see if the sender mail address has a DNS A or MX
record. This check is less restrictive than the check for Missing sender MX. If this check
fails, then Missing sender MX also fails. We recommended that you only use one of these
two checks at the same time.
Invalid HELO/EHLO hostname – Checks to see if the HELO/EHLO address is a valid
hostname.
Unknown HELO/EHLO domain – Checks to see if the HELO/EHLO address has a DNS
A or MX record.

These checks relate to issues with the connecting client’s SMTP connection and message
information:
n

n

n
n
n

Unauthorized pipelining – Checks to see if the client sends SMTP commands ahead of
time without knowing that the mail server actually supports SMTP command pipelining.
This check detects bulk mail software that improperly uses SMTP command pipelining to
speed up deliveries.
HELO/EHLO doesn’t match client – Checks to see if the HELO/EHLO address matches
the sending host address.
Missing From header – Checks to see if the From header is present.
Missing To header – Checks to see if the To header is present.
Envelope sender doesn’t match From header – Checks to see if the From header
matches the envelope sender address.

These checks identify clients who have recently sent spam or viruses and only work if you
enable Threat Prevention (configured in Security > Anti-Spam > Threat Prevention.)
n
n

Recent spam from client – Checks to see if the sending host recently sent spam.
Recent virus from client – Checks to see if the sending host recently sent a virus.

If a message fails four or more checks, the weight assigned to Mail Anomalies in the Intercept
settings is the score used for Intercept processing.
3. Click Apply.
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DNS Block Lists
DNS Block Lists (DNSBL) contain the addresses of known sources of spam and are maintained by
both commercial and non-commercial organizations. The lookup mechanism is DNS-based that
results in a lookup on the specified DNSBL server for every server that attempts to connect to the
WatchGuard XCS.
The weight assigned to DNS Block Lists in the Intercept settings is the score used by Intercept
processing when a DNSBL triggers for a message. If a sender is matched on more than one DNS
Block List, this increases the weight score assigned by Intercept for each list on which it is matched.
Note If a message that you want to receive is blocked by a DNSBL, add a Specific Access
Pattern to "Trust" messages from that client. You can also use Pattern Filters set to
"Bypass" (also bypasses Anti-Spam and content checks), "Trust" (also accepts and
trains as valid mail) or "Accept" (just accept without training) the message, however,
this may interfere with later message processing and using Specific Access Patterns
is recommended.
To configure DNS Block Lists:
1. Select Security > Anti-Spam > Anti-Spam.
2. Select DNS Block List.
The DNS Block List page appears.

3. To reject mail from blocked clients regardless of other message processing, select the Reject
on DNSBL check box.
WarningReject on DNSBL rejects the message at SMTP connection time regardless of
other Intercept processing. Use caution when you enable this feature.
4. In the DNSBL Reject Threshold text box, type the number of block lists on which the server
must be listed before you reject a message.
If this value is set to 2 (default) the server must appear on at least two DNSBLs before it is rejected.

5. To use DNSBLs in the Intercept Anti-Spam decision, select the Enable DNSBLs for AntiSpam check box.
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6. In the Check Relays text box, type how many relay points, starting from the latest headers to
the earliest, should be checked against a DNS Block List.
The Check Relays setting deals with spammers who are relaying their messages through an
intermediate server. The information about the originating server is carried in the headers of the
message. Acceptable values are between “0” and “ALL”. We recommend that you leave this
option at the default value of “0”.
Note You must enable the Check Relays option if the WatchGuard XCS is behind another
MTA or mail gateway. This action makes sure that the relay before the intermediary
MTA is checked.
7. In the Exclude Relays text box, type how many received headers to exclude from DNSBL
checks, starting from the earliest to the most recent.
Some ISPs include the originating dial-up IP as the first relay point. This can result in blocking
dial-ups that are legitimate servers. We recommend you set this value to “1” or “0”. Use “1” if any
of the DNSBL servers utilized include dynamic IP addresses (for example, a dial-up
connection). If the DNSBL service does not include dial-ups, set this to “0” to make sure you do
not reject mail originating from web mail systems.
This is an example of using the Check Relays and Exclude Relays options:
Server A -> Server B -> Server C -> Server D -> WatchGuard XCS
With the mail relayed through four previous servers (A-D), the received headers of a message
appear in this order:
Received: D
Received: C
Received: B
Received: A
With Check Relays enabled, the system starts with server D and checks the configured
number of received headers. If Check Relays is set to “3”, it checks D, C, and B.
Select the Exclude Relays option to ignore the configured number of received headers starting
at the end of the header list, regardless of what the Check Relays option is set to. If Exclude
Relays is set to “1”, then server A is excluded from the checks.
8. Click Apply.
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DNSBL Servers
To edit the list of DNS Block List servers:
1. Click Edit.

2. Click Apply when finished.
Note Do not modify the default WatchGuard DNSBL servers.

Timeout Mode
The Timeout Mode allows the timely recovery of lookup timeouts to the DNSBL domain and improves
redundancy with alternate DNSBL domains in the event the primary domain is unavailable. If you
cannot contact the primary or alternate DNSBL domains, the DNSBL check is skipped for the
message. An alarm also triggers to notify you if the system cannot contact a service.
n

n

n

Alternate – Use the alternate DNSBL domain specified in the Alternate Domain field. The
system checks the status of the primary domain every 5 minutes. The system reverts to the
primary domain when the primary domain service is restored. This is the default setting.
Disable – Do not perform DNSBL lookups if the DNSBL domain is unavailable. The system
checks the status of the domain every 5 minutes. Domain queries resume when the service is
available again.
Ignore – Continue to attempt a lookup to the DNSBL domain. If the system exceeds the
timeout threshold (900 seconds), trigger an alarm and skip the query.
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URL Block Lists
URL Block Lists contain a list of domains and IP addresses of URLs that have appeared previously in
spam, phishing, or other malicious messages. This feature examines a message for any URLs
contained in the body to see if they appear on a block list.
Similar to DNS Block Lists, the WatchGuard XCS queries the URL Block List to see if a URL exists on
the configured block list server. If a match is found, this information is used by the Intercept engine to
decide whether a message is spam or legitimate mail.
If the URL in a message is matched on a URL Block List, it is assigned a score as per the URL Block
List weight configured in the Intercept component weight setting. If a URL is matched on more than
one URL Block List, this increases the weight of the score assigned by Intercept for each list on which
it is matched.
To configure URL Block Lists:
1. Select Security > Anti-Spam > Anti-Spam.
2. Select URL Block List.
The URL Block Lists page appears.

3. Select the Enable UBLs check box.
4. Select the Enable Outbound UBLs text box to scan outbound mail with the URL Block List
feature.
5. In the Maximum UBL Lookup Time text box, type the maximum time (in seconds) for a
lookup to a URL Block List.
This option prevents excessive processing time for messages that contain a large number of
URLs. If all of the URLs in a message cannot be looked up before the timeout value is reached,
the checks stop and only the URLs checked within the time limit are used in the Intercept AntiSpam decision. Valid values are from 1 to 3600. The default is 60 seconds.
6. Select the Treat redirector links as spam check box to treat legitimate redirection and URL
shortener sites abused by spammers as spam.
7. Click Apply.
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UBL Domains
You can check URLs in a message based on domain, IP address, or name server (NS) records.
All three types of lists can be used at the same time.
n

n

n

Domain – Perform lookups using the base (registrar) domains or IP addresses for URLs in the
message text. These lists contain the domain names of servers known to send spam.
IP Address – Perform lookups using the resolved host IP addresses for URLs in the message
text. These lists contain the IP addresses of servers known to send spam.
Name Server – Perform lookups using the name server records for URLs in the message text.
These lists contain the names and IP addresses of DNS servers used to host domains that are
sources of spam.

WatchGuard provides a default server that you can use for the URL Block List feature. You can add
other servers, but you must use caution when you add servers because some free services can
introduce false positives. We recommend these WatchGuard hosted services:
n
n
n

ubl.dnsbl.borderware.com – Domain type (default)
ublip.dnsbl.borderware.com – IP Address type (works with all XCS versions)
ublns.dnsbl.borderware.com – Name Server type (requires 10.0 Update 3 or higher)

Timeout Mode
The Timeout Mode allows for the timely recovery of lookup timeouts to the UBL domain and improves
redundancy with alternate UBL domains in the event the primary domain is unavailable. If you cannot
contact the primary or alternate UBL domains, the UBL check is skipped for the message. An alarm
also triggers to notify you if the system cannot contact a service.
n

n

n

Alternate – Use the alternate UBL domain specified in the Alternate Domain field. The system
checks the status of the primary domain every 5 minutes. The system reverts to the primary
domain when the primary domain service is restored. This is the default setting.
Disable – Do not perform UBL lookups if the UBL domain is unavailable. The system checks the
status of the domain every 5 minutes. Domain queries resume when the service is available again.
Ignore – Continue to attempt a lookup to the UBL domain. If you exceed the timeout (900
seconds), trigger an alarm and skip the query.

UBL Whitelist
You can define a list of trusted domains and IP addresses that bypass URL Block List scanning, even
if messages from those addresses contain URLs that appear in a URL Block List.
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1. Click the Edit button to configure the UBL Whitelist.
2. Type a domain name or IP address to trust, then click Add.
3. If you enter a domain (for example, example.com), all subdomains of that domain are included
(for example, www.example.com).

Upload and Download Lists
You can upload a list of domain names and IP addresses in one text file. The entries must appear one
per line in this format:
example.com
example2.com
example3.com
192.168.1.100

You must use a text editor to create the file ubl_wl.csv.
To update a UBL file:
1. To download the UBL list from the WatchGuard XCS, click Download File.
2. Open the file and update the UBL list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
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Reputation Enabled Defense (RED)
Reputation Enabled Defense provides connection-level security for email and web through a reputation
lookup that scores mail servers and web site URLs as good, bad, or unknown/neutral. The lookup
relies on a powerful, cloud-based reputation database that aggregates data from multiple feeds,
including industry-leading block lists and Anti-Virus engines.
The WatchGuard XCS uses this information to either reject the message immediately or contribute to
the Intercept score if a message is detected from a source with a poor reputation or numerous virus
infections.
If you enable Reputation Enabled Defense, the WatchGuard XCS queries for statistics from the RED
service for the sender IP of each message received, excluding those from trusted and known
networks. With the information returned from RED, the XCS can make a decision about whether a
message is spam or legitimate mail. A reputation closer to “0” indicates the sender is extremely reliable
and rarely sends spam or viruses. A reputation closer to “100” indicates the sender is extremely
unreliable and often sends spam or viruses. An IP address with no previous information from any
source is assigned an initial neutral value of “50”.
Reputation Whitelists allow you to train on messages from known legitimate sources based on their
reputation.
Note Reputation Enabled Defense is also known as RED or BSN. "BSN" may appear in
some logs and drop-down selections, and refers to the Reputation Enabled Defense
feature.

Domain and Sender Reputation
Domain and Sender Reputation increases the reputation effectiveness to examine not only the IP
reputation of a sender, but also the domain name and envelope sender information from that IP
address. A domain can receive a reputation independent of the behavior of another domain originating
from the same address.
A specific sender address receives a reputation independent of the behavior of another sender address
from the same domain or IP address. For a message from the sender user@example.com, a query is
sent to RED to check the sender address user@example.com, the domain example.com, and the
originating IP address of the connection.
RED examines the behavior of the user at its originating IP address (user@example.com,
207.236.65.232), and also the domain at its originating IP address (example.com, 207.236.65.232).
The result generated by RED depends on the reputation for that specific sender at that IP address, on
the reputation of the domain originating from that IP address, and on reputation of the IP address itself.
If there is enough information to make a decision on the reputation of a specific sender at that IP
address (user@example.com, 207.236.65.232), RED does not make use of the information on the
domain and IP address reputation. If there is enough information to make a decision on the reputation
of a domain at that IP address (example.com, 207.236.65.232), RED does not make use of the
information on the IP address reputation. If there is no recorded reputation information on a specific
sender address or domain, RED uses the reputation of the IP address.
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The Domain and Sender Reputation query and any uploaded information is sent to the RED network as
a one-way hash that cannot be reversed. All information shared with RED is encrypted to protect the
details of the domain and sender. If you disable this option, only the IP address reputation is used when
you query and share statistics with RED.

Reputation Enabled Defense Statistics Sharing
These statistics are sent to the RED network when Share Statistics is enabled:
n
n
n
n
n
n
n
n
n
n
n

Originating IP address
Destination IP address
Total mail
Clean mail
Spam mail (this includes results of Intercept scanning)
Anti-virus scanning results
Outbreak control results
Known and unknown recipients
Malformed mail
Domain and user information (sent using a one-way hash for security purposes)
Checksum identification of attached files
Note Reputation service queries use the DNS protocol on UDP port 53. Statistics sharing
uploads data to the reputation network using HTTPS on TCP port 443. You must open
up these ports on your network firewall if the system is located behind the firewall.
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Trusted Clients and Known Mail Servers
You can trust friendly local networks or addresses of known mail servers in their environment that relay
mail through this system. To trust specific networks and servers, add them to the relays IP Address
list in the Threat Prevention configuration page to prevent them from being blocked by Threat
Prevention and RED, as well as make sure that reputation statistics for these addresses are not
reported to RED.
For example, in certain environments with a backup MTA (Mail Transfer Agent) server, the backup
system may be classified with a poor reputation because the mail received from the backup includes
relayed spam. If the WatchGuard XCS is offline, mail is collected by the backup MTA as specified in
the organization's MX records. When the WatchGuard XCS comes back online, this mail (which may
include spam, viruses, and other types of infected mail) is forwarded from the backup MTA to the
WatchGuard XCS for processing. If RED is enabled, this backup system may receive a low reputation
score from RED.
Reputation Enabled Defense checks and statistics sharing are not performed for any internal IP
addresses and systems listed in the Relays list. If a message comes from an IP address identified in
the Relays list and Share Statistics is enabled, an upload of information can still occur. If a prior
network hop is listed in a Received header, it is considered the source of the message and an upload
occurs as if that IP address had sent it directly. Each system in the Received header is consulted until
a suitable one is found. Identified relays and internal IP addresses are ignored.
To add a system to the relays list:
1. Select Security > Anti-Spam > Reputation Enabled Defense.
2. Click the internal hosts and friendly mail relays link.
The relays Static IP/CIDR List page appears.

3. Add the address of an internal relay.
4. Click Add.
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Configure Reputation Enabled Defense Checks
To configure Reputation Enabled Defense:
1. Select Security > Anti-Spam > Reputation Enabled Defense.
The Reputation Enabled Defense page appears.

2. From the Timeout Mode drop-down list, select a timeout mode to use in the event the primary
domain is unavailable.
In the event the primary RED domain is unavailable and the timeout mode is set to Alternate,
an alternate RED domain is queried. If the primary or alternate RED domains cannot be
contacted, the RED check is skipped for the message. An alarm triggers to notify you if you
cannot contact service.
n

n

n
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Alternate – Use an alternate RED domain for queries. The system checks the status of the
primary domain every 5 minutes. The system reverts to the primary domain when the
primary domain service is restored. You cannot modify the alternate RED domain.
This is the default setting.
Disable – No RED lookups are performed if the RED domain is unavailable. The system
checks the status of the domain every 5 minutes. Domain queries resume when the
service becomes available.
Ignore – Continue to attempt a lookup to the RED domain. The query is skipped and an
alarm triggers if you exceed the timeout threshold (900 seconds).
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3. To share Reputation Enabled Defense information, for example, spam and virus statistics for
connecting client IP addresses, from this XCS device with the RED network, select the Share
Statistics check box.
Note You must enable TCP Port 443 outbound to upload statistics to the reputation server.
There are no security risks associated with sharing statistics. The XCS device does
not relay any private or sensitive information to the Reputation Enabled Defense
service.
4. To use domain and sender behavior when you perform Reputation Enabled Defense checks,
select the Use Domain and Sender Behaviour check box.
This option increases the effectiveness of RED by examining not only the IP reputation of a sender,
but also the domain name and envelope sender information from that IP address.

5. To reject messages from senders whose reputation is above the configured Reputation
Threshold, select the Reject on Reputation check box.
A reputation closer to “0” indicates the sender is extremely reliable and rarely sends spam or
viruses.
A reputation closer to “100” indicates the sender is extremely unreliable and often sends spam
or viruses. An IP address with no previous information from any source is assigned an initial
neutral value of “50”.
To override a RED reject, add the server to the internal hosts and friendly mail relays list. You
can also override RED rejects with a Specific Access Pattern set to Trust the rejected address.
You cannot override RED rejects with a policy.
Note You can also use a Pattern Filter set to Bypass (also bypasses all Anti-Spam and
content checks), Trust (to accept and train as valid mail) or Accept (just accept
without training) the message. This may interfere with later message processing and
we recommend you use the mail relays list.
6. In the Rejection Threshold text box, type a threshold over which a message is rejected.
The default value is “90”. If the reputation of a connecting system is greater than this value, it is
rejected. The lower the reputation threshold, the greater the chance that a system with valid
mail is blocked. This setting is only valid when you enable Reject on Reputation.
7. To reject messages from senders based on the criteria configured in the Infection Threshold
option, select Reject on Infection.
8. From the Infection Threshold drop-down list, select the criteria for rejecting messages based
on whether the sending host is Currently infected (received in last hour), or Recently infected
(received in last day).
This is setting is only valid when you enable Reject on Infection.

9. To reject messages sent directly from dial-up connection, select the Reject Connection From
Dial-ups check box.
Note If a message is not rejected because it violates a reputation threshold, the reputation
score and information about whether the sender is a dial-up is incorporated into the
overall Intercept Anti-Spam decision.
10. You can customize the Reputation Enabled Defense Reject Message.
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Use “%s” to specify the IP address of the rejected sender.
For example,
go to http://www.reputationauthority.org/lookup?ip=%s

Reputation Enabled Defense rejection, infection, and dial-up log messages include a URL
similar to this example:
450: blocked by Intercept:
http://www.reputationauthority.org/lookup?ip=207.236.65.226&d=4ECD2A71BB0D0E6
A&u=45F00D38BFC08DFC

where the IP address is the connecting server that was rejected. The “d=” and “u=” section are
domain and user hashes for the domain and sender reputation. Click the URL to open up the
Reputation Enabled Defense (powered by ReputationAuthority) web page that displays
reputation statistics for the specified IP address, domain, and user.

11. To check incoming messages against the spam information gathered by the RED network,
select the Enable Reputation Enabled Defense for Anti-Spam check box.
12. In the Check Relays text box, specify how many received headers to check with RED.
For example, an email message may have been relayed by four mail servers before it reached
the XCS. Use this field to specify how many relay points, starting from the latest headers to the
earliest, should have their reputation checked by RED. Acceptable values are between “0” and
“ALL”. The default is “0”.
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Note You must enable Check Relays if the system is installed behind another MTA or mail
gateway. This action makes sure that the relay before the intermediary MTA is
checked.
13. In the Exclude Relays field, specify how many received headers to exclude from RED checks,
starting from the earliest header to the most recent.
For example, if Check Relays is enabled, setting this value to “1” means that the first relay
point is not checked. Note that some ISPs include the originating dial-up IP as the first relay
point which can lead to legitimate mail being classified as spam by RED. We recommend you
set this value to “0” (off) or “1”. The default is “0”.
Note The Exclude Relays setting is only enabled if you enable Check Relays.
As an example of using the Check Relays and Exclude Relays options, consider this
scenario:
Server A -> Server B -> Server C -> Server D -> WatchGuard XCS

With the mail relayed through four previous servers (A-D), the received headers of a message
appear in this order:
Received: DReceived: CReceived: BReceived: A

With Check Relays enabled, the XCS starts with server D and checks the configured number
of received headers. If Check Relays is set to “3”, it checks D, C, and B.
Use the Exclude Relays option to ignore the configured number of received headers starting at
the end of the header list regardless of what the Check Relays option is set to. If Exclude
Relays is set to “1”, then server A is excluded from the checks.
14. Click Apply.
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Token Analysis
Token Analysis is a sophisticated method of identifying spam based on statistical analysis of mail
content. Simple text matches can lead to false positives because a word or phrase can have many
meanings depending on the context. Token Analysis provides a way to accurately measure how likely
any particular message is to be spam without having to specify every word and phrase.
Token Analysis derives a measure of a word or phrase contributing to the likelihood of a message being
spam. This is based on the relative frequency of words and phrases in a large number of spam
messages. From this analysis, it creates a table of tokens (words associated with spam) and
associated measures of how likely a message is spam.
Token Analysis analyzes a new message, extracts the tokens (words and phrases), finds their
measures from the table, and aggregates these measures to produce a spam metric for the message.
This spam metric is the score assigned by Token Analysis to use in the Intercept Anti-Spam decision.
Token Analysis has a built-in weighting mechanism that assigns a value between 0 and 100 to indicate
whether a message is spam. A message with a low metric (closer to 0) is considered to be legitimate,
while a message with a high metric (closer to 100) is considered to be spam. Token Analysis uses
three sources of data to build its run-time database:
n
n
n

The initial default database based on analysis of known spam.
Tables derived from an analysis of local legitimate mail. This is referred to as “training”.
Training provided by spam from Pattern Filter Spam, Reputation, Brightmail, DNSBL, UBL,
SPF, and DomainKeys Intercept components.
Note Token Analysis is also known as Statistical Token Analysis (STA). "STA" appears in
many logs and drop-down selections, and refers to the Token Analysis feature.

How Token Analysis Works
Consider this simple message:
--------------------------------------------------------------Subject: Get rich quick!!!!
Click on http://getrichquick.com to earn millions!!!!!
---------------------------------------------------------------

Token Analysis breaks the message down into these tokens:
[Get] [rich] [quick!!!] [Click] [on] [http://getrichquick.com] [to] [earn]
[millions!!!!!]

Each token is looked up in the database and a spam metric is retrieved. The token “Click” has a high
metric of 91, whereas the word “to” is neutral (indicating neither spam nor legitimate.) These metrics
are aggregated using statistical methods to give the overall score for the message of 98.
Mail messages with a spam metric of 90 or greater are very likely to be spam. Lower values (50-60)
indicate possible spam, while very low values (20-25) are unlikely to be spam. These spam metrics are
the score assigned by Token Analysis as part of the final Intercept Anti-Spam decision.
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Token Analysis Training
When first enabled, the WatchGuard XCS immediately starts training on inbound and outbound mail.
The WatchGuard XCS uses the Token Analysis Anti-Spam feature for spam and legitimate mail
training.
Token Analysis training includes:
n
n
n

The initial default database based on analysis of historical known spam
Training derived from analysis of local legitimate mail (trusted outbound mail)
Spam training provided through mail processed by the Intercept Anti-Spam features

Local outbound mail is assumed to be trusted and not spam, and the frequency of the words found in
these messages can be used to modify the values supplied by WatchGuard’s default training
database. For example, a mortgage company uses the word “refinance” frequently in its regular mail.
The likelihood of this word suggesting spam is therefore reduced.
Token Analysis trains messages from these sources as legitimate mail:
n
n

n
n
n

Specific Access Pattern Trust
Reputation Whitelist (Reputation Enabled Defense list of hosts that are known to send
legitimate mail)
Pattern Filter train action
User submitted legitimate mail (Not Spam)
Trusted Subnet (mail originating on a specific trusted network interface)

Token Analysis trains messages for spam if one of these features classifies a message as spam:
n
n
n
n
n
n
n
n

Reputation Enabled Defense
DNS Block Lists
URL Block Lists
Pattern Filter spam
Backscatter Detection
DKIM/DomainKeys and SPF
Brightmail
User submitted Spam

Training Period
Depending on the amount of mail sent and received in your environment, it can take several days of
mail processing and training to properly adjust the default training database for the content of your
organization’s mail flow.
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Configure Token Analysis
To configure Token Analysis
1. Select Security > Anti-Spam > Anti-Spam.
2. Select Token Analysis.

3. Select Enable Token Analysis.
4. Select Enable X-STA Headers to insert X-STA (Token Analysis) headers into all messages.
These headers are not visible to the user, but you can use them to gather information on why
mail is processed by Token Analysis in a particular way.
These headers are inserted:
n

n

n

X-STA-Metric – The score assigned by Token Analysis, for example, 95, which indicates a
spam message.
X-STA-NotSpam – Indicates the words with the highest non-spam value found in the
message.
X-STA-Spam – Indicates the words with the highest spam value found in the message.

5. Click Apply.

Database and Training
The Token Analysis database is built and rebuilt at two hour intervals from several sources, for
example, the supplied spam data, updated data from WatchGuard, trained spam from other Intercept
features, and local training. The database is not built for the first time until two hours after installation,
and you can click Rebuild Database at any time to rebuild the Token Analysis database.
You must delete all training material if your system has been misconfigured and starts to treat trusted
mail as untrusted or vice versa. Click Delete Training to remove all training material.
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Token Analysis Advanced Options
To configure advanced Token Analysis options, click Advanced.
Note These options are for advanced configuration only, and we recommend that you use
the default values. Modifications to the default values can decrease Token Analysis
accuracy and should be used with care.

Neutral Words
Neutral words are words that may or may not indicate spam. For example, a mortgage company may
want to build a neutral word list that includes “refinance” or “mortgage” because these words show up
quite frequently in spam mail. By adding them to the neutral word list, the likelihood of this word
suggesting spam would be reduced to a neutral value.
n

n

Default Neutral Words – Select the check box to enable the WatchGuard neutral words list.
This list helps prevent pollution of the Token Analysis database. We recommend that you leave
this option enabled.
Uploaded Neutral Words – Select the check box to enable the uploaded neutral words list.

To upload a file, click Upload Neutral Words. The file must be in text format and contain a list of
neutral words with one word per line. If you upload a new list, it replaces the previous neutral words list.
Note The WatchGuard XCS automatically rebuilds the Token Analysis database during the
upload of a neutral words list.

Token Analysis and Languages
The Token Analysis spam database is based on English language spam. As a result, it may not be
initially responsive to spam created in other languages. The ability to learn means that it can readily
adapt to other languages. Token Analysis trains on local legitimate mail from the moment the system is
started. This helps properly characterize the local language use by building up a database of good
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words to help prevent mail messages from being classified as spam. To train the system with known
local language spam mail, we recommend that you set up rules to use the Certainly Spam action in the
Pattern Filters. Messages specified as spam are forwarded to Token Analysis and increase its
database of local language words.

Japanese, Chinese, and Korean Languages
The language options alter the Token Analysis processing behavior for Japanese, Chinese, and
Korean language messages to make sure they are not automatically classified as spam. These include
these character sets:
n
n

n

Japanese major character sets – ISO-2022-JP, EUC-JP, Shift-JIS
Chinesemajor charactersets–GB2312,HZ-GB-2312,BIG5,GB7589,GB7590,GB8565.2-88,
GB12052,GB/T12345,GB/T13131,GB/T13132,GB/T13000.1,ISO-2022-CN,ISO-2022-CN-EXT
Korean major character sets – KS C 5601 (KS C 5601-1987), EUC-KR, ISO-2022-KR

For each character set, select how Token Analysis processes the message:
n

n

n

Default – All content is processed by Token Analysis. If you receive legitimate mail in these
languages, this may result in false positives.
No Token Analysis Scan – Token Analysis scanning is turned off for all messages containing
Japanese, Chinese, and Korean language characters.
Lenient Token Analysis Scan – Token Analysis scanning is turned off for only the parts of the
message containing Japanese, Chinese, and Korean language characters. The rest of the
message is processed normally. If there are 20 or fewer tokens in the message of nonJapanese, Chinese, and Korean characters, the Token Analysis scan is skipped for that
message.

Image Analysis
An image spam email message typically consists of random text or no text body and contains an
attachment picture (usually .gif or .jpg format) that supplies the text and graphics of the spam
message. These types of spam messages are difficult to detect because the message contains no
helpful text or URL characteristics that can be scanned and analyzed. The Image Spam Analysis
feature performs advanced analysis of image attachments to help determine if the message is spam or
legitimate mail. Similar to the other Anti-Spam features that detect spam characteristics in the text of a
message, the Image Analysis feature extracts certain characteristics of the attached image to
determine if these characteristics are similar to those seen in actual spam messages.
1. Make sure the Enable Token Analysis option is enabled using Scanning and Training mode.
2. Select the Enable Image Analysis check box in the Options section.
3. Click Apply.
Allow at least 24 hours for the Token Analysis scanner to scan and train incoming mail and update its
database to see an improvement in spam catch rates. To accelerate this process:
1.
2.
3.
4.

Select Administration > Software Updates > Security Connection.
To retrieve the latest Token Analysis database updates, click Connect Now.
Select Security > Anti-Spam > Anti-Spam > Token Analysis.
Click Rebuild Database to perform a manual rebuild of the Token Analysis database.
The database is rebuilt automatically every two hours.
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RTF Analysis
Spammers can embed spam text and images in RTF (Rich Text Format) documents. The Token Analysis
scanner creates tokens for unique RTF properties to be able to detect characteristics of RTF spam.

PDF Spam Analysis
In response to the effectiveness of image spam detection technologies, spammers have attempted to
circumvent the anti-spam scanners by embedding spam text and images in PDF (Portable Document
Format) documents. Within these PDF documents, the images and text themselves can be further
obfuscated with various image distortion techniques and using “word salad” text that contains valid text
included with the spam message text. A further technique used to avoid detection is to compress the
PDF into an archive file, for example, .zip. Token Analysis can improve detection of PDF spam by
analyzing specific information in the PDF, for example, the document meta-properties (author, creation
date, etc.) and the text and images contained in the PDF. The Token Analysis scanner creates tokens
for each of these unique PDF properties to be able to detect characteristics of PDF spam.
Note The PDF Analysis feature uses the Token Analysis component to analyze PDF spam
messages. You must enable Token Analysis for PDF Spam detection to work. To
perform content inspection of archive files, for example, .zip, that contain PDF files,
you must enable Kaspersky Anti-Virus.
Tokens generated by the PDF analysis feature (by analyzing text in the PDF) are also utilized by the
Spam Words and URL Block List (UBL) features. They cannot be used for the Objectionable Content
Filter.
n

Enable PDF Analysis – Enables PDF analysis to allow the system to scan PDF files for
spam. This is enabled by default.
Note If the PDF document size is larger than 45kb, analysis of the document is skipped.
Larger documents are less likely to be spam messages.

n

n

Analyze PDF Text – Select this check box to extract and analyze the text in a PDF file. This
allows the scanner to examine the PDF text for words that may indicate it is a spam message.
Tokens created from the text in a PDF are used by Token Analysis, Spam Words, and the URL
Block list features.
Analyze PDF Images – Select this check box to analyze images in PDF documents for image
spam. You must also enable the Image Analysis option to analyze images in PDF documents.
Note PDF text and image analysis are enabled by default. Disable these options if there is
an increased amount of false positives (legitimate mail identified as spam), or if
system message processing performance is affected.
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Detect PDF JavaScript
The WatchGuard XCS can detect JavaScript embedded in PDF (Adobe Portable Document Format)
files. This allows you to block the transmission of PDF documents containing JavaScript code,
including code that could be malicious. JavaScript code can be executed when a user opens the file in
a PDF reader.
You can use the Attachment Control feature to manage inbound and outbound message attachments
that contain the JavaScript content type application/javascript. JavaScript is blocked by default, but
you can change the action to Strip to strip JavaScript attachments from an email message.
Note The text/javascript content type has no affect on PDF attachments with embedded
JavaScript.
PDF JavaScript Detection in Archive Files
Note these limitations when detecting JavaScript code in PDF files in an archive (such as .zip):
n

n

Kaspersky Anti-Virus must be enabled to be able to scan PDF files inside an archive file
attachment.
A PDF will not be scanned for embedded JavaScript if the PDF is larger than 54kb and part of
an attached archive (such as a .zip file).

Diagnostics
The diagnostics section allows you to configure diagnostic options for Token Analysis to help with
troubleshooting.
n

Enable X-STA Headers – This setting inserts X-STA (Token Analysis) headers into all
messages.
These headers are not visible to the user (although you can filter them in most mail clients), but
you can use them to gather information on why mail is processed in a particular way.
These headers are inserted:
o

o

o

n

n
n
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X-STA-Metric – The score assigned by Token Analysis, for example, 95,
which indicates a spam message.
X-STA-NotSpam – Indicates the words with the highest non-spam value
found in the message.
X-STA-Spam – Indicates the words with the highest spam value found in the
message.

Enable Monitoring – Select the check box to monitor messages received by the specified
email address.
Monitor email for – Type an email address that you want to monitor.
Copy to – Copy messages and the Token Analysis diagnostic to this email address.
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Legitimate Mail Training
Local mail is assumed to be not spam, and Token Analysis can train local mail to identify tokens that
indicate legitimate mail.
n

Trusted/Local Mail – To train all local trusted network mail for Token Analysis, select the
Trusted/Local Mail check box. This includes outbound mail from a trusted subnet (based on
the network interface with the Trusted Subnet option enabled), and mail trusted by a Pattern
Filter.
Note If you do not train on local trusted mail, use the Heuristic 1 Intercept Decision strategy
to de-emphasize Token Analysis. This prevents false positives when you use the
Heuristic 2 strategy.

n

Reputation Whitelist – To train on legitimate mail based on Reputation Enabled Defense
whitelists of hosts that are known to send legitimate mail, select the Reputation Whitelist
check box.
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Reputation Whitelists are similar to block lists that are used to identify servers that send a lot of
spam messages. Whitelists indicate messages that originate from a server IP address that
never sends spam. This information is very useful in the overall Anti-Spam decision. For
example, in certain cases, a message can receive a high Token Analysis score, but because
the server is listed on a whitelist, this indicates the message is most likely legitimate mail. This
feature also provides a method to train the Token Analysis feature for mail environments that do
not process the local outbound mail flow.

Legitimate Mail Settings
n

n

n

n

Local Limit – Type the maximum number of messages from local users to use for Token
Analysis training. When the limit is reached, older training messages are deleted as new
messages arrive. Default is 20000.
User Submitted Limit - Type the maximum number of user submitted legitimate mail
messages used for training. When the limit is reached, older messages are deleted as new
messages arrive. The default is 2000. You can enter values between 200 and 100000.
Local Threshold – Set the threshold for messages from local users to be used for training. If
the Token Analysis classification for the message is greater than or equal to the specified
number, the message is used for training.
Source Weighting % – For Token Analysis to be useful and efficient, the training must be
based on well selected data. The initial database supplied by WatchGuard represents well
selected data, and is therefore highly weighted, compared to uploaded legitimate mail or
legitimate mail from the trusted network.
o Default – Type a percentage for the weight of the WatchGuard maintained Token
Analysis database of valid mail.
o Uploaded – Type the weight of locally uploaded valid mail. To upload legitimate mail,
click Upload Legitimate Mail. The mail must be in plain-text Unix mbox format. You
must upload a minimum of ten messages to be effective.
o Detected – Enter the weight of mail detected from trusted networks that are
automatically trained as valid mail.
o Submitted– Weight of legitimate mail messages submitted by end users.
Note When you upload mail, we recommend that you set the weighting to 60% for Default,
20% for Upload, 10% for Detected, and 10% for Submitted. Significant changes to the
source weighting can decrease Token Analysis accuracy.

Spam Training
Select which features are used for spam training:
n
n
n
n
n
n
n
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Backscatter Detection – Train mail marked as spam by Backscatter Detection.
DNS Block List – Train mail marked as spam by DNS Block Lists.
DomainKeys Authentication – Train mail marked as spam by DomainKeys.
DKIM Authentication – Train mail marked as spam by DKIM (DomainKeys Identified Mail).
Pattern Based Message Filtering – Train mail marked as spam by Pattern Filters.
RED Reputation – Train mail marked as spam by Reputation Enabled Defense.
RED Dial-up – Train mail marked as spam by Reputation Enabled Defense DUL (dial-up).
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n
n

SPF – Train mail marked as spam by SPF.
URL Block List – Train mail marked as spam by the URL Block Lists.

Spam Settings
n
n

n

n

Spam Limit – Type the maximum number of spam messages used for training.
User Submitted Limit - Type the maximum number of user submitted spam messages used
for training. When the limit is reached, older messages are deleted as new messages arrive.
The default is 2000. You can enter values between 200 and 100000.
Spam Training Threshold – Set the threshold for spam messages to use for training.
If the Token Analysis classification for the message is less than or equal to the specified
number, use the message for training.
Source Weighting – For Token Analysis to be useful and efficient, the training must be based
on well selected data. The default database supplied by WatchGuard represents well selected
data and is therefore highly weighted, compared to uploaded spam mail.
o Default – Type a percentage for the weight of the WatchGuard maintained Token
Analysis database of spam mail.
o Uploaded – Type the weight of locally uploaded spam mail. To upload spam mail, click
Upload Spam Mail. The mail must be in plain-text Unix mbox format. Upload a
minimum of ten messages to be effective.
o Detected – Weight of mail from DNSBL, UBL Block Lists, Pattern Filters or Reputation
Enabled Defense automatically trained as spam.
o Submitted– Weight of spam messages submitted by end users.
Note When you upload mail, we recommend that you set the weighting to 60% for Default,
20% for Upload, 10% for Detected, and 10% for Submitted. Significant changes to the
source weighting can decrease Token Analysis accuracy.

Dictionary Spam Count
Recentchanges tothewaythatspammerscomposetheirmessages canreducetheeffectiveness ofthe
TokenAnalysis filter.By introducinglargenumbersofnormalwords intotheirspammessages,spammers
canhidetheircontentbecausethenormalwords outweighthespamwords andresultinalowspamcount.
Moreaggressivesettingscanresultinmorefalsepositives.TheWatchGuardXCScountersthis intwoways:
1. All words in the dictionary are assigned a base level of how likely they are to be spam. In a
normal message, this increased level does not result in a false positive, since the overall count
is low. In a spam message, the result is different; the normal words do not counteract the spam
content, and the message is correctly identified as spam.
2. Training on local mail now works to reduce this base level closer to zero. This further reduces
the likelihood of a false positive.
The Dictionary Count is set to “1” by default. This should be sufficient for most situations. We
recommend that you only change the default value if these conditions occur:
n

n

If there are too many false positives and this is not alleviated by training, then the Dictionary
Count should be set to “0” to disable this feature.
If too much spam is getting through, then increase the Dictionary Count. Increase the value to
“10”. If this results in too many false positives, reduce it to “5”.
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Note Only modify the dictionary count setting if other measures (training, threshold
changes, uploading spam and/or legitimate mail) have been tried and have not
provided the desired result.

Troubleshoot Token Analysis
Token Analysis is a very effective anti-spam tool and provides the mail administrator with a variety of
options to finely tune this feature for their particular environment. With these advanced controls, there
is a greater chance of creating a configuration that may result in excessive false positives (mail marked
as spam when they are legitimate) or false negatives (mail not marked as spam when they are spam.)
These are some considerations when troubleshooting issues with Token Analysis:
For excessive false positives:
n
n

n

n

Make sure that the system has gone through a cycle of training.
Make sure that any mailing lists that the organization sends out are trusted (with Pattern Filters)
as Accept.
Check for tokens that may be words used by the organization for their regular business. For
example, a financing company would want the words “mortgage” or “refinance” to be allowed as
legitimate tokens.
Lower the component weighting in the Intercept settings.

For excessive false negatives:
n
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Check that any mailing lists received by the users are trusted with Pattern Filters as Bypass or
Accept.
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WatchGuard XCS Outlook Add-in
The WatchGuard XCS Outlook Add-in places special Spam and Not Spam buttons on your Microsoft
Outlook client toolbar. This tool allows you to report any spam messages that bypassed the spam
filters and were delivered to your inbox, and also report false positives where legitimate messages
were classified as spam.

To report and train on spam messages that appear in your inbox, you can select the message, then
click "Spam". To report and train on legitimate messages that were classified as spam, select the
message, then click "Not Spam".
When you click the Spam button:
n
n
n
n

The message can remain in the inbox, be moved to the Junk folder, or deleted.
The message is trained as spam by the WatchGuard XCS.
The message is relayed to WatchGuard servers for training.
The sender is added to your personal Blocked Senders List.

When you click the Not Spam button:
n
n
n

The message is trained as legitimate mail (Not Spam) by the WatchGuard XCS.
The message is relayed to WatchGuard servers as legitimate mail training.
The sender is added to your personal Trusted Senders List.

See Custom Actions for Pattern Filters and Content Rules to configure User Reported Spam and Not
Spam training options on the Custom Actions page.
Note The ability to configure WatchGuard XCS Outlook Add-in training options and end
user Trusted/Blocked Senders List settings requires WatchGuard XCS 9.1 Update 2
or greater. For earlier versions of XCS, the messages are relayed to WatchGuard
only, and you must manually create a Pattern Filter to not train on outbound messages
sent to @mailsupport.watchguard.com.

Download and Install the WatchGuard XCS Outlook Add-in
The WatchGuard XCS Outlook Add-in is available for these versions of Outlook:
n
n
n
n

Outlook 2003
Outlook 2007
Outlook 2010
Outlook 2013

To download the Add-in for your version of Outlook:
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1. Select Support > Microsoft Outlook Add-ins from the WatchGuard XCS Web UI, and then
select WatchGuard Portal.
You can also go to http://www.watchguard.com/archive/softwarecenter.asp.
2. Log in to the WatchGuard Portal and click the Articles & Software tab.
3. Select WatchGuard XCS.
4. Search to see all available Software Downloads articles and find the Software Download
content for the WatchGuard XCS Software Downloads.
5. Select the download link for your specific version of Outlook.
Installation instructions are included with the download file.

Operating System and Language Support
WatchGuard XCS Outlook Add-in for Outlook 2003, 2007, and 2010:
n
n
n

Windows XP
Windows Vista
Windows 7

WatchGuard XCS Outlook Add-in for Outlook 2013:
n
n
n

Windows 7
Windows 8
Windows 8.1

Supported languages:
n
n
n
n
n

English (default)
French (fr)
Spanish (es)
Japanese (ja)
Simplified Chinese (zh-CHS)

Software Requirements
For WatchGuard XCS Outlook Add-in for Outlook 2003, 2007, and 2010:
n

n
n

.NET Framework 3.5 (Not included). You must download the .NET Framework software from
Microsoft.
Windows Installer 3.1 (included in the setup.exe file)
Microsoft Office Primary Interop Assemblies (included in the setup.exe file)

For WatchGuard XCS Outlook Add-in for Outlook 2013:
n

.NET Framework 4.5 or greater (Not included). You must download the .NET Framework
software from Microsoft.

Use the setup.exe file to install the WatchGuard XCS Outlook Add-in and prerequisites (except the
.NET Framework software which must be installed separately).
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If you already have the prerequisite software installed, you can install the WatchGuard XCS Outlook
Add-in with the .msi file. Network administrators can use the .msi installation file to push the add-in to
desktop workstations in an Active Directory domain, but the prerequisite software must already be
installed on the desktop workstations or be pushed by the administrator before the add-in installation.

Install the WatchGuard XCS Outlook Add-in
To install the WatchGuard XCS Outlook Add-in:
1. Close Microsoft Outlook if it is currently running.
2. Make sure you have downloaded and installed the .NET Framework software for your Outlook
Add-in version.
3. Unzip the download package.
4. Double-click the setup.exe installation file.
You are prompted to install each prerequisite software as required.

5. Follow the prompts to install the WatchGuard XCS Outlook Add-in.
6. Click Close when the installation completes.

Configure the WatchGuard XCS Outlook Add-in
To configure the WatchGuard XCS Outlook Add-in:
1. Start Microsoft Outlook.
A new add-in appears that displays the Spam, Not Spam, and Configure buttons.

Note You may be prompted to confirm the installation of the Outlook Add-in when Microsoft
Outlook starts.
2. Click Configure.
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3. To ask for confirmation when you click the Spam or Not Spam button, select the Confirm
submissions check box.
4. To save any messages that you submit as Spam or Not Spam in your Sent Items folder, select
the Save submissions in Sent Items check box.
5. From the Spam submission action drop-down list, select the action to perform on a spam
message when you click the Spam button:
n
n
n

Submit – Submits the spam message. The message remains in the inbox.
Submit and delete – Submits the spam message and then deletes the message.
Submit and move to Junk folder – Submits the spam message and moves the message
to the Junk folder.

6. The Submit spam to text box displays the email address to which to send "Spam" message
submissions.
The default is spam@mailsupport.watchguard.com.
The Submit not spam to text box, displays the email address to which to send "Not Spam"
message submissions.
The default is notspam@mailsupport.watchguard.com.
7. Click OK.
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Backscatter Detection
Backscatter is a type of spam attack where spam mail is sent to email servers with forged header
information for the Envelope Sender address. If the email server bounces this email back to the sender,
a bounced message usually has the Envelope Recipient set to the Envelope Sender of the original
message, and the undeliverable message notification is sent to the email address of the innocent user.
There can also be other unsuspecting email servers in the message path, and in a large spam
campaign the target systems are flooded with these backscatter spam messages.
Backscatter spam is mitigated with special signing techniques, for example, Bounce Address Tag
Validation (BATV). BATV uses message signing to sign the local Envelope Sender address. If the
message is bounced back, the Envelope Recipient address signature is validated which prevents any
undeliverable message bounce notifications from being returned to a forged address.
Note Messages are not signed if they are sent to a local internal recipient.
For example, if the WatchGuard XCS sends an outgoing message to an external user from:
user@example.com, a PRVS (Simple Private Signature) tag is created utilizing the key index, the
timestamp and expiration term of the message, and a private key. An SHA1 message digest is
generated for this information that results in this format:
<prvs=[Key Index][Expiry][Digest][Email address]>

With this information:
Key Index = 0Expiry = 110 (generated from the current time and the expiry time)SHA
1 digest = 450a98Email Address = user@example.com

Results in the email address are rewritten with this PRVS tag:
<prvs=0110450a98=user@example.com>

If this message is bounced back to the WatchGuard XCS, it extracts and verifies the address
signature. If the signature cannot be verified, or if it is invalid or expired, the WatchGuard XCS can
reject the message immediately, or contribute to the overall Intercept Anti-Spam score for the
message.
WarningVerify that the gateway device, for example, the WatchGuard XCS, is the only
device performing PRVS tag signing and verification, and that you disable
PRVS tag signing and verification on any internal mail servers.

Intercept Anti-Spam Processing
For Intercept Anti-Spam processing, the Backscatter Detection feature creates a result code between
0 and 100 for the message. This table describes the result codes that are returned for a message after
Backscatter Detection processing.
Any result greater than code 50 results in the message being considered spam, and the configured
Backscatter Detection Intercept weight is applied to the overall Intercept Anti-Spam score for the
message.
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Code

Description

0

No PRVS checking or signing was performed

1

OK (signature verified)

50

Unsigned

51

Invalid key

52

Invalid signature

53

Signature expired

60

Syntax error 1

61

Syntax error 2

62

Syntax error 3

Anti-Spam Header
Any Backscatter Detection results are added to the Anti-Spam header (if enabled), using this format:
<Backscatter on/off><Explanation/Result Code>

For example:
bsctr:off
bsctr:spam/52
bsctr:passed/1
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Configure Backscatter Detection
To enable and configure Backscatter Detection:
1. Select Security > Anti-Spam > Anti-Spam.
2. Select Backscatter Detection.
The Configure Backscatter Detection page appears.

3. Select the Enable Backscatter Detection check box.
Note If you enable Backscatter Detection and disable envelope signing and verification, the
XCS strips the PRVS tags (even if invalid) from the message and delivers the
message to its destination.
4. To sign outgoing (non-local) email messages with the Backscatter verification signature, select
the Enable envelope signing check box.
5. To verify the sender address signature of incoming messages, select the Enable Verification
check box.
This option makes sure that invalid addresses are rejected immediately or scanned by Intercept AntiSpam depending on your configuration.

6. In the Message life time text box, type the number of days before the signature expires and is
considered invalid.
Expired signatures cause the Backscatter verification check to fail and triggers the specified action.
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7. To immediately reject any messages that fail the Backscatter Detection signature validation
(this includes an invalid Envelope Recipient address, syntax errors, invalid keys, and expired
signature), select the Reject upon verification failure check box.
When this option is disabled, the results of the Backscatter Detection scanning are used as part of
the overall Intercept Anti-Spam score.

8. To reject bounce messages that do not contain any signature to verify, select the Reject
unsigned recipients check box.
This option requires that you also enable Reject upon verification failure. We recommend
that this option not be enabled until the XCS device has been signing and verifying message
senders for a period of time to make sure that any existing unsigned messages that are still in
circulation are not rejected.
9. From the Current Key drop-down list, select the key to use for Backscatter Detection email
signing.
The key can be up to 1024 characters. Click Show Advanced Mode to manually configure
additional keys to use. You can also change the key in the Current Key text box, and the
Active Key Index is updated automatically when you apply the settings. The previous key is
saved in the advanced settings.
WarningYou should not change the keys too frequently because any message signed
with a previous key are no longer accepted and could be rejected.
We recommend that you do not manually edit the keys.
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Sender Policy Framework (SPF)
Sender Policy Framework is a sender authentication technology that prevents spammers from
spoofing mail headers and impersonating a legitimate email user or domain to prevent phishing attacks.
Unsuspecting users can reply to these seemingly legitimate addresses with personal and confidential
information.
SPF provides a means for authenticating the source of an email by sending a query to the sending
domain’s DNS records. The SPF protocol allows server administrators to describe their email servers
in their DNS records. By comparing the headers of the email with the SPF value, the receiving host can
verify that the email is originating from the legitimate mail server for that domain. This prevents
spammers from sending forged emails.
SPF actions only apply to incoming mail messages that have failed an SPF check (the email message
does not match the corresponding published SPF record.) If a specific mail server does not have an
existing SPF record then the message is processed normally. Administrators can misconfigure their
DNS SPF records, which results in false positives and legitimate hosts being blocked from sending
you mail.
The weight assigned to SPF in the Intercept settings is the score used by Intercept processing if the
message fails an SPF check.
SPF is an emerging anti-fraud and anti-phishing technology that is designed primarily as a mechanism
to prevent forged emails rather than an anti-spam measure. SPF is dependent on network
administrators publishing their legitimate email servers in their DNS records and keeping these records
current. WatchGuard recommends that customers that use SPF in their DNS infrastructure review
their own SPF records to make sure they are accurate.

SPF Records
The SPF protocol allows you to describe your email servers in an SPF TXT record that is attached to
the domain's DNS record. A typical SPF DNS record is:
example.com IN TXT "v=spf1 mx -all"

Add this data as a TXT record to your domain. The first part is the name part of the record, for example,
“example.com”, and the text in quotes is your TXT record data.
n
n
n

v=spf1 identifies the TXT record as an SPF string.
mx specifies that mail can come from only the mail servers defined in your MX records.
-all specifies that no other servers are able to send from the specified domain.

You can set TXT records for both domains and individual hosts.

Configure SPF
To configure SPF
1. Select Security > Anti-Spam > Anti-Spam > SPF.
The SPF (Sender Policy Framework) page appears.
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2. Select the Enable SPF check box.
3. To strip any “Received-SPF” header from incoming messages, select the Strip incoming SPF
headers check box.
Spammers can attach their own forged SPF headers to create the impression that the email is from a
legitimate source.

4. Toadd anSPF headerto theoutgoing message,select theAdd outgoing SPF headercheck box.
5. Click Apply.
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DomainKeys
DomainKeys is a sender authentication technology that prevents spammers from spoofing mail
headers and launching phishing attacks. The sender of an email message is authenticated when the
XCS device queries the sending domain’s DNS records. The DomainKeys protocol allows server
administrators to add a digital signature to their outgoing messages that is validated with DNS.
The domain owner generates a public and private key pair to use for signing all outgoing messages.
The public key is published in their DNS records and the private key is used to sign outbound
messages. By checking the signature in the headers of the email with the public key, the receiving host
can verify that the email is originating from the legitimate mail server for that domain. This prevents
spammers from sending forged emails. The WatchGuard XCS supports the signing of outgoing
messages with DomainKeys in policies.
DomainKeys actions only apply to incoming mail messages that have failed a DomainKeys check (for
example, an email message where the signature in the message header does not match the
corresponding published DomainKeys record.) If a specific mail server does not have an existing
DomainKeys record, then the message is processed normally. It is possible that administrators can
misconfigure their DNS DomainKeys records, which results in false positives and legitimate hosts
being blocked from sending you mail.
The WatchGuard XCS also supports DKIM (DomainKeys Identified Mail) that is an enhanced version
of the DomainKeys protocol.

DomainKeys and Attachment Stripping
The WatchGuard XCS Attachment Control feature performs attachment stripping after the
DomainKeys signature verification of inbound messages. This may invalidate DomainKeys message
signatures for further recipients because the system modifies the message body. The WatchGuard
XCS verifies any DomainKeys signatures before stripping attachments, but the signature is not valid
for the final recipient because the message has been altered by the system to remove the
attachments.

Configure DomainKeys Authentication
1. Select Security > Anti-Spam > Anti-Spam > DomainKeys Authentication.
The DomainKeys Authentication page appears.
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2. Select the Enable DomainKeys Authentication check box.
3. To remove Authentication-Results: headers attached to incoming messages, select the Strip
incoming headers check box.
This option protects against spammers who add a forged DomainKeys header to the message.

4. To add an Authentication-Results: header to incoming messages after they have been
processed and verified by DomainKeys, select the Add Authentication Header check box.
5. Select from these checks to consider a message as spam:
n

n

n
n

n

n

n

n
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No Signature When Required – Consider the message as spam when there is no
signature, even if the sender says they sign all messages.
No Signature When Not Required – Consider the message as spam when there is no
signature and the sender says they may not sign all messages.
Invalid Signature – Consider the message as spam when the signature is invalid.
Key Revoked – Consider the message as spam when the key used to sign the message is
no longer valid.
Invalid Message Syntax – Consider the message as spam when the signature cannot be
checked because the message has invalid syntax.
No Key – Consider the message as spam when the sending domain did not provide a key
for the selector specified in the message.
Bad Key – Consider the message as spam when the sending domain provides an
unusable key.
DNS Error – Consider the message as spam in the event a DNS error prevents a
DomainKeys lookup for a sender’s key.
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You can also perform these checks for messages from senders who test their DomainKeys
implementation with a test flag inserted into their DomainKeys DNS records. We recommend
that you use the default settings which perform lenient checks against these test messages.
6. Click Apply to save your configuration.

DomainKeys Log Messages
These response codes for DomainKeys processing appear in the Mail Log:
0
1
2
3
4
5

-

Pass
Neutral
Fail
Soft Fail
Temporary Error
Permanent Error

The logs also indicate which DomainKeys check caused an error:
DomainKeys: from=user@example.com, result=permerror(bad key)

DomainKeys Outbound Message Signing
To enable signing of outgoing messages, you must generate a public/private key pair. The private key
is used to digitally sign the message (added as a prefix to the header). The public key is published in
the domain’s DNS records. The receiving server can query the domain owner’s DNS records for the
public key and authenticate the message.
The WatchGuard XCS supports the signing of outgoing messages with DomainKeys within policies.
This allows you to enable signing for only specific domains that have been configured in DNS for use
with DomainKeys.
1. Select Configuration > Mail > DKIM/DomainKeys.
The DKIM/DomainKeys Signing page appears.

2. Select the Allow Message Signing check box.
3. From the Signing Method drop-down list, select the default signing method.
4. Select Security > Policies > Policies to edit an existing policy or to add a new policy.
The DKIM/DomainKeys signing section appears in the Email tab of a policy.
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5. Enable or disable Message Signing for outbound messages in this policy. Select Undefined to
use the global setting.
6. Select the Signing Method for this policy. Select Undefined to use the global setting.
7. To remove duplicate headers, for example, Subject and To: fields, from the signature
calculation, select the Remove Duplicate Headers check box.
Any headers listed with the “h=” tag in the DomainKeys header are filtered for duplication and
the corresponding headers are removed from the message envelope. Enable this option only if
you experience problems with rejected messages because of duplicate headers.
8. To add a list of the headers included in the DomainKey-Signature: header, select the List
Headers check box.
The headers appear in the section starting with "h=". We recommend that you enable this
option. Only the listed headers are used when verifying the signature. If this is option is
disabled, then all headers after the signature are used in verifying the signature. Any headers
added by intermediary servers after the message is signed invalidate the signature. Disable this
option to increase security, but this can create a large number of invalid signatures because of
headers added by intermediary servers.
9. From the Canonicalization drop-down list, specify how white space characters are treated
during message signing.
The default is Relaxed / No Folding White Space which ignores these characters during
signing. This option is more lenient so that messages reformatted in transit, for example,
spaces or lines inserted into or removed from the message by intermediate servers between the
signer and the receiver, are still valid. Select Simple to keep the signed message intact and
include white space characters so that any lines that are reformatted in transit fail validation.
10. From the Selector Name drop-down list, choose the selector for signing.
11. Click Edit List to edit the Selector List.
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A selector is a tag for a DNS record that is used by other servers to verify your DomainKeys
signature. This tag is comprised of upper and lower case letters, digits, dashes, and
underscores. Each selector has an associated public and private key that is generated by the
server by with external methods. The selector is stored in a DNS TXT record with this tag:
<selector>._domainkey.<your_domain>

12. Click Add Selector.

13. In the Display Name text box, type a name for this selector.
14. In the Selector text box, type the tag name for this selector.
15. Leave the DKIM Domain text box blank. This field is for DKIM (DomainKeys Identified Mail)
selectors only.
16. From the Key Size drop-down list, select the key size for the generated key pair.
Larger keys result in secure implementations because it decreases the probability that the keys
can be compromised.
17. To generate a private/public key pair, click Generate Key Pair.
The generated keys appear in the Private Key and Public Key sections.

18. To indicate that this DomainKeys DNS record is used for testing only, select the Testing check
box.
This allows the administrator to perform testing on the validity of their configuration. Receivers are
generally more lenient with verification errors if the sender is in testing mode.

19. In the Notes text box, type any additional comments, for example, listing reasons why a
particular selector is revoked.
20. Click Apply to save the configuration.
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DomainKeys DNS Record
When you create the private/public key pair, the WatchGuard XCS automatically generates a TXT
record that you can use with your DNS server for DomainKeys signing. This record contains a copy of
your public key that receiving sites use to authenticate the digital signature in your outgoing messages.

A domain using DomainKeys (for example, example.com) has a new subdomain in their DNS
configured as “_domainkey” prefixed to the domain, for example, “_domainkey.example.com”.
This is a typical DomainKeys DNS record:
newselector._domainkey.example.com IN TXT "v=DKIM1; k=rsa;
p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCB"

Administrators add this data as a TXT record to their DomainKeys domain (_
domainkey.example.com). The first part is the name part of the record, and the text in quotes is entered
as your TXT record data.The TXT data contains information on the DomainKeys policy.
For example,
n
n
n
n
n

o=- means all emails from this domain are signed
o=~ means some emails from this domain are signed
t means Test
r to enter the responsible email address
n to enter free form notes on the record

Public key records are identified by a specific Selector (which allows a domain to have more than one
public key in DNS) and stored in separate TXT records for that DomainKeys domain name. For
example, the previously defined "_domainkey.example.com" domain contains name entries for each
selector.
For example,
newselector

The corresponding TXT data consists of various options and the public key to use.
For example,
g=; k=rsa; t=y; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCB

The value after “p=” is the public key. There are also other fields available for granularity (g), test (t),
and notes (n).
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DKIM (DomainKeys Identified Mail)
DKIM is an enhanced version of DomainKeys that uses sender authentication technology to prevents
spammers from spoofing mail headers and launching phishing attacks. The sender of an email
message is authenticated when the XCS device queries the sending domain’s DNS records. The
DKIM protocol allows server administrators to add a digital signature to their outgoing messages that is
validated with DNS.
As an enhancement to DomainKeys, DKIM offers additional parameters to the signing mechanism for
enhanced security and spoofing protection, and allows authorized third-party signing of messages for a
domain independent from the message author.
The domain owner generates a public and private key pair to use for signing all outgoing messages.
The public key is published in their DNS records and the private key is used to sign outbound
messages. By checking the signature in the headers of the email with the public key, the receiving host
can verify that the email is originating from the legitimate mail server for that domain. This prevents
spammers from sending forged emails. The WatchGuard XCS supports the signing of outgoing
messages with DKIM in policies.
DKIM actions only apply to incoming mail messages that have failed a DKIM check (for example, an
email message where the signature in the message header does not match the corresponding
published DKIM record.) If a specific mail server does not have an existing DKIM record, then the
message is processed normally. It is possible that administrators can misconfigure their DKIM DNS
records that results in false positives and legitimate hosts being blocked from sending you mail.

Configure DKIM Authentication
1. Select Security > Anti-Spam > Anti-Spam > DKIM Authentication.
The DKIM Authentication page appears.
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2. Select the Enable DKIM Authentication check box.
3. To add an Authentication-Results: header to incoming messages after they have been
processed and verified by DKIM, select the Add Authentication Header check box.
4. Select from these checks to consider a message as spam:
n

n
n

n

n

n

No Signature When Required – Consider the message as spam when there is no
signature, even if the sender says they sign all messages.
Invalid Signature – Consider the message as spam when the signature is invalid.
Key Revoked – Consider the message as spam when the key used to sign the message is
no longer valid.
Invalid Message Syntax – Consider the message as spam when the signature cannot be
checked because the message has invalid syntax.
No Key – Consider the message as spam when the sending domain did not provide a key
for the selector specified in the message.
DNS Error – Consider the message as spam in the event a DNS error prevents a DKIM
lookup for a sender’s key.

You can also perform these checks for messages from senders who test their DKIM
implementation with a test flag inserted into their DKIM DNS records. We recommend that you
use the default settings which perform lenient checks against these test messages.
5. Click Apply to save your configuration.

DKIM Log Messages
These response codes for DKIM processing appear in the Mail Log:
0
1
2
3
4
5

-

Pass
Neutral
Fail
[not applicable to DKIM]
Temporary Error
Permanent Error

The logs also indicate which DKIM check caused an error:
DKIM: from=user@example.com, result=fail(bad signature)

DKIM Outbound Message Signing
To enable signing of outgoing messages, you must generate a public/private key pair. The private key
is used to digitally sign the message (added as a prefix to the header). The public key is published in
the domain’s DNS records. The receiving server can query the domain owner’s DNS records for the
public key and authenticate the message.
The WatchGuard XCS supports the signing of outgoing messages with DKIM in policies. This allows
you to enable signing for only specific domains that have been configured in DNS for use with DKIM.
1. Select Configuration > Mail > DKIM/DomainKeys.
The DKIM/DomainKeys Signing page appears.
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2. Select the Allow Message Signing check box.
3. From the Signing Method drop-down list, select the default signing method.
4. Select Security > Policies > Policies to edit an existing policy or to add a new policy.
The DKIM/DomainKeys signing section appears in the Email tab of a policy.

5. Enable or disable Message Signing for outbound messages in this policy. Select Undefined to
use the global setting.
6. Select the Signing Method for this policy. Select Undefined to use the global setting.
7. To list the headers included in the DKIM-Signature: header, select the List Headers check box.
This option adds the "z=" field which is a visible list of the header content. Only the listed
headers are used when verifying the signature.
8. From the Canonicalization drop-down list, specify how white space characters are treated
during message signing.
The default is Relaxed / No Folding White Space which ignores these characters during
signing. This option is more lenient so that messages reformatted in transit, for example,
spaces or lines inserted into or removed from the message by intermediate servers between the
signer and the receiver, are still valid. Select Simple to keep the signed message intact and
include white space characters so that any lines that are reformatted in transit fail validation.
9. From the Selector Name drop-down list, choose the selector for signing.
10. Click Edit List to edit the Selector List.
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A selector is a tag for a DNS record that is used by other servers to verify your DKIM signature.
This tag is comprised of upper and lower case letters, digits, dashes, and underscores. Each
selector has an associated public and private key that is generated by the server by with
external methods. The selector is stored in a DNS TXT record with this tag:
<selector>._domainkey.<your_domain>

11. Click Add Selector.

12. In the Display Name text box, type a name for this selector.
13. In the Selector text box, type the tag name for this selector.
14. In the DKIM Domain text box, you can enter a domain name for DKIM if you are signing
messages for a domain that is different than your system domain name. Leave this field empty
to use the domain name of your system.
15. From the Key Size drop-down list, select the key size for the generated key pair.
Larger keys result in secure implementations because it decreases the probability that the keys
can be compromised. The default is 1024.
16. To generate a private/public key pair, click Generate Key Pair.
The generated keys appear in the Private Key and Public Key sections.

17. To indicate that this DKIM DNS record is used for testing only, select the Testing check box.
This allows the administrator to perform testing on the validity of their configuration. Receivers are
generally more lenient with verification errors if the sender is in testing mode.

18. In the Notes text box, type any additional comments, for example, listing reasons why a
particular selector is revoked.
19. Click Apply to save the configuration.
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DKIM DNS Record
When you create the private/public key pair, the WatchGuard XCS automatically generates a TXT
record that you can use with your DNS server for DKIM signing. This record contains a copy of your
public key that receiving sites use to authenticate the digital signature in your outgoing messages.

A domain using DKIM (for example, example.com) has a new subdomain in their DNS configured as “_
domainkey” prefixed to the domain, for example, “_domainkey.example.com”.
This is a typical DomainKeys DNS record:
newselector._domainkey.example.com IN TXT "v=DKIM1; k=rsa; n=;
p=MIGfMA0GCSqGSIb3DQEBAQUBiQK"

Administrators add this data as a TXT record to their DKIM domain (_domainkey.example.com). The
first part is the name part of the record, and the text in quotes is entered as your TXT record data.The
TXT data contains information on the DKIM policy.
Public key records are identified by a specific Selector (which allows a domain to have more than one
public key in DNS) and stored in separate TXT records for that DKIM domain name. For example, the
previously defined "_domainkey.example.com" domain contains name entries for each selector.
For example,
newselector

The corresponding TXT data consists of various options and the public key to use.
For example,
v=DKIM1; k=rsa; n=; p=MIGfMA0GCSqGSIb3DQEBAQUBiQK

The value after “p=” is the public key. There are also other fields available such as test (t) and notes (n).

ADSP (Author Domain Signing Practice) DNS Records for DKIM
When you use DKIM signing, you have the option of using ADSP (Author Domain Signing Practice).
ADSP is an extension to DKIM where the domain name of the signing entity is included as part of the
Author Domain Signature to prove that it is authorized to relay mail messages for the sending author
address which is the address in the From: header field.
This is a typical ADSP record for DKIM:
_adsp._domainkey.example.com IN TXT "dkim=all"

You can specify one of these three signing practices:
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all – All mail from the domain is signed with an Author Domain Signature.
unknown – The domain may sign some or all email messages with an Author Domain
Signature.
discardable – All mail from the domain is signed with an Author Domain Signature. The
receiving mail server should discard the message if the signature is invalid or missing.
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Brightmail Anti-Spam
Symantec Brightmail Anti-Spam™ is an add-on subscription that you can run independently from
Intercept, or you can fully integrate Brightmail with the Intercept Anti-Spam engine.
You can enable Brightmail for a 30-day evaluation period to allow you to test multi-layered Anti-Spam
engines.
Brightmail generates a classification for a message that is used with the Intercept Anti-Spam engine. A
message classified as spam by Brightmail is considered Certainly Spam by Intercept and receives a
score equal to the Certainly Spam threshold. Messages classified as suspected spam by Brightmail
are considered Probably Spam in Intercept and receive a score equal to the Probably Spam threshold.
If a message passes Brightmail scanning as a clean message, it receives an Intercept score of 0. You
can also skip Brightmail scanning if Intercept has already classified a message as spam.
To enable and configure Brightmail:
1. Select Security > Anti-Spam > Brightmail.
The Brightmail page appears.

2. To enable Brightmail Anti-Spam scanning, select the Enable check box.
3. From the Brightmail Mode drop-down list, select which mode to run in:
n

n
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Perform Brightmail Actions – Brightmail runs independently of Intercept and perform its
own actions.
Use in Intercept Spam Decision – Enable Brightmail for use with the Intercept AntiSpam engine. The Brightmail scanning result is used in the Intercept Anti-Spam decision
for a message.
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4. From the Brightmail Skip Threshold drop-down list, select when to skip Brightmail
processing depending on how Intercept has classified the message.
n

n

n

n

Never Skip – Perform Brightmail scanning regardless of previous Intercept scanning
results.
Intercept Maybe Spam – Skip Brightmail scanning for messages already classified by
Intercept as Maybe Spam or higher.
Intercept Probably Spam – Skip Brightmail scanning for messages already classified by
Intercept as Probably Spam or higher.
Intercept Certainly Spam – Skip Brightmail scanning for messages already classified by
Intercept as Certainly Spam.

5. In the Bytes of Message to Scan text box, type the number of bytes of a message to scan.
Use a lower number of bytes to increase the scanning speed of Brightmail.

6. In the Largest Message To Scan text box, type the largest size of message to scan with
Brightmail.
Messages larger than this value are ignored because spam mail is typically small in size.
Scanning large messages also decreases performance.
Note Brightmail processing is skipped if the message size exceeds the threshold, even if
the Brightmail Skip Threshold is set to “Never Skip”.
7. In the Maximum Total Headers to Scan text box, type the maximum number of headers to
scan to prevent messages with many thousands of headers from causing delays in processing.
The default maximum total number of message headers to scan is set to 32768 bytes. If the
maximum is exceeded, the message is classified as spam.
8. In the Statistics Update Interval text box, type the interval (in minutes) to send statistics to
Brightmail.
The default interval is set to ten minutes.

9. To enable a tracker header that contains a description of what Brightmail rules apply for a
message, select the Tracker Header check box.
10. To enable the Open Proxy List feature, select the Brightmail Open Proxy List check box.
The Open Proxy List contains the IP addresses of proxy servers with open or insecure ports.
Brightmail blocks all mail coming from any server on this list.
11. From the Action drop-down list, select the action to take when Brightmail classifies a message
as spam and the mode is set to Perform Brightmail Actions.
n
n

n
n

n
n
n
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Just log – Log the occurrence and take no other action.
Modify Subject Header – Insert the specified text in the Action Data field into the
message subject line.
Add header – Add an “X-” mail header as specified in the Action Data field.
Redirect to – The message is delivered to the mail address or server specified in the
Action Data field.
Discard mail – Reject the message and do not send a notification to the sender.
Reject mail – Reject the message and send a notification to the sender.
BCC – Send a blind carbon copy of the message to the mail address specified in the
Action Data field.
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n

Quarantine: System – Place the message into the system quarantine area. This is the
default action. You can also choose a custom quarantine.
Quarantine: DLP – Place the message into the DLP quarantine area.

12. In the Action Data text box, type the additional data for the specified action:
n

n

n

Modify Subject Header – The specified text is inserted into the subject line.
For example, [BMSPAM].
Redirect to – Send the message to a mailbox, for example, spam@example.com. You
can also redirect the message to a spam quarantine server, for example,
spam.example.com.
Add header – An “X-” message header is added with the specified text, for example, “XReject: bmspam”. The header action data must start with “X-” and must contain a colon
followed by a space.

13. To enable Brightmail suspected spam processing, select the Enable Suspected Spam
Processing check box.
Messages detected by Brightmail as suspected spam are classified by Intercept as Probably Spam.

14. In the Suspected Spam Threshold text box, type the threshold level to detect suspected
spam.
You can enter values from 25 to 89. Lower numbers are more aggressive. The default value is 70.

15. Click Apply.

Brightmail Conduit
Brightmail uses pattern files to match known spam. The Brightmail Conduit feature automatically
updates these pattern files to make sure they are always up-to-date.
If you are using an external proxy server to access the Internet, you must configure it in Configuration
> Network > External Proxy Server.
Note The first time Brightmail is enabled, it may take 5-10 minutes for the database to
initialize. Brightmail updates the rule list incrementally and in some cases it may take
up to 24 hours until the rule list is completely up to date.
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User Spam Quarantine
The WatchGuard XCS Intercept Anti-Spam feature performs actions on spam messages based on
their classification. Messages classified as Certainly Spam are usually rejected or discarded, while
messages classified as Probably Spam and Maybe Spam are usually quarantined. The administrative
quarantine is an area on the system where all quarantined messages are stored, and is only accessible
to the administrator.
When spam is filtered and processed, occasionally, a false positive (a legitimate email classified as
spam) result can occur. It would be an impossible task for the administrator to examine every message
in the quarantine area for messages that are false positives.
The User Spam Quarantine feature redirects spam mail into a local quarantine area for each individual
user. With this feature, users can log in to the WatchGuard XCS to see and manage their own
quarantined spam. Users can then identify and release any false positives from the quarantine, and
delete messages that are actually spam.
Spam Quarantine summary notifications are sent to users to notify them of existing mail in their
quarantine. The email notification itself can contain links to take action on messages without the need
for the user to log in to the quarantine.

Notification Domain Support
The User Spam Quarantine feature on the WatchGuard XCS only supports a single end-user
notification domain.
For example, a single end-user may have multiple email addresses (john@example.com,
john.smith@sales.example.com, jsmith@example2.com), but spam quarantine notifications are
supported only for the primary domain email address, in this case john@example.com.
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If you need to support different users from multiple domains, for example, john.smith@example1.com,
sally.brown@example2.com, etc.) we recommend you use the WatchGuard QMS (Quarantine
Management Server).

WatchGuard Quarantine Management Server (QMS)
In addition to the local User Spam Quarantine feature of the WatchGuard XCS, organizations can also
purchase the WatchGuard QMS (Quarantine Management Server), which is a separate device to
which you can redirect spam messages from a WatchGuard XCS.
The WatchGuard QMS is intended for large enterprises, and provides performance improvements to
the integrated quarantine services on the WatchGuard XCS because quarantined spam is stored on a
separate system. This decreases the processing load and amount of disk space used on the
WatchGuard XCS.
The WatchGuard QMS also provides the ability to support multiple domains and clustering, while the
WatchGuard XCS User Spam Quarantine feature only supports a single domain.

Local Spam Quarantine Account
To access quarantined mail, a local account must exist for each user. You can create a local account,
or you can use the LDAP Mirrored Users feature to import user accounts from an LDAP compatible
directory, for example, Active Directory, and mirror them locally.
See Directory Users for more information on importing and mirroring LDAP user accounts.
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Configure the Spam Quarantine
To configure the Spam Quarantine:
1. Select Configuration > WebMail > User Spam Quarantine.
The User Spam Quarantine page appears.

2. Select the Enable Spam Quarantine check box.
3. From the Expiry Period drop-down list, select an expiration period for mail in each quarantine
folder.
Any mail quarantined for longer than the specified value is deleted.

4. From the Folder Size Limit drop-down list, select a size, in megabytes, to limit the amount of
stored quarantined mail in each quarantine folder.
5. To enable a summary email notification that alerts users to mail that has been placed in their
quarantine folder, select the Enable Summary Email check box.
6. In the Limit # of message headers sent text box, type the maximum number of headers that
are sent in the spam digest message.
Type 0 to send all message headers.

7. In the Number of days links accessible text box, type the number of days that the message
links in a spam summary message are accessible by users.
The default is 8.

8. In the Notification Domain text box, type the domain for which notifications are sent.
This is typically the Fully Qualified Domain Name of the email server. The User Spam Quarantine
only supports one domain.

9. From the Notification Days drop-down list, select the days to send the summary notification.
10. From the Notification Times drop-down list, select the time to send the summary notification.
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Note The Spam Summary processing begins at this time, but the actual delivery of the
summary notifications is not performed until the processing (which may take several
minutes) is complete.
11. In the Spam Folder text box, type a folder name for the user’s spam folder.
This must be an RFC821 compliant mail box name. This folder appears in a user’s mailbox when
they receive quarantined spam.

12. In the Mail Subject text box, type the subject of the spam summary notification message.
You can use the WatchGuard XCS system variables in the subject field.

13. To insert a link in the notification summary to allow the user to add the sender to their Trusted
Senders List, select the Allow Trusting Senders check box.
14. To insert a link in the notification summary to allow the user to read the original message, select
the Allow reading messages check box.
15. To insert a link in the notification summary to allow the user to release the message to their
inbox, select the Allow releasing of email check box.
16. In the Mail Content Preamble text box, you can edit custom text and HTML versions of the
spam summary message that is sent to end users.
This message contains the links to the user’s quarantined spam. You can use the WatchGuard
XCS system variables in the preamble.

Spam Digest Notification
You can send a Spam Digest email notification to alert users to mail that has been placed in their
quarantine folder. Additional links in the message allow the end user to read the message, release the
message from the quarantine to their inbox, or add the sender to their Trusted Senders list.
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Configure Spam Message Redirect Options
To quarantine spam mail to the User Spam Quarantine, you must set the Intercept action to Redirect
to and set the action data to the address of the spam quarantine server. The Redirect To action
rewrites the envelope recipient address with the new domain for the quarantine.
To quarantine mail to the spam quarantine:
1. Select Security > Anti-Spam > Anti-Spam.

2. Set the Action for the spam level that you want to use for the quarantine (for example, Probably
Spam) to Redirect to.
3. Set the Action data to the FQDN of the spam quarantine (either this WatchGuard XCS, or
another WatchGuard XCS that hosts the User Spam Quarantine.)
For example, xcs.example.com .
4. Click Apply.
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Access the Spam Quarantine
You can view the quarantine spam folder from the WatchGuard XCS WebMail interface. End users can
log in to their local or mirrored account on the WatchGuard XCS and view their own quarantine folder.
You must enable WebMail access on a network interface in Configuration > Network > Interfaces to
allow users to log in to the WatchGuard XCS locally or use the linked actions in the spam quarantine
digest notification.
If you do not want end users to log in locally to the WatchGuard XCS to retrieve these messages,
users can use the linked actions contained in the spam digest notification to manage their quarantined
messages.

Enable WebMail and Spam Quarantine Access
To enable WebMail and Quarantine access:
1. Select Configuration > Network > Interfaces.
2. Select the WebMail check box for the specific network interface that you want to allow users to
log in.

3. Click Apply.
You must restart the system.

4. Select Configuration > WebMail > WebMail.
5. To provide users with the spam quarantine controls in the WebMail interface, select the User
Spam Quarantine check box.

6. Click Apply.
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Access the Spam Quarantine with WebMail
To access the quarantine folder with WebMail:
1. Log in to your WatchGuard XCS WebMail account.
2. Select Spam Quarantine on the left menu.
Your user spam quarantine page appears.

When you are in the Spam Quarantine page, you can perform these actions:
n
n
n
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To release the message back into your inbox, click the Release link.
To automatically add the sender to your Trusted Senders List, click the Trusted Sender link.
Toautomatically addthe senderto yourBlocked Senders List, click the Blocked Sender link.
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About Trusted and Blocked Senders Lists
The WatchGuard XCS allows end users to configure their own Trusted and Blocked Senders Lists to
control how mail is processed depending on the sender of a message.

Trusted Senders List
The Trusted Senders List allows users to create their own lists of senders that are not blocked by the
WatchGuard XCS spam filters. Users can utilize the WebMail interface to create their own Trusted
Senders List based on the sender’s email address. You can also add Trusted Senders directly from the
Spam Quarantine notification message, or through the WatchGuard XCS Outlook Add-in when
classifying messages as Not Spam. The Trusted Senders list is applied to the Envelope From or
Header From of a message.
The Trusted Senders List overrides these Anti-Spam actions:
n
n
n

Modify Subject Header
Add Header
Redirect

These rules also apply for the Trusted Senders List:
n

n

n

n

n

If the message is rejected for reasons other than spam, for example, viruses or attachment
controls, the Trusted Senders List has no effect.
A Reject or Discard action rejects or drops the message regardless of the settings in the
Trusted Senders List.
If the action is set to Just Log or BCC, the trusted message passes through, but is still logged
or BCC’d.
Pattern Filter spam actions set to Medium or High priority cannot be trusted. This allows you to
enforce a strong security policy through higher level priorities.
The Trusted Senders List cannot trust items rejected during the SMTP connection, for example,
rejections because of Reputation Enabled Defense and DNSBL checks.

Blocked Senders List
The Blocked Senders List allows end users to specify a list of addresses from which they do not want
to receive mail. These senders are blocked from sending mail to that specific user through the
WatchGuard XCS. If a sender is on the Blocked Senders List, the WatchGuard XCS rejects or
discards the message. The Blocked Senders list is applied to the Envelope From or Header From of a
message.
Note The Trusted Senders List is processed before the Blocked Senders List. If a Blocked
Sender also appears in the Trusted Senders List, the email is delivered.
If there are multiple recipients for a message, and only specific recipients have blocked the sender:
n
n
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The message is delivered for those recipients that did not block the sender
The message is rejected for those who have blocked the sender.
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Local users can log in and create their own list of Blocked Senders. Users do not need a local account
on the system, as they can be authenticated with LDAP to an authentication server and the user's
Trusted/Blocked Senders List is saved locally on the WatchGuard XCS. You can also add Blocked
Senders through the WatchGuard XCS Outlook Add-in when classifying a message as spam.

Configure the Trusted and Blocked Senders List
You must enable the Trusted and Blocked Senders List feature globally to allow end users to configure
their own lists.
To enable the Trusted and Blocked Senders List:
1. Select Configuration > WebMail > Trusted/Blocked Senders.
The Trusted and Blocked Senders List page appears.

2. Select the Permit Trusted Senders lists check box.
3. In the Maximum # of trusted entries per user text box, type the maximum number of users
that can be entered on the list.
The default is 100. Valid values are from 1 to 1000000.
4. Select the Permit Blocked Senders lists check box.
5. In the Maximum # of blocked entries per user text box, type the maximum number of users
that can be entered on the list.
The default is 100. Valid values are from 1 to 1000000.
6. In the Trusted/Blocked Senders domain text box, type the domain for which you process
messages.
This is the domain portion of a user's email address. For example, if you deliver mail to your mail
server using "user@example.com", enter example.com .
7. From the Blocked Senders Action drop-down list, select the action to perform when a user on
the Blocked Senders List attempts to send mail through the WatchGuard XCS.
n
n

Reject – Rejects the message and sends a notification to the sender.
Discard – Discards the message and does not send a notification to the sender.

8. Click Apply.

Configure WebMail Access for Trusted/Blocked Senders
You must enable WebMail to allow users to view and edit their Trusted/Blocked Senders List.
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Users do not need a local account on the WatchGuard XCS. Users can authenticate with a RADIUS or
LDAP authentication server, for example, Active Directory. The user’s Trusted/Blocked Senders List
is saved locally on the WatchGuard XCS.
To enable WebMail access:
1. Select Configuration > Network > Interfaces.
2. Select the WebMail check box.

3. Click Apply.
You must restart the system.

4. Select Configuration > WebMail > WebMail.
5. Select the Trusted/Blocked Senders check box.

6. Click Apply.
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Import Trusted/Blocked Senders List
You can update the Trusted and Blocked Senders Lists manually or automatically from a global list
located on an external web server or a Quarantine Management Server (QMS). You can schedule the
list update to occur at regular intervals or you can update the list immediately.
We recommend that organizations use either the personal Trusted/Blocked Senders List or the
imported list, and not both at the same time.
To import a Trusted/Blocked Senders List:
1. Select Configuration > WebMail > Trusted/Blocked Senders.
The Trusted/Blocked Senders List page appears.

2. In the Imported Trusted/Blocked List section, select the Enable imported list check box.
3. In the List source URL text box, type the URL from which to retrieve the Trusted or Blocked
Senders List.
For example,
http://listserver.example.com/wblist.csv

For the WatchGuard Quarantine Management Server (QMS), type:
http://wqs.example.com/getwblist.spl

4. To enable scheduled updates, select the Automatic update check box.
5. From the Update Interval drop-down list, select the time interval for how often to retrieve the list.
6. To immediately perform a manual update, click Update imported list now.

Import List File
You can upload a list of Trusted or Blocked Senders in a text file. The file must be in CSV format and
contain comma or tab separated entries.
Use this format:
[recipient],[sender],[block or trust]

For example:
user@example.com,spam@example1.com,blockuser@example.com,hacker@example1.com,blocku
ser@example.com,friend@example1.com,trustuser@example.com,friend2@example1.com,trus
t

You must use a text editor to create the file bwlist.csv.
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To update a list file:
1. To download the list from the WatchGuard XCS, click Download File.
2. Open the file and update the list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
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Add Trusted and Blocked Senders
To create a Trusted Senders List:
1. Log in to your WebMail account.
2. Select Trusted Senders from the left menu.

3. In the Add new email address to always accept text box, type an email address.
4. Click Add.
To create a Blocked Senders List:
1. Log in to your WebMail account.
2. Select Blocked Senders from the left menu.

3. In the Add new email address to always block text box, type an email address.
4. Click Add.
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QMS Wizard
The QMS Wizard guides you through the required configuration to integrate the WatchGuard XCS with
the WatchGuard QMS (Quarantine Management Server). This allows you to redirect spam messages
from the WatchGuard XCS to the quarantine area on the WatchGuard QMS where users can manage
their quarantined spam.
The WatchGuard QMS is intended for large enterprises, and provides performance improvements to
the integrated quarantine services on the WatchGuard XCS because quarantined spam is stored on a
separate system. This decreases the processing load and amount of disk space used on the
WatchGuard XCS. The WatchGuard QMS also provides the ability to support multiple domains and
clustering, while the WatchGuard XCS User Spam Quarantine feature only supports a single domain.

QMS Configuration
You must configure the WatchGuard QMS before starting the QMS Wizard:
Please see the WatchGuard QMS User Guide for details on how to perform these tasks:
n

n

n

n

Select Configuration > Quarantine > User Spam Quarantine to enable and configure spam
quarantine services on the WatchGuard QMS.
Select Configuration > Mail > Delivery and set the Relay To field to the IP address of the
WatchGuard XCS device.
This ensures that any notifications and released spam messages will be sent to the
WatchGuard XCS for delivery.
Create local quarantine user accounts, or import user accounts from an LDAP directory.
By default, the WatchGuard QMS automatically creates a new user account when new spam
messages are received for a user.
Select Configuration > Quarantine >Trusted/Blocked Senders, enable Permit
Downloads, and set the Allowed IPs text box to the IP address of the WatchGuard XCS.

Start the QMS Wizard
You can access the QMS Wizard on the Frequent Tasks page.
1. From the Frequent Tasks page, select QMS Integration Wizard.
An introduction page appears.
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2. Click Continue.
3. On the Integration Settings page, configure these settings:
n

n

QMS Server IP Address – Enter the IP address of your WatchGuard QMS. The system
will test your connection to the QMS and warn you if you it cannot connect to the
IP address you specified.
Actions – You must configure the WatchGuard XCS to redirect specific classifications of
spam messages to the QMS.
o Redirect "Probably Spam" messages to QMS – Redirects any messages that
are classified by Intercept Anti-Spam as "Probably Spam" to the QMS. This is the
default setting.
o Redirect "Maybe Spam" messages to QMS – Redirects any messages that are
classified by Intercept Anti-Spam as "Maybe Spam" to the QMS.
o Import Trusted/Blocked Senders List from QMS – You can update the Trusted
and Blocked Senders Lists automatically from a global list located on the QMS.
You can schedule the list update to occur at regular intervals or you can update the
list immediately.

4. Click Continue.
5. The Done page describes the configuration that occurs after you complete the wizard.
These configuration items include:
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n

n

n

n

n

Mail Route – A mail route is created for the specific QMS address called ".quarantine_
reroute". This special reroute option is used as the Intercept Anti-Spam action to redirect
spam messages to the QMS.
Specific Access Patterns – A Specific Access Pattern is created to trust the address of
the QMS to ensure that any mail from the QMS, such as spam digest notifications and
released quarantine messages, are not scanned by the Intercept Anti-Spam or Content
Control features.
Intercept Anti-Spam – Intercept is configured to redirect spam messages for the specified
spam classifications to the QMS.
Pattern Filter – A Pattern Filter is created to prevent training on messages containing the
subject 'Quarantined Email Summary". This prevents spam digest notifications messages
from the QMS from being trained by Intercept Anti-Spam.
Trusted/Blocked Senders List – If enabled, the Trusted/Blocked Senders List will be
imported from the QMS using the specified source URL of the QMS.

6. Click Done to complete the initialization.
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About Policies
With policies, specific messaging security features can be customized and applied to different email
domains, user groups, IP addresses (Web traffic only), and specific users.
You can use these WatchGuard XCS features with policies:
n
n

n
n
n

Intercept features (Anti-Virus, Spyware, Outbreak Control, Anti-Spam actions and thresholds)
Content Controls (OCF, Attachment Scanning, Content Scanning, Document Fingerprinting,
Content Rules, Pattern Filters)
Anti-Spam options (Intercept scanners, Component weights)
Email features (Annotations, Encryption, Archiving, DomainKeys signing)
Web Proxy features (HTTP/S access, Trusted/Blocked sites, Download/Upload limits, URL
Blocking, URL Categorization, Web Reputation)

For example, you can enable Intercept Anti-Spam settings for specific domains, but disable scanning
for other domains. Each Anti-Spam action can be customized so that one domain rejects spam
messages, while another domain modifies the subject header of a spam message.
Content control actions for inbound and outbound messages can also be specifically defined for the
requirements of each domain, group, IP address, or user. For example, you can enable inbound and
outbound Content Scanning and Attachment Control checks for some domains, and disable outbound
message scanning for other domains.
Specific features can be enabled or disabled independently for email messages and web requests, and
separate actions can be applied for inbound and outbound traffic.
In addition, you can add an effective time period to apply to any policy, based on the current time and
day of the week.
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Sender and Recipient Policy Determination
When a message arrives, the XCS system determines the policy settings for each message recipient
with these rules:
n

n

If the message is outbound (trusted), and is addressed to a non-local recipient, then the
sender’s policy settings is used for the recipient.
If the message is inbound (untrusted), or is trusted but addressed to a local recipient, then the
recipient’s policy settings is used for the recipient.

The recipient’s policy takes precedence if both the sender and recipient addresses match a policy.
Note Policy settings are processed after any mail mappings. If the final recipient is a local
user, or a user in a domain that the WatchGuard XCS routes mail for, then it is
considered a local recipient.

Policy Hierarchy
There are several types of policies that can apply to a user: User Policy, IP Address Policy, Group
Policy, Domain Policy, and Default Policy. Recipients can belong to multiple policies. For example,
the recipient user@example.com could have a user-based policy for user@example.com and a policy
based on the domain example.com.
The final policy for the recipient is the merged result of any existing policies for that user. Any settings
conflicts are resolved in this order:
n
n
n
n
n
n

User policy (user@example.com)
IP address policy (10.0.1.100)
Group policy (Sales)
Domain policy (example.com)
Default policy
Global settings

For example,
If both a user and domain policy apply to a user
n
n

The Anti-Virus feature is enabled in the domain policy
Anti-Virus is disabled in the user policy

The final result is that Anti-Virus is disabled for the user based on the user policy.

Time Policy
Time policies are used for web-traffic only.
If time policies are configured, a policy with a specific effective time frame takes precedence over a
policy with an effective time period of “Always”.
For example,
If a domain has these two domain policies applied to it:
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n
n

Policy 1 has an effective time frame of Always
Policy 2 has an effective time frame of Monday to Friday 9am to 5pm

The final result is that Policy 2 takes effect if the current time is within the effective time period.

Multiple Group Policies
If a user belongs to multiple groups, the imported group order determines the precedence. In the Group
Policy configuration page, you can arrange the list of groups into priority order.
For example:
n
n
n
n

A user belongs to Group1 and Group2
Group 1 Policy is set to a higher priority then Group 2 Policy
Group 1 Policy has Token Analysis enabled
Group 2 Policy has Token Analysis disabled

The final result is that the user’s email is scanned by Token Analysis.
Note Group policies are not merged as they are with User and Domain policies. If a user
belongs to more than one group, only the first group policy in the specified group
ordering is applied.

Pattern Filter Priority
if you use pattern filters with policies, there can sometimes be conflicting priorities for global pattern
filters and policy pattern filters. When it processes pattern filter rules, the XCS system makes these
decisions:
1. The priorities of all actions are considered. If there is only one High priority action, that filter is used.
2. For pattern filters that have the same priority, policies are resolved in this order:
n
n
n
n
n

User Policy
IP address policy
Group policy
Domain policy
Default policy/Global settings

3. For the same priority and same policy level, actions are resolved in this order:
n
n
n
n
n
n
n
n
n
n
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Reject
Discard
Quarantine
Certainly Spam
Redirect
Trust
Relay
Accept
Just Log
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When you create pattern filters in policies, specific message parts, for example, Envelope-to and
Envelope-from, Client IP, and Host, are not available. Pattern filters on these message parts cause
actions to trigger before the recipients are known, and they are not available for use in policies.
Note BCC and Do Not Train actions do not prevent lower priority actions. For example, a
BCC action at “High” priority in the global pattern filter list and an Accept action at
“Medium” priority in a policy results in an Accept action and a BCC action.
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Create Policies
These sections describe how to enable and define policies. These are the general steps to create
policies:
1. Define global settings for Default Policy.
2. Add and define new domain, group, IP address, and user policies

Define Global Settings for Default Policy
Before you create specific domain, group, IP address, and user policies, we recommend that you
define default global settings for Intercept, Anti-Spam, Content Controls, and other features before you
define more granular policies based on these global settings.
These settings are inherited by the Default policy. The Default policy is the policy used by all users that
do not belong to any other specific policy.
Note If you disable a feature globally, it cannot be enabled by a policy. The feature is
completely disabled, regardless of how a policy is configured.

Add a Policy
To add or edit a policy:
1. Select Security > Policies > Policies.
The Policies page appears.

2. Click Create New Policy, or click Configure to edit an existing policy. You can also click
Copy to copy an existing policy before you customize it.
The features for each policy are displayed in the Policy Summary section.
The display indicates the enabled/disabled status and configured actions for each policy
feature.
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3. In the Name text box, type a descriptive name for this policy.
For the Default policy, the name can be changed, but the policy cannot be disabled.

4. In the Description text box, type a description for the policy.
5. To edit the settings for a feature for this policy, click the Edit link for the appropriate category.
You can select Anti-Spam and Anti-Virus, Content Control, Email, or HTTP.
6. Click Apply.

Anti-Spam and Anti-Virus
Configure your settings for this policy for inbound and outbound Anti-Virus, Spyware, Outbreak
Control, Malformed Mail, and Anti-Spam.
Select Enabled or Disabled for each option as required for this policy, or select Undefined to use the
inherited settings from another policy, the Default policy, or the global settings.
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n

n

Anti-Virus – Enable or disable inbound and outbound Anti-Virus for this policy for email and
HTTP. You must enable Anti-Virus scanning globally to be used in policies. Independent
inbound and outbound actions and notifications can be set for the email and HTTP scanners for
this policy.
Treat as Virus – Enable or disable these Anti-Virus options for this policy:
o

Attachments containing unknown viral code — The Anti-Virus scanner can detect code
that resembles the patterns of a virus.

Corrupt attachments — The Anti-Virus scanner may not be able to scan corrupted
attachments which can contain viruses.
o Password-protected attachments — Attachments protected by a password cannot be
opened by the Anti-Virus scanner and could contain viruses. Disable this option if you use
password-protected files and archives in your organization.
o Attachments causing scan errors — Attachments that cause errors while being scanned
by the Anti-Virus scanner can contain viruses.
Spyware – Enable or disable inbound and outbound Spyware detection for this policy for email
and HTTP. You must enable Spyware scanning globally to be used in policies. Independent
inbound and outbound actions and notifications can be set for the email and HTTP scanners for
this policy.
Outbreak Control– Set the inbound and outbound Outbreak Control settings for this policy.
You must enable Outbreak Control globally to use this feature in policies. The Detection Hold
Period is set in hours. The default hold period is 8 hours. In most cases, the Anti-Virus pattern
files are updated within 2 to 4 hours of a new virus being discovered. We recommend that you
set the hold period for a long enough time to enable the files to be rescanned with updated AntiVirus pattern files as they become available.
Malformed Mail– Set the Malformed Mail settings for this policy. You must enable Malformed
Mail scanning globally to use this feature in policies.
o

n

n

n
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n

n

n

n

n

Anti-Spam – Set the Anti-Spam settings for each spam category (Certainly, Probably, and
Maybe Spam) for this policy. The Threshold spam score for each category can be set between
1-100. (The default global values are: Certainly Spam: 99, Probably Spam: 90, and Maybe
Spam: 60). Independent notification actions can be set for the email and HTTP scanners for this
policy. You can also configure scanner settings and component weights for each Intercept
feature.
Scanners – Enable or disable each Intercept scanner for this policy. You must enable the
Intercept scanner globally to be used in policies. For Spam Words, select Define in the Spam
Words Dictionaries section to select your dictionaries. For Weighted Dictionaries, you can
enter a custom weight for this policy between 1 and 10000.
Brightmail – Configure the Brightmail settings for this policy. You must license and enable
Brightmail globally in Security > Anti-Spam > Brightmail to use this feature in policies.
Intercept Global Decision Strategy – Set the Intercept Decision Strategy to use for this
policy.
Intercept Global Component Weights – Set the component weights for each Intercept
component for this policy. Each weight must be a number between 0 and 100.
Outbound Anti-Spam – Set the Outbound Anti-Spam settings for this policy. You can use the
Spam Rules, Spam Words, and URL Block List Anti-Spam features to scan outbound mail for
spam messages. Select an email action to perform when outbound spam is detected. You can
also use the Mail Surge Detection feature to identify internal mail users who are sending an
unusually large amount of mail messages which can indicate spam activity. Set the action to
take when a mail surge is detected.

Content Control Policy Settings
Configure your Content Control settings for this policy for inbound and outbound Attachment Control,
Content Scanning, the Objectionable Content Filter (OCF), and Pattern Filters.
Select Enabled or Disabled for each option as required for this policy, or select Undefined to use the
inherited settings from another policy, the Default policy, or the global settings.
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For both inbound and outbound Attachment Control, you can configure these settings:
n

n

Attachment Control – Enable or disable Attachment Control for this policy. You must enable
Attachment Control globally to be used in policies.
Edit Types– Enable or disable the editing of the attachment types for this policy. Click File
Extensions or Content Types to edit the list of attachment types for this policy. If disabled, the
Attachment Control types list of the default policy or other overriding policy is used.

n

Action – Click Edit to configure the action to take when a blocked attachment is detected in
email traffic. You can enable notifications for the administrator and the user, but you can
customize the notification only in the Default policy.

n

Attachment Size Limits – Enable or disable Attachment Size Limits for inbound and outbound
email messages. Enter the attachment size limit (in bytes). Attachments greater than this
threshold trigger the defined Action. The global default is 10240000 bytes. Set to “0” to indicate
no limit.
Note The Maximum Message Size configured in Configuration > Mail > Access is also
set to 10240000 bytes, and as a result, this threshold is exceeded if the attachment
size is close to the attachment size limit. We recommend that the Maximum Message
Size value be at least 1.5 times the value of the Attachment Size Limit to make sure
that large attachments do not exceed the Maximum Message Size.

n

Content Scanning – Set the inbound and outbound Content Scanning settings for email and
HTTP for this policy. You must enable Content Scanning globally to use this feature in policies.
Select the Compliance dictionaries for use with this policy. For weighted dictionaries, a
weighted threshold can be set from 1-10000. You can define independent actions and
notifications for the email and HTTP scanners for this policy.
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n

n

n

Objectionable Content Scanning – Set the inbound and outbound OCF Scanning settings for
email and HTTP for this policy. You must enable OCF globally to use this feature in policies.
Select the OCF dictionaries for use with this policy. For weighted dictionaries, a weighted
threshold can be set from
1-10000. You can define independent actions and notifications for the email and HTTP scanners
for this policy. You can customize notification settings only in the Default policy.
Document Fingerprinting – Enable or disable Document Fingerprinting for this policy. You
must enable Document Fingerprinting globally to use this feature in policies. Enter a Document
Fingerprinting threshold between 0 and 100. Scores closer to “0” indicate the Allowed category.
Scores closer to 100 indicate the Forbidden category. A score greater than the threshold
triggers the specified email action. Document Fingerprinting is applicable only to email
messages.
Content Rules – Enable or disable Content Rules for this policy. You must enable Content
Rules globally to use this feature in policies. Set the inbound and outbound Content Rules for
this policy.
Pattern Filters – Click Pattern Filters to define email pattern filters for use with this policy. If
you disable Pattern Filters in a policy, this action does not disable any globally defined Pattern
Filters.

Email Policy Options
Configure your email settings for this policy for the Annotations, Encryption, Archiving, and
DomainKeys features.
Select Enabled or Disabled for each option as required for this policy, or select Undefined to use the
inherited settings from another policy, the Default policy, or the global settings.
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n

n

n

Annotations – Enable or disable annotations for this policy. Annotations can be used for
appending disclaimers, legal and policy notices, and custom mail footers to all messages
leaving your organization.
Edit Annotations – Enable or disable a customized annotation for this policy. To use a custom
annotation with the policy, click Edit Annotations. If this option is disabled, the Default policy
annotation is used. This annotation is only applied to outgoing mail messages.
SecureMail Encryption – Enable or disable SecureMail encryption for this policy. You must
enable SecureMail Encryption globally to use this feature in policies.
Note Encryption features only appear in policies if licensed.

n

n

n

Branding Profile – Type the name of a branding profile to use with SecureMail encryption for
this policy. The branding profile allows you to display custom logos and branding text for your
organization on encrypted message envelopes. Leave this field blank to use the default primary
branding profile defined on the SecureMail configuration page.
Archiving Headers – Set any archive headers (for High, Medium, and Low Priority) for this
policy. A correct X header must be used, for example, X-Archive: high. You must enable
Archiving globally to use this feature with policies.
DKIM/DomainKeys – Set the DKIM/DomainKeys configuration for this policy. You must
enableDKIM/ DomainKeys globally to use this feature with policies. To edit the list of selector
names that are used with the policy, click Edit List.
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HTTP Policy Options
You must enable the Web Proxy before you can use the feature in policies.
Note When you use the Web Proxy, group policy web users must have a mail attribute
matching the format sAMAccountName@DomainName for group policy to work
properly.
Select Enabled or Disabled for each option as required for this policy, or select Undefined to use the
inherited settings from another policy, the Default policy, or the global settings.

n

n

HTTP Access – Enables the Web Proxy to control access to and manage content from external
web sites.
HTTPS Access – Enables the Web Proxy to control access to and manage content from
external web sites using HTTPS. To inspect the content of HTTPS traffic, you must enable the
HTTPS Deep Inspection feature.
Note If the HTTP and HTTPS Access fields are "Undefined", they inherit the state of the
global setting for the HTTP Proxy (enabled or disabled).

n

Trusted Sites – The Trusted Sites list allows the administrator to define a list of specific web
sites that bypass all scan features. These feature include Anti-Virus, HTTP content control
features (Attachment Control, Objectionable Content, Content Scanning), and URL filtering
features (URL Blocking and URL Categorization). Trusted Sites are configured with the
Dictionaries feature. Click Add or Edit to manage your Trusted Sites list.
Use a Domain or IP type list that contains a list of domains or IP addresses. Use Domain if
you mix IP addresses and domain names in the same list.
For example,
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example1.com example2.com 192.168.1.128
n

Blocked Sites – Select a predefined list of Blocked Sites, or set to None to allow all sites. The
Web Proxy blocks these sites for all users. Blocked Sites are configured with the Dictionaries
feature. Click Add or Edit to manage your Blocked Sites lists.
Use a Domain or IP type list that contains a list of domains or IP addresses. Use Domain if
you mix IP addresses and domain names in the same list.
For example,
example1.com example2.com 192.168.1.128

Note If a site appears in both the Trusted and Blocked Sites lists, the Trusted Sites list
takes precedence.
n

n

n

n

URL Blocking – Enables URL blocking to block access to web sites that appear on a URL
Block List.
Upload and Download Limit – Enter the size limit (in megabytes) for HTTP downloads and
uploads. The default is 7 MB. Keep the field clear or set it to “0” for no limit. Files larger than this
size are bypassed or blocked depending on the configured action.
Download and Upload Limit Action – Set the Download Limit Action and Upload Limit
Action to apply when the message exceeds the size threshold:
o Undefined – Any limits and actions on downloads and uploads use the inherited
settings from another overriding policy or the default policy.
o Block – The file transfer is blocked and an error message is sent to the web client to
indicate the reason the download or upload is blocked.
o Bypass – The file transfer is not blocked and bypasses any HTTP content scans. This
allows larger files to be uploaded or downloaded, but prevents the use of too many
scanning resources because of their size. This is the default value.
URL Categorization – Enables URL Categorization for use with this HTTP policy. URL
Categorization prevents HTTP access to web sites with a predefined list of blocked web sites
organized in several topic categories.
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o

o

You can enable or disable each web site category in this policy. You can also
configure the HTTP action for connections blocked by URL Categorization.
From the Bypass URL Categorization drop-down list, select a list that
contains the web site domains that are not categorized by URL
Categorization. Click Add or Edit to manage your domain lists.

Note Any web sites defined in the Trusted or Blocked Sites list override URL
Categorization blocking.
n

382

Web Reputation Enabled Defense – Enable or disable Web Reputation for this policy or
select Undefined to use the inherited value from another policy, the Default policy, or the global
settings.
o From the Reputation Threshold drop-down list, select Define to enter a value, or
select Undefined to use the inherited value from another policy, the Default policy, or
the global settings.
o In the Action field, click Edit to define an action to perform if a web site reputation
score exceeds the configured Reputation Threshold.
o From the Bypass Anti-Virus Scanning, drop-down list, enable or disable the option to
bypass Anti-Virus scanning for web connections if the reputation of the requested web
site is below the specified threshold.
o From the Bypass Anti-Virus Threshold drop-down list, select Define and type a
threshold below which web sites bypass Anti-Virus scanning, or select Undefined to
use the inherited value from another policy, the Default policy, or the global settings.
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Define Domain, Group, IP Address, and User policies
When global settings and policy settings are defined, administrators can create and define policies for
domains, groups, IP addresses, and users.
These policies are described in detail in the subsequent sections.

Default Time Policy
Time policies are used for web traffic only.
Time-based policies enable policies to be applied based on the current time and day of the week. Timebased policies are configurable for user policies, IP address policies, group policies, domain policies,
and the Default policy.
The Default Time Policy takes effect for a message if no other policy applies. The Default Policy is set
for an effective time period of Always and cannot be changed. Any Default Time Policies you add
overrides the Default Policy.
Note Time policies are not used for email messages.
1. Select Security > Policies > Default Time Policy.
The Default Time Policy page appears.

2. Click Add Policy.
3. From the Policy drop-down list, select an existing policy to add.
4. From the Effective drop-down list, select Specific Times to configure the time periods for
which this policy takes effect, or select Always for no time restriction.
Click the "+" symbol to add additional time periods.

5. Click Add Policy to add additional default time policies, if required.
6. Click Apply.
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Domain Policies
You can define domain policies to enable different policies for different domains in an organization.
For example, you can create a policy to assign annotations to different email domains that require
separate annotations (for example, a legal disclaimer) appended to their messages.
To create a domain policy:
1. Select Security > Policies > Policies.
The Policies page appears.

2. Click Create New Policy.

3.
4.
5.
6.
7.
8.
9.
10.
11.
12.

In the Name text box, type a name for this policy, for example, example.com .
Select the Enable This Policy check box.
In the Description text box, type a detailed description for this policy.
Customize the policy as required by selecting the feature tabs, for example, Anti-Virus and
Anti-Spam, Content Controls, Email, and HTTP.
For example, to customize an annotation for this domain policy, select the Email section.
From the Annotations drop-down list, select Enabled.
Click the Edit Annotations button to customize the annotation that is appended to messages
for this domain.
Click Apply.
Click Apply to save the domain policy.
Select Security > Policies > Domain Policy.
The Domain Policy page appears.
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13. In the Domain text box, type the domain to which this policy applies.
For example, example.com
Use a leading “.” to indicate subdomains of the specified domain.
For example, .example.com
matches these domains: a.example.com, b.example.com, c.d.example.com , but not
example.com .
14. From the Policy drop-down list, select the policy to apply to the specified domain.
15. From the Effective drop-down list, select Specific Times to configure the time periods for
which this policy takes effect, or select Always for no time restriction.
Click the "+" symbol to add additional time periods.

16. Click Add Policy to add additional policies for this domain.
You can add up to five policies.

17. Click Apply.

Upload and Download Domain Policy Lists
You can upload a list of domain policy assignments in a text file. The file must contain comma or tab
separated entries with one entry on each line.
Use this format:
[Domain],[policy],[startday],[starthr],[startmin],[stopday],[stophr],[stopmin]

Days are specified by a number from 0 to 6, starting with Sunday (0). Hours are specified in 24-hour
format with a number from 0 to 23. Minutes are specified in these increments: 0,15,30,45.
For example:
example.com,Example1Policy,1,9,0,5,17,0example2.com,Example2Policyexample3.com,Exam
ple3Policy,0,8,0,4,12,0

You must use a text editor to create the file domain_policy.csv.
To update a domain policy text file:
1. To download the domain policy list from the WatchGuard XCS, click Download File.
2. Open the file and update the domain policy list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
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Group Policies
You can customize policies for users who belong to specific groups. For example, a Sales group can
have different content scanning policies than users in the Development group. Group policies are also
useful for providing different annotations or Anti-Spam scanning features for each user group.

Enable Group Policy
Before you import users and groups, enable Group policy to make sure the imported groups are
displayed in the group policy page. If the Group policy option is enabled after you import group
membership information, you must wait until the next scheduled import, or perform a manual import,
before the list of groups appear on this page.
1. Select Security > Policies > Group Policy.
The Group Policy page appears.

2. Click Enable Group Policy.
The Group Policy configuration page appears.

Import LDAP Group Information
Before you configure Group policy, you must first import group membership information from an LDAP
directory server.
1. Select Configuration > LDAP > Directory Users.
The Directory Users page appears.
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2. From the Directory Server drop-down list, select a configured server.
3. In the Search Base text box, type a path to start the search from.
For example: dc=example,dc=com .
4. From the Scope drop-down list, select the scope for the search.
n
n
n

Base – Searches the base object only.
One Level – Searches objects beneath the base object, but excludes the base object.
Subtree – Searches the entire subtree, of which the base distinguished name is the
topmost object, and includes the base object.

5. In the Query Filter text box, type the appropriate filter for your LDAP server.
For Active Directory use:
(|(|(objectCategory=group)(objectCategory=person))
(objectCategory=publicFolder))

This query filter includes mail-enabled Exchange public folders to prevent them from rejection if
Reject on Unknown Recipient is enabled.
For iPlanet and OpenLDAP, use the(objectClass=person) query filter.
6. In the Timeout text box, enter the maximum interval, in seconds, to wait for the search to
complete.
You can enter values from 1 to 100 seconds.

7. In the Email attribute text box, type the attribute that identifies the email address of the user.
For Active Directory, iPlanet, and OpenLDAP, type mail .
Note When you use the Web Proxy, group policy web users must have a mail attribute
matching the format sAMAccountName@DomainName for group policy to work
properly.
8. In the Email alias attribute text box, enter the attribute that identifies alternate email
addresses for the user.
For Active Directory, type proxyAddresses .

User Guide

387

Policies

For iPlanet, type Email . For OpenLDAP, leave this field blank.
9. In the Member Of text box, type the attribute that identifies the groups to which the user
belongs.
For Active Directory, type memberOf .
For iPlanet, type Member . For OpenLDAP, leave this field blank.
10. In the Account Name Attribute text box, type the attribute that identifies an account name for
the user for login.
In Active Directory, type sAMAccountName.
For iPlanet, use uid . For OpenLDAP, use cn .
11. Click Apply.
12. Click Import Now to import users and their corresponding group memberships from an LDAP
directory.
Click Import Settings to set up scheduled imports.

Configure Group Policy
After you import group and user information from an LDAP directory server, you can configure Group
policies.
1. Select Security > Policies > Group Policy.
The Group Policy page appears.

2. Select Create Group Policy.

3. From the Group drop-down list, select an existing group.
4. From the Policy drop-down list, select the policy to apply to the specified group.
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5. From the Effective drop-down list, select Specific Times to configure the time periods for
which this policy takes effect, or select Always for no time restriction.
Click the "+" symbol to add additional time periods.

6. Click Add Policy to add additional policies for this group.
You can add up to five policies.

7. Click Apply.

Re-order Groups
If the user belongs to more than one group, group policies are applied in the order the groups are
imported.
For example, in the case of annotations, the annotation used for a user who belongs to multiple groups
is the annotation for their first group that appears in the group order.
To re-order groups:
1. Click Re-order Groups.
The Re-order Group Policies page appears.

2. Select a group to move.
Note Only groups assigned to a policy are displayed.
3. Click Up or Down to move the group up and down the list order.
Click Top and Bottom to move the selected group to the top or bottom of the list.
4. When you have finished the re-ordering of groups, click Apply.
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Orphaned groups
Orphaned LDAP groups are groups that have been deleted from the LDAP directory but still exist in the
local group list. Any policies configured for these orphaned groups are not processed.
To remove orphaned groups from the Group policy page, click Delete Orphans.

Upload Group Policy Lists
You can upload lists of group policy assignments in a text file. The file must contain comma or tab
separated entries with one entry per line.
Use this format:
[group],[policy],[startday],[starthr],[startmin],[stopday],[stophr],[stopmin]

Days are specified by a number from 0 to 6, starting with Sunday (0). Hours are specified in 24-hour
format with a number from 0 to 23. Minutes are specified in these increments: 0,15,30,45.
For example:
sales,salespolicy,1,9,0,5,17,0marketing,marketingpolicydev,devpolicy,0,8,0,4,12,0

You must use a text editor to create the file group_policy.csv.
To update a group policy text file:
1. To download the group policy list from the WatchGuard XCS, click Download File.
2. Open the file and update the group policy list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
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IP Address Policies
You can customize web policies for specific IP addresses or networks. IP address-based policies take
precedence over domain and group policies, but can be overridden by a user policy.
IP address policies are specifically for web traffic only, and apply to the IP address of the web browser
client, or the IP address of an intermediary HTTP proxy that is positioned between web clients and the
WatchGuard XCS.
Note IP address policies are not used for email messages.
1. Select Security > Policies > IP Policy.
The IP Policy page appears.

2. In the IP text box, enter the IP address or network to which to apply the policy.
You must enter a valid IP address or network using CIDR/slash notation. The WatchGuard
XCS automatically adds the network /32 for a single IP address.
For example, to enter an IP address, type 10.0.10.100 or a123:b123:: .
To enter a network, use slash notation. For example, type 10.1.0.0/16 or a123:b123::/64 .
3. From the Policy drop-down list, select the policy to apply to the specified IP address or
network.
4. From the Effective drop-down list, select Specific Times to configure the time periods for
which this policy takes effect, or select Always for no time restriction.
Click the "+" symbol to add additional time periods.

5. Click Add Policy to add additional policies for this IP address or network.
You can add up to five policies.

6. Click Apply.

Upload and Download IP Address Policy Lists
You can upload a list of IP address policy assignments in a text file. The file must contain comma or
tab separated entries with one entry on each line.
Days are specified by a number from 0 to 6, starting with Sunday (0). Hours are specified in 24-hour
format with a number from 0 to 23. Minutes are specified in these increments: 0,15,30,45.
Use this format:
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[IP/Net],[policy],[startday],[starthr],[startmin],[stopday],[stophr],[stopmin]

You must enter single IP addresses using CIDR/slash notation with the network /32, for example,
10.1.1.10/32.
For example:
10.0.1.10/32,IPPolicy1,1,9,0,5,17,010.1.0.0/16,IPNetPolicy10.0.10.100/32,IPPolicy2,
0,8,0,4,12,0

You must use a text editor to create the file ip_policy.csv.
To update an IP address policy text file:
n
n
n
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To download the IP address policy list from the WatchGuard XCS, click Download File.
Open the file and update the IP address policy list.
Click Upload File and upload the edited file to the WatchGuard XCS.

WatchGuard XCS

Policies

User Policies
You can customize policies for individual user email addresses. User policies take precedence over
domain, IP address, and group policies, and are useful for to create individual exceptions to these
policies.
In this example, we create a user policy with custom Anti-Virus settings.
1. Select Security > Policies > Policies.
The Policies page appears.

2. Click the Create New Policy link.
The Policy Settings page appears.

3.
4.
5.
6.

In the Name text box, type a name for this policy.
Select the Enable This Policy check box.
In the Description text box, type a detailed description for this policy.
To customize the Anti-Virus settings for both inbound and outbound directions for this user
policy, select Anti-Spam and Anti-Virus and make any required changes to the policy.
7. Click Apply.
8. Select Security > Policies > User Policy.
The User Policy page appears.

9. In the Email text box, type the email address of the user.
10. From the Policy drop-down list, select the policy to apply to the specified user.
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11. From the Effective drop-down list, select Specific Times to configure the time periods for
which this policy takes effect, or select Always for no time restriction.
Click the "+" symbol to add additional time periods.

12. Click Add Policy to add additional policies for this user.
You can add up to five policies.

13. Click Apply.

Upload and Download User Policy Lists
You can upload a list of user policy assignments in a text file. The file must contain comma or tab
separated entries with one entry on each line.
Days are specified by a number from 0 to 6, starting with Sunday (0). Hours are specified in 24-hour
format with a number from 0 to 23. Minutes are specified in these increments: 0,15,30,45.
Leave the time fields blank if the effective time is set to Always.
Use this format:
[email],[policy],[startday],[starthr],[startmin],[stopday],[stophr],[stopmin]

For example:
user@example.com,User1Policy,1,9,0,5,17,0user2@example.com,User2Policyuser3@example
.com,User3Policy,0,8,0,4,12,0

You must use a text editor to create the file email_policy.csv.
To update a user policy text file:
1. To download the user policy list from the WatchGuard XCS, click Download File.
2. Open the file and update the user policy list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
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Policy Diagnostics
From the Policy Diagnostics page, you can test your policy structure and make sure the final result for
a specific user is the desired result. There are several policies that can apply to a single user: domain
policies, user policies, IP address policies, group policies, time policies, and the Default policy.
You can enter the sender and recipient’s email address, the IP address, the time period, direction and
trusted level of the message. The policy diagnostic page displays each policy feature and includes
information on which policies were overridden by another policy with higher priority.
To run policy diagnostics:
1. Select Security > Policies > Diagnostics.
The Policy Diagnostic page appears.

2. To test an outbound message, in the Sender text box, enter the test sender email address.
Keep this field blank to indicate any sender for inbound mail.

3. In the Recipient text box, type the test recipient email address for the message.
The final result displayed during the diagnostics is the final policy result for this specific user.

4. In the IP Address text box, type an optional IP Address for the message, if required.
5. From the Time drop-down list, select the time stamp for the message.
6. From the Direction drop-down list, select the direction for the message to determine policy
results when the message is inbound or outbound.
7. From the Trusted drop-down list, select whether the message is considered to be from a trusted
(Yes) or untrusted source (No).
8. Click Lookup.
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The Policy Diagnostics summary page gives you a detailed analysis of how the various active
policies combine to determine the final disposition of messages. The results include a table that
displays the WatchGuard XCS features that are configured on a per-policy basis.
Each column displays the contributions to the disposition of the message by each policy (user,
IP address, group, domain, and Default).
For each feature, an “X” indicates the defined policy was used to determine the final result. Any
policies that were overridden by the applied policy are indicated by an “_” underscore character.
An empty column indicates that a matching policy was not found by the policy resolution
engine.
At the end of each feature row, the final result of the policy is indicated, for example, “Disabled”
for Kaspersky Anti-Virus.
Because policies are initialized with reasonable defaults, and those values may match the
overall default setting, it can appear that a particular policy has been overridden, when in fact
there is no apparent configuration responsible for this. For example, the default setting for
Content Scanning is “disabled”. If a user policy is defined, but Content Scanning is not part of
that definition, and nothing else overrides the default, then it appears that the contribution has
come from the user policy.
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About the Web Proxy
The WatchGuard XCS incorporates a Web Proxy that manages web traffic and controls access to
external web sites. The system scans web traffic using a subset of the same scanners that examine
email messages to inspect the content of web traffic and file transfers. The Web Proxy can also scan
encrypted HTTPS traffic and FTP traffic over HTTP using the same scanners as the HTTP proxy.
With the WatchGuard XCS policy features, you can apply web access policies to different users,
groups, IP addresses, and domains. The Web Proxy analyzes client requests and allows or blocks
access to specific web sites based on the configured access policies. The Web Proxy can block or
allow access to web sites using Fully Qualified Domain Names (FQDN) and IP addresses, for
example, http://www.example.com and http://10.1.0.10/.
Policy features apply specific web access policies to different users, groups, IP addresses, and
domains, and you can customize notifications for blocked connections or files and send them to the
administrator and recipient.

Web Traffic Content Inspection
The Web Proxy inspects downloaded and uploaded content with these features:
n
n
n

n
n
n
n

n

Kaspersky Anti-Virus – Scans for viruses and spyware in downloaded and uploaded files.
URL Block Lists – Blocks access to web sites that appear on a URL Block List.
Objectionable Content Filter (OCF) – Scans web traffic for objectionable content based on a
dictionary of blocked words and phrases.
Attachment Control – Allows or blocks specific file extensions and MIME types.
Content Scanning – Allows or blocks files based on specific text content in a file.
Web Reputation – Allows or blocks web requests based on the reputation of the web site.
URL Categorization – Allows or blocks web sites based on a list of blocked web site content
categories.
HTTP Trusted and Blocked Sites List – Allows or blocks web sites based on a managed list
of web site domains.
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Web Proxy Authentication
You can allow unauthenticated access for all users, or require authentication before access to external
web sites is allowed. If authentication is enabled, all end users that use the Web Proxy must be
authenticated by the WatchGuard Single Sign-On Agent (Active Directory), LDAP server, or have a
local account to get access to web sites through the Web Proxy.
Users must authenticate to the system with their account credentials. All access is denied until the
user is authenticated to the system. If authentication is disabled, all users use the Default policy, or an
IP address policy if one is assigned, for web access control. You can also configure the WatchGuard
XCS to bypass HTTP authentication for specific web domains or from specific source IP addresses
and networks.

Traffic Accelerator
The expansive growth of large, media intensive, interactive, and collaborative web sites requires
greater bandwidth that can overload corporate networks. The WatchGuard Traffic Accelerator solution
provides several web traffic enhancements to reduce bandwidth consumption, server loads, and
network latency, that results in better network performance and availability. The WatchGuard Traffic
Accelerator includes these features:
n

Streaming Media Bypass – The WatchGuard Traffic Accelerator has the ability to bypass
streaming media content to reduce the strain on bandwidth resources.
See Streaming Media Bypass for more detailed information on configuring the streaming media
bypass.

n

Web Cache – The web cache feature of the WatchGuard Traffic Accelerator solution enables
faster retrieval of web sites to provide temporary storage of web data. This feature reduces
bandwidth consumption and improves performance for subsequent accesses of these web
sites because the data and images are read from the disk cache instead of going out to the
Internet.
See Web Cache for detailed information on configuring the web cache.

These additional features help improve scanning efficiency:
n

n
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Preview Scanning – The system scans the initial header of the response and takes immediate
action based on your configured policies. This increases scanning efficiency because the rest
of the content does not have to be scanned. Only certain types of responses can be handled
with a header preview scan, such as detection of MIME types for content control and streaming
media bypass, or checks on maximum files sizes reported in the header.
Early Response – Early response scanning allows the web proxy to take action based on
scanning only part of the downloaded content. This early response is useful for detecting issues
such as files beyond the maximum file size where the file should not be scanned. The remainder
of the content is not scanned.
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n

n

Client Request – Many HTTP security features, such as URL Categorization, URL Block
Lists, and Trusted/Blocked Lists can perform actions based on the URL without scanning the
actual downloaded content. For example, if a requested URL is blocked by URL Categorization,
the actual downloaded content is not scanned. These web scanning decisions are performed
very quickly based on your configured policies.
Policy Caching – For greater efficiency, some common policy results are cached, such as
those where continuous amounts of web traffic with the same content triggers the same policy.
In general, access of cached data is still sent to the Web Proxy content scanners because
different users can have different HTTP content policies applied to them, but efficiency can be
improved by using fewer policies that are wider in scope. The more policies you have results in
a higher probability that cached policy results are replaced by the scanning result of a different
policy.
Web Site Content Caching – Web site content is cached if the web server does not send a
non-caching directive in the response and the response data passes the requirements of the
scanning policy.

Web Proxy Chaining
The Web Proxy supports proxy chaining to a remote proxy server. This feature forwards requests to
another proxy server in an organization’s network before it connects to the Internet. This can be a
requirement in specific environments where you must access a primary proxy server before web traffic
is allowed outside of the organization’s network.

Automatic Client Proxy Configuration
Organizations that want to enforce the use of a proxy policy without manual configuration of each
individual browser can use these methods for automatic proxy configuration:
n

n

Proxy Auto-Config (PAC) file – A Proxy Auto-Config (PAC) file defines how a web browser
can automatically choose an appropriate proxy server to connect to. The PAC file is a script file
that browsers read and execute to determine which proxy to use.
Web Proxy Autodiscovery Protocol (WPAD) – The Web Proxy Autodiscovery Protocol
(WPAD) is supported by most web browsers to locate a Proxy Auto-Config (PAC) file
automatically and then use this information to configure the browser's web proxy settings. The
protocol can use DHCP or DNS to locate the PAC file.
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Web Proxy Limitations
These are the current limitations with the Web Proxy:
n

n

n

n

Clustering is not supported in Transparent Mode. A Web Proxy running in Transparent Mode
can be clustered with a non-Web Proxy system, for example, a WatchGuard XCS appliance
that processes email.
URL Categorization of HTTPS URLs and FTP over HTTP scanning is not supported in
Transparent mode.
FTP over HTTP scanning only supports FTP used in a web browser. Standalone FTP clients or
web browser extensions that use the “CONNECT” method are not supported.
You cannot use local or LDAP authentication when in Transparent mode.

Web Proxy Best Practices
These are best practices to follow when you implement the Web Proxy for the first time:
n

n

n

n

n
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We recommend that you run the system for at least 24-48 hours with minimal scanning enabled
before you enable threat and content control scans on web traffic. This allows the web cache to
be populated and increases performance. After this initial period, you can enable threat and
content control scanners as needed.
We recommend DNS caching be enabled to increase Web Proxy performance. This option is
enabled by default in Configuration > Network > Interfaces.
Make sure you enable Large MTU on the network interface designated for HTTP Proxy access.
This option is enabled by default in Configuration > Network > Interfaces.
When you configure the Web Proxy in Transparent Mode, make sure that you enable the Large
MTU setting on the network interface configured as the Bridge In interface. You must enable
the Web Proxy and reboot the system before you can enable bridging and Transparent Mode on
a network interface.
Make sure that your local DNS server is configured and works. Misconfigured DNS services
and domain name translation issues can significantly decrease Web Proxy performance or
cause the Web Proxy to fail.
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Configure the Web Proxy
To enable and configure the Web Proxy:
1. Select Configuration > Web > HTTP/S Proxy.

2. Select the Enable HTTP/HTTPS Proxy check box.
3. Select the Enable FTP Proxy check box to enable the FTP Proxy and allow scanning of FTP
traffic over HTTP.
4. In the Proxy Port text box, type the port on which the Web Proxy listens for messages.
The default is TCP port 8080. If this XCS device is deployed in Transparent Mode, the default TCP
port is 80 and cannot be modified.

Note Up to three additional ports (for example, 8081, 8082, 8083) can be opened up
internally based on the number of Web Proxy processes in use. Higher-end
WatchGuard XCS hardware models can use more Web Proxy processes.
5. In the HTTPS Ports text box, type a list of HTTPS ports that are allowed through the Web
Proxy.
The standard HTTPS port 443 is included by default. Separate multiple ports with commas. For
example: 443,8443

6. From the Authentication Type drop-down list, select a method of authentication.
See Enable Web Proxy Authentication for detailed information on configuring Web Proxy
authentication.
7. In the Allowed Networks text box, type a comma-separated list of networks (in CIDR/slash
notation format, IPv4 or IPv6) that are allowed to get access to the Internet through the Web
Proxy, for example,
10.0.0.0/8,192.168.0.0/24,a123:b123::/64
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The Allowed Networks text box cannot be left blank. If you want to allow all networks,
type 0.0.0.0/0 .
Note Make sure that you do not enter subnets that overlap with each other in the Allowed
Networks text box.
8. From the Verbose Logging drop-down list, select Enabled to turn on additional log details in
the Web Proxy log.
In the default configuration, only rejected web requests or requests that are matched in a
content control feature are recorded on the Recent Web Activity page. To see the activity of all
Web requests, including those that passed all security and content checks, enable this feature.
WarningYou should only enable the Verbose Logging option for a short period of time for
troubleshooting purposes. Performance is negatively affected when Verbose
Logging is enabled and the system is processing web requests.
9. Click Apply.

Advanced Options
Click Show Advanced Options to reveal additional options for the Remote Proxy configuration.

Remote Proxy
In the Remote Proxy URL text box, type an optional address of an external proxy server to which to
forward web requests. This is required if the WatchGuard XCS connects through an intermediary proxy
server before requests are sent to the Internet.
Type a URL with this format, hostname:port.
For example,
proxy.example.com:8080

Keep this field blank if the system connects directly to the Internet.

If you have configured a remote proxy that requires basic authentication, from the Remote Proxy
Auth Type drop-down list, select Basic Proxy Authentication.
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Type the Remote Proxy Username and Remote Proxy Password that is used to authenticate the
WatchGuard XCS with the remote proxy. Make sure that you configure the specified user name on the
remote proxy.
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Web Proxy Network Interface Settings
You must enable Web Proxy access on a specific network interface after the Web Proxy feature is
enabled globally.
Note You must enable the HTTP/HTTPS Proxy feature and reboot the device before you
configure the network interfaces for bridging and Transparent Mode operation.
To enable the Web Proxy on a network interface:
1. Select Configuration > Network > Interfaces.
2. Choose a network interface and select the HTTP/HTTPS Proxy check box.
3. If IP Address Proxy or Portal Authentication is enabled, make sure you enable the Admin &
Web User Login option to allow users to authenticate through the Web Proxy.
4. If you use the Transparent Proxy feature, you must enable the HTTP/HTTPS Proxy and Large
MTU check boxes and assign an IP address to the Bridge In interface. The Bridge Out
interface must be a disabled interface and it must also have the Large MTU option enabled.

5. Click Apply.
You must reboot the system.
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Transparent Mode
To enable the Web Proxy in Transparent Mode:
1. Select Configuration > Web > HTTP/S Proxy.
2. Select the Enable HTTP/HTTPS Proxy check box.
3. Click Apply.
You must reboot the system.

Note You must enable the HTTP/HTTPS Proxy and reboot the device before you configure
the network interfaces for Transparent Mode operation. If Transparent Mode is
enabled and the HTTP/HTTPS Proxy is disabled, network traffic on TCP port 80 is
blocked and the Web Proxy does not record any information. The default port for
HTTP traffic (TCP port 80) cannot be modified in Transparent Mode.
4. Select Configuration > Network > Interfaces.
5. Make sure that you configure the Bridge In network interface with an appropriate IP address.
6. Select the HTTP/HTTPS Proxy and Large MTU options.

7. In the Bridging section, select the Enable Bridging check box.
You must enable bridging for Transparent Mode to work correctly.
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8. Select a configured network interface to use as the Bridge In interface for Transparent Mode.
For greater security and performance, select an interface on a dedicated, non-routable subnet.
You must configure this interface with an IP address and enable the HTTP/HTTPS Proxy
access and Large MTU options before you select the interface as the Bridge In interface.
9. Select an unconfigured network interface to use as the Bridge Out interface for Transparent Mode.
For greater security and performance, select an interface on a dedicated, non-routable subnet.
This interface does not require an IP address and is configured automatically for use with the
bridge.
10. Select the Enable Transparent Mode check box.
11. Click Apply.
You must reboot the device.

Disable the Web Proxy in Transparent Mode
To disable the Web Proxy feature, but still allow all traffic (this includes HTTP port 80) to pass through
the system while in Transparent Mode:
1. Select Configuration > Network > Interfaces.
2. For the Bridge In interface, disable the HTTP/HTTPS Proxy option.
3. Click Apply.
You must reboot the device.

When the system restarts, all network traffic passes through the system and no Web Proxy functions
are performed or recorded as log messages.
Note If Transparent Mode is enabled, but the HTTP/HTTPS Proxy is disabled, all TCP port
80 HTTP traffic is blocked, and no log messages for HTTP traffic are generated.
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HTTPS Deep Inspection
The Web Proxy can perform deep content inspection of encrypted HTTPS traffic using the same
scanners as the HTTP proxy, such as Anti-Virus, the Objectionable Content Filter, Reputation Enabled
Defense, and Content Scanning.
HTTPS uses a digital certificate to encrypt and decrypt user page requests as well as the pages that
are returned by the web server. Because HTTPS traffic is encrypted, the XCS device must decrypt it
before it can be examined.
When a client web browser attempts to make a connection to an HTTPS encrypted web site, the XCS
proxies the HTTPS connection on the client's behalf.
The client initially establishes an HTTPS session with the XCS device, and the client must trust a
resigning certificate from the XCS device. This certificate can be self-signed and generated locally on
the XCS, or you can use a certificate from a Certificate Authority (CA), such as an internal CA server.
The WatchGuard XCS creates its own HTTPS connection to the requested web server, and decrypts
and scans the HTTPS data. After it examines the content, the XCS encrypts the traffic with the
resigning certificate and delivers the content through the HTTPS session with the client.

HTTPS Deep Inspection Limitations
These are the current limitations with HTTPS Deep Inspection:
n
n
n

HTTPS Deep Inspection is not supported in Transparent proxy mode.
HTTPS Deep Inspection is not supported with a remote proxy configured.
When using basic authentication and HTTPS scanning with user policies, the user is only
authenticated in the first connection request.
o Subsequent encrypted packets are processed as an "unknown" unauthenticated user
and the Default policy is applied instead of the user's policy.
o If you use IP Portal or IP Proxy authentication, user policies are properly applied.

Configure HTTPS Deep Inspection
To configure HTTPS deep inspection.
1. Select Configuration > Web > HTTPS Deep Inspection.
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2. Select the Enable HTTPS Deep Inspection check box.
3. Select the Block Sites with Untrusted Certificates check box to block web sites that use
untrusted or expired certificates.
The client browser will display a notification that the site has been blocked.
WarningBlocking untrusted certificates can cause connectivity issues with local web
servers that use self-signed certificates.
If this option is disabled (the default setting), the system allows the connection through with no
notification and the client browser will be unaware that the site is actually untrusted.
4. Click Apply.

Resigning CA Certificate
HTTPS sessions must be resigned by the XCS to allow for deep inspection of HTTPS content. This
resigning certificate is used by client web browsers to trust these HTTPS connections from your XCS
device to prevent certificate warnings and errors. We recommend that you download the certificate
from the XCS device and distribute it to each user so that they do not receive browser warnings about
untrusted certificates.
n

n

408

The Current Certificate text box displays the resigning certificate currently in use. A selfsigned certificate is installed by default.
Click Upload a Resigning CA Certificate to upload a resigning certificate obtained from a
Certificate Authority (CA).
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Click Generate a New Resigning CA Certificate to create and apply a new self-signed
resigning certificate if you do not require a certificate from a CA or if you want to use your own
organization's details for the certificate instead of the default certificate.
Click Generate a Certificate Signing Request to create a Certificate Signing Request (CSR)
that contains your information, including the public key, used by a Certificate Authority (CA) to
create your resigning certificate.

To download the current certificate for distribution to other users, click Download Certificate. See
Import the Resigning Certificate into the Client Web Browser for details on trusting this certificate on
the client.
To download the private key, click Download Private Key. For example, you may want to have
another copy of the private key for backup purposes.
WarningDo not distribute the private key to other users.

Bypass Domains
The ability to inspect HTTPS traffic can present an issue of confidentiality for users in your
organization. To help protect the personal information of clients connecting to sites such as personal
banking, you can bypass HTTPS deep inspection for specific web domains.
In the Bypass Domains section, select a list of web domains that bypass HTTPS deep inspection.
Select a dictionary, then use the arrows to move the dictionary from the Available Domain
Dictionaries list to the Dictionaries in use list.
Note The domain dictionary must be of the type "Domain" to appear in the available
dictionaries list.
You can upload the domain list on the Dictionaries page, or click Add or Edit to manage your
dictionaries. You must create a "Domain" type dictionary with one domain entry per line.
For example:
example.com
example1.com
example2.com

All subdomains of the specified domain are included. For example, the domain example.com also
includes subdomain.example.com.
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Upload a Resigning CA Certificate
If you have obtained a certificate from a Certificate Authority (CA) to use for resigning:
1. Copy and pastethe encodedcertificate informationreturned by the CAinto theCertificate textbox.

2. Select the Use this private key check box and copy and paste the private key text into the
Private key text box.
The private key must match the certificate public key. If you have previously uploaded this
certificate and private key, or created a Certificate Signing Request (CSR) for this certificate,
the system will remember the private key and you do not have to enter the key again.
3. Click Apply when finished.
Note When you apply a new CA certificate, the web proxy will restart. This operation can
take a few minutes to complete.
You must distribute the certificate to end users so that they can import the certificate into their web
browser's trusted CA list. This ensures that users will not see certificate errors when you have applied
the resigning certificate to the XCS device.
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Generate a New Resigning CA Certificate
If you want to use a self-signed certificate generated locally by your XCS device for resigning HTTPS
sessions, enter this information:

n

n

n

n
n

n

Server Organization Name – Type the organization name for the certificate. The maximum
length is 64 characters and you cannot use the ", $, and ` characters.
City – Type the City for the organization. The maximum length is 128 characters and you
cannot use the ", $, and ` characters.
State/Province – Type the State/Province for the organization. The maximum length is 128
characters and you cannot use the ", $, and ` characters.
Country – Type the Country code for the organization. This field must be two letters.
Days to Certificate Expiry – Type the number of days until the certificate expires. The default
is 730.
Size of Certificate's Public Key – Select the size of the public key. Higher values are more
secure. The default is 2048 bit.

Click Generate CA Certificate & Apply to create a local self-signed resigning certificate and
immediately apply it to your device.
Note When you apply a new self-signed certificate, the web proxy will restart. This
operation can take a few minutes to complete.
Click Generate CA Certificate Only to create a local self-signed resigning certificate but do not apply
it to the device. Use this method so that you can generate the certificate and distribute it to end users
to import the certificate into their web browser's trusted CA list. When this is complete, you can apply
the certificate to your device. This ensures that users will not see certificate errors when you have
applied the resigning certificate to the XCS device.
When you apply the new resigning certificate, this page appears:
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Click Remove Self-Signed CA Certificate to remove the current resigning certificate.
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Generate a Certificate Signing Request
If you want to generate a Certificate Signing Request (CSR) to send to a Certificate Authority (CA),
enter this information:

n

n

n

n
n

Server Organization Name – Type the organization name for the certificate. The maximum
length is 64 characters and you cannot use the ", $, and ` characters.
City – Type the City for the organization. The maximum length is 128 characters and you
cannot use the ", $, and ` characters.
State/Province – Type the State/Province for the organization. The maximum length is 128
characters and you cannot use the ", $, and ` characters.
Country – Type the Country for the organization. This field must be two letters.
Size of Certificate's Public Key – Select the size of the public key. Higher values are more
secure. The default is 2048 bit.

Click Generate CSR to create the Certificate Signing Request. The encoded text contains your
information, including the public key, used by the Certificate Authority (CA) to create your certificate.
The corresponding private key is created at the same time and is saved on your XCS device.
When you have generated the Certificate Signing Request, copy the text in the Certificate Request
text box, and send this information to your Certificate Authority. The CA will use this information to
generate your certificate.
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Click Remove CSR to remove this Certificate Signing Request from the system.
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Import the Resigning Certificate into the Client Web Browser
The WatchGuard XCS uses its own certificate that is presented to the user in place of the destination
site HTTPS certificate. The XCS can use a self-signed certificate or a certificate issued by a
Certificate Authority (CA). The client must trust the resigning certificate from the XCS device to
prevent the client browser from reporting certificate errors because the CA identified in the certificate is
not trusted.
You must import the certificate into the browser's list of trusted certificates.

Download the Resigning Certificate
To download the resigning certificate from the XCS device:
1. Select Configuration > Web > HTTPS Deep Inspection.

2. Select Download Certificate.

Import a Certificate into Firefox
To import the certificate into the Mozilla Firefox web browser:
1. Select Options > Advanced > Encryption.
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2. Click View Certificates.
3. Select the Authorities tab.

4. Click Import to add the resigning certificate to the list of trusted CAs.
5. Select Trust this CA to identify web sites, then click OK.
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6. Click OK.

Import a Certificate into Internet Explorer
To import the certificate into the Internet Explorer web browser:
1. Select Tools > Internet Options > Content > Certificates.
2. Select the Trusted Root Certification Authorities tab.

3. Click Import.
The Certificate Import Wizard appears.
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4. Click Next.
5. Click Browse and select the certificate file.
6. Click Next.

7. Accept the default setting for the certificate store location "Trusted Root Certification
Authorities", and click Next.
8. Click Finish.
9. Click OK.
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About Web Proxy Authentication
If you enable Web Proxy authentication, users must authenticate to the WatchGuard XCS with a user
name and password before they are allowed access to browse web sites.
There are three methods to configure authentication:
n

Local Account – A local account can be set up to authenticate web users. You cannot use
local account authentication if the system is part of a cluster, because local accounts are not
available.
See Local User Accounts for details on how to add a local user account.

n

LDAP Web Users – When users log in to the Web Proxy, they can be authenticated directly
with an LDAP server. The LDAP Web Users feature allows LDAP-authenticated clients to use
the Web Proxy feature. Web clients must use a login name and password to authenticate to an
LDAP server before they can get access through the Web Proxy. LDAP Authentication enables
the system to authenticate the user directly to an LDAP directory server without the need to
create a local account.
See LDAP Web Users for details on how to configure the LDAP Web Users feature.

n

Single Sign-On Agent – Users are automatically authenticated to the Web Proxy if they have
been authenticated on a Microsoft Windows domain monitored by the WatchGuard Single SignOn (SSO) agent.
See WatchGuard Single Sign-On for details on how to configure the Single Sign-On agent.

About IP Address-based Authentication
When you use IP address-based authentication, the authenticated user is tracked by their IP address
and users never have to re-authenticate during their browser sessions.
IP-based authentication also enables authentication when using the Web Proxy in a Transparent Mode
deployment.
An IP Address Portal Authentication method is also available that presents the user with a login portal
page where they enter their local or LDAP user name and password and agree to a usage policy
agreement before they are allowed access to browse web sites. The Portal authentication method
uses HTTPS to protect the transmission of the user’s credentials.
When you use Proxy and Portal IP address-based authentication:
n

Users can log out of their authenticated sessions with this URL:
http://<hostname>/portal/logout

n

n

Users must re-authenticate to the Web Proxy if they receive a different IP address from a
DHCP server when their IP address is renewed.
Make sure that no intermediary proxies are installed before the Web Proxy because clients
must have a unique IP address to be identified for IP-based authentication. Clients that connect
through another proxy use the IP address of the intermediary proxy server.
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Enable Web Proxy Authentication
To enable Web Proxy authentication:
1. Select Configuration > Web > HTTP/S Proxy.
The Configure HTTP/HTTPS Proxy page appears.

2. From the Authentication Type drop-down list, select the authentication method.
n

n

No Authentication – Disables authentication and allows all users access to web sites
through the Web Proxy. If No Authentication is selected, web clients always use the
Default policy settings, or an IP address policy if one is assigned, for web access.
Basic Authentication – Allows only authenticated users access to web sites through the
Web Proxy. The user must have a local account or must be authenticated directly to an
LDAP server. The user must log in with their local or LDAP user name and password before
they can connect to web sites through the Web Proxy. When you use Basic
Authentication, the user’s credentials are sent in clear text. The user must enter their
credentials for each browser session. Note that basic authentication cannot be used in
Transparent Mode.

Note When using basic authentication and HTTPS scanning with user policies, the user is
only authenticated in the first connection request. Subsequent encrypted packets are
processed as an "unknown" unauthenticated user and the Default policy is applied
instead of the user's policy.
n
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IP Address Proxy Authentication – Allows only authenticated users access to web sites
through the Web Proxy. The user must have a local account or must be authenticated
directly to an LDAP server. The user must log in with their local or LDAP user name and
password before they can connect to web sites through the Web Proxy. When you use the
Proxy Authentication method, the user’s credentials are sent as basic HTTP authentication
in clear text. The system tracks the user based on their IP address. The user is never
prompted again for their credentials in any current or new web browser session. IP address
proxy authentication mode is supported when you use the Web Proxy in full proxy mode
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n

and Transparent Mode.
IP Address Portal Authentication – Allows only authenticated users access to web sites
through the Web Proxy. Users are presented with a web proxy login portal page where they
must enter their local or LDAP user name and password, and agree to a usage policy
agreement before they are allowed access to browse web sites. (You can customize the
usage policy agreement on the Configuration > Miscellaneous > Customization page.)
The Portal Authentication method uses HTTPS to protect the transmission of the user’s
credentials. The system tracks the user with their IP address. The user is never prompted
again for their credentials in any current or new web browser session. IP address portal
authentication mode is supported when you use the Web Proxy in full proxy mode and
Transparent Mode.

Note If you use the IP Address-based Proxy and Portal Authentication methods, you must
enable the Admin & Web UserLogin option on the HTTP Proxy network interface
for users to authenticate to the Web Proxy. If you use IP address-based
authentication in full proxy mode, there is additional configuration required on the client
browser to route authentication requests correctly. See Web Client Configuration for
details.
n

Single Sign-On – Allows only authenticated users access to web sites through the Web
Proxy. Users are automatically authenticated to the Web Proxy if they have been
authenticated on a Microsoft Windows domain monitored by the WatchGuard Single SignOn (SSO) agent. You can configure a secondary authentication method if the Single SignOn authentication attempt fails. The Web Proxy tracks the user by their IP address, and the
user will never be asked again for their credentials in any current or new web browser
sessions. Single Sign-On mode is supported when using the Web Proxy in full proxy mode
and Transparent Mode.
o SSO Agent IP Address – For Single Sign-On authentication, type the IP Address
of the Single Sign-On (SSO) agent that manages user authentication events on the
Windows domain.
o Secondary Authentication Type – Select a secondary authentication method if
Single Sign-On authentication fails. Authentication failure can occur if the SSO
Agent cannot be contacted, or if the client is a non-Windows client that is not
supported by the SSO agent. Select No Authentication, or IP Address Portal
Authentication.

See WatchGuard Single Sign-On and Configure the SSO Agent for detailed information on how
to install and configure the SSO agent.
3. These options appear when you select any of the authentication options:
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n

n

n

n

Redirect Using – If you use the IP Address Proxy or Portal authentication methods, you
must select whether to redirect to the authentication page using the Web Proxy Hostname
or IP Address. Select Hostname if you use a CA-signed certificate on your system to
prevent a certificate warning error in the client browser. Otherwise, select IP Address.
Make sure you add the Web Proxy hostname or IP address to your local web browser's
proxy exclusion list to prevent a local proxy loop when you access the authentication page.
Session Timeout – When you use IP Address Proxy or Portal Authentication mode, you
can set a session expiry timeout that forces the user to re-authenticate when they exceed
the time out value.
o Never – The user session never expires. This setting is persistent if the system
restarts.
o Expire – The user session expires after the specified time period (in days and
hours). The user is required to re-authenticate when their session expires.
Networks that Bypass Authentication – Type a comma-separated list of networks (IPv4
or IPv6) that bypass authentication. Any user on these networks is not required to
authenticate to use the Web Proxy. For example,
10.0.0.0/8,192.168.3.5/32,a123:b123::/64 .
Domains that Bypass Authentication – Type a comma-separated list of domains that
bypass authentication. If a user gets access to the specified web domain, they are not
required to authenticate to the Web Proxy. All subdomains of the specified domain are
included.
Authentication bypass occurs before policy resolution. Users that bypass authentication
always use the Default policy, or an IP address policy if one is assigned, for their access
settings. Any web requests to a domain that bypasses authentication are not reported in
the user’s web reporting information because only the IP address is recorded.
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WatchGuard Single Sign-On
To simplify the authentication process for your web users, you can use the WatchGuard Single SignOn (SSO) solution. With SSO, your users provide their credentials one time (when they log on to their
computers on an Active Directory domain) and are automatically authenticated to your XCS device
when they use the Web Proxy.

The WatchGuard SSO Solution
The WatchGuard SSO solution includes these components:
n

n

n

SSO Agent – To use SSO, you install the SSO Agent on one computer in your domain, such as
your domain controller. This enables the SSO Agent to run as a domain user account with
domain admin privileges. With these privileges, when users try to authenticate to your domain,
the SSO Agent can query the client computer or the Event Log Monitor for the correct user
credentials and provide those user credentials to your XCS device.
SSO Client – When you install the SSO Client software on your client computers, the SSO
Client receives the call from the SSO Agent and returns accurate information about the user
who is currently logged in to the computer. The SSO Agent does not have to contact the client
computer directly for the Active Directory credentials for the user, because when it contacts the
SSO Client, it receives the correct information about who is currently logged in to the computer
and to which Active Directory groups the user belongs.
Event Log Monitor – If you do not want to install the SSO Client on each client computer, you can
instead install the Event Log Monitor on a server in each domain in your network. This can be the
domain controller or another domain member server. You then configure the SSO Agent to get user
login information from the Event Log Monitor. This is known as clientless SSO. With clientless
SSO, the Event Log Monitor collects login information for users that have already logged on to the
domain. It then stores the user credentials and user group information for each user.
Note Clientless SSO is not supported in a TLS-Enabled Active Directory environment.

Before You Begin
n
n

n
n

n

n

n

You must have an Active Directory server on your network.
Your XCS device Web Proxy authentication configuration must be set to use Single Sign-On
authentication.
Each user must have an account set up on the Active Directory server.
Each user must log on to a domain account for Single Sign-On (SSO) to operate correctly. If
users log on to an account that exists only on their local computers, their credentials are not
checked and the XCS device does not recognize that they are logged in.
Make sure that TCP port 445 (port for SMB/Windows Networking) is open on client computers.
If you use third-party firewall software on your network computers, make sure that TCP port 445
is open.
Make sure that TCP port 4116 (used for connections to the SSO Client) is open on the client
computers. Not required for clientless SSO.
Make sure that TCP port 4114 is open on the computer where you install the SSO Agent.
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n

Make sure that TCP port 4135 is open on the domain controller computer where you install the
Event Log Monitor.
Make sure that the Microsoft .NET Framework 2.0 or higher is installed on the computer where
you install the SSO Agent and the Event Log Monitor.
Make sure that all computers from which users authenticate with SSO are members of the
domain with unbroken trust relationships.

Install the WatchGuard Single Sign-On (SSO) Agent
The SSO Agent is a service that receives requests for XCS authentication and checks user status with
the Active Directory server. The service runs with the name WatchGuard Authentication Gateway on
the computer where you install the SSO Agent software. This computer must have the Microsoft .NET
Framework 2.0 or later installed. The WatchGuard Authentication Gateway service must run as a user
who is a member of the Domain Admins group. We recommend that you create a new user account for
this purpose and then add the new user to the Domain Admins group. For the service to operate
correctly, make sure you configure this Domain Admin user account with a password that never
expires.
The Event Log Monitor is an optional component of the WatchGuard Authentication Gateway. If you do
not install the SSO Client on all of your client computers, we recommend that you install the Event Log
Monitor. When a logon event occurs, the Event Log Monitor polls the destination IP address (the client
computer) for the user name and domain name that was used to log in. Based on the user name
information, the Event Log Monitor gets the user groups to which the user belongs from the domain
controller and sends that information to the SSO Agent. This enables the SSO Agent to correctly
identify a user and make sure that each user can only log on from one computer at a time. If you have
more than one domain, install the SSO Agent on only one computer or domain controller in your
network, and install the Event Log Monitor on each of your domain controllers. The SSO Agent then
contacts each Event Log Monitor to get information for the users on that domain.

Download the SSO Agent Software
To download the SSO Agent software:
1. Go to http://www.watchguard.com/archive/softwarecenter.asp.
2. Log in to the WatchGuard Portal and click the Articles & Software tab.
3. Search to see all available Software Downloads articles and find the WatchGuard XCS
Software Downloads article.
4. Download the WatchGuard Single Sign-On Agent software and save the file to a convenient
location.

Install the SSO Agent and the Event Log Monitor Service
If you have more than one domain, make sure that you install the Event Log Monitor on each of your
domain controllers.
1. Double-click WG-Authentication-Gateway.exe to start the Authentication Gateway Setup
Wizard.
To run the installer on some operating systems, you might need to type a local administrator
password, or right-click and select Run as administrator.
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2. To install the software, follow the instructions on each page and complete the wizard.
3. On the Select Components page, make sure to select the check box for each component you
want to install:
n WatchGuard Authentication Single Sign-On Agent
n WatchGuard Authentication Event Log Monitor
4. On the Domain User Login page, make sure to type the user name in the form:
domain\username . Do not include the .com or .net part of the domain name.
For example, if your domain is example.com and you use the domain account ssoagent, type
example\ssoagent .
You can also use the UPN form of the user name: username@example.com . If you use the UPN
form of the user name, you must include the .com or .net part of the domain name.
5. Click Finish to close the wizard.
When the wizard completes, the WatchGuard Authentication Gateway service starts automatically.
Each time the computer starts, the service starts automatically.
See Configure the SSO Agent for detailed information on how to configure the SSO Agent.

Install the WatchGuard Single Sign-On (SSO) Client
As a part of the WatchGuard Single Sign-On (SSO) solution, you can install the WatchGuard
SSO Client. The SSO Client installs as a Windows service that runs under the Local System account
on a workstation to verify the credentials of the user currently logged in to that computer. When a user
tries to authenticate, the SSO Agent sends a request to the SSO Client for the user's credentials. The
SSO Client then returns the credentials of the user who is logged in to the workstation.
The SSO Client listens on TCP port 4116. When you install the SSO Client, port 4116 is automatically
opened on the workstation firewall.
Because the SSO Client installer is an MSI file, you can choose to automatically install it on your
users' computers when they log on to your domain. You can use an Active Directory Group Policy to
automatically install software when users log on to your domain. For more information about software
installation deployment for Active Directory group policy objects, see the documentation for your
operating system.

Download and Install the SSO Client Software
1. Go to http://www.watchguard.com/archive/softwarecenter.asp.
2. Log in to the WatchGuard Portal and click the Articles & Software tab.
3. Search to see all available Software Downloads articles and find the WatchGuard XCS
Software Downloads article.
4. Download the WatchGuard Single Sign-On Client software and save the file to a convenient
location.
5. Double-click WG-Authentication-Client.msi to start the Authentication Client Setup Wizard.
On some operating systems, you might need to type a local administrator password to run the
installer.

6. To install the software, follow the instructions on each page and complete the wizard.
7. Click Close to exit the wizard.
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After the wizard completes, the WatchGuard Authentication Client service starts automatically.
Each time the computer starts, the service starts automatically.

Configure the SSO Agent
You must specify the domains to use for authentication and synchronize the domain configuration with
the SSO Agent. You can also specify options to use SSO without the SSO Client. This is known as
clientless SSO. You configure settings for clientless SSO when you configure the SSO Agent. To
configure the SSO Agent settings, you must have administrator privileges on the computer where the
SSO Agent is installed. When you first launch the SSO Agent, it generates the Users.xml and
AdInfos.xml configuration files. These configuration files are encrypted and store the domain
configuration details you specify when you configure the SSO Agent.
The SSO Agent has two default accounts, administrator and status, that you can use to log in to the
SSO Agent. To make changes to the SSO Agent configuration, you must log in with the administrator
credentials. After you log in for the first time, we recommend you change the passwords for the default
accounts. The default credentials (username/password) for these accounts are:
n
n

Administrator — admin/readwrite
Status — status/readonly

Log In to the SSO Agent Configuration Tool
1. Select Start > WatchGuard > WatchGuard SSO Agent Configuration Tool.
The SSO Agent Configuration Tool login dialog box appears.

2. In the User Name text box, type the administrator user name: admin .
3. In the Password text box, type the administrator password: readwrite .
The SSO Agent Configuration Tools dialog box appears.

4. Configure your SSO Agent as described in the subsequent sections.
Changes to the configuration are automatically saved.
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Manage User Accounts and Passwords
After you log in for the first time, you can change the password for the default accounts. Because you
must log in with the administrator credentials to change the SSO Agent settings, make sure you
remember the password specified for the administrator account. You can also add new user accounts
and change the settings for existing user accounts.

Change a User Account Password
For the admin and status accounts, you can only change the password for the account; you cannot
change the user name.
From the SSO Agent Configuration Tools dialog box:
1. Select Edit > User Management.
The User Management Form dialog box appears.

2. Select the account to change.
For example, select admin.
3. Click Change Password.
The Change Password dialog box appears.

4. In the Password and Confirm Password text boxes, type the new password for this user
account.
5. Click OK.

Add a New User Account
From the SSO Agent Configuration Tools dialog box:
1. Select Edit > User Management.
The User Management Form appears.
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2. Click Add User.
The Add User dialog box appears.

3. In the User Name text box, type the name for this user account.
4. In the Password and Confirm Password text boxes, type the password for this user account.
5. Select an access option for this account:
n Read-Only
n Read-Write
6. Click OK.
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Edit a User Account
When you edit a user account, you can change only the access option. You cannot change the user
name or password for the account. To change the user name, you must add a new user account and
delete the old user account.
From the SSO Agent Configuration Tools dialog box:
1. Select Edit > User Management.
The User Management Form appears.

2. Select the account to change.
3. Click Edit User.
The Edit User dialog box appears.

4. Select a new access option for this account:
n Read-Only
n Read-Write
5. Click OK.

Delete a User Account
From the SSO Agent Configuration Tools dialog box:
1. Select Edit > User Management.
The User Management Form appears.

2. Select the account to delete.
3. Click Delete User.
The Delete User dialog box appears.

4. Verify the User Name is for the account you want to delete.
5. Click OK.

Configure the SSO Agent
To configure your SSO Agent, you can add, edit, and delete information about your Active Directory
domains. When you add or edit a domain, you must specify a user account to use to search your
Active Directory server. We recommend that you create a specific user account on your server with
permissions to search the directory and with a password that never expires.

Add a Domain
From the SSO Agent Configuration Tools dialog box:
1. Select Edit > Add Domain.
The Add Domain dialog box appears.

2. In the Domain Name text box, type the name of the domain.
For example, type example.com .
3. In the NetBIOS Domain Name text box, type the first part of your domain name, without the
top level extension (such as, .com).
For example, type example .
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4. In the IP Address of Domain Controller text box, type the IP address of the Active Directory
server for this domain.
5. In the Port text box, type the port to use to connect to this server.
The default setting is 389.
6. In the Searching User section, select an option:
n Distinguished Name (DN) (cn=username,cn=users,dc=example,dc=com)
n User Principal Name (UPN) username@example.com
n Pre-Windows 2000 (netbiosDomain\username)
7. In the corresponding text box, type the user information for the option you selected.
Make sure to specify a user who has permissions to search the directory on your Active
Directory server.
8. In the Password of Searching User and Confirm password text boxes, type the password
for the user you specified.
This password must match the password for this user account on your Active Directory server.
9. To add another domain, click OK & Add Next. Repeat Steps 2–8.
10. Click OK.
The domain name appears in the SSO Agent Configuration Tools list.

Edit a Domain
When you edit an SSO domain, you can change all the settings except the domain name. If you want
to change the domain name, you must delete the domain and add a new domain with the correct name.
From the SSO Agent Configuration Tools dialog box:
1. Select the domain to change.
2. Select Edit > Edit Domain.
The Edit Domain dialog box appears.

3. Update the settings for the domain.
4. Click OK.

Delete a Domain
From the SSO Agent Configuration Tools dialog box:
1. Select the domain to delete.
2. Select Edit > Delete Domain.
A confirmation message appears.

3. Click Yes.
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Configure Clientless SSO
If the SSO Client is not installed or is not available, you can configure the SSO Agent to use clientless
SSO to get user login information from the Event Log Monitors, which are installed on your domain
controllers and members. When a user tries to authenticate, the SSO Agent sends the user name and
IP address of the client computer to the Event Log Monitor. The Event Log Monitor then uses this
information to query the client computer over TCP port 445 and retrieve the user credentials from the
logon events on the client computer. The Event Log Monitor the user credentials from the client
computer and contacts the domain to get the user group information for the user. The Event Log
Monitor then provides this information to the SSO Agent.
After you install the SSO Agent, you must add the domain information of the domains where the Event
Log Monitors are installed to the SSO Agent configuration in the Event Log Monitor Contact
Domains list. If you have only one domain and the SSO Agent is installed on the domain controller, or
if you have more than one domain and the Event Log Monitor is on the same domain as the SSO Agent,
you do not have to specify the domain information for the domain controller in the SSO Agent
configuration Event Log Monitor Contact Domains list.
If you do not install the SSO Client on your user's computers, make sure the Event Log Monitor is the
first entry in the SSO Agent Contacts list. If you specify the SSO Client as the primary contact, but
the SSO Client is not available, the SSO Agent queries the Event Log Monitor next, but this can cause
a delay.
Before you configure and enable the settings for clientless SSO, you must make sure the client
computers on your domain have TCP 445 port open, or have File and printer sharing enabled, and have
the correct group policy configured to enable the Event Log Monitor to get information about user login
events. If this port is not open and the correct policy is not configured, the Event Log Monitor cannot
get group information and SSO does not work properly.
On your domain controller computer:
1. Open the Group Policy Object Editor and edit the Default Domain Policy.
2. Make sure the Audit Policy (Computer Configuration > Windows Settings > Security
Settings > Local Policies > Audit Policy) has the Audit account logon events and Audit
logon events policies enabled.
3. At the command line, run the command gpupdate/force /boot .
When the command runs, this message string appears:
Updating Policy… User Policy update has completed successfully. Computer
Policy update has completed successfully.

4. Reboot the domain controller computer.
You can add, edit, and delete domain information for clientless SSO.
From the SSO Agent Configuration Tools dialog box:
1. Select Edit > Clientless Settings.
The Clientless Settings dialog box appears.
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2. In the SSO Agent Contact list, select the check box for each contact for the SSO Agent:
n SSO Client
n Event Log Monitor
n Active Directory Server
Active Directory Server is always enabled but cannot be the first option in the list.

3. To change the order of the SSO Agent Contacts, select a contact and click Up or Down.
4. Add, edit, or delete a domain.
5. Click OK to save your settings.

Add a Domain
You can specify one or more domains for the Event Log Monitor to contact for user login information.
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Note If you have only one domain, and the Event Log Monitor is installed on the same
domain member as the SSO agent, you do not have to specify the domain.
From the Clientless Settings dialog box:
1. Click Add.
The Event Log Monitor Settings dialog box appears.

2. In the Domain Name text box, type the name of the domain that you want the Event Log
Monitor to contact for login credentials.
3. In the IP Address of Domain Controller text box, type the IP address for the domain.
4. Click OK.
The domain information you specified appears in the Event Log Monitor Contact Domains list.

Edit a Domain
From the Clientless Settings dialog box:
1. Select the domain to change.
2. Click Edit.
The Event Log Monitor Settings dialog box appears.

3. Update the settings for the domain.
4. Click OK.

Delete a Domain
From the Clientless Settings dialog box:
1. Select the domain to delete.
2. Click Delete.
The domain is removed from the list.
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Web Proxy Authentication Logout
Web Proxy Portal and Proxy authenticated users have the ability to log out of their sessions. This is
useful for shared computers that are used by several different users to make that each user uses their
own Web Proxy policies when they browse web sites.
When the user logs in to the Web Proxy Portal Authentication page, a URL is displayed that redirects
the user to the portal logout page where “<my_hostname>” is the address of the WatchGuard XCS. We
recommend the user bookmarks this URL in their client web browser.
http://<my_hostname>/portal/logout

For Proxy authenticated users that do not use the Portal, you must provide this URL to the end users.

Flush All Web Single Sign-on Sessions
To force a logout of all Portal and Proxy IP address-based authenticated users, you can flush all
authenticated sessions from the Activity > Status > Utilities page. Web Proxy users must reauthenticate before they can get access to web sites through the Web Proxy.
Note In a cluster, the Flush button is available only on the Primary cluster system.
1. Select Activity > Status > Utilities.

2. In the Flush Web Single Sign-On Sessions section, click the Flush button.
The system flushes all Web Proxy authenticated sessions for both Proxy and Portal IP
address-based authenticated users.
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Web URL Block Lists
URL Block Lists contain a list of domains and IP addresses of URLs that have appeared previously in
spam, phishing, or other malicious web site content.
TheURL Block Lists featureallows youto block access toweb siteURLs thatappear ona URLBlock List.
To enable URL Block Lists:
1. Select Configuration > Web > URL Block Lists.
The Web URL Block Lists page appears.

2.
3.
4.
5.
6.

Select the Enable Web URL Block Lists check box.
From the Action drop-down list, select an action to take if a URL is on a URL Block List.
Select Reject to reject the web request.
Select Just Log to allow the request and record the event in the Web Proxy log.
Select Notify user to enable notification to the end user if the web site is blocked.
You can customize the notification sent to the end user.

7. Select Notify administrator to enable notification to the administrator if the web site is
blocked.
You can customize the notification sent to the administrator.

Note Notifications are not sent for a Just Log action.
8. Select UBL Whitelist to configure domains that bypass URL Block List processing.
9. Select UBL Domains to customize the URL Block List lookup domains to use for URL checks.
10. Click Apply.
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Configure URL Block Lists in a Policy
The URL Blocking option uses the URL Block List feature to block access to specific web sites.
To enable URL Blocking in a policy:
1.
2.
3.
4.
5.
6.

Select Configuration > Web > More > URL Block Lists.
Select the Enable Web URL Block Lists check box.
Click Apply.
Select Security > Policies > Policies.
Select an existing policy to configure its settings, or create a new policy.
Select HTTP.

7. From the URL Blocking drop-down list, select Enabled, or select Undefined to use the
inherited settings from another overriding policy or the Default policy.
8. Click Edit to set the Action to either Reject to reject the connection (default), or Just Log to
allow the connection and record the issue in the Web Proxy log.
9. You can enable and configure notifications for the administrator and end user.
You can customize the notification only in the Default policy. Notifications are only sent for a
Reject action, not Just Log.
10. Click Apply.
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Web Reputation
The Reputation Enabled Defense (RED) service helps to identify web sites that contain malicious or
inappropriate content. It reports behavioral information based on a collection of statistics about a web
site URL. The statistics are based on the occurrences of the web site hosting viruses, spyware, and
malware. This information is collected from installed WatchGuard products worldwide that share their
Web Anti-Virus and Spyware scanning results with RED.
The Web Reputation feature queries the RED service for the reputation of the requested web site URL.
With this information, the WatchGuard XCS can make a decision about whether to allow or block a
web site request based on the reputation score of the web site URL.

Reputation Score
The reputation score can be from 1 to 100. A reputation closer to 1 is good and indicates the web site is
extremely reliable and rarely hosts viruses or spyware. A reputation closer to100 is bad and indicates
the web site is extremely unreliable and often spreads viruses and spyware. A web site with no
previous information from any source is assigned an initial neutral value of 50.
You can set a reputation threshold over which web URLs are rejected. For example, if you set the
threshold to 90, any web URL with a reputation score greater than 90 is rejected. This prevents your
web clients from access to URLs that have historically hosted viruses and spyware.
The reputation score is tracked for a specific URL path, for example, www.example.com/url/path.
The corresponding top-level domain reputation, example.com, is independently tracked, and the
amount of web site URLs with a good reputation at that top-level domain reflects positively on its
reputation, even if a sub-domain or hosted URL contains viruses or spyware and has a bad reputation.
For example, a URL that hosts a virus at www.example.com/url/path/virus.exe can have a reputation
of 98, but the top-level domain site www.example.com can have reputation score of 55.

Web Reputation Statistics Sharing
When you enable Web Reputation, web scanning statistics from your device are shared with the
Reputation Enabled Defense service. This information is collected from installed WatchGuard
products worldwide to generate the reputation score for web sites based on Anti-Virus and Spyware
scanning results (Clean, Virus-infected, Spyware-infected, and Suspicious).
Note Web Reputation queries and statistics sharing uploads to RED use UDP port 10108.
This port must be opened up on your network firewall if the WatchGuard XCS is
located behind the firewall.

Bypass Anti-Virus and Spyware Scanning
You can bypass Anti-Virus and Spyware scanning for web requests if the reputation of the requested
web site URL is below a specified bypass threshold. For example, if you set the bypass threshold to
10, any web site with a reputation score lower than 10 bypasses Anti-Virus and Spyware scanning.
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This feature increases the performance of web processing because the WatchGuard XCS must do
only minimal scanning for web sites with good reputations where the probability of harmful content is
minimal.

Configure Web Reputation
To configure Web Reputation:
1. Select Configuration > Web > Reputation Enabled Defense.
2. To enable Web Reputation lookups and allow statistics to be shared with RED, select the
Enable check box.

3. Select the Reject on Reputation check box to enable reputation lookups for web URLs to the
RED network.
4. In the Reject Threshold text box, type a threshold over which a web site is blocked. You must
enter a value between 1 and 100. The default value is 90. If the reputation of a web site is
greater than this value, the web request is rejected. The lower the reputation threshold, the
greater the chance you could block a legitimate web site.
5. In the Bypass Scanning section, select the Bypass Anti-Virus & Spyware scanning for
good reputation check box to bypass Anti-Virus scanning for web requests if the reputation of
the requested web site URL is below the specified threshold.
This feature increases the performance of web processing because the XCS device does only
minimal scanning for web sites with good reputations where the probability of harmful content is
minimal.
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6. In the Bypass Threshold text box, type the threshold below which web sites bypass Anti-Virus
scanning.
You must enter a value between 1 and 100. The default is 10. The higher the bypass threshold, the
greater the chance you could bypass Anti-Virus and Spyware scanning for a malicious web site.
7. Select Notify user to send a notification to the end user if the web site is blocked.
You can customize the notification sent to the end user.

8. Select Notify administrator to send a notification to the administrator if the web site is
blocked.
You can customize the notification sent to the administrator.

9. Click Apply.

Configure Web Reputation in a Policy
The Web Reputation feature queries the RED service for the reputation score of the requested web site
URL. With the information returned from RED, the WatchGuard XCS can make a decision about
whether to allow or block a web site request based on the reputation of the web site.
To configure Web Reputation settings in a policy:
1.
2.
3.
4.
5.
6.
7.

Select Configuration > Web > Reputation Enabled Defense.
Select the Enable check box.
Click Apply.
Select Security > Policies > Policies.
Select a policy to configure, or create a new policy.
In the policy editor, select the HTTP section.
In the Web Reputation Enabled Defense section, enable or disable Reject on Reputation
for this policy.
Select “Undefined” to use the inherited value from another policy, the Default policy, or the global
settings.

8. From the Reputation Threshold drop-down list, select Define to enter a value.
Select “Undefined” to use the inherited value from another policy, the Default policy, or the global
settings.

Type a reputation threshold score over which a web site is blocked. If the reputation score of a
web site is greater than this value, it is blocked. Note that the lower the reputation threshold, the
greater the chance that a valid web site is blocked.
9. In the Action field, click Edit to define an action to take if a web site reputation score exceeds
the configured Reputation Threshold.
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n
n

Reject – Rejects the web request and prevents clients from access to the web site.
Just Log – Web sites that exceed the Reputation Threshold are recorded in the Web Proxy
log file, but no action is taken on the web site URL and the web connection is not blocked.

You can enable and configure notifications for the administrator and end user when a web site is
blocked because of a bad reputation. You can customize the notification only in the Default
policy.
Notifications are only sent for a Reject action, not Just Log.
10. From the Bypass Anti-Virus Scanning, drop-down list, enable or disable the option to bypass
Anti-Virus scans for web connections if the reputation score of the requested web site is below
the specified threshold.
This feature increases the performance of web processing because the XCS device does only
minimal scans for web sites with good reputations where the probability of harmful content is
minimal.
11. From the Bypass Threshold drop-down list, select Define and type a threshold below which
web sites bypass Anti-Virus scanning.
Select “Undefined” to use the inherited value from another policy, the Default policy, or the global
settings.

12. Click Apply.

Web Reputation Lookup
You can enter a specific web site URL to check its current reputation score. You must have the
Reputation Enabled Defense feature enabled to perform a web reputation lookup.
For more information, see Reputation Enabled Defense (RED) and Configure Web Reputation.
To check the reputation of a web site URL:
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1. Select Activity > Status > Utilities.
2. In the Diagnostics section, click Web RED Lookup.

3. Enter a web URL address.
You do not have to enter the prefix http://.

For example, www.example.com
4. Click Lookup.
The results of the reputation lookup appear.

A reputation closer to 1 indicates the web site is extremely reliable and rarely hosts viruses or
spyware. A reputation closer to 100 indicates the web site is extremely unreliable and often
spreads viruses and spyware. A web site with no previous information from any source is
assigned an initial neutral value of 50.
The top-level domain receives an independent reputation of any URL it hosts, and its overall
reputation score is continually adjusted based on the amount of URLs it hosts with good and
bad reputations.

Traffic Accelerator
The WatchGuard Traffic Accelerator solution provides several web traffic enhancements to reduce
bandwidth consumption, server loads, and network latency, which results in better network
performance and availability.
The WatchGuard XCS TrafficAccelerator includes these features:
n

n

Streaming Media Bypass – To manage streaming media traffic, the WatchGuard Traffic
Accelerator can bypass streaming media content to reduce the strain on bandwidth resources.
Web Cache – The web cache feature of the WatchGuard Traffic Accelerator solution enables
faster retrieval of web sites because it provides temporary storage of web data. This feature
reduces bandwidth consumption and improves performance for subsequent accesses of these
web sites because the data and images are read from the disk cache instead of going out to the
Internet.
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Web Cache
The Web Proxy uses a disk cache that caches data and images from web sites visited by users of the
Web Proxy. This feature reduces bandwidth consumption and improves performance for subsequent
accesses of these web sites because the data and images are read from the disk cache instead of
going out to the Internet to retrieve the data. The web request is compared to the cached data of the
requested web site to make sure it has the latest data to update the disk cache with any web site
updates.
For greater efficiency, some policies are also cached, such as those where large amounts of web
traffic with the same content triggers a specific policy. In other cases, access of cached data is still
sent to the Web Proxy content scanners because different users can have different HTTP content
policies applied to them.
All file types are cached depending on the web server HTTP directive that identifies what files are
allowed to be cached. For example, HTTP redirects and cookies are not cached for security reasons.
There is no limit to the size of a file that can be cached.
The web cache is enabled by default to provide faster retrieval of web site data from the local disk
cache. In some high-volume environments, the web cache can grow to sizes that result in reduced
cache performance. In these cases, we recommend you disable HTTP caching.
Ifthereis noexplicitexpiry timesetby awebserver,theCache Expiry Timeoptionindicates themaximum
time(indays)files resideinthewebcacheuntilthey areexpiredandpurged.Thedefaultis 5days.
n

n

If there is no explicit expiry time set by a web server, the web proxy calculates the expiration
time using its own calculations. If the result of this calculation is greater than the value
configured in the Cache Expiry Time, the cache entry is purged.
If a cache entry has an explicit expiry time set by a web server, the web proxy uses this expiry
time and the Cache Expiry Time setting on the web proxy is ignored.

To configure the advanced Web Proxy cache settings:
1. Select Configuration > Web > Traffic Accelerator.
2. Clear the Enable HTTP Caching check box if you want to disable the web cache.
Only disable the web cache if you are in a high-volume environment and the cache size is reducing
cache performance.

3. In the Cache Expiry Time text box, type the number of days that files reside in the cache until
they are removed.

3. Click Apply
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Note These settings are advanced options and must only be modified with guidance from
Technical Support. Misconfiguration can negatively affect performance.
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Web Cache Disk Use
The web disk cache is located in the local mail storage area. To see the details of this disk partition:
1. Select Activity > Status > Dashboard.
2. Select System Summary.
3. In the Disk Usage section, the Mail Storage Area(/server/mail partition) indicates the
percentage of disk space used and the space available in the web disk cache. If you store local
mailboxes on the server, this partition also includes stored local mail.

Flush the Web Cache
By default, the WatchGuard XCS is set to automatically purge the web cache every 5 days to remove
all files that are older than 5 days. You can configure this option on the Configuration > Web > Traffic
Accelerator page.
On the Activity > Status > Utilities page, you can manually purge the web cache. You may want to
purge the entire web cache to resolve issues with certain web pages that do not updated with newer
content, or problems with connections to specific web sites.
To flush the web cache:
1. Select Activity > Status > Utilities.
2. Go to the Utilities section.
3. Adjacent to Flush Web Cache, click Flush.
This action completely empties the web cache and restarts the Web Proxy service.

Flush Web Cache URLs
You can flush a specific URL from the web cache if you have problems loading or refreshing the URL.
The URL must be specified exactly the way it is typed including the protocol.
For example,
http://www.example.com/index.html or ftp://ftp.example.com.
To flush the cache entry for a specific URL:
1. Select Activity > Status > Utilities.
2. In the Flush URL from Web Cache text box, type the required URL, for example,
http://www.example.com/index.html .
3. Click Flush.
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Streaming Media Bypass
The Web Proxy can proxy and scan embedded streaming media content to provide quick delivery of
data to the requesting web client.
You can configure a list of specific MIME content types that bypass Web Proxy threat and content
control scanners and are delivered immediately to the web client. A predefined default list of common
streaming media types is configured to bypass scanners. When you skip a streaming media type, all
scanners (Anti-Virus, the Objectionable Content Filter, Content Scanning, and Attachment Control) are
bypassed.

Configure Skipped MIME Types
To modify the list of MIME types that bypass content and threat scanning:
1. Select Configuration > Web > Traffic Accelerator.

2. Use the arrow icons to add or remove items from the Available Types and Do Not Scan list.
3. You can add a new MIME type if it is not in the current list.
Type a valid MIME time in the texts box, for example, video/x-flv for Flash video, and then
click Add to List
The new type is immediately added to the Do Not Scan section.

4. Click Apply.
These are the default MIME types that bypass scanners:
MIME Type

Description

application/smil

Synchronized Multimedia Integration Language

application/vnd.ms.wms-hdr.asfv

Windows Media

application/vnd.ms.wms-hdr.asfv1

Windows Media

application/x-fcs

Flash Communication Server

application/x-javascript

Javascript

application/x-mms-framed

Windows Media

application/x-quicktimeplayer

Quicktime Player
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MIME Type

Description

application/x-quicktime-response

Quicktime Player response

application/x-shockwave-flash

Shockwave Flash

application/x-wms-logstats

Windows Media

audio/mp4

MP4 Audio

audio/mpeg

MP3 or other MPEG audio

audio/x-scpls

Shoutcast Playlist

image/x-icon

Website favicon format

video/flv

Flash video

video/m4v

Video (Protected)

video/mp4

MP4 video

video/mpeg

MPEG-1 video

video/quicktime

QuickTime video

video/vnd.mpegurl

M4U format

video/x-dv

Digital Video File

video/x-flv

Flash Video

video/x-m4v

Video (Protected)

video/x-ms-asf

Windows Media

video/x-msvideo

Video for Windows (AVI)

video/x-ms-wmv

Windows Media Video

video/x-sgi-movie

SGI Movie
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Web Client Configuration
Depending on the deployment configuration, web clients must have their web browser proxy set to the
address of the WatchGuard XCS, for example, hostname.example.com:8080. The disadvantage of
this method is that it is not scalable for large user environments in which manual browser
reconfiguration is not practical. You can also implement proxy auto-discovery or traffic redirection
methods that use additional routers or traffic managers.
To avoid the need for manual web browser configuration, we recommend that you use the Transparent
Mode deployment. See Transparent Mode for more details on the Transparent Mode deployment.
To manually set a proxy server setting in Internet Explorer 7 or greater:
1.
2.
3.
4.

Select Tools > Internet Options.
Select the Connections tab.
Click LAN Settings.
In the Proxy server section, type the hostname or IP address of the proxy, for example,
hostname.example.com , and set the port used by the proxy, for example, 8080 .

To manually set a proxy server setting in Mozilla Firefox 3 or greater:
1.
2.
3.
4.
5.

Select Tools > Options.
Click Advanced.
Select the Network tab.
Click Settings.
In the Manual Proxy Configuration section, type the hostname or IP address of the proxy, for
this example, hostname.example.com , and set the port used by the proxy, for this example, 8080 .

Optionally, if your organization uses an automatic proxy configuration, you can configure your web
client to detect automatic proxy settings.

IP Authentication Browser Configuration Mode
If you use IP address-based authentication in Web Proxy mode (not in Transparent Mode), the client
web browser tries to route the authentication request and response through the proxy itself. This can
cause a proxy loop because the proxy server uses its own IP address instead of the client. An error is
displayed in the web browser that prevents authentication to the proxy server.
To prevent this issue, you must configure the client browser to bypass the local proxy server address.
Note This browser configuration change is not required when using IP-based authentication
in Transparent Mode.
To bypass the proxy server address in Internet Explorer 7 or greater:
1.
2.
3.
4.
5.

Select Tools > Internet Options.
Select the Connections tab.
Click the LAN Settings.
Click Advanced.
In the Exceptions section, type the address of the proxy server, for example, 192.168.1.200 .
You can also add a network wildcard, for example, 192* .
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To bypass the proxy server address in Mozilla Firefox 3 or greater:
1.
2.
3.
4.
5.

Select Tools > Options.
Click Advanced.
Select the Network tab.
Click Settings.
In the No Proxy for: section, type the address of the proxy server, for example,
192.168.1.200 .
You can also add a network, for example, 192.168.1.0/24 .

Automatic Web Proxy Client Configuration
Organizations that want to enforce the use of a proxy policy do not want to manually configure each
individual browser can use these methods for automatic proxy configuration:
n

n

Proxy Auto-Config (PAC) file — A Proxy Auto-Config (PAC) file defines how a web browser
can automatically choose an appropriate proxy server to connect to. The PAC file is a script file
that browsers read and execute to determine which proxy to use.
Web Proxy Autodiscovery Protocol (WPAD) — The Web Proxy Autodiscovery Protocol
(WPAD) is supported by most web browsers to automatically locate a Proxy Auto-Config (PAC)
file, and then use this information to configure the browser's web proxy settings. The protocol
can use DHCP or DNS to locate the PAC file.

PAC File
You can use a PAC file with a web browser’s proxy settings to configure the browser with the proxy
server address. The PAC file can be hosted locally or on a network server. If you use the PAC file with
WPAD, the file must be called “wpad.dat”.
A simple PAC file contains text that sets the address for the proxy. For example,
function FindProxyForURL(url, host){return "PROXY proxy.example.com:8080";}

You can create more advanced proxy configurations.
For example,
function FindProxyForURL(url, host)
{ if (isInNet(host, "192.168.1.0", "255.255.255.0")) {
return "DIRECT"; }
else if (url.substring(0, 5) == "http:") {
return "PROXY 192.168.1.200:8080"; }
else if (url.substring(0, 6) == "https:") {
return "PROXY 192.168.1.200:8080"; }
else { return "DIRECT"; }
}
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In this example, 192.168.1.0 is the local network you want to bypass, and 192.168.1.200 is the
address of the proxy server. You can also use a fully qualified domain name (FQDN), for example,
proxy.example.com.
Replace these example addresses with your local network and proxy server addresses. If the server
fails to respond, then the browser tries to contact the web server directly and does not use the proxy
server.

Load Balance on IP Address
This example assigns even and odd IP addresses to different proxy servers to distribute web proxy
connections:
function FindProxyForURL(url, host)
{
var ipSubs = myIpAddress().split(".");
if ( (ipSubs[3] % 2) == 0 ) {
return "PROXY 192.168.1.200:8080 ; PROXY 192.168.1.201:8080";
} else {
return "PROXY 192.168.1.201:8080 ; PROXY 192.168.1.200:8080"; }
}

Load Balance on URL Address
This example assigns requested URL addresses to specific proxy servers based on the letters in the
URL to distribute web proxy connections:
function FindProxyForURL(url, host)
{ ret = URLhash(url);
if ( (ret % 2) == 0 ){
return "PROXY 192.168.1.200:8080 ; PROXY 192.168.1.201:8080";
} else {
return "PROXY 192.168.1.201:8080 ; PROXY 192.168.1.200:8080";
}
}function URLhash(name){var cnt=0;
var str=name.toLowerCase(name);
if ( str.length ==0) {
return cnt;
}
for(var i=0;i >= str.length ; i++) {
var ch= atoi(str.substring(i,i + 1));
cnt = cnt + ch;
}
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return cnt ;
}
function atoi(charstring)
{

if ( charstring == "a" ) return 0x61; if ( charstring == "b" ) return 0x62;
if ( charstring == "c" ) return 0x63;

if ( charstring == "d" ) return 0x64;

if ( charstring == "e" ) return 0x65;

if ( charstring == "f" ) return 0x66;

if ( charstring == "g" ) return 0x67;

if ( charstring == "h" ) return 0x68;

if ( charstring == "i" ) return 0x69;

if ( charstring == "j" ) return 0x6a;

if ( charstring == "k" ) return 0x6b;

if ( charstring == "l" ) return 0x6c;

if ( charstring == "m" ) return 0x6d;

if ( charstring == "n" ) return 0x6e;

if ( charstring == "o" ) return 0x6f;

if ( charstring == "p" ) return 0x70;

if ( charstring == "q" ) return 0x71;

if ( charstring == "r" ) return 0x72;

if ( charstring == "s" ) return 0x73;

if ( charstring == "t" ) return 0x74;

if ( charstring == "u" ) return 0x75;

if ( charstring == "v" ) return 0x76;

if ( charstring == "w" ) return 0x77;

if ( charstring == "x" ) return 0x78;

if ( charstring == "y" ) return 0x79;

if ( charstring == "z" ) return 0x7a;

if ( charstring == "0" ) return 0x30;

if ( charstring == "1" ) return 0x31;

if ( charstring == "2" ) return 0x32;

if ( charstring == "3" ) return 0x33;

if ( charstring == "4" ) return 0x34;

if ( charstring == "5" ) return 0x35;

if ( charstring == "6" ) return 0x36;

if ( charstring == "7" ) return 0x37;

if ( charstring == "8" ) return 0x38;

if ( charstring == "9" ) return 0x39;

if ( charstring == "." ) return 0x2e;
return 0x20;
}

Bypass the Proxy for Specific URLs and Domains
You can specify URLs and entire web domains to bypass the proxy, for example, local Intranet traffic
or problematic web sites, in the PAC file. The specific PAC file entries for the URLs and domains must
be inserted before the proxy server specification in the PAC file.
function FindProxyForURL(url, host)
{
// our local URLs from the domains below example.com don't need a proxy:
if (shExpMatch(url,"*.example.com/*")) {return "DIRECT";}
if (shExpMatch(url, "*.example.com:*/*")) {return "DIRECT";}
return "PROXY 10.1.77.200:8080; DIRECT";
}
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WPAD with DNS
The DNS-based WPAD mechanism builds a series of URLs that point to a wpad.dat PAC file. The
series of URLs starts with the full primary domain name and continues to progressively shorter
suffixes until the base domain is used. For example, if the full primary domain name is
host.country.example.com, the URLs attempted are:
http://wpad.country.example.com/wpad.dat
http://wpad.example.com./wpad.dat

If the web browser is configured to automatically detect proxy settings, it tries to download the PAC file
from each URL until it either succeeds or runs out of URLs to check. If the client cannot connect to any
of the URLs, then the web browser tries to contact the web server directly and does not use the proxy
server.

WPAD with DHCP
The DHCP-based WPAD mechanism passes the URL of the PAC file as option number 252 in the
DHCP lease granted to the system. If the web browser is configured to automatically detect proxy
settings, it gets the URL from the DHCP lease to download the PAC file. The DHCP Server must be
configured to use option 252 (that contains the URL of PAC file) in the DHCP lease.

Web Proxy Auto Configuration
You can upload a PAC file that client web browsers can use with WPAD or manual configuration to
retrieve the PAC file settings.
Note PAC files are not replicated in a cluster or in Centralized Management. In a cluster
environment, only one system in the cluster must be used to host the PAC file.
To upload a PAC file to the WatchGuard XCS:
1. Select Configuration > Web > Proxy Auto Configuration.

2. Click Browse to select a file.
This file must be a text file. The file can have any name, but it is made available to web clients as
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wpad.dat.

3. Click Apply.
The contents of the PAC file appear.

4. Configure the web browser clients to use WPAD automatic settings, or with the URL to the
WatchGuard XCS PAC file.
For example:
http://proxy.example.com/wpad.dat

Internet Explorer Client Configuration
To configure proxy server settings in Internet Explorer 7 or greater:
1.
2.
3.
4.

Select Tools > Internet Options.
Select the Connections tab.
Click LAN Settings.
Select one of these options:
n

n

To use WPAD to automatically detect the proxy settings for the network:
Select Automatically detect settings. The web browser uses WPAD methods to
discover the location of the configuration file with DNS or DHCP.
To manually enter the script path:
Select the Use automatic configuration script check box and enter the location of the
PAC file. The PAC file can be stored locally or at a network URL.
For example,
http://proxy.example.com/wpad.dat

Mozilla Firefox Client Configuration
To configure proxy server settings in Mozilla Firefox 3 or greater:
1.
2.
3.
4.
5.

Select Tools > Options.
Select Advanced.
Select the Network tab.
Click Settings.
Select one of these options:
n

n

To use WPAD to automatically detect the proxy settings for the network:
Select Auto-detect proxy settings for this network. The web browser uses WPAD
methods to discover the location of the configuration file with DNS or DHCP.
To manually enter the URL for the configuration:
Select the Automatic proxy configuration URL option and enter the location of the PAC
file.
The PAC file can be stored locally or at a network URL.
For example:
http://proxy.example.com/wpad.dat

452

WatchGuard XCS

Web Scanning

Client Browser Notifications
If a web request is blocked by any security or content scanning feature, the web client displays an error
notification.
For example,

The error message shows the reason why the web request is rejected. In this example, the web
request is blocked because the web site is in a blocked URL Categorization category.
You can customize the HTTP notifications in policies in the Default policy.
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Web Proxy Access with Policies
The Web Proxy uses policies to define access and content controls for different users, groups, IP
addresses, and domains.
Note When you modify an HTTP policy, it can take up to two minutes for the policy change
to take effect because the Web Proxy service must be restarted. Any current web
sessions, for example, streaming media and logged-in web sessions, are reset.
To configure the Web Proxy settings in a policy:
1.
2.
3.
4.

Select Security > Policies > Policies.
Select a policy to configure, or create a new policy.
In the policy editor, select the HTTP section.
From the HTTP Access and HTTPS Access drop-down lists, select Enabled or Disabled, or
set to Undefined to use the settings inherited from another policy, the Default policy, or the
global settings.
If these options are “Undefined”, they inherit the state of the global setting for the HTTP Proxy
(enabled or disabled).

5. Click Apply.

Web Policy Scanner Actions
For each feature that scans web traffic, you can set a configurable action. These scanners include
inbound and outbound Anti-Virus and Spyware scanning, Attachment Control, Content Scanning, and
the Objectionable Content Filter (OCF).
Note If you use Attachment Control with Web content and set a “Reject” HTTP action for
blocked image types and other web file types, this action effectively stops many web
sites from working correctly because files required to see the web site are blocked.
To configure the Web Proxy actions in a policy:
1. Select Security > Policies > Policies.
2. Select a policy to configure, or create a new policy.
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3. In the policy editor, select the Anti-Spam and Anti-Virus section (for Anti-Spam, Anti-Virus, and
Spyware), or the Content Control section (for Attachment Control, Content Scanning, and OCF).
In this example, you can select actions for inbound and outbound Anti-Virus for HTTP.

4. In the Action field, click Edit to define an action to take:
n
n

Reject – Rejects the web request and prevents clients from access to the web site.
Just Log – Web sites are recorded in the Web Proxy log file, but no action is taken and the
web connection is not blocked.

You can enable and configure notifications for the administrator and end user when a web site is
blocked. You can customize the notification only in the Default policy.
Notifications are only sent for a Reject action, not Just Log.

HTTP Trusted and Blocked Sites
The Trusted Sites list allows the administrator to upload a list of web sites that bypass all scanning
features. This includes Anti-Virus, HTTP content control (Attachment Control, Objectionable Content,
Content Scanning), and URL filtering features (URL Blocking and URL Categorization).
The Blocked Sites list contains a list of domains and IP addresses that are blocked to end users that
access these sites through the Web Proxy.
Note If a site appears in both the Trusted and Blocked Sites list, the Trusted Sites list takes
precedence.
Any web sites defined in the HTTP Trusted or Blocked Sites list override the URL
Categorization block list.

Create a Trusted or Blocked Sites List
To create a list of domains for a Trusted or Blocked Sites list:
1. Create a list of domains and IP addresses in a text file. Use one domain per line.
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For example,
example.com
example2.com
192.168.1.128
a123:b123::c123

All subdomains of the specified domain are included. For example, the domain example.com
includes subdomain.example.com .
2.
3.
4.
5.

Select Security > Policies > Policies.
Select your policy.
Select HTTP.
In the Trusted Sites or Blocked Sites drop-down list, select an existing dictionary, or click
Add or Edit to manage your dictionaries.
6. Enter or upload your dictionary.
7. Set the Type to Domain or IP. Use Domain if you mix IP addresses and domain names in the
same list.
8. Click Apply.
In the HTTP policy, you can now select the list as a Trusted or Blocked Sites list.

Configure Trusted and Blocked Sites Lists
To configure the HTTP Trusted and Blocked Sites lists:
1.
2.
3.
4.

Select Security > Policies > Policies.
Select an existing policy, or create a new policy.
Select HTTP.
Set Trusted Sites to None to make sure that all web sites browsed through the Web Proxy are
scanned by the Web Proxy’s scan features, or select a predefined list of Trusted Sites from the
drop-down list.
This list of web sites bypass all HTTP scans for users of the Web Proxy.

5. Set Blocked Sites to None to not block any specific web sites, or select a predefined list of
Blocked Sites from the drop-down list.
These sites are blocked and Web Proxy users cannot get access to this sites.

Web Proxy URL and IP Address Blocking
The Web Proxy does not do PTR (Pointer record) reverse lookups for each site browsed to, and when
you block a specific hostname, it does not block the associated IP address for that hostname if it is
specified. You must add the IP address separately to a block list to prevent access to the web site with
its IP address.
For example, if you want to block www.example.com , you must make sure you block both the domain
name www.example.com , and its corresponding IP address, for example, 192.168.1.128 .
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If you enter an IP address, it blocks both the IP and domain name if the domain name resolves to that
same address.
If you use an address list with the Trusted and Blocked Sites feature, you can add domain names and
IP addresses to the same list using a Domain type dictionary.
For example,
example.com 192.168.1.128 website.com 10.10.1.10

HTTP Upload and Download Limit
In the HTTP section of a policy, you can set a limit on the size of both HTTP uploads and downloads to
prevent unnecessary load on network and system resources. When a file exceeds the specified
threshold, the file can be blocked, or scanning can be bypassed to allow the upload and download of
large files without the use of a large amount of system scanning resources.
To configure HTTP upload and download limits:
1.
2.
3.
4.

Select Security > Policies > Policies.
Select an existing policy or create a new policy.
Select HTTP.
In the Performance Options section, type the largest size (in MB) allowed for an HTTP upload
or download.
The default is 7 MB. Leave the field defined as blank or “0” for no limit. Select Undefined to use
the inherited settings from another overriding policy or the Default policy.

5. Set the Download Limit Action and Upload Limit Action that is applied when the file
exceeds the size threshold:
n

n

n
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Undefined – Any limits and actions on downloads and uploads use the inherited settings
from another overriding policy or the Default policy.
Block – The file transfer is blocked, and an error message is sent to the web client to
indicate the reason the download or upload was blocked.
Bypass – The file transfer is not blocked and bypasses any HTTP content scans. This
allows the upload and download of larger files and prevents them the use of too many scan
resources because of their size. This is the default value.

457

Web Scanning

URL Categorization
URL Categorization is a licensed option you can use together with the Web Proxy. This feature
prevents access to HTTP and HTTPS web sites based on a predefined Control List of blocked web
sites organized in several topic categories. Because it transparently blocks undesirable Internet
content, URL Categorization can assist in productivity management and reduce network bandwidth
consumed by Internet browsing. Web site filtering prevents clients in an organization from connections
to non-business related web sites, provides protection against malicious web sites, prevents viruses
and malware from entering an organization, and prevents users from visits phishing sites.
URL Categorization uses a single global Control List database of millions of web sites classified into
over 50 categories from hundreds of countries and in over 65 languages. The list of web sites and their
categories is continuously updated, and updates to the Control List database are downloaded daily by
the XCS system.
URL Categorization filters web sites based on the Fully Qualified Domain Name (FQDN), for example,
www.example.com. You can block or allow any specific category of web sites. The
URL Categorization feature supports scanning of both HTTP and HTTPS URLs.
Note URL Categorization of HTTPS URLs is not supported in Transparent web proxy mode.
You can also configure URL Categorization and category selection with policies, and specify a list of
web sites that are exempt from categorization so they are not blocked by the URL Categorization
feature.

Uncategorized Sites
Select the "Uncategorized" category to block web sites that are cannot be classified in any specific
category. The “Uncategorized” category is not selected by default.
Note Be careful when you enable this category as you could block legitimate external or
internal web sites, or specific pages of those sites even if the primary page is part of a
known category. Use the Bypass URL Categorization feature in an HTTP policy to
prevent trusted sites from being blocked.

URL Categories
These are the default web site categories for URL Categorization:
URL Categorization Categories
Adult/Sexually Explicit

Kids Sites

Advertisements & Popups

Motor Vehicles

Alcohol & Tobacco

News

Arts

Peer-to-Peer

Blogs & Forums

Personals & Dating
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URL Categorization Categories
Business

Philanthropic & Professional Orgs.

Chat

Phishing & Fraud

Computing & Internet

Photo Searches

Criminal Activity

Politics

Downloads

Proxies & Translators

Education

Real Estate

Entertainment

Reference

Fashion & Beauty

Religion

Finance & Investment

Ringtones/Mobile Phone Downloads

Food & Dining

Search Engines

Gambling

Sex Education

Games

Shopping

Government

Society & Culture

Hacking

Spam URLs

Health & Medicine

Sports

Hobbies & Recreation

Spyware

Hosting Sites

Streaming Media

Illegal Drugs

Tasteless & Offensive

Infrastructure

Travel

Intimate Apparel & Swimwear

Violence

Intolerance & Hate

Weapons

Job Search & Career Development

Web-based Email
Uncategorized

Default Blocked Categories
These web site categories typically contain inappropriate and offensive content, and are blocked by
default:
Default Blocked Categories
Adult/Sexually Explicit

Phishing & Fraud

Alcohol & Tobacco

Spam URLs
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Default Blocked Categories
Criminal Activity

Spyware

Gambling

Tasteless & Offensive

Hacking

Violence

Illegal Drugs

Weapons

Intolerance & Hate

Categories to Block if Required by an Organization
These additional web site categories could be blocked based on the requirements of an organization.
These categories include blogs, games, webmail, and streaming media sites.
Categories to Block if Required by an
Organization
Advertisements & Pop-Ups

Personals and Dating

Blogs & Forums

Photo Searches

Chat

Proxies & Translators

Downloads

Ringtones/Mobile Phone Downloads

Games

Sex Education

Hosting Sites

Sports

Intimate Apparel & Swimwear

Streaming Media

Job Search & Career Development

Travel

Peer-to-Peer

Web-based Email

Categories to Block to Enhance Productivity
These web site categories can be blocked to increase productivity in an organization, if required.
These categories include news, entertainment, and shopping web sites.
Categories to Block to Enhance Productivity
Computing & Internet

Kid's Sites

Business

Motor Vehicles

Computing & Internet

News

Education

Philanthropic & Professional Orgs.

Entertainment

Politics

Fashion & Beauty

Real Estate
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Categories to Block to Enhance Productivity
Finance & Investment

Reference

Food & Dining

Religion

Government

Search Engines

Health & Medicine

Shopping

Hobbies & Recreation

Society & Culture

Infrastructure
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Configure URL Categorization
To configure URL Categorization:
1. Select Configuration > Web > URL Categorization.

2. Select the Enable URL Categorization blocking check box.
You cannot enable URL Categorization until the Control List is downloaded, and this check box will
be disabled until the download is complete.

Note In a cluster, the Control List is not replicated from a cluster Primary to Secondary
systems. To update the Control List on the Secondary, change the run mode to
Standalone, update the Control List, and switch back to Secondary mode.
3. Select the Enable checking of IP addresses check box (enabled by default) to check the
resolved IP addresses of URLs against the URL Categorization Control List.
If you enable IP address checking, legitimate URLs can be blocked by URL Categorization
because they originate from a shared IP address where other blocked sites also originate. A
best effort is made to resolve the IP address of the URL, however, IP address blocking may not
immediately take effect for an URL the first time it is browsed to because the address may not
have been immediately resolved before the request was processed.
For each category, select the corresponding option to enable blocking of the web sites in that
category, or clear the check box to allow clients to connect to the web sites in that category.
4. Click Apply.

Configure URL Categorization in a Policy
You can customize URL Categorization blocking and the Control List categories to use when you
create access control policies.
To configure URL Categorization settings in a policy:
1.
2.
3.
4.
5.
6.
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Select Configuration > Web > URL Categorization.
Select the Enable URL Categorization blocking check box.
Click Apply.
Select Security > Policies > Policies.
Select which policy to configure, or create a new policy.
In the policy editor, select the HTTP section.
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7. In the URL Categorization section, enable or disable URL Categorization blocking for this
policy, and select which categories are allowed or blocked.
Select “Undefined” to use the inherited value from another policy, the Default policy, or the global
settings.

8. Click Edit to modify the HTTP action of the message if the URL is blocked by URL
Categorization.
n
n

Reject – Rejects the web request and prevents clients from access to the web site.
Just Log – Categorized web sites are recorded in the Web Proxy log file, but no action is
taken on the web site URL and the web connection is not blocked.

You can enable and configure notifications for the administrator and end user when a web site is
blocked because of URL Categorization. You can customize the notification only in the Default
policy.
Notifications are only sent for a Reject action, not Just Log.
9. From the Bypass URL Categorization drop-down list, select a list that contains the web site
domains that are exempt from categorization by the URL Categorization feature.
See Bypass URL Categorization for more details on this feature and how to upload a list of web
domains to bypass.

Control List Updates
Click Update Control List to manually download and apply the latest URL Categorization Control List.
The Control List Status section displays the date of the latest Control List download. Updates to the
Control List are automatically downloaded every 24 hours at 12:00 AM. Control List database updates
are incremental and only take a short amount of time to complete after the initial Control List download.
URL Categorization uses TCP port 80 to download the Control List. This port must be open for the
WatchGuard XCS if the device is located behind a network firewall.
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The status of the download can be seen from Activity > Logs > System.
For example,
May 22 13:21:16 host spl: sc_download=started May 22 13:21:16 host spl: sc_
download=Download in progress

Bypass URL Categorization
The Bypass URL Categorization feature allows you to create a list of web site domains or IP
addresses that are exempt from URL Categorization. This enables you to create a list of specific
external or internal web sites to make sure they are not blocked.
We recommend that you also add any local trusted sites that use an internal IP address to the bypass
list to prevent any web sites on the internal network from being blocked by URL Categorization.
To create a list of web site domains:
1. Create a list of domains and IP addresses in a text file, with one domain per line.
For example,
example.com example2.com example3.com 10.0.1.10

All subdomains of the specified domain are included. The domain example.com also includes
subdomain.example.com .
2.
3.
4.
5.

Select Security > Policies > Policies.
Select your policy.
Select HTTP.
In the Bypass URL Categorization drop-down list, select an existing dictionary, or click Add
or Edit to manage your dictionaries.
6. Enter or upload your dictionary.
7. Set the dictionary Type to Domain or IP.
Use Domain if you mix IP addresses and domain names in the same list.
8. Click Apply.
You can now select the list for the Bypass URL Categorization option in an HTTP policy.
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Local User Accounts
Local user accounts are available on the WatchGuard XCS that you can use for local mailboxes, admin
accounts, web mail access, User Spam Quarantine, and Trusted/Blocked User Lists.
Note Local users are not available on cluster systems, except for admin users.
To create a local account:
1. Select Administration > Accounts > Local Accounts.
2. Click Add.
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3. In the User ID text box, type a mail box name for the user.
4. In the Forward email to text box, type an optional address to which to forward all mail.
5. In the Set Password text box, type a password for the user.
The user should change this password the first time they log in. If you enable Strong Password
Enforcement (configured in the admin user), the user password must be at least 6 characters
and contain alphabetic and non-alphabetic characters.
6. In the Confirm Password text box, type the user password again for confirmation.
7. In the Disk Space Quota text box, type the maximum disk space, in megabytes (MB), that this
user can use.
To disable the quota, leave this text box blank, or type 0 .
8. In the Accessible IMAP/WebMail Servers section, select any additional servers that this user
can access for IMAP and WebMail.
9. In the Administer Privileges section, you can select additional privileges for this user for the
Tiered Administration or Dedicated Domain Admin features.
See Tiered Administration for details on tiered admin privileges.
See Delegated Domain Administration for details on Delegated Domain Administration.

Upload and Download User Lists
You can upload a list of local accounts in a text file. The file must contain comma or tab separated
entries with one entry per line.
Use this format:
[login],[password],[email address],[quota in MB]

For example:
user1,ajg7rY,user1@example.com,0
user2,gh39ds,user2@example.com,100

You must use a text editor to create the file user.csv.
To update a local account list:
n
n
n

To download the local account list from the WatchGuard XCS, click Download File.
Open the file and update the local account list.
Click Upload File and upload the edited file to the WatchGuard XCS.
Note When you upload a user list, it does not store any Tiered Admin settings. You must
select Tiered Admin privileges in the user account page.
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Tiered Administration
Tiered Administration allows you to assign additional administrative access permissions on a per-user
basis. For example, to designate another user as an alternate administrator, you can select the Full
Admin option in their user profile. To distribute administrative functions, you can configure more
selective permissions to only authorize a user for certain tasks, for example, administer users and
reports, configure Anti-Spam filter patterns, or view the Message History database.
Note You cannot assign LDAP users tiered admin privileges.
To enable tiered admin privileges:
1. Select Administration > Accounts > Local Accounts.
2. Select a specific user profile.

3. Select the corresponding check box to enable a specific admin privilege.
Full Admin
The user has administrative privileges equivalent to the admin user.
Administer Aliases
The user can add, edit, remove, upload, and download aliases (this excludes LDAP
aliases.)
Administer Filter Patterns
The user can add, edit, remove, upload, and download Pattern Filters and Specific Access
Patterns.
Administer Mail Queue
The user can administer mail queues.
Administer Reports
The user can view, configure and generate reports, and view system activity.
Administer Users
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The user can add, edit, and relocate user mailboxes (except the Full Admin users). This
includes the ability to upload and download user lists. The user can also configure User
vacation notifications.
Administer Vacations
The user can edit local user’s vacation notification settings and other global vacation
parameters.
Message History
The user can view the Message History database and perform quick searches of the recent
Mail and Web activity on the Dashboard.
View Dashboard
The user can view the Dashboard page. Tiered admins can only perform a quick search of
the recent Mail and Web activity if Message History is also enabled.
View Alarms
The user can view the Alarms in the Alarms Indicator and the Local Alarms page, but
cannot acknowledge them.
View System Logs
The user can view all system logs.
Administer All Quarantines
The user can view, delete, and send all quarantined files in the system quarantine and all
custom quarantines.
Quarantine: System
The user can view, delete, and send quarantined files in the primary system quarantine only.
Quarantine: DLP
The user can view, delete, and send quarantined files in the DLP quarantine only.
Any other custom quarantines will also appear in this list and can be independently managed by
a tiered admin user.
4. Click Apply.
Ifyougrantfullorpartialadminaccess tooneormoreuseraccounts,theactions performedby these
administratorsareloggedbecausetheyhaveanidentifiableUserIDthatistrackedbytheWatchGuardXCS.
Note A user with Full Admin privileges cannot modify the profile of the Admin user, but they
can edit other users with Full Admin privileges.

Tiered Administration and WebMail Access
You must enable Tiered Admin and WebMail access on a network interface to allow Tiered Admin
users to log in and administer the WatchGuard XCS.
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1. Select Configuration > Network > Interfaces.
2. Select the Admin & Web User Login and Webmail check boxes on the required network
interface.

3. Click Apply.
You must restart the system.

Log In with Tiered Administration Privileges
When you assign tiered admin privileges to a user, they can access the corresponding administrative
functions through the WebMail client interface.
To log in as a Tiered Administrator:
1. Log in to the WatchGuard XCS device.
2. Select the feature to administer from the drop-down list.
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Tiered Admin User Profile Page
Tiered administrators who do not have full admin privileges and do not have a local account (for
example, on a clustered system) can update their profile and change their password from the User
Profile page.
To modify your tiered admin user profile settings, select User Profile from the drop-down list. From
this page you can modify your forwarding email address and your password.
Note This User Profile page does not appear and is not required for tiered admin users with
full admin privileges and a local (non-cluster) account.
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Delegated Domain Administration
Delegated Domain Administration allows the primary administrator to delegate to specific users
administrative rights to manage settings for a specific domain with domain policies.
The Delegated Domain Administrator can login to the WatchGuard XCS through the WebMail interface
and configure and manage these settings for their specific domains:
n

n

Manage settings for their domain with a subset of configuration options in a Domain Policy
o Anti-Virus actions and Notifications
o Anti-Spam controls: Certainly, Probably, and Maybe Spam Thresholds and Actions
o Intercept Component Weights
o Attachment Control Inbound and Outbound Attachment Types, Actions, and
Notifications
o Email Annotations
Manage the Quarantine for their Delegated Domain
o The Delegated Domain Administrator can view messages, delete messages, or release
them from the quarantine to the end user.

The primary WatchGuard XCS administrator must create Delegated Domains and assign the
Delegated Domain Admin for each domain. You can add Delegated Domains manually or upload them
using a list of Delegated Domains and corresponding Delegated Domain Admins. You can delegate
multiple domains to a single Delegated Domain Administrator, and you can assign multiple
administrators to a Delegated Domain.
Note The Delegated Domain Administration configuration does not support Centralized
Management.

Delegated Domain Administration and Clustering
Delegated Domains on the Primary cluster device are replicated to other devices in the cluster. To
manage the Delegated Domain policy, the Delegated Domain Administrator only needs to log in to the
Primary device to manage the domain settings. The configuration is replicated to all other devices in
the cluster.
In a cluster, you must configure Delegated Domain Policies on the Primary, and not the Secondary or
other cluster devices. The configuration is automatically synchronized with the other devices in the
cluster.
To view and manage the Quarantine for a domain, the Delegated Domain Administrator must log in to
each device in the cluster as required, because each device stores its own dedicated quarantine area.
On a cluster, you can create Delegated Domain Administrators in the Administration > Accounts >
Tiered Admin menu on the cluster Primary device.

Delegated Domain policies
The WatchGuard XCS automatically creates new domain policies and domain policy assignments for
each new delegated domain you upload or manually create. Each policy uses the name of the
delegated domain and you can view the policy in the Policies menu.
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The Delegated Domain Administrator can log in to the WatchGuard XCS through WebMail and
administer a subset of the policy for their domain.
Each delegated domain policy is automatically associated with the domain. To view these domain
policy associations, select Security > Policies > Domain Policy.
To delete a delegated domain policy and its association, select Administration > Accounts >
Delegated Domains and delete the delegated domain. The domain policies are automatically deleted
when you delete the corresponding delegated domain.

Create a Delegated Domain Administrator
To create a delegated domain administrator:
1. Select Administration > Accounts > Local Accounts.
On a cluster Primary, select Administration > Accounts > Tiered Admin.
2. Create a new user, or modify an existing user.
3. In the Administrator Privileges section, select the Delegated Domain Admin check box.
Note The Full Admin and other Tiered Admin privileges are not available or supported when
you select the Delegated Domain Admin option.

4. Ifyou havenot yetcreated thecorresponding DelegatedDomain, youmust createthe domainin
Administration > Accounts > Delegated Domains.
You can also select the Delegated Domain Admin userfor the domain on the Delegated Domains page.

If you have already created Delegated Domains, a list of Delegated Domains appears. Select
which domains this user can administer. You can assign more than one Delegated Domain to
the user.
5. Click Create or Apply to save the user’s settings.
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Create Delegated Domains
You must create local users (or Tiered Admin users in a Cluster) before you create a Delegated
Domain to assign an existing local user as the Delegated Admin for the domain. For a large number of
delegated domains, we recommend that you upload a list of Delegated Domains and Admin users.
When you create a new delegated domain, the WatchGuard XCS automatically creates new domain
policies, domain policy assignments, and the domain administrator users.
For example, for the delegated domain entry:
example.com, admin1@example.com

These items are created:
n

n
n
n

A new delegated domain called example.com assigned to the administrator
admin1@example.com.
A new admin1 user with delegated domain permissions for the example.com domain.
A new policy called example.com.
A domain policy association between the domain example.com, and the delegated domain
policy example.com.

To create a Delegated Domain and assign an administrator:
1. Select Administration > Accounts > Delegated Domains.
2. Select Create Delegated Domain.
3. In the Domain text box, type the domain name.
For example, example.com .

4. From the User drop-down list, select an administrator that is the first administrative user for this
domain.
To appear in this list, the user must already exist as a local user.

Note You cannot assign Full admins and Tiered Admin the Delegated Domain Admin
permission, and these users do not appear in the drop-down list of admins.
You can add more delegated domain administrators for the domain in Administration >
Accounts > Local Accounts (or Administration > Accounts >Tiered Admin on a cluster
Primary.)
5. New domain policies are automatically created for each new Delegated Domain.
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To make these new policies use the Default policy values, select the Make new policies a
duplicate of the default policy check box.
Clear this check box to assign the new domain policies as Undefined.
6. Click Finished.

Delete a Delegated Domain
To delete a delegated domain, click the Delete link beside a specific domain.
If you delete a delegated domain, this action also deletes the associated domain policies and domain
policy assignments for that domain. Delegated domain admin users are not affected if you delete the
domain they administer.

Upload Delegated Domains
You can upload a list of delegated domains and associated domain administrator email addresses. The
list source can be an existing list (configured in Security > Content Control > Dictionaries), or you
can upload a file from the Delegated Domains page.
Note Do not upload users who already exist as Full Admin or Tiered Admin users.
To upload a list of delegated domains and administrators:
1. Select Administration > Accounts > Delegated Domains.
2. Click Upload Delegated Domains.
3. From the Existing List drop-down list, select a list, or click Browse to select a file to upload.
Create this as a text file with this format:
domain, admin-email

For example,
example.com, admin1@example.com

You can assign multiple domain administrators for each domain with multiple entries.
For example,
example.com, admin1@example.com
example.com, admin2@example.com
example.com, admin3@example.com

Specific administrators can be a domain administrator for multiple delegated domains.
For example,
example1.com, admin1@example.com
example2.com, admin1@example.com
example3.com, admin1@example.com

4. To make these new policies use the current Default policy values, select the Make new
policies a duplicate of the default policy check box.
Clear this check box to leave the domain policies as initially undefined.
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5. Click Continue.
The list is merged with any existing entries.

When you upload a new delegated domain and domain administrator, the WatchGuard XCS
automatically creates new domain policies, domain policy assignments, and the domain administrator
local user.
For example, for the delegated domain entry:
example.com, admin1@example.com

These items are created:
n

n
n
n

A new delegated domain called example.com assigned to the administrator
admin1@example.com.
A new admin1 user with delegated domain permissions for the example.com domain.
A new policy called example.com.
A domain policy association between the domain example.com, and the delegated domain
policy example.com.

Upload Delegated Domain Administration Users
If an administrative user for a delegated domain does not exist before the domain list upload, the
WatchGuard XCS automatically creates the user. For example, for the administrative user
admin1@example.com, the system creates this local username and password:
n
n

Username: admin1.example.com
Password: admin1
Note Users created automatically have the domain name appended to their username.
When you create local accounts, they do not append the domain name.

This user is managed in Administration > Accounts > Local Accounts, (or Administration >
Accounts > Tiered Admin on a cluster Primary). The Delegated Domain Admin option and their
corresponding domains are automatically selected for the user.

Administer Delegated Domains
To administer a domain, the delegated domain administrator must log in to the WatchGuard XCS
through WebMail where they can access a subset of configuration options to customize for their
domain.
You must enable the WebMail and Admin & Web User Login options on a network interface to allow
delegated domain admins to log in to the WatchGuard XCS.
To enable WebMail and Admin & Web User Login on a network interface:
1. Select Configuration > Network > Interfaces.
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2. Select the WebMail and Admin & Web User Login check boxes on the required interface.
3. Click Apply.
You must restart the system.

Log in to Delegated Domain Administration
To login to a delegated domain to administer its policies, the delegated domain administrator must log
in directly to the WatchGuard XCS with their login name, for example, admin1 (or
admin1.example.com if the user was created in an uploaded list).
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Select a domain and function from the drop-down list in the top-left corner of the page. If the delegated
domain administrator is associated with multiple domains, the drop-down list contains links to all the
domains to which they are assigned.
n
n

To manage the delegated domain policy, select the Manage link.
To view the messages in the delegated domain quarantine area, click the Quarantine link.

Manage the Delegated Domain
1. To modify the configuration for the Domain policy, select the Manage option for the Delegated
Domain.
This policy only provides a subset of the full policy configuration for the Delegated Domain Admin
user to manage. The primary WatchGuard XCS Administrator still has full access to all options in the
Domain Policy.

Note In a cluster, you must always configure the Delegated Domain Policies on the Primary
cluster device. The configuration is automatically synchronized with the other devices
in the cluster.
These policy items are available to configure:
n

n
n

Anti-Spam and Anti-Virus
o Anti-Virus Actions and Notifications
o Anti-Spam Controls – Certainly, Probably, and Maybe Spam Thresholds and
Actions
o Intercept Component Weights
Attachment Control – Inbound and Outbound Attachment Types, Actions, and Notifications
Email – Annotations

2. Click Apply to save the settings for this policy.

View the Delegated Domain Quarantine
Any message security features that quarantine mail, for example, Anti-Virus, Anti-Spam, and
Attachment Control, place the mail messages in the quarantine area. To view the Quarantined
messages for this specific delegated domain, select the Quarantine option.
Click on a Queue ID to view the details of a message, or click Delete to delete the message from the
quarantine. Quarantined messages can also be released from the quarantine and delivered to their
original destination by clicking the Release button.
The delegated domain administrator can view messages, delete messages, or release them from the
quarantine to the end user. In a cluster environment, the delegated domain administrator must log in to
each device in the cluster to view and manage its quarantine area.
Use the search field to look for specific messages within the quarantine. For example, you can search
for the name of a specific virus so that any quarantined messages infected with that specific virus
appear.
Use the Delete All and Release All buttons specifically with the search function. You must enter a
specific search pattern before you use these controls.
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Mirror Accounts
You can import LDAP user accounts from a directory server and mirror them locally. This allows you to
create local accounts to allow these users to log in locally for the Spam Quarantine and
Trusted/Blocked Senders features.
These mirror accounts are not local accounts that can accept mail. Local accounts are only used for
the Spam Quarantine and Trusted/Blocked Senders features.
See Directory Users for more detailed information on creating mirror accounts.
To display all mirrored users:
1. Select Administration > Accounts > Mirror Accounts.
The Mirror Accounts page appears.

2. To remove selected individual user mirror accounts, click Remove.
To show only the local users on this WatchGuard XCS, click Show Local Users.
Use the Remove All button with the search function. You must enter a specific search pattern
before you click Remove All to delete the results.
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Remote Accounts and Directory Authentication
Directory authentication allows users to authenticate to the WatchGuard XCS without a local account.
When an unknown user logs in, the WatchGuard XCS sends the User ID and password to the
specified LDAP or RADIUS server. If the user successfully authenticates, the WatchGuard XCS logs
them in and provides access to the specified servers.
LDAP and RADIUS provide a convenient way to allow access to internal mail servers or webmail
servers, for example, Outlook Web Access (OWA). Users that log in locally to an Exchange server
based on an Active Directory identity can use the same identity to use Outlook Web Access with the
Secure WebMail service.
If you define both LDAP and RADIUS authentication services, the WatchGuard XCS tries to
authenticate with RADIUS first, and then LDAP if RADIUS authentication fails.

The server “This WatchGuard XCS” is only accessible to mirror users imported from an LDAP
directory.
See Directory Users for more detailed information on mirrored accounts.
The other servers listed in the Accessible Servers section are configured in Configuration >
WebMail > WebMail. See Secure WebMail for more detailed information on configuring this feature.
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Configure LDAP Authentication
To configure LDAP for authentication:
1. Select Administration > Accounts > Remote Authentication.
2. Click the New button in the LDAP Sources section to define a new LDAP source.

3. In the Directory Server drop-down list, select a configured LDAP directory server for
authentication.
4. In the Search Base text box, type the starting base point to start the search from.
For example, cn=users,dc=example,dc=com .
5. From the Scope drop-down list, select the scope of the search.
n
n

n

Base – Searches the base object only.
One Level – Searches objects one level beneath the base object, but excludes the base
object.
Subtree – Searches the entire subtree of which the base distinguished name is the
topmost object. This includes the base object.

4. In the Query Filter text box, type a specific query filter to search for a user in your LDAP
directory hierarchy.
For Active Directory, type (ObjectClass=user) .
5. In the Timeout text box, type the maximum interval, in seconds, to wait for the search to
complete.
The default is 5. You must enter a between 1 and 100.

6. In the Account name attribute text box, type the account name result attribute that identifies a
user’s login or account name. For Active Directory, type sAMAccountName .
7. Click Apply.

RADIUS Authentication
1. Select Administration > Accounts > Remote Authentication.
2. Click New in the RADIUS Server section.
The RADIUS Authentication Source page appears.
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3. In the Server text box, type the FQDN or IP address of the RADIUS server.
4. In the Shared Secret text box, type the password for the RADIUS server.
A shared secret is a text string that acts as a password between a RADIUS server and client.
Choose a secure shared secret of at least 8 characters in length, and include a mixture of upper
and lowercase alphabetic characters, numbers, and special characters, for example, the “@”
symbol.
When you add a RADIUS server, the administrator of the RADIUS server must also list this
WatchGuard XCS as a client with the same shared secret. All listed RADIUS servers must
contain the same users and credentials.
5. In the Timeout text box, type a maximum timeout value, in seconds, to contact the RADIUS
server.
The default is 10 seconds.

6. In the Retry text box, type a time interval, in seconds, to retry a connection attempt to the
RADIUS server.
The default is 3 seconds.

7. Click Add.

POP3 and IMAP Access
Mail is delivered to local mailboxes after the same processing that applies to all other destinations.
Users can use any POP3 or IMAP-based mail client to download their messages from a local mailbox.
User’s can also access their mailboxes through the WatchGuard XCS WebMail client.
Note Use the secure versions of POP and IMAP to make sure passwords are not
transmitted in clear text.
To configure POP3 and IMAP Access:
1. Select Configuration > Mail > POP3 and IMAP.
The POP3 and IMAP page appears.
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2. From the POP service is drop-down list, select enabled to enable POP and secure POP
access.
3. From the IMAP on port 143 and 993 is drop-down list, select enabled to enable IMAP and
secure IMAP access.
4. Select Configuration > Network > Interfaces.

5. On the required network interface:
n
n
n
n

Select the IMAPS Server check box to enable access to secure IMAP on this interface.
Select the IMAP Server check box to enable access to IMAP on this interface.
Select the POP3S Server check box to enable access to secure POP on this interface.
Select the POP Server check box to enable access to POP on this interface.

6. Click Apply.
You must restart the device.
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Relocated Users
Use the Relocated Users page to return information to the sender of a message on how to reach users
that no longer have an account on the WatchGuard XCS. You can also specify a full domain if the
address has changed for a large number of users.
1. Select Administration > Accounts > Relocated Users.
2. Click the Add button to add a new relocated user.

3. In the User text box, type a user or domain name.
For example, user1 , user1@example.com , or @example.com .
4. In the User has moved to… text box, type the appropriate contact information for the relocated
user, for example, their new email address, street address, or phone number.
5. Click Apply.
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Vacation Notification
When a user is out of the office, they can enable the Vacation Notification feature that sends an
automated email reply to incoming messages. The reply message is fully configurable, and allows a
user to personalize their vacation notification message.
Vacation notifications are processed after mail aliases and mappings. You must create notifications for
a specific end user and not for an alias or mapping. Vacation Notifications are not available in a cluster.
To enable Vacation Notifications:
1.
2.
3.
4.
5.
6.

Enable Vacation Notifications globally.
Configure individual settings:
Configure Vacation Notification for the user in the user configuration page.
The user configures their own Vacation Notification through WebMail.
To enable Vacation Notifications:
Select Administration >Accounts > Vacations.
The Vacations page appears.

7. To enable Vacation Notifications globally for all users, select Enable Vacation Notification.
8. In the Domain Part of Email Address text box, type the domain name that is appended to
local user names.
For example, example.com .
9. In the Interval Before Re-sending text box, type the number of days to send a notification after
a previous notification was sent, if a new email arrives from the original sender.
The default is 7 days.

10. In the Subject text box, type the subject for the default notification message.
Users can change the subject and message from their own user profile.

11. In the message text box, type the text for the Vacation Notification message.
Users can change the message from their own user profile.

12. To see all Vacation Notification settings and to add arbitrary notifications for non-local users,
click Edit Vacations.
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Click on an existing email address to edit the user’s vacation notification settings, or type an
address if this user has no vacations defined.
From this page, you can configure the notification settings and the address from which incoming mail
receives a vacation response.

User Vacation Notification Profile
You can configure vacation notifications for individual users in their user profile in the Local Accounts
page. Users can configure their own Vacation Notification settings in their profile through the WebMail
client.
To configure Vacation Notification:
1.
2.
3.
4.

Log in to the WebMail client.
Select User Profile.
Set the Vacation Start Date on the left calendar.
Set the Return to Work Date on the right calendar.
The vacation notices are sent out automatically during this time.

5. Modify the default Subject and contents of the response message as required.

6. Click Save User Profile.
Note Vacation Notifications are not sent to bulk messages, for example, mailing lists and
system generated messages. Vacation Notifications are also not sent to messages
identified as spam.
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Secure WebMail
The Secure WebMail feature provides a highly secure mechanism to access webmail services, for
example, Microsoft OWA (Outlook Web Access), Lotus iNotes, and IMAP servers. Webmail services
provide a simple remote interface for users to access their mail server mailboxes remotely through a
web browser.
Because these webmail services are accessible from the Internet, they present a number of security
challenges. The Secure WebMail feature is designed to support the use of webmail services and
protect Webmail servers from Internet attacks. The connection is managed using a full application
proxy.
The WatchGuard XCS completely recreates all HTTP/HTTPS requests made by the external client to
the internal webmail server.

Note In a clustered environment, you can only enable the Secure WebMail proxy on the
Primary device in the cluster.
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Configure Secure WebMail
To enable and configure Secure WebMail servers:
1. Select Configuration > Network > Interfaces.
2. Select the WebMail check box on the required network interface.

3. Click Apply.
You must restart the device.

4. Select Configuration > WebMail > WebMail.
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5. In the Servers section, click Add Server.

6. In the Address text box, type the IP address, hostname, or URL of the WebMail server.
WebMail servers must be one of these servers: IMAP, Outlook Web Access (OWA), or Lotus iNotes.

7. In the Label text box, type an optional label to describe this server.
8. In the Users who may access this server section, select any local users who are able to
access this server.
If you use Remote Authentication and do not use local users, no additional configuration is required.

To try the user’s WebMail ID/Login first before prompting for an ID and password, select the
Automatic Server Login check box.
Leave this option disabled to force a login prompt for each new server. This option enables
single login capabilities to allow users to login to the WatchGuard XCS and their WebMail
server with only one login. Disable Automatic Server Login if the server is set to expire
passwords after three failed attempts.
9. To try the most recent credentials first when the user switches servers, select the Use Most
Recent check box.
The Use Most Recent option only applies to users with more than one accessible WebMail server.
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10. To allow support for Outlook Web Access 2000 and limited support for OWA 2003, select the
Force Compatibility check box.
11. To make the server invisible to users in the Secure WebMail server drop-down list, select the
Make Invisible check box.
12. From the Keep Alive drop-down list, select the frequency to send keep-alive messages to the
WebMail server to keep the client connection alive.
13. You can set these additional options:
n

n

n

Cached server passwords – Enable this option to keep a copy of the user’s password
until they explicitly log out. If a user switches servers, they do not need to re-enter their
password.
Share cookies between servers – Enable this option to make sure that when a user
moves from server to server or is redirected to another server, the user’s session cookies
are also passed along.
Upload Maximum File Size – Type the maximum upload file size (in MB) allowed.

14. Click Apply.

Access Types
These options enable controls in the WebMail interface for features, for example, the Spam
Quarantine, Trusted and Blocked Senders, and Administrative Access.

n

n
n

n
n

Administrative Access – Enables access to administrative functions if the user has
administrative privileges, for example, through Tiered Administration.
Local Mail – Enables access to IMAP servers on the local network.
Proxy Mail – Enable proxy mail access to other WebMail/IMAP servers. This is required for
access to other web mail servers, for example, OWA for iNotes.
User Spam Quarantine – Enables the Spam Quarantine controls.
Trusted/Blocked Senders List – Enables the Trusted and Blocked Senders List controls.

For organizations that only want to use local mailboxes for the Spam Quarantine controls or Trusted
Senders, we recommend that you disable Local Mail and Proxy Mail access, and enable Personal
Quarantine Controls and Trusted/Blocked Senders. This displays only those functions to the end
user when they log into the WebMail account. You can disable Personal Quarantine and
Trusted/Blocked Senders if you only use the Spam Quarantine summary email for these features and
do not require the users to log in locally.
Note You must enable at least one of these options to allow WebMail access on a specified
interface in Configuration > Network > Interfaces. If you disable all of these access
options, the WebMail access option on a network interface is disabled.
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WebMail Client
Use the WebMail client to access local mailboxes, IMAP Servers, administrative access, the User
Spam Quarantine, and the Trusted/Blocked Senders List. WebMail logins are authenticated as local
users or remote LDAP and RADIUS users.
To access the WebMail client:
1. From a web browser, type the host name or IP address of the WatchGuard XCS that runs
WebMail.
2. Log in with your local or LDAP/RADIUS user ID and password.
After you successfully log in, the WebMail interface appears.

Configure WebMail Client Options
To configure WebMail Client options:
1. Select Configuration > WebMail > WebMail.
2. Go to the WebMail Options section.

3. To enable a popup window for new mail notification, select the New Mail Popup check box.
To see popup windows, you must enable popups on your web browser.

4. To minimize the use of new popup browser windows and use the main frame, select the
Minimize Popups check box.
5. To enable the ability to view HTML mail, select the Enable Inline HTML-mail Viewing check
box.
For security reasons, any scripts and fetches for external objects are filtered.

6. To enable the ability to save sent mail in the user’s mailbox, select the Save Sent Mail check box.
7. In the Sent Mail-box text box, type the name to use for the sent mail folder if you enable this
feature.
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8. To allow a user to edit the From: field when they compose a message, select the Editable
From check box.
9. Click Apply.
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Configure Secure WebMail for Outlook Web Access
The Secure WebMail proxy provides a highly secure mechanism to access Microsoft OWA (Outlook
Web Access). OWA uses a very similar interface to Outlook and provides an easy to use remote
interface for users to access their Exchange mailboxes remotely. With OWA, users can see all of their
mail, contacts, and calendar using a web browser.
Because OWA is accessible from the Internet, its presents a number of security challenges. The
Secure WebMail Proxy feature is designed to support OWA use and protect it from Internet attacks.
The OWA connection is managed using a full application proxy. The WatchGuard XCS completely
recreates all HTTP/HTTPS requests made by the external client to the internal OWA Exchange server.
In a typical deployment, OWA users connect to the OWA interface on the public interface of the
WatchGuard XCS. The WatchGuard XCS then proxies the traffic with its private interface to the OWA
server. The connection is secure because the WatchGuard XCS recreates requests by the OWA
clients.
If you deploy the WatchGuard XCS on the DMZ of a network firewall, OWA users first connect to the
public interface of the network firewall. The traffic is forwarded to the WatchGuard XCS and then the
requests are recreated and forwarded to the OWA server. On the network firewall, incoming port 443
needs to be opened from the public interface to the DMZ to allow traffic from the Internet to the
WatchGuard XCS. You also open up port 80 from the DMZ to the private network to allow the
WatchGuard XCS to connect to the OWA server.
Note The WatchGuard XCS Secure WebMail proxy does not support OWA Premium Client
mode. You must disable this feature when using OWA.

Enable the Secure WebMail OWA Proxy
To configure the OWA proxy.
1. Select Configuration > WebMail > WebMail.
2. Click the Add Server button.
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3. In the Address text box, type the URL where OWA is located.
For example,
http://owa.example.com/exchange/

4. In the Label text box, enter an optional name to describe this server.
5. In the Users who may access this server section, select any local users that are allowed to
use OWA.
You can also enable this option from the user's individual mailbox properties. Users can also
authenticate to OWA through Active Directory/LDAP.

6. The WatchGuard XCS sends the user account portion of the user's mail attribute (for example,
user, in the address user@example.com) to the OWA server by default.
If the LDAP user's sAMAccountName is equivalent to the mail attribute, select the Try
Webmail ID/login first option.
If this is different from the sAMAccountName attribute, clear the Try Webmail ID/login first
check box. If this option is enabled, the user receives an invalid ID error message. The user
then needs to enter their user name and password again to gain access to OWA.
7. Click Apply.
8. Select Configuration > WebMail > WebMail.
9. In the Access Types section, select the Proxy mail check box.

10. Click Apply.
11. Select Configuration > Network > Interfaces.
12. Select the WebMail check box on the network interface from which users are accessing
WebMail.
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13. Click Apply.
You must restart the device.
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Outlook Web Access (OWA) Integration
These sections describe the configuration steps to perform on your OWA server to integrate the server
with the WatchGuard XCS Secure WebMail proxy.
n
n
n

OWA 2007 Configuration
OWA 2010 Configuration
Disable OWA Premium Client Mode

OWA 2007 Configuration
To configure IIS for use with OWA 2007:
1.
2.
3.
4.
5.

Open the Internet Information Services (IIS) Manager.
Select [SERVERNAME] > Web Sites > Default Web Site.
Right-click on owa and select Properties.
Select the Directory Security tab.
Click Edit... in the Secure Communications section.

6. Make sure that the Require secure channel (SSL) option is disabled.
7. Click OK.

OWA 2007 Authentication Configuration
The WatchGuard XCS supports only Basic Authentication when communicating with the OWA server.
To configure OWA 2007 to use basic authentication:
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1.
2.
3.
4.

Open the Exchange Management Console.
Select Server Configuration > Client Access.
Select the Outlook Web Access tab.
Right-click on owa (Default Web Site) and select Properties.

5. Select the Authentication tab.
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6. Select the Use one or more standard authentication methods option and select Basic
authentication.
Note that this configuration disables forms-based authentication. Users will no longer see the OWA
login screen when accessing OWA.

7. Click OK.
8. Restart IIS by running the following command from the command line:
iisreset /noforce

OWA 2010 Configuration
To configure IIS for use with OWA 2010:
1.
2.
3.
4.
5.

498

Open the Internet Information Services (IIS) Manager.
Select [SERVERNAME] > Web Sites > Default Web Site > owa.
Double-click SSL Settings.
Make sure that Require SSL is disabled.
Click Apply in the Actions panel.
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Install Basic Authentication
The WatchGuard XCS supports only Basic Authentication when communicating with the OWA server.
To make sure that Basic Authentication is installed on IIS:
1.
2.
3.
4.

Open the Internet Information Services (IIS) Manager.
Select Server Manager > Roles > Web Server (IIS).
Click Add Role Services.
Make sure that Basic Authentication is installed.
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OWA 2010 Authentication Configuration
To configure OWA 2010 to use Basic Authentication:
1.
2.
3.
4.
5.
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Open the Exchange Management Console.
Select Server Configuration > Client Access.
Select the Outlook Web Access tab.
Right click on owa (Default Web Site) and select Properties.
Select the Authentication tab.
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6. Select the Use one or more standard authentication methods option and select Basic
authentication.
Note that this configuration disables forms-based authentication. Users will no longer see the OWA
login screen when accessing OWA.

7. Click OK.
8. Restart IIS by running the following command from the command line:
iisreset /noforce

Disable OWA Premium Client Mode
The WatchGuard XCS only supports Outlook Web Access Light Client mode. The Premium Client
mode version must be disabled for the WatchGuard XCS Secure WebMail Proxy to work properly.
Outlook Web Access Premium Client mode requires Internet Explorer 6 or later, and provides features
that are not available in the Light Client mode version, such as Unified Messaging and the ability to
check spelling. By default, all others browsers will use the Light Client version.
Outlook Web Access Light Client mode runs on most Web browsers providing a simplified user
interface and reduced feature set as compared to Outlook Web Access Premium Client mode.
Note Public Folders are not available when using the Light Client mode.
To disable Premium Client mode on OWA 2007 or OWA 2010:
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1.
2.
3.
4.
5.
6.

Open the Exchange Management Console.
Select Server Configuration > Client Access.
Select the Outlook Web Access tab.
Right-click on owa (Default Web Site) and select Properties.
Select the Segmentation tab.
Select Premium Client and click Disable.

7. Click OK.
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About Threat Prevention
The Threat Prevention feature detects and mitigates incoming threats. When you enable the default
Threat Prevention configuration, the WatchGuard XCS can recognize these threats:
n
n
n
n
n

Directory harvesting
Denial of Service (DoS) attacks
Connections from blocked addresses
Connections originating from addresses that send spam
Connections originating from addresses that send viruses

The WatchGuard XCS retains historical information about connecting IP addresses and how they
behave.
You can accept or reject a connection at connection time based on this current and historical data.
You can also push this information to a perimeter F5® or Cisco® device that can rate limit, throttle or
block a given IP address for a period of time before it reaches the WatchGuard XCS.

How Threat Prevention Works
The Threat Prevention feature performs these tasks:
n

n
n

n

n

Determines the threat level of connecting IP addresses and retains historical statistics about
that address
Acts on the connection’s IP address based on its connection history
The Threat Prevention feature is involved in these stages of mail delivery for a specific client IP
address:
At connection request time, the WatchGuard XCS provides the history for the IP address to the
rules script that determines if the connection is allowed or rejected. It also identifies how to
further classify the address into a specific data group.
After early mail scanning, the WatchGuard XCS adds the number of known recipients, unknown
recipients, and DNSBL results to the history of the connecting address.
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n

After full mail scanning, the WatchGuard XCS records the results of Anti-Virus, Anti-Spam, and
Malformed message scanning in the history for the IP address.
Prior to connection, an F5 or Cisco device (if configured) can block an IP address before it
reaches the WatchGuard XCS.

Threat Prevention in a Cluster
When you use the Threat Prevention feature in a cluster, you only need to configure it on the Primary
device of the cluster. The Primary is the only point of contact between the cluster and any configured
load balancing devices.
Note Threat Prevention decisions are based on per system statistics, and not on statistics
for the entire cluster.
If you demote a Primary cluster device, and promote a Secondary to be Primary, the cluster switches
control and resynchronizes to the load balancing device. Threat Prevention runs independently on each
device in the cluster, but only the Primary pushes data to the external devices.
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Configure Threat Prevention
A Connection Rules script runs each time a client tries to connect to the WatchGuard XCS. This
configurable. script determines whether to accept or reject a connection based on the threat prevention
history of the IP address. The script is also responsible for moving IP addresses into appropriate data
groups.
To configure Threat Prevention:
1. Select Security > Anti-Spam > Threat Prevention > Configure.
The Threat Prevention page appears.

2. Select the Enable Threat Prevention check box.
The default connection rules immediately take effect.

Note Examine and customize (if required) the default connection rules before you enable
Threat Prevention.

Mail Relays
You can trust friendly local networks or addresses of known mail servers in your environment that relay
mail through the WatchGuard XCS. You can add these specific networks and servers to the relays
IP/CIDR list in the Threat Prevention configuration to prevent the Threat Prevention and Reputation
Enabled Defense features from blocking them, as well as to make sure that reputation statistics for
these addresses are not reported to the Reputation Enabled Defense service.
For example, it is possible that in environments with a backup MTA (Mail Transfer Agent), the backup
can be blocked by Threat Prevention rules or improperly classified by Reputation Enabled Defense. If
the primary WatchGuard XCS is offline, mail is collected by the backup MTA as specified in your
organization's DNS MX records.
When the primary WatchGuard XCS comes back online, this mail (that can include spam, viruses, and
other types of infected mail) from the backup MTA is forwarded to the WatchGuard XCS for
processing. Because of this mail, the backup MTA can be blocked Threat Prevention, or receive a low
reputation score by Reputation Enabled Defense.
To add a server to the relays list:
1. Select Security > Anti-Spam > Threat Prevention > Configure.
2. Click internal hosts and friendly mail relays.
The relays static IP/CIDR list page appears.
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3. Add the address of any internal relays and a description.
4. Click Add.
5. Click Apply.
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About Connection Rules
Threat Prevention uses a scripting language for connection rule checks that drive the decision process.
The script can reject or accept mail based on various statistics available at the time of client
connection. The listed default rules are processed in order.

n
n
n

n
n
n

n

Rule – A descriptive name for the rule.
Rule ID – The ID number associated with the rule.
Condition – Condition statement to execute. Condition statements are described in detail in
the next section.
List – Defines which list to insert the IP address.
Action – Action to take if the condition is “true”, for example, Accept or Reject.
Reject Code – Reply code to send to the connecting client.
n For Reject, this is “450 (temporary)” or “550 (permanent)”.
n For Accept, the reply code is set to “220 (OK)”.
Move – Use the arrow icons to modify the processing order of the connection rules.

To add a new connection rule:
1. Click Add Rule.
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2. Click Apply.
The script is automatically checked for syntax and execution errors.

3. Click Advanced to view the entire connection rules script based on the configured rules.
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Rules Script
The Threat Prevention feature runs a connection rules script each time a client connects to the
WatchGuard XCS. The script determines whether to accept or reject a connection based on its threat
prevention history. The script is also responsible for moving IP addresses into appropriate data groups,
for example, infected or spammers. You cannot edit the full script, but you can define rules that are
updated in the script.

Basic Rule Structure
The basic structure of a connection rule is:
n

n
n

n

Rule Condition – A set of criteria that must be met for the rule to trigger, for example,
“stats1h.virus > 10” (10 or greater virus-infected messages sent in the last hour). Threat
Prevention collects over fifteen different types of data that you can use to create a rule
condition.
Action – Action to take when the rule condition is true, for example, Accept or Reject.
Reject code – The reject code to send back to the sending server, for example, temporary
reject (450) or permanent reject (550).
List – The data group to which to add this IP address, if the condition is true. For example, a
sender that triggers a spam rule is placed in the spammers group.

Default Connection Rules
The default connection rules are active when you enable Threat Prevention. These rules include
checks for typical conditions, for example, blocked clients, virus and junk mail senders, and denial of
service (DoS) attempts. The default rules are also helpful for learning how to put together condition
statements for your own custom connection rules.
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Reject Blacklisted Clients
This rule checks to see if the client is already blocked by Threat Prevention. The condition statement
“is_blacklist” checks if the client is listed in the blacklist IP/CIDR list. The client is rejected and added
to the blacklisted data group if the condition is true.

Reject Clients Performing Directory Harvesting
This rule checks whether the client has been involved with directory harvesting activities intended to
discover valid email addresses from the WatchGuard XCS. This condition statement is used to identify
if a client is considered a directory harvester:
stats30m.bad_recipients >= 50 && stats30m.good_recipients < 3 && (!is_internal &&
!is_mynetworks)

This statement checks these conditions:
n
n
n

the number of invalid recipients from the client in the last 30 minutes is greater than or equal to 50
the number of good recipients from the client in the last 30 minutes is less than 3
the client does not exist in the internal or mynetworks IP/CIDR lists (to trust the client)

If all the conditions are true, then reject the connection and add its IP address to the harvesters data group

Reject Clients Sending Too Many Viruses
This rule checks whether the client has recently sent a large number of viruses. This condition
statement is used to identify whether the client is considered a source of viruses:
stats1h.virus > 10 && stats1h.perc_virus_to_messages > 50 && stats1h.perc_ham_to_
messages < 25 && (!is_internal && !is_mynetworks)

This statement checks these conditions:
n
n

n
n

the number of viruses received from this client in the last hour is greater than 10
the percentage of virus infected messages received from this client in the last hour is greater
than 50
the percentage of clean messages received from this client in the last hour is less than 25
the client does not exist in the internal or mynetworks IP/CIDR lists (to trust the client)

If all the conditions are true, then reject the connection and add its IP address to the infected data group

Throttle Clients Listed on Multiple DNSBL
This rule checks whether the client has been listed on more than one DNS Block List of blocked
clients. If the client is on more than one DNSBL, it is considered a known open-relay that sends out a
large number of spam messages. This condition statement is used to identify whether the client is on
more than one DNSBL:
block_list > 1 && (!is_internal && !is_mynetworks)

This statement checks these conditions:
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n
n

the client exists on more than one DNSBL
the client does not exist in the internal or mynetworks IP/CIDR lists (to trust the client)

If all the conditions are true, then temporarily reject the connection and add its IP address to the
spammers data group.

Throttle Clients Listed on a DNSBL and Sending Spam
This rule checks whether the client exists on only one DNS Block List. In this case, there is the
possibility that the client is on this DNSBL by mistake, and the WatchGuard XCS makes additional
checks to examine its recent history of mail messages. This condition statement is used to identify
whether a client is on one DNSBL and sends a large number of spam messages:
block_list == 1 && stats30m.bad_mail > 10 && stats30m.ham < 2 && (!is_internal &&
!is_mynetworks)

This statement checks these conditions:
n
n

n
n

the client exists on only one DNSBL
the number of spam and junk messages received from this client in the last 30 minutes is
greater than 10
the number of clean messages received from this client in the last 30 minutes is less than 2
the client does not exist in the internal or mynetworks IP/CIDR lists (to trust the client)

If all the conditions are true, then temporarily reject the connection and add its IP address to the
spammers data group.

Throttle Clients Sending Too Much Spam
This rule checks whether the client sends out a large amount of spam or junk mail in proportion to the
number of legitimate messages. This condition statement is used to identify whether a client is sending
a large amount of spam or junk messages, as compared to legitimate messages:
stats1h.bad_mail > 20 && stats1h.perc_ham_to_spam < 25 && stats5m.messages > 10 &&
(!is_internal && !is_mynetworks)

This statement checks these conditions:
n
n

n
n

the number of spam and junk messages received from this client in the last hour is greater than 20
the percentage of clean messages compared to spam received from this client in the last hour is
less than 25
the number of messages sent from this client in the last five minutes is greater than 10
the client does not exist in the internal or mynetworks IP/CIDR lists (to trust the client)

If all the conditions are true, then temporarily reject the connection and add its IP address to the tarpit
data group.

Throttle Internal Clients With Many Open Connections
This rule checks whether the client is on an internal network and is using a lot of open connections that
may result in a denial of service. This condition statement is used to identify whether an internal client
is creating a large amount of open connections:
open_connections > 50 && is_internal
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This statement checks these conditions:
n
n

the number of open connections from this client is greater than 50
the client is listed in the internal IP/CIDR list

If all the conditions are true, then temporarily reject the connection.

Throttle External Clients With Many Open Connections
This rule checks whether an external client is using a lot of open connections that can result in a denial
of service. This condition statement is used to identify whether an external client is creating a large
amount of open connections:
open_connections > 20 && !is_internal

This statement checks these conditions:
n
n

the number of open connections from this client is greater than 20
the client is not listed in the internal IP/CIDR list

If all the conditions are true, then temporarily reject the connection.

Throttle Clients Sending Large Amounts of Mail
This rule checks whether a client is sending too many messages that can result in a denial of service.
This condition statement is used to identify whether a client is sending an abnormal amount of
messages:
!is_peers && !is_internal && stats1h.messages > 50000

This statement checks these conditions:
n
n

the client is not listed in the peers and internal IP/CIDR lists (to trust the client)
the number of messages sent from this client in the last hour is greater than 50000

If all the conditions are true, then temporarily reject the connection.
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Create Connection Rules
To create custom connection rules:
1. Select Security > Anti-Spam > Threat Prevention.
2. Click Add Rule.
The Add New Connection Rule page appears.

You can configure these options:
n
n

Description – Type a descriptive summary of the rule.
Condition – Type a condition statement to execute.

For example:
stats1h.bad_mail > 20 && (!is_internal && !is_mynetworks)

This statement checks whether the client has sent more than 20 virus-infected or spam
messages in the last hour, and is not on the internal or mynetworks IP address lists.
See Build Condition Statements for detailed information on creating custom statements.
n
n

n

n

Action – Action to take if the condition is true. Options are Accept Mail or Reject Mail.
Reject Code – Reply code to send to the connecting client. For Reject Mail, this is “450
(temporary)” or “550 (permanent)”. For Accept Mail, the reply code is set to “220 (OK)”.
Reject Message – A customized reject message to send to the connecting client. The
%IP% variable can be used to include the IP address of the client in the message.
Add to List – Select a data group to which to add the client IP address if the condition is
true.
View and configure these lists in Security > Anti-Spam > Threat Prevention > Data
Groups.

3. Click Apply.
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Build Condition Statements
The Threat Prevention rules are based on condition statements that define various criteria for the
connecting clients and their historical behavior. These tables describe the variables, parameters, and
Boolean operators available to create Threat Prevention rules.

General Statistics
These are general statistics that you can use when you create connection rules. These include items,
for example, the IP address of the connecting client, and how many open connections a client is using.
Statistic

Description

ip_address

The IP address of the connecting client. You
must enter the IP in quotation marks.
For example: ip_address=="10.10.1.100"

current_group

The name of the current data group the client IP
addresses is in, if any.

open_connections

The current number of open connections to this
IP address.

block_list

If DNS Block lists are enabled, this indicates
the number of lists the IP address is on.

rule_no

Indicates the connection rule number for
ordering purposes.

For example, as part of your condition statement to prevent denial of service attacks, you can check
that the client does not have a large amount of open connections with this statement:
open_connections > 50

IP Lists
These parameters identify whether the client IP address is listed in any of the pre-defined IP lists
(defined in Security > Anti-Spam > Threat Prevention > IP/CIDR Lists).
This allows you to check if the client IP address is trusted because it is identified as an internal
system, a network under your control, or a peer address. The client can also be blocked if it appears in
the local blacklist.
IIP/CIDR List

Description

is_internal

Checks if the client IP address is listed in the internal
address list.

is_mynetworks

Checks if the client IP address is listed in the
mynetworks address list.
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IIP/CIDR List

Description

is_peers

Checks if the client IP address is listed in the peers
address list.

is_blacklist

Checks if the client IP address is listed in the blacklisted
address list.

For example, to check if the connecting client is in the blacklist IP/CIDR list, use this condition
statement:
is_blacklist

If the client is already listed in the blacklist IP list, the condition is true and the configured action
executed.
You can use these to make sure that clients are trusted because they are considered internal or under
an organization's control. For example, to check for a large amount of open connections, and to make
sure this client is not an internal client, use this statement:
open_connections > 50 && !is_internal

This statement checks clients who have more than 50 open connections and do not belong to the
internal IP/CIDR list.

Email Statistics
These email statistics can be used to build condition statements in the connection rules based on the
types of messages received. These statistics identify the number of messages based on their
classification, for example, virus-infected, malformed, spam, and clean. Several statistics also
indicate the percentage of one type of message to another, for example, the percentage of spam
messages to total messages received.
Email Statistic

Description

messages

Total number of messages from successful connections.

virus

Number of virus-infected messages.

malformed

Number of malformed messages.

spam

Number of spam messages (Intercept Certainly Spam or
Probably Spam, Brightmail spam, and Pattern Filter
spam).

ham

Number of messages that are clean (not spam, virus, or
malformed).

connection_attempts

Number of attempted connection attempts.

bad_mail

Number of viruses, malformed, and spam messages.

bad_recipients

Number of unknown recipients (or 0 if the Reject on
unknown recipient feature is disabled).
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Email Statistic

Description

good_recipients

Number of legitimate recipients.

perc_ham_to_messages

Percentage of clean messages to the total amount of
messages.

perc_virus_to_messages

Percentage of virus-infected messages to the total
amount of messages.

perc_spam_to_messages

Percentage of spam messages to the total amount of
messages.

perc_malformed_to_messages

Percentage of malformed messages to the total amount of
messages.

perc_bad_to_messages

Percentage of bad messages (virus, malformed, and
spam) to the total amount of messages.

perc_ham_to_spam

Percentage of clean messages to the total amount of
spam messages.

These email statistics must be used in combination with a specific time period. This allows you to
check for the number of certain types of email messages, for example, spam messages, in a certain
time period, for example, 24 hours.
This table describes various time periods that you can use in conjunction with the email statistics
variables.
Time Period

Description

stats1m

Statistics for the last minute.

stats5m

Statistics for the last 5 minutes.

stats15m

Statistics for the last 15 minutes.

stats30m

Statistics for the last 30 minutes.

stats1h

Statistics for the last hour.

stats24h

Statistics for the last 24 hours (1 day).

Specify the time period and the email statistics parameter separated by a “.” (period). For example, to
check how many spam messages were received in the last 24 hours, use this statement:
stats24h.spam

To check the percentage of the number of spam messages compared to the total amount of messages
in the last hour, use this statement:
stats1h.perc_spam_to_messages
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Boolean Operators and Syntax
These are the Boolean operators that you can sue when building condition statements. To combine
operators, use this syntax, (a && (b || c)) . This produces the result: a AND (b OR c).
Boolean Operator

Description

&&

and

!

not

||

or

>

Greater than

<

Less than

==

Equal to

>=

Greater than or equal to

<=

Less than or equal to

For example, to make sure a host is not listed in the internal and mynetworks IP/CIDR lists (to trust the
system for Threat Prevention), use this statement:
!is_internal && !is_mynetworks

This example shows how to use multiple Boolean operators to combine condition statements:
stats30m.bad_recipients >= 50 && stats30m.good_recipients < 3

This example checks the number of good and bad recipients in the last 30 minutes. If the bad recipients
are greater than or equal to 50, and the good recipients are less than 3, then the condition is true.

Connection Rules Script Error Check
When you are finished with the changes and additions to the connection rules, click Apply. The results
of the script test are displayed. This includes any syntax errors if they occur. If an error occurs,
examine the rule you just applied and check the condition statement to make sure that it conforms to
the proper syntax and that you correctly entered any variables or parameters.
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IP/CIDR Lists
Use IP/CIDR address lists to define specific groups of IP addresses that affect Threat Prevention
processing. When a client connects, the connection rules script looks up the client’s IP address in the
existing IP/CIDR lists and performs any defined actions for that list. This allows you to trust, block, or
provide additional classification for a specific IP address or subnet.
For example, if the address is listed in the blacklist, the connection rules script rejects the message.
Addresses in the peers or mynetworks list are exempted from some of the checks because they are
known sources or internal networks of your organization.
It is critical that you add any non-routable networks that you use locally to the internal address list and
make sure any networks under your organization’s control or friendly networks are listed in the
mynetworks and peers list respectively. This prevents any local addresses from being blocked by
Threat Prevention processing.
To configure IP/CIDR lists:
1. Select Security > Anti-Spam > Threat Prevention > IP/CIDR Lists.
The Static IP/CIDR Lists page appears.

n
n

n

n

n

blacklist – List of any IP addresses or networks from which you do not want to receive email.
internal – List of internal non-routable IP addresses from which you always accept mail, for
example, the 192.168.0.0 network.
mynetworks – A list of networks and subnets under your organization’s control from which
you always accept mail.
peers – A list of special sites, for example, peer ISP networks from which you typically
accept mail.
The peers list is not used by the default connection rules. You must modify the current rules
or add a new connection rule to use this list.
relays – A list of mail servers that need to relay mail through this WatchGuard XCS. This
prevents these servers from being blocked by content-based Threat Prevention rules and
Reputation Enabled Defense, as well as being reported to the Reputation Enabled Defense
service.

2. Click Add.
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3. In the Name text box, type a name for this list.
This text box cannot be left blank, and must consist of only alphanumeric characters.

4.
5.
6.
7.
8.
9.
10.
11.

In the Description text box, type a description for this address list.
In the IP/CIDR text box, type one of these address types:
Single IP address, for example, 192.168.1.125
Subnet in CIDR format, for example, 192.168.0.1/24
Class A, B, or C subnet with trailing octets removed, for example, 192.168
In the Comment text box, type a descriptive comment to describe the address in this list.
Click Add.
Click Apply.

Upload and Download IP Addresses
You can upload a list of list addresses in one text file. The file must contain comma or tab separated
entries. Use this format:
[address],[description]

For example:
192.168.0.0/16,non-routable

You must use a text editor to create the file ipcidr.csv.
To update a list file:
1. To download the list from the WatchGuard XCS, click Download File.
2. Open the file and update the list.
3. Click Upload File and upload the edited file to the WatchGuard XCS.
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Data Groups
Threat Prevention places IP addresses into Data Groups for a specified period of time and sets the
response to connection requests for clients who are in these groups. You can configure data groups to
perform a specific action (for example, “450 temporary reject” or “550 permanent reject”) and a time
period to execute that action.
Data groups differ from IP/CIDR lists because their contents are always changing based on the latest
threat prevention data. Use IP/CIDR lists to define trusted and blocked lists based on addresses
specific to your organization. Data groups build their data from the history of connecting addresses,
and assign specific rules and actions to these addresses based on that history.
The Threat Prevention connection rules script adds IP addresses to these lists if they match a specific
behavior. For example, messages from an IP address that indicate harvesting of email addresses are
moved into the harvesters list. When that same IP address tries to connect again after being added to
the list, it is rejected with a configured reject code for the list if it is configured with the reject action.
For example, the harvesters list rejects with the code “550 denied due to too many unknown
recipients”. No further statistics are gathered on that IP address during this early reject period and
further Threat Prevention rules do not apply. The data group releases the IP address after a
configurable period of time. Data groups can contain tens of thousands of IP addresses.
Data groups with an action of Just Log pass the request on to the rules processing script. The rules
script can then specify its own reject or accept action. If the rules script specifies an accept action,
further statistics are gathered as the mail is received and processed.

Integration with F5 and Cisco Devices
You can also push the contents of data groups to a perimeter F5 or Cisco device. This allows the F5 or
Cisco device to process connections from the IP address and to act accordingly before the connection
reaches the WatchGuard XCS.

Configure Data Groups
To configure data groups:
1. Select Security > Anti-Spam > Threat Prevention > Data Groups.
The Dynamic Lists page appears.
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There are five predefined data groups:
n
n
n
n
n

blacklisted – Addresses that are blocked.
harvesters – Addresses known to be involved in email address directory harvesting.
infected – Addresses known to send virus-infected messages.
spammers – Addresses known to send large amounts of spam.
tarpit – Group used to temporarily reject connections to slow down incoming connections
from an address.

2. Select a group to edit its properties, or click the Add button to add a new group.

n

n
n

n

n

n

n

n

n

Name – Type a descriptive name for this list. If you push data to an F5 or Cisco device, this
list name must match the group name configured on the device.
Description – Type a description of this list.
Action – Action to take if a connecting IP address is listed in this group. Options are Reject
Mail or Just Log.
Reject Code – If the selected action is Reject Mail, reply to the connection request with
this reject code. Select “450” (temporary) or “550” (permanent).
Reject Message – Type the reject reason provided to the client. This message is sent only
if the action is set to Reject Mail.
Entry Duration – Type the duration (in seconds) for an IP address to remain in this list after
it has been placed into this group by a connection rule. This duration period only applies to
the groups on the WatchGuard XCS and is not pushed to an F5 or Cisco device.
Maximum Entries – Type the maximum entries allows simultaneously in the list. You can
enter a value from 0 to 100000. Set to 0 for unlimited.
Push to Cisco Devices – Push data to all configured Cisco devices. The list name must
be identical to the group name defined on the Cisco device. You can only assign one data
group to push information to a Cisco device.
Push to F5 Devices – Push data to all configured F5 devices. The Group name must be
identical to the group name defined on the F5 device.

3. Click Apply.
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F5 Devices
You can push Threat Prevention information to an existing F5 device. You can then configure the F5
device to rate limit, throttle, or block a given IP address.
The data groups defined with the Threat Prevention feature are used to populate data groups on the F5
with the same name. For example, IP addresses already defined into a spammers group are pushed to
the same group name on the F5 device. This allow the F5 to manage the response to these addresses.
When an item is removed from a Threat Prevention data group, it is automatically removed from the F5
data group.
Note that the duration period of the IP address only applies to the data groups on the WatchGuard
XCS. The device constantly pushes updated list information to the F5 every 30 seconds to make sure
the lists are current and accurate. Any expired IP addresses are removed and new addresses since the
last update are added to the F5 device’s list. The data group is also fully synchronized every hour with
the F5 device.
You must configure iRules on the F5 device to act on the data groups as appropriate. The Threat
Prevention feature does not automatically create iRules on the F5 device.
Note The F5 device must be version 9.0.5 or greater.
To configure an F5 device:
1. Select Security > Anti-Spam > Threat Prevention > F5 Devices.
2. Click Add.
The Add F5 Connection page appears.

n
n
n
n

Name – Type a descriptive name to refer to this specific F5 device.
URL – Type the full URL for the F5 device. For example, https://192.168.1.100 .
User Name – Type a valid user name to log in to the F5 device.
Password – Type a password for the user name.

3. To test your connection and login parameters on the F5 device, click Test.
4. Click Apply.

Enable Data Transfer to an F5 Device
You can push items from the Threat Prevention data groups to the F5 data groups of the same name on
one or more F5 devices.
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To push data to the F5 device:
1. Select Security > Anti-Spam > Threat Prevention > Data Groups.
2. For each data group, make sure you select the Push to F5 Devices check box.

3. Click Apply.

Configure F5 Data Groups
You must manually create the data group names defined on the WatchGuard XCS on the F5 devices.
These groups are not automatically created with the Threat Prevention feature.
Note On the F5 device, you must create the groups as “external file” address data groups,
not address groups. External file address groups are updated frequently with many IP
addresses without affecting F5 performance.
To create groups on the F5 device:
1.
2.
3.
4.
5.
6.

Log in to the F5 administration interface.
Select Local Traffic > iRules.
Click the Data Group list tab.
Click Create.
Type the same group name as the data group defined in the Threat Prevention feature.
Select External file (not Address).
A subset of options appear.

7. Type the group name and select Address in the File Contents list.
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8. Click Finished.
9. Repeat the steps for each data group.
You must perform this procedure on each F5 device.

10. Create an iRule for the data group.

This is a typical iRule for the default set of data groups provided with Threat Prevention:
when CLIENT_ACCEPTED {
if {[matchclass [IP::remote_addr] equals $::harvesters] }
{ TCP::respond "550 Message Rejected - Too many unknown recipients\r\n" drop }
if {[matchclass [IP::remote_addr] equals $::spammers] } { TCP::respond "550
Message Rejected - Too much spam\r\n" drop }
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if {[matchclass [IP::remote_addr] equals $::blacklisted] } { TCP::respond
"550 Message Rejected - client blacklisted\r\n" drop }
if {[matchclass [IP::remote_addr] equals $::infected] } { TCP::respond "550
Message Rejected - Infected\r\n" drop } if {[matchclass [IP::remote_addr] equals
$::tarpit] } { pool slow_rateclass }}

11. Create any rate shaping classes, virtual hosts, and pools, as necessary for normal configuration
of an MTA.
In the previous example, a pool called “slow_rateclass” is required that is configured with rate
shaping to allow a limited rate of traffic.
12. To verify you have configured the F5 device correctly in the Threat Prevention feature, on the
WatchGuard XCS, select Security > Anti-Spam > Threat Prevention > F5 Devices, and
click Test.
The WatchGuard XCS attempts to list the contents of the F5 data group.
If successful, the list of IP addresses that have been pushed to the F5 device appear. The test
feature does not interrupt mail delivery or communications with the F5.
Note In F5 version 9.0.5, you cannot view the contents of external file data groups from the
F5 web interface. Use the Test button in the Threat Prevention menu to view the
contents of external file data groups.

WatchGuard XCS and F5 Integration Notes
Note these considerations when you integrate the WatchGuard XCS and an F5 device:
n

n

n

n

The Threat Prevention feature updates continuously but also synchronizes with each F5 Data
Group once an hour to make sure there are no discrepancies.
If the F5 device does not contain a data group, Threat Prevention attempts to synchronize with
it once every second. It reports the warning once every 30 seconds in the mail logs for this
condition.
If there is a loss of communications between the WatchGuard XCS and the F5 device, the
Threat Prevention feature retries the connection to the F5 up to ten times.
When you use F5 integration with a cluster, only the Primary device’s data groups are pushed to
the F5 device.
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Cisco Devices
You can push Threat Prevention information to an existing Cisco device. The WatchGuard XCS can
update the Cisco device with information from a single data group. To configure the Cisco device to
block a given IP address, add the IP address to an appropriate ACL (Access Control List). When an item
is removed from the Threat Prevention list, it is automatically removed from the Cisco IP access list.
Note The system utilizes the IP named access control list feature to forward information to
the Cisco device. Cisco IOS version 11.2 or later is required for WatchGuard XCS and
Cisco integration.
To configure a Cisco device:
1. Select Security > Anti-Spam > Threat Prevention > Cisco Devices.
2. Click Add.
The Add Cisco Connection page appears.

n
n

n
n
n

Name – Type a descriptive name to refer to this specific Cisco device.
URL – Type the full telnet URL for the Cisco device. For example,
telnet://192.168.1.175 .
User Name – Type a valid user name to log in to the Cisco device.
User Password – Type a corresponding password for the user name.
Administrative Password – Type the administrative (enable) password for this Cisco
device.

3. Click Apply.

Enable Data Transfer to a Cisco Device
The Threat Prevention feature pushes items from a defined data group to an IP access list on a Cisco
device. To push data to the Cisco device.
1. Select Security > Anti-Spam > Threat Prevention > Data Groups.
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2. For the data group you want to push, select the Push to Cisco Devices check box.
The Cisco device can only accept one data group. We recommend that you use the blacklisted
list to block clients on the Cisco device.
The duration period of the IP addresses only apply to the data groups on the WatchGuard XCS.
The WatchGuard XCS constantly pushes updated list information to the Cisco device every 30
seconds to make sure the lists are current and accurate.
Any expired IP addresses are removed and new addresses since the last update are added to the
Cisco device’s list. The data group is also fully synchronized with the Cisco device every hour.
For IOS version 12.1 and later, Threat Prevention lists are automatically created on the Cisco
device when group information is pushed, however, the IP access group must still be assigned
to a specific interface.
WarningMake sure that the Maximum Entries value is customized to the capabilities of
your Cisco device. Large values can overrun a Cisco device that can only
handle a certain amount of access list entries.
3. Click Apply.
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Cisco Device Configuration
To configure the Cisco device:
1. Log in to the Cisco device with the “enable” privilege.
2. Change to configure mode:
# configure terminal

3. Change to interface mode (where x and y are the Ethernet interface):
# interface FastEthernet x/y

4. Attach the IP access group to the WatchGuard XCS data group:
# ip access-group <access_list_name> in

5. Exit from the config-if mode:
# exit

6. Perform the same steps for each Cisco interface as required.
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Threat Prevention Status
The Threat Prevention Status page displays the current state of the threat prevention feature and
provides information on the current number of items in each specified list, for example, the number of
addresses listed as spammers.
To view the current threat status, select Activity > Status > Threat Prevention.
A summary of the entire threat prevention database appears. This information includes:
n
n
n

The number of IP addresses in the Threat Prevention database
The number of open connections and open connections in a DNSBL
The number of items in each defined data group, for example, tarpit, harvesters, spammers,
infected, and blacklisted.

To search for the state of a specific IP address, type the address in the IP text box. A new table
appears for that specific IP address, and displays statistics on the number of messages from that IP
address during a specific time period and the types of messages received.
To reset the status data and clear the Threat Prevention database, click Reset Threat Prevention
History.
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About Clustering
Clustering provides a highly scalable, redundant messaging security infrastructure that enables two or
more WatchGuard XCS devices to act as a single logical unit for processing messages for redundancy
and high availability benefits.
There is no theoretical limit to the size of the cluster, and you can add devices to the cluster to increase
processing and high-availability capabilities. When you use Clustering, message traffic flow is never
interrupted because of individual device failures.
You can manage a cluster from any single device in the cluster, and all devices in the cluster can
process messages. Any configuration changes, for example, Anti-Spam and Policies, are propagated
to all cluster devices.

Cluster Architecture
The WatchGuard XCS devices participating in the cluster communicate together through a network
interface connected to a separate network called the cluster network. The cluster network is a
dedicated, physically secure subnet, and the devices communicate clustering information with each
other through this network. You can add or remove devices from the cluster network without
interruption to message processing.
Note Cluster members must be connected together on the same network.
The WatchGuard XCS clustering architecture is illustrated in this diagram.
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The WatchGuard XCS operates in one of four different modes in a cluster:
n

n

n

n

Primary – This device is the primary master system for the cluster. All configuration is
performed on this device. Other devices in the cluster pull configuration changes from the
Primary automatically when you apply a new configuration.
Secondary – A device running in Secondary mode operates the same way as a Client cluster
device except that it retains a copy of the master database replicated from the Primary. If the
Primary cluster device fails, the Secondary can be promoted to Primary status.
Client – A device that runs in Client mode pulls its configuration from an existing Primary. After
the initial setup, no configuration is required on the Client. You can promote a Client to a
Secondary.
Unlike a Primary or Secondary, a Client does not contain a copy of the full configuration
database.
Standalone – The device initially installs in Standalone mode. In this mode, the device still
processes mail, but does not participate as part of the cluster and does not pull configuration
updates. This mode is primarily used to remove a cluster device for offline maintenance or
software updates.

XCSv Cluster Setup
To set up multiple XCSv virtual devices in a cluster, you must configure a dedicated virtual network
switch on the VMware host system to ensure that no data can leak to other virtual machines running on
your VMware host. This virtual switch must be mapped to actual physical network interfaces on the
VMware host system if you are clustering with XCSv devices on another physical VMware host. If
your clustered XCSv devices are hosted on the same VMware host system, the virtual switch does not
have to be mapped to physical network interfaces and you can configure the switch as an internal
logical switch.
If you install clustered XCSv devices on the same VMware host, this configuration only provides
software redundancy in the event one of the XCSv virtual devices fails. If a hardware or software issue
affects the VMware host, your entire XCSv cluster will be affected.
We recommend that if you set up multiple XCSv devices in a cluster, you should install your XCSv
virtual devices on separate VMware hosts for hardware and software redundancy in the event an issue
affects the VMware host.
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Formore detailedinformation onconfiguring XCSv virtual devices in acluster, seethe XCSv Setup Guide.

Load Balancing
Although the cluster is treated as one logical system for processing messages, network traffic is
processed independently by each cluster device and requires the use of a load balancing system to
distribute mail flow between the devices in the cluster.

Email Load Balancing with DNS
You can use a DNS round-robin technique to distribute incoming SMTP mail connections to the
devices in the cluster. For example, add these entries to your DNS MX records to distribute mail to two
different WatchGuard XCS devices.
example.com IN MX 10 mail1.example.com
example.com IN MX 10 mail2.example.com

Assign different priority values to give priority to specific devices. For example:
example.com IN MX 5 mail1.example.com
example.com IN MX 10 mail2.example.com

Note Load balancing for specific types of network traffic (for example, HTTP) is not
possible with DNS round-robin techniques.

Traffic Load Balancing with a Load Balancer Device
You can also use a hardware load balancing device to send messages to different WatchGuard XCS
devices in a cluster. If one of the devices fails, the load balancer distributes the load between the
remaining devices. You can configure the load balancer to distribute the mail stream connections
intelligently across all devices in the cluster based on device load and availability.
External load balancing devices are mandatory if you need to route specific traffic (for example, SMTP
and HTTP) through specific hosts in the cluster. For example, SMTP mail can be processed by two
cluster devices, while HTTP is handled by another two different devices. You can configure the load
balancer to route protocol-specific traffic as required.

Cluster Feature Support
These features are not supported in a cluster:
n

n

User Spam Quarantine – We recommend you use the WatchGuard QMS (Quarantine
Management Server) in a cluster environment.
Local Users – Local mail users cannot exist in a cluster.

In addition, these features are not synchronized across a cluster:
n

Unique networking settings, for example, the host name and IP address, and network interface
specific settings
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n
n
n
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Performance settings and SSL Certificates
Secure WebMail configuration (in a clustered environment, the Secure WebMail proxy can only
be enabled on the Primary in the cluster)
Reports and logs
Token analysis spam training databases
Web Proxy PAC files
Vacation notifications
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Configure Clustering
These are the steps to install and configure a cluster:
1. Hardware and Licensing – Make sure that all devices use the same hardware and run the
identical, licensed versions of software. This includes any software updates.
2. Cluster Network Configuration – Configure a network interface on each device for clustering.
3. Select a Cluster Mode – For each device in the cluster, you must choose a mode for the
device to run in (Primary, Secondary, Client, Standalone). The first device must be the Primary,
the second Secondary, and other devices can be configured as a Secondary or Client.

Hardware and Licenses
All cluster devices must be the same level of hardware, be properly licensed, and run the identical
version of software (this includes patches and updates). Any feature key discrepancies appear in the
Cluster Activity page.
Cluster devices should be new installations with no changes to the default configuration. When a
device is connected to the cluster, it receives its configuration from the Primary.

Cluster Network Configuration
To configure the network settings for two devices in a cluster:
1. Connect an unused network interface from each device in the cluster to a common network
switch, or connect each interface with a crossover network cable. This forms the cluster
network, a control network where clustering information is passed back and forth between the
devices that form the cluster.
For security reasons, this network must be isolated and not be connected to the main network.
For a cluster of two devices, you can connect a crossover network cable between the selected
interfaces to provide a secure connection without the need for a network switch.
2. On each device, select Configuration > Network > Interfaces.
3. Select the interface connected to the cluster network.
4. From the Interface Mode drop-down list, select Cluster.
The interface is automatically configured for exclusive use on the cluster network.

5. Make sure that an NTP time server is configured on each device, and add additional NTP
servers for redundancy.
You cannot enable clustering until you configure an NTP server. The time server synchronizes all
cluster devices from a common time source.
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6. Click Apply.
You must restart the system.

Select a Cluster Mode
When the WatchGuard XCS restarts, select a cluster mode for this device. Initially, the device starts in
Standalone mode. The first device set up in the cluster must be designated as the Primary system.
1. Select Activity > Status > Cluster Activity.

2. From the Local Runmode drop-down, select Primary.
3. Click Switch.
For your other cluster devices, configure at least one device as the Secondary. You can
configure the other devices as a Secondary or Client. When you add devices to a cluster, the
configuration of the Primary is replicated automatically to the new cluster device.
When you have configured all of your clustered devices, the Cluster Activity page displays the
mode and status of the other members of the cluster.
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Cluster Management
All cluster configuration is performed from the Primary. When a device is added to the cluster for the
first time, the configuration of the Primary is replicated to the new cluster member. Any changes to the
configuration of the Primary results in a broadcast notifying the other members of the cluster that a
change has been made. The other devices in the cluster then pull the updated configuration from the
Primary.

Cluster Activity
The main Cluster Activity page displays processing statistics for the entire cluster.
Select Activity > Status > Local Activity to see the statistics only for this specific device.

Mail Statistics
The queue statistics columns for email are:
n

n

n

Arrived – The total number of messages processed by the cluster (messages accepted).
These include messages that are spam, viruses, and filtered because of content.
Sent – The total number of messages sent by the cluster. This includes mailer daemon mail,
quarantine notifications, mail delivery delay notifications, local mail, alarms, and reports. If a
message has multiple recipients, each delivered recipient is added to the total.
Spam – The total number of messages classified as spam by Intercept for the cluster. This
includes Certainly Spam, Probably Spam, Maybe Spam, and rejected spam messages. This
category is based on the Spam logging configuration in Configuration > Miscellaneous >
Reports. The spam action of Just Log is counted in the total if you enable it in the spam logging
configuration.
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Reject – The total number of messages rejected because of these features:
o Reject on unknown sender domain
o Reject on missing sender MX
o Reject on non FQDN sender
o Reject on unauth pipelining
o Reject on Unknown Recipient
o Relay Access Denied
o Threat Prevention Reject
o Reputation Enabled Defense Reject (Reputation, Infected, Dial-up)
o DNS Block List Reject
o Specific Access Pattern Reject
o Pattern Filter reject
o Anti-Spam Reject (is also included in Anti-Spam statistics column)
o Anti-Virus Reject (is also included in Anti-Virus statistics column)
o Attachment Control Reject
o Objectionable Content Filter Reject
o Content Scanning Reject
Virus – The total number of virus-infected messages. This includes rejected messages.
Spyware – The total number of spyware-infected messages. This includes rejected spyware
messages.
Clean – The total number of messages accepted for delivery inbound and outbound by the
WatchGuard XCS that passed all security and spam/content filters. This includes messages
detected by these features that have an action of Just Log.

HTTP Statistics
The statistics columns for the HTTP Proxy are:
n
n

n
n

HTTP Requests – The total number of incoming and outgoing HTTP requests.
Reject – The total number of web requests rejected because of the threat and content control
scanners.
Virus – The total number of web requests blocked because the web site contained a virus.
Spyware – The total number of web requests blocked because the web site contained spyware.

Servers
The statistics and information provided in the Servers section of the Cluster Activity page are:
n
n

n

n

n
n
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Host – Indicates the host name of the cluster device.
Mode – Indicates which cluster mode the specific host is running in, for example, Primary,
Secondary, or Client.
Feature Key – All cluster devices must have the same licensed features. This column
indicates if the feature key is “OK” for this cluster device, or a “Mismatch” appears if the feature
key on this host does not match the other devices in the cluster.
Status – Indicates if the cluster device is currently “Running” and processing messages or
“Stopped”.
Uptime – Indicates how long this cluster device has been running since its last restart.
Load Averages – Indicates CPU load for this cluster device over 1 minute, 5 minutes, and 15
minutes.
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n

Queued – Indicates how many messages are currently in the Mail Queue waiting to be
delivered.
You can view and manage these messages in Activity > Queue/Quarantine > Mail Queue.
Deferred – Indicates the number of messages that have their delivery deferred because the
destination mail server is unavailable. The WatchGuard XCS attempts to deliver these
messages at a later time.
Total – The total of all messages that are queued for delivery or deferred on this cluster device.

Stop and Start Messaging Queues
If you click the Stop or Start messaging button on a cluster device, this action applies on all devices in
the cluster.
To modify an individual cluster device’s messaging status, change the run mode to Standalone, and
then click the Stop or Start messaging button as required. The full main menu is only available on the
Primary system. Secondary and Client devices only show a subset of options because most of the
configuration is replicated from the Primary.

Change Cluster Run Mode
If a Primary device fails, you can log in to the Secondary and change its mode to Primary. A Client
must be first promoted to a Secondary before it can be promoted to a Primary. This is because a Client,
unlike a Secondary, does not contain a copy of the Primary’s database.
To change the mode of a cluster device:
1. Log in to the device you want to modify.
2. On the Cluster Activity page, from the Local Runmode drop-down box, select a new mode.
3. Click Switch.

Cluster System Maintenance
Use the Standalone cluster mode to perform maintenance on a device, for example, to update a feature
key, make hardware modifications, perform software updates, and troubleshoot issues. In Standalone
mode, the device still processes messages, but does not receive configuration updates from the
Primary. This prevents configuration misalignment between devices with different software versions or
licensed features.
Note It is critical that you set a cluster system to Standalone mode when you perform any
feature key or software updates.
When you have finished the system maintenance and restarted the device, you can set the mode of
the device back to its original cluster state. The device returns to the cluster and continues to process
mail. Configuration replication from the Primary resumes when you have rejoined the device to the
cluster.
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Unlike a Primary or Secondary, a Client does not contain a copy of the configuration database. When
you switch between Client and Standalone modes, this can result in the user interface configuration of
the Standalone not reflecting its actual configuration as a Client in the cluster. To make sure a Client
has the latest configuration changes, set its mode to Secondary and wait 15 minutes before you set the
mode to Standalone.

Perform a System Update on a Cluster Device
To perform a system update, for example, a feature key or software update, in a cluster consisting of a
Primary, a Secondary, and a Client:
1. On all devices in the cluster, change the cluster run mode to Standalone mode.
Note We recommend that you stop message processing on any Client systems before you
switch them to Standalone mode. This prevents the system from processing mail
with a default configuration when you change the mode back to Client. The Client
needs time to update its configuration from the Primary system when the Client is
added to the cluster again after the update.
2.
3.
4.
5.
6.
7.

Perform the update on the Primary, and then restart the system.
Change the run mode of the Primary system from Standalone back to Primary mode.
Perform the update on the Secondary, and then restart the system.
Change the run mode of the Secondary system from Standalone back to Secondary mode.
Perform the update on any Client systems, and then restart the system.
Change the run mode of the Client systems from Standalone back to Client mode..

This procedure ensures that while the devices are updated, there are no configuration changes to the
cluster.

Cluster Reports and Message History
In clustered environments, reports generate information aggregated for the entire cluster. System and
Resource reports display information for each host in the cluster. You can also search the message
database on a single device or on the entire cluster. The history and status of any message is instantly
retrieved regardless of which device processed the message.

Cluster Device Failures
If a device in a cluster fails, all traffic is still processed by the remaining cluster devices. If you use load
balancing devices or DNS round-robin techniques, traffic is routed to the other devices in the cluster. If
a Primary device fails, all traffic is still processed by the remaining devices, but you cannot make
configuration changes to the cluster. You must promote a Secondary device to Primary mode to allow
further configuration changes to the cluster.
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Backup and Restore in a Cluster
In a cluster, all Secondary and Client cluster devices pull their configuration directly from the Primary,
and it is critical that you back up the Primary configuration on a regular basis to preserve your cluster
configuration. Backup Secondary and Client devices if you want to retain their mail queues,
quarantined messages, and any reporting data.

Recover a Primary Cluster System
In the event a Primary system fails, you must promote an existing Secondary system to Primary.
When the issue with your original Primary is resolved, it should be restored (this includes any mail
queues, quarantined messages, and reporting data) and reinserted into the cluster as a Secondary
system. Operating as the Secondary, this device pulls an updated cluster configuration from the
Primary. If required, this device can be promoted back to its original Primary mode.

Recover a Secondary and Client Cluster System
If a cluster member that is a Secondary or Client fails and cannot be recovered, it must be reinstalled
and inserted back into the cluster in its original cluster mode (Secondary or Client) where it then pulls
its configuration information from the Primary. Configuration items specific to this cluster device, for
example, network settings, SSL certificates, performance settings, and SNMP configuration, must be
manually reconfigured. If you have backed up mail queues, quarantined messages, and reporting data
for these devices, you can restore them individually without restoring the system configuration from
backup.

Threat Prevention and Clustering
When you use Threat Prevention features in a clustered environment, you only need to configure
Threat Prevention on the Primary device of the cluster.
Note Threat Prevention decisions are based on per device statistics, and not on statistics
for the entire cluster.
The Primary is also the only point of contact between the cluster and any configured load balancing
devices. If you demote a Primary, and promote a Secondary to be Primary, the cluster switches control
and resynchronizes to the load balancing device. Threat Prevention still runs independently on each
device in the cluster, but only the Primary pushes data to the external devices. See About Threat
Prevention for more detailed information.

Clustering and Centralized Management
Clusters are used for high availability and load balancing of messages for a single site, and typically
include devices with identical configurations. Centralized Management allows you to monitor and
manage multiple clusters and independent devices with unique configurations for an entire
organization.
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Centralized Management is a separate function than clustering. You can use Centralized Management
in conjunction with clustering, especially in environments where individual devices and clusters are
located in different geographical locations or require a unique configuration.
Centralized Management allows you to treat each cluster as a single Entity within the Federation. You
only need to add the Primary device of each cluster to the Centralized Management Federation. If you
synchronize a configuration to the Primary of the cluster, the clustering configuration replication
process applies the configuration to the other devices (for example, Secondary and Clients) in the
cluster. For a Manager system, the Secondary system in the cluster can take over as the Manager
system if the Primary is unavailable.
See About Centralized Management for more detailed information.
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About Centralized Management
Centralized Management allows you to efficiently monitor and manage several WatchGuard XCS
devices, running independently or as part of a cluster, from a single management system. In large
enterprise networks, there can be several WatchGuard XCS devices operating as clustered or nonclustered systems that are located in geographically distant locations. Each of these devices can have
several shared configuration parameters and also require unique configurations for their particular
location.
A set of clustered or non-clustered devices that are monitored and managed by Centralized
Management are called a Federation. Each device within the Federation is called an Entity. The
Manager system acts as the single point of management and provides the ability to add clustered and
non-clustered Entities to the Federation.
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All communication between the Manager and Entity systems in a Federation is secure to make sure
that communication between devices are not intercepted or decoded by third-parties. Control
messages between devices are authenticated to make sure they originate from authorized entities in
the Federation.

Centralized Management and Clustering
Centralized Management is a separate function than clustering. You can use Centralized Management
in conjunction with clustering, especially in environments where individual devices and clusters are
located in different geographical locations or require a unique configuration.
Clusters are used for high availability and load balancing of messages for a single site, and typically
include devices with identical configurations. Centralized Management allows you to monitor and
manage multiple clusters and independent devices with unique configurations for an entire
organization.
Centralized Management allows you to treat each cluster as a single Entity within the Federation. You
only need to add the Primary device of each cluster to the Centralized Management Federation. If you
synchronize a configuration to the Primary of the cluster, the clustering configuration replication
process applies the configuration to the other devices (for example, Secondary and Clients) in the
cluster. For a Manager system, the Secondary system in the cluster can take over as the Manager
system if the Primary is unavailable.
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Centralized Management Features
Centralized Management provides these features and benefits:
n

n

n

n

n
n

Allows you to group a Manager and Entity devices (this includes clustered and non-clustered
devices) into a single Centralized Management Federation.
Allows you to monitor the activity and status of all Entities in the Federation from the Manager
device.
Allows you to define a global configuration set that you can apply to all Entities in a Federation
(this includes independent devices and clusters). Most aspects of the configuration are
available for distribution. This includes message delivery settings, policies, policy mappings,
and mail routes.
You can modify the local configuration of Entity devices in the Federation for unique local
requirements.
You can view reports from all Entities in the Federation on the Manager system.
You can search the Message History of all Entities in the Federation on the Manager system.

Deployment
Centralized Management can be deployed on any type of WatchGuard XCS device. This includes
clustered and non-clustered systems. The device running as the Manager can still process messages
and perform security processing independently or as part of an existing cluster.

Centralized Management in a Cluster
In this deployment, the Centralized Management device is running in a cluster at the main
organizational site running on the Primary system. In this configuration, the Secondary cluster system
can take over as the Manager system if the Primary is not available.
The Manager system can monitor and manage other Entities in the Federation. This includes entire
clusters (Site B), or independent non-clustered devices (Site C).
When you add a cluster to a Federation, you only need to add the Primary for that cluster. All
configuration items synchronized from a Configuration Set to the Primary are automatically replicated
to the Secondary and Client devices as part of the clustering configuration replication process.

User Guide

545

Centralized Management

Centralized Management on a non-Clustered System
You can also deploy the Manager device on an independent non-clustered system while managing both
clustered (Site B), and non-clustered sites (Site C) in other locations.
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Networking Ports and Addresses
Centralized Management uses TCP port 10106 to communicate between systems in the Federation.
You must open this port inbound and outbound on a network firewall if the devices are located behind
the firewall.
If the IP addresses are NAT (Network Address Translation) addresses, you must specify the Entities
and Manager with the public address of the firewall. You can do this during the Entity configuration
process when you add the Entities to the Manager system.
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Create a Centralized Management Federation
To configure Centralized Management:
n
n
n

Enable Centralized Management on the Manager.
Enable Centralized Management on the Entity.
Add the Entities to the Manager.

Enable Centralized Management on the Manager
To enable Centralized Management and configure the Manager device:
1. Log in to the Manager system.
2. Select Configuration > Network > Interfaces.
3. Select the Centralized Management check box for the required interface.

4. Click Apply.
You must restart the system.

5. Select Administration > Multi-System Management > Centralized Management >
Configure.
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6. Select the Enable Centralized Management check box.
7. From the Mode drop-down list, select Manager.
This device acts as the single point of management for a Centralized Management Federation of
Entities.

8. In the Name text box, type a name to identify this device in the CM federation.
The default name is the device host name.

9. Click Finished.
10. Click Show Advanced Options to display the key used by this Manager device to authenticate
to other Entities in the Federation.
If you use automatic key exchange (this is the default behavior), there is no additional
configuration required. If you use manual key exchange, this Manager key is manually copied to
each Entity in the Federation.

Configure Manager Systems in a Cluster
If the Manager device is configured in a cluster, enable Manager mode on the Primary device. You
must also enable the Secondary device in the cluster as a Manager in Centralized Management to
make sure that the Secondary system in the cluster can take over as the Manager if the Primary is
unavailable.
Note You must switch all devices to Standalone mode before you configure Centralized
Management.
To configure the Secondary device:
1.
2.
3.
4.
5.

Log in to the cluster Secondary system.
Change the cluster mode to Standalone mode.
Select Configuration > Network > Interfaces.
Select the Centralized Management check box for the required interface.
Click Apply.
You must restart the system.

6. Select Administration > Multi-System Management > Centralized Management >
Configure.

7. Select the Enable Centralized Management check box.
8. From the Mode drop-down list, select Manager.
This Secondary device becomes the Manager if the Primary Manager is unavailable.

9. In the Name text box, type a name to identify this device in the CM federation.
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The default name is the device host name.

10. Click Finished.
To configure the Primary cluster Manager:
1.
2.
3.
4.
5.

Log in to the Primary cluster Manager.
Change the cluster mode to Standalone mode.
Select Configuration > Network > Interfaces.
Select the Centralized Management check box for the required interface.
Click Apply.
You must restart the system.

6. Select Administration > Multi-System Management > Centralized Management >
Configure.

7. Select the Enable Centralized Management check box.
8. From the Mode drop-down list, select Manager.
This device acts as the single point of management for a Centralized Management Federation of
Entities.

9. In the Name text box, type a name to identify this device in the CM Federation.
The default name is the device host name.

10. Click Finished.
Now you must switch both devices back to their original Cluster mode top make sure they are properly
configured and licensed as Centralized Management Managers before you cluster the devices and add
Entities to the Federation.
1. Log in to the Primary and change the cluster mode of the Primary from Standalone mode to
Primary mode.
2. Log in to the Secondary system and change the cluster mode of the Secondary system from
Standalone mode to Secondary mode.
After you change the cluster mode, the Centralized Management menu items no longer appear
on the Secondary. Any Centralized Management configuration performed on the Primary is
automatically replicated to the Secondary system.
3. On the Primary, select Administration > Multi-System Management > Centralized
Management > Configure.
4. From the Secondary Hostname drop-down list, select the Secondary device in the cluster and
click Finished.
This device becomes the Manager system if the Primary is unavailable.
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The cluster Manager setup is now complete. Proceed to the next section to add Entity systems to the
Federation.

Enable Centralized Management on Entity systems
To enable Centralized Management on each Entity in the Federation:
1. Log in to the Entity system.
2. Select Configuration > Network > Interfaces.
3. Select the Centralized Management check box for the required interface.

4. Click Apply.
You must restart the system.

5. Select Administration > Multi-System Management > Centralized Management >
Configure.
6. Select the Enable Centralized Management check box.
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7. From the Mode drop-down list, select Entity.
This device acts as an Entity in a Centralized Management Federation. You can monitor and
manage this device from the Manager. If this Entity is clustered, select the Secondary address
from the drop-down list. The Secondary take over for the Primary Entity if it is unavailable.
You do not need to enable Centralized Management on other devices in the cluster (for
example, Secondary and Client devices). They receive their CM configuration from the Primary
Entity in the cluster.
8. In the Name text box, type a name to identify this system in the CM Federation.
The default name is the device host name.

9. Click Finished.
To add the Entity to the Centralized Management Federation, you must add the device to the
Entity configuration on the Manager, as described in the next section.
10. Click Show Advanced Options to reveal the configuration items for manual key exchange
between the Manager and Entity systems.
The Manager and Entity systems in the Federation use automatic key exchange by default for
authentication. Manual key exchange allows you to manually copy the key values between the
Manager and Entity devices to troubleshoot key exchange issues.
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Enable Manual Key Exchange – Select the check box to enable manual key exchange.
Primary Key – This is a static value that displays the key for this specific device. This
Entity’s key is copied to the Manager.
Manager Name – Type the name of the Manager.
Primary Manager IP – Type the IP address of the Primary Manager.
Primary Manager Key– Copy the key from thePrimary Managerand pasteit intothe textbox.
Secondary Manager IP – If the Manager is clustered, type the IP address of the
Secondary that takes over as the Manager if the Primary is unavailable.
Secondary Manager Key – Copy the key from the Secondary Manager and paste it in the
text box.
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Add Entities to a Federation on the Manager System
To add new Entities to the Centralized Management Federation:
Note You must enable and initialize Centralized Management on Entities before you add
them to the Federation on the Manager.
Log in to the Manager system.
1. Select Administration > Multi-System Management > Centralized Management >
Entities.
2. Click Create New Entity.

3. In the Primary Entity Address text box, type the IP address of the Primary Entity.
If the Entity is located behind a NAT device, for example, a network firewall, type the public address
of the NAT device.

4. In the Secondary Entity Address text box, type the Secondary Entity address if this device is
clustered.
5. In the Primary Entity Username text box, type the admin user for the device.
This is the administrative user for this system.

6. In the Primary Entity Password text box, type the password for the admin user.
7. From the Primary Manager Address drop-down list, select the IP address of the Primary
Manager device.This is the IP address of the Manager in the Federation. If Centralized
Management is used in a cluster, select the Secondary Manager address from the drop-down
list. If the Manager is located behind a NAT device, for example, a network firewall, select
Specify from the drop-down list and type the public address of the NAT device.
8. Click Apply.
9. Click Finished.
10. Click Show Advanced Options to reveal the configuration items for manual key exchange.
Manual key exchange allows you to manually copy the key values between the Manager and
Entity devices to troubleshoot key exchange issues.
n
n
n
n
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Enable Manual Key Exchange – Select the check box to enable manual key exchange.
Entity Name – Type the name of the Entity system.
Primary Entity Key– Copy the key from thePrimary Entity system andpaste itin thetext box.
Secondary Entity Key – If this Entity is clustered, copy the key from the Secondary Entity
and paste it in the text box.

WatchGuard XCS

Centralized Management

Configuration Sets
Centralized Management allows you to create a global configuration set and apply it to the devices
participating in the Centralized Management Federation.
The configuration set includes most aspects of the configuration which can be distributed to Entities in
the Federation. This includes message delivery settings, policies, policy mappings, and mail routes.
Items unique to each device, for example, the network configuration, are not included.
Note You can only apply a single global configuration set at any one time.
When you synchronize the configuration set with the Federation for the first time, the configuration set
replaces the current local configuration on all Entities in the Federation. Administrators of the Entity
systems can modify their local configuration as required to allow for any unique local requirements.
Any subsequent configuration sets applied to the Entity only override local values that are not modified.
Click the Purge Local Settings link in the menu bar to purge and replace the local Entity configuration.

Configuration Set Features
You can customize and replicate these features in a configuration set:
Category

Configuration Item

Configuration

Directory Servers and Users
LDAP Aliases, Mapping, Recipients, Relay, Routing
Alarms
Customization
SNMP
External proxy server

Mail

Mail Access
Mail Delivery
Aliases
Routing
Mapping
Virtual Mapping
Archiving
DKIM/DomainKeys

Encryption
External Encryption
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Category

Configuration Item
SecureMail Encryption
TLS Encryption

Web Proxy

HTTP/HTTPS Proxy Server
HTTPS Scanning
URL Categorization
Reputation Enabled Defense
Traffic Accelerator
User Reporting
URL Block Lists
Proxy Auto Configuration

Intercept

Intercept Settings
Connection Control
Threat Prevention
Anti-Spam and Brightmail
Anti-Virus and Spyware
Outbreak Control
Malformed Mail

Content Control

Attachment Control
Content Control
Content Scanning
Document Fingerprinting
Objectionable Content Filter
Pattern Filters
Content Rules
Dictionaries

Policy

Policies (Policies are accepted as a whole, and individual
parts of a policy cannot be overridden locally)
User, Group, IP, Time, and Domain Policies

User Accounts

Mirror Accounts
Trusted/Blocked Senders
User Spam Quarantine
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Category

Configuration Item
Remote Authentication

Reports

Reports
Reports and Logging configuration

These features are unique to a specific host device and you cannot define them in a configuration set:
Category

Configuration Item

Configuration

Network Settings
Virtual Interfaces
Performance Settings
Static Routes
Web Server
Queue Replication

Intercept

Token Analysis Advanced Settings

User Accounts

Admin Account
Local Accounts
Relocated Users
POP3 & IMAP
SecurID

Management

Backup & Restore (Target names require a variable by the
hostname, for example, %q)
Daily Backup

Web Proxy
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Create a Configuration Set
To create a Centralized Management configuration set:
1. Log in to the Manager system.
2. Select Administration > Multi-System Management > Centralized Management >
Configuration Set.
3. Click Create New Configuration Set or click the Configure link to edit an existing
configuration set.

4. In the Name text box, type a name for this configuration set.
5. In the Description text box, type a detailed description for this configuration set.
6. Click Finished.
Note The name “Global” is a reserved word and cannot be used. The name “Global” appears
as the name of the configuration set on all Entity devices.

Define a Configuration Set
To select and define a configuration set:
1. Log in to the Manager system.
2. From the drop-down list, select a configuration set.
For example, ConfigSet.
The initial context in the drop-down list is This Machine. This context indicates the current local
configuration of the device.

When you select a configuration set, the page indicates the current loaded configuration set.
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You can now customize the configuration as required using the displayed menu items.
This configuration is only saved for this specific configuration set. Only a subset of the main
menu appears. This menu displays only configuration parameters that can be replicated to
Entities in a Federation.
3. Select This Machine from the drop-down list to exit the configuration set and return to the
original configuration menu for the Manager.

Apply a Configuration Set
To apply a configuration set to the Entities in the Federation:
1. Log in to the Manager system.
2. Select the configuration set to replicate from the drop-down list, for example, ConfigSet.

3. Click Synchronize.
The configuration set is synchronized with all Entities and the Manager device in the Federation.
A message appears that indicates that you cannot use the device until the synchronization is
complete.
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Note Make sure each Entity in the Federation is running the same software level (this
includes any applicable software updates), before you synchronize a configuration.

View a Configuration Set on an Entity
To view the configuration settings in the Global configuration set:
1. Log in to the Entity.
2. Select Global from the drop-down list.
The display indicates that the global configuration is loaded.

The Global configuration set appears as Read Only. This indicates that only the Manager can
modify the Global configuration set. Administrators on the Entity machine can browse the
configuration to view what settings apply in the Global configuration set.
3. To modify the Global configuration set for local requirements, select This Machine from the
drop-down list.
In this context, any changes you apply only affect this device. This allows the Entity
administrator to modify or extend the Global configuration set with local requirements as
needed.

Purge Local Settings
When the Manager in the Federation initially synchronizes a configuration set to this Entity, the
configuration set overrides any current local configuration. Any subsequent configuration sets applied
to this Entity only override local values that are not modified.
To remove all local configuration overrides and use the current Global configuration set, on the Entity,
select Administration > Centralized Management > Configure, then click Purge.
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A message appears that indicates that you cannot use the device until the purge process is complete.
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Centralized Management Activity
To display the Centralized Management Activity page, select Activity > Status > CM Activity on the
Manager. This page displays the connectivity status and statistics for all Entities in the Federation.

n
n
n
n
n
n
n

n

Entity – Displays the Entity name.
Type – Describes the type of Entity. For example, “Cluster” or “No Cluster”.
Communication – Indicates the current status of the Entity. For example, “Connected”.
License – Indicates whether this device has an active system license and the software version.
Uptime – Displays how long the device has been running since the last restart.
Queued – Displays the number of messages currently queued for delivery on the Entity.
Deferred – Indicates the number of messages on the Entity that have had their delivery deferred
because the destination mail server is unavailable. The device attempts to deliver these
messages at a later time.
Total – Displays the total number of messages currently queued for delivery or deferred on the
Entity.

Entity Status
To view the status of an Entity, select Administration > Multi-System Management > Centralized
Management > Entity Status.
The status displays the name of the Manager system of the Federation, the communications status of
this Entity, and the time of the last communication between the Manager and Entity.
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Centralized Management Reports
When you use Centralized Management, the Manager can view reports generated on other Entities in
the Federation. This allows you to view and manage reports from one central location, and you do not
have to login to each Entity to view its reports.
You can also search the Message History of all Entities in the Federation from the Manager and view
the results without having to log in to each Entity.

View Centralized Management Reports
To view Centralized Management reports:
1. Log in to the Manager system.
2. Select Activity > Reports > Centralized Management.
The CM Reports page displays the available reports and indicates which Entities have generated
the reports.

3. To refresh the Entity report list with any new generated reports, click Update Report List.
4. Click a report to view the reports for each Entity that has generated that type of report.
For example, Web Summary Report.
From this page you can view and manage the generated reports for each Entity. To delete a
report, select the Entity report, and then click Delete Selected Reports.
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View Message History
You can search the Message History across all Entities in the Federation from the Manager device.
This includes all search criteria and advanced search parameters.
To search the Message History of Entities in the Federation:
1. On the Manager, select Activity > History > Message History.
A list of Entities appears in the right-side box.

2. Select the Entities on which you want to perform the message history search.
3. Enter your search criteria, and then click Search.
The Entity column identifies the Entity device on which the search results appeared.

By default, the results are sorted by Entity. You can also sort by other criteria, for example, host
name or date.
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About Reports
The WatchGuard XCS reporting functions provide a comprehensive range of informative reports:
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n
n

Full Email Report
Email Executive Summary
Virus Report
Spyware Report
Traffic Report
Email Analysis Report
Intercept Report
Attachment Control Report
Per-user Attachment Report
Pattern / Filter Report
Outbound Content Control Report
Connection Control Report
User / Host Report
Session Summary
Reputation Domain Report
Rules Report
System and Resource Summary
Web Analysis Report
Web Summary Report
Web User Summary Report

You can generate reports on demand and at scheduled times. The reports data is derived from
information written to the message logs and stored in the reporting database. You can store and view
up to a month’s reporting data, depending on message loads for your particular environment.
Note The XCS device automatically adjusts the number of days of reporting data that can
be stored based on current device resources.
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Reports are stored on the system for online viewing, and can also be emailed automatically to the
administrator. Reports can be generated in PDF (Adobe Portable Document Format), CSV, and HTML
format. You can customize the logo that appears on the header of your reports.
In clustered environments, reports generate information aggregated for the entire cluster. System and
resource reports display information for each host in the cluster. In Centralized Management
environments, the Manager system can configure and view reports for all Entities in a Centralized
Management Federation.

Domain Reporting
For organizations that support multiple domains, you can add per domain information to specific reports
to provide you with statistics for each domain hosted by the WatchGuard XCS. You can also enable
domain reports that create separate reports for each hosted domain. These domain reports can be
emailed to the specific administrator of each domain.
Note Per Domain and Hosted Domain reports are not available for all report types.See
Report Types for detailed information on the data that is generated for each report type.

Inbound and Outbound Reporting
In most cases, inbound messages are considered untrusted, and outbound messages are considered
trusted. For any of the recipient-based reports, the inbound or outbound status is determined by mail
routes during message processing. For domain-based reports, you can upload a list that contains
hosted domains and their administrative email addresses in Security > Content Control >
Dictionaries. In this case, inbound and outbound determinations are based on the sender and recipient
of the message.
For example, for a list of the hosted domains example1.com and example2.com:
n
n
n

Inbound mail for example1.com is based on the recipient domain being example1.com
Outbound mail for example1.com is based on the sender domain being example1.com
These same rules apply for example2.com, but mail from example1.com to example2.com is
counted as outbound for example1.com and inbound for example2.com
Note When you create Hosted Domain outbound reports, make sure that the uploaded
domain name is the domain of the Sender. Inbound reports use the domain of the
Recipient.
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Schedule Reports
To schedule and generate reports:
1. SelectActivity>Reports>Schedule.

The Report Definitions page displays any scheduled and defined reports. This includes the
report name, report type, the reporting time period, the frequency, and the last time the report
was generated.
2. Click the Edit link to edit an existing report, or click the Create New Report link to create a new
report definition.
3. To view the last generated report from this report definition, click the Last Generated date link.
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Create a New Report
To create a new report:
1. Click the Create New Report link.
The Report Definition page appears.

2. In the Report Name text box, type a descriptive name for this report.
The name must only contain alphanumerical letters, numbers, and spaces, and must not contain any
special characters.

3. From the Report Type drop-down list, select the which type of report to run.
Select a category of reports, for example, Email, Web, and System, and then choose a report
sub-type for that category.
4. From the Period drop-down list, select the time period for the report coverage:
n
n
n
n
n

Previous Day (includes up to midnight of the previous day)
Last 7 Days
Sunday - Saturday (includes 7 days from a Sunday to the next Saturday)
Monday - Friday (includes 5 days from Monday to Friday)
Previous Month (this is the previous calendar month).

Note To report on the previous month in a report definition, the Reporting Summary Days
option in Configuration > Miscellaneous > Reports must be set to 60 days or more
to have enough data to cover the previous month time period.
5. From the Run this report drop-down list, select the day and time to run the scheduled report.
6. In the Email this report section, select who to send a copy of the report to when it is
generated.
Select The administrator to send it to the administrator of this system, and/or select Other and
enter a comma separated list of addresses to which to send the report.
For example,
admin@example.com,admin2@example.com,admin3@example.com
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7. From the Table Length drop-down list, select the length for each report field.
For example, in the Top Viruses list, the top 50 viruses are displayed if this field is set to 50. The
default is 25. You can configure the default value in Configuration > Miscellaneous >
Reports.
8. Click Save and Start to save the report and generate it immediately.
Select Save or Save As (to save under a different name) to save the report and run it at the
scheduled time and day.
Click Delete to remove this report definition. Any reports associated with this report definition
are not deleted and can still be viewed.

Domain Reports
The Domain Reporting option allows specific reports to be generated and customized for systems that
accept messages for multiple domains. To upload a list of hosted domains and associated domain
administrator email addresses, select Configuration > Miscellaneous > Reports.
Note When you upload hosted domains, statistics collection on these domains begin from
that point and may not be immediately available for reports. You can upload a
maximum of 250 domains.

These options are available:
Data aggregated for all domains
This option generates reports based on all message domains hosted by this system. The
reports do not break down any report statistics based on each domain, but report on all
messages as a whole for this system. This is the default setting.
Include per domain tables
This option generates the system reports, but includes tables displaying a summary of the
messages based on each domain hosted by the system. For example, if you run a Full Email
Report, only one Full Email Report is generated, but it includes statistics on each domain in
separate tables in the report.
Separated reports one for each hosted domain
This option generates the system reports, but creates a separate report for each domain hosted
by the system. For example, if you run a Full Email Report, a Full Email Report is generated
separately for each domain on the system.
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Note Per Domain and Hosted Domain reports are not available for all report types. See
Report Types for detailed information on the data that is generated for each report type.
Email Domain Reports
Select to whom a copy of the report are sent to when the report is generated. Select Each
domain administrator to send the report to the administrator of each domain, and/or select
Other and enter a comma separated list of addresses to which to send the report.
For example:
admin@example.com,admin2@example.com,admin3@example.com

If a separate report is run for each domain, the domain administrator only receives the report for
their own domain.
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View Reports
To view your generated reports:
1. Select Activity > Reports > View.
The Generated Reports page appears.

Reports are generated in PDF (Adobe Portable Document Format), CSV, and HTML format.
2. Click the appropriate icon to view the contents of the report in the specified format.
The report either appears in a new browser window (for an HTML report) or you can save the PDF
and CSV versions of the report on the local computer.

Note HTML reports are optimized for on-screen viewing, and are not recommended for
printing reports. The PDF report type should be used for report printing.
You can filter the generated reports page by report definition name or by the type of report using
the drop-down list of available report names or definitions.
3. Click Search to filter the reports list.
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Custom Report Logo
You can upload a custom logo for the header of your reports.
To customize a logo for the reports:
1. Select Configuration > Miscellaneous > Customization.

2. Go to the Administration section.
This logo is used for both Web UI admin pages and generated reports.

3. For the logo you want to customize, click Browse to choose a file, and then click Next to upload
the file.
Most graphic formats are supported (GIF, JPEG, PNG, BMP), but we recommend that you use
graphics suitable for web pages, for example, GIF and JPEG. The maximum file size is 32k
with a recommended height of 40 pixels.
The logo space has an aspect ratio of about 2.3:1. We recommend you use a square or
horizontal logo with up to a 2:1 aspect ratio.
Select the Reset this Logo to the Default link to revert to the default logo.
4. Click Finished.
Note After you have uploaded a custom logo, the logo will only appear in new generated
reports. Previously generated reports are not affected.
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Report Types
Full Email Report
Includes the highlights from all listed Email report types. Individual reports may have more
detailed information that are not found in the Full Email Report. This report does not include Web
Proxy statistics. You can generate Per-domain and hosted domain reports with this report.
Email Executive Summary
The Email Executive Summary provides an overview of mail processing statistics for inbound
and outbound mail. You can generate hosted domain reports with this report.
n

n

Inbound Message Summary – Indicates the number of inbound messages that are
rejected, classified as spam, caught by content control, contained viruses, or are clean.
Rejected – Indicates the number of messages rejected by Reputation Enabled Defense
and other features that reject a message before the SMTP connection is complete. This
category is displayed for inbound mail only. This statistic includes these connection
rejects: Reputation Enabled Defense Connection Reject (Reputation, Infection, and Dialup), DNS Block List Reject, Threat Prevention Reject, Specific Access Pattern Reject,
Pattern Filter reject, Connection Rule reject, Reject on unauthorized SMTP pipelining,
Reject on unknown sender domain, Reject on missing reverse DNS, Reject on missing
sender MX, Reject on non FQDN sender, Reject on Unknown Recipient, Reject on
missing addresses, Reject if number of recipients exceeds maximum, Reject if message
size exceeds maximum.

Note The bar graph on the right side of the report only indicates rejected messages for
Reputation Enabled Defense feature only, and does not include other SMTP
connection rejects.
n

n

n

n

n
n
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Detected Spam – Indicates the number of messages that are classified as spam. This
includes Certainly Spam, Probably Spam, Maybe Spam, Brightmail spam, Reputation
Enabled Defense Spam, and DNS Block List Spam. This category is displayed for inbound
mail only. This category also depends on the Spam logging configuration in Configuration
> Miscellaneous > Reports. The spam action of Just Log are counted in the total if
enabled in the spam logging configuration.
Content Filters – Indicates the number of messages that had illegal content detected by
the Content Control features (Attachment Control, Content Scanning, Pattern Filters,
Content Rules, Document Fingerprinting, and Objectionable Content Filtering).
Detected Viruses – Indicates the amount of messages that contained viruses, spyware, or
were malformed.
Clean – Indicates the number of messages that are processed by the system and passed
all security, spam, and content checks. This includes messages that are detected by these
features but have an action of Just Log.
Total – The total number of messages.
Outbound Message Summary – Indicates the number of outbound messages that have
had their content detected by the Content Control features (Objectionable Content Filter,
Attachment Control, Content Scanning, Pattern Filters, Content Rules, Document
Fingerprinting) and Clean mail.
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Inbound Rejected Connections – Indicates the number of messages are rejected during
the SMTP connection by Reputation Enabled Defense and other connection-level reject
features, for example, Specific Access Patterns.

Virus Report
Includes information on inbound and outbound viruses, lists of top viruses, and top virus
senders. You can generate hosted domain reports with this report.
n

n

n

n

n

Inbound Viruses – Displays the top inbound viruses and the amount of times they were
detected. This includes a graph showing the thousands of viruses detected per hour.
Recent Inbound Virus Details – Displays the most recent inbound virus-infected
messages. This includes the Queue ID, Time Received, Sender, Recipient, and Virus Name.
Outbound Viruses – Displays the top outbound viruses and the amount of times they
were detected. This includes a graph showing the thousands of viruses detected per hour.
Recent Outbound Virus Details – Displays the most recent outbound virus-infected
messages. This includes the Queue ID, Time Received, Sender, Recipient, and Virus Name.
All Outbound Virus Senders – Displays information on the top virus senders. This includes
the sender email address, virus name, and the number of virus-infected messages sent.

Spyware Report
Provides a chart on the number and types of Inbound and Outbound spyware programs found in
Email messages. You can generate hosted domain reports with this report.
n

n

Inbound and Outbound Spyware Blocking – Indicates the different types of spyware
programs that were detected. A graph indicates the number of spyware programs blocked
per hour.
Inbound and Outbound Spyware Summary – Provides a list of the most recent Inbound
and Outbound messages that were detected as containing spyware. Includes information
on the Queue ID of the message, the time received, the Sender and Recipient addresses,
and the name of the spyware program.

Traffic Report
Reports on message volume and connection counts. You can generate per-domain and hosted
domain reports with this report.
n

n

n

n

n
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Total Traffic Summary – Displays the total number of inbound and outbound mail
messages. This includes a graph showing the amount of mail in thousands of messages
per hour.
Total Traffic by Domain – Indicates the number of inbound and outbound mail messages
per domain.
Total Traffic Size – Indicates the total size of inbound and outbound mail messages in
MB. This includes a graph showing the amount of mail per hour in MB per hour.
Total Size by Domain – Indicates the total size of inbound and outbound mail messages
per domain in MB.
Connection Summary – Displays the number of mail connections to this system that
passed or were incomplete (rejected). This includes a graph showing the number of
connections in thousand connections per hour.
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Mail Processing Times – Indicates for this server the average processing time in seconds
for each message. This includes a graph showing the average time in the mail queue in
seconds per hour.

Email Analysis Report
Provides an overview of mail traffic analysis by the mail scanning features. You can generate
per-domain and hosted domain reports with this report.
n

n

Inbound and Outbound Message Summary – A pie chart displays a breakdown of
inbound and outbound messages processed based on Reputation Enabled Defense and
Connection Rejects, Detected Spam, Content Filters (Attachment Control, Content
Scanning, Pattern Filters, Content Rules, Document Fingerprinting, and Objectionable
Content Filtering), Detected Viruses (Viruses, Spyware, and Malformed), Clean, and Total
Mail messages. A graph displays the thousands of messages per hour based on the type of
message.
Inbound and Outbound Analysis Details and Recipient Actions – Displays a pie chart
with details of the total number of inbound and outbound messages for each type of
message classification (Clean, Attachment Control, Virus, Certainly Spam, Probably
Spam, Maybe Spam, and Document Fingerprinting). Also displays a pie chart of the
different types of applied recipient actions on inbound and outbound mail (Pass, message
was Clean and no action taken, Quarantined, Subject Modified, Reject, and Just Log).

Intercept Component Report
Reports on Intercept Anti-Spam processing. This includes the frequency of spam received
based on spam category, the Token Analysis score of messages received, and Intercept
component contribution.
n

n

n

Spam Frequency – This graph displays the frequency of Certainly Spam, Probably Spam,
and Maybe Spam, received over a period of time.
Token Analysis Score – This graph displays the number of messages received based on
their Token Analysis score.
Intercept Component Contributions – This table displays statistics on identified spam
for each Intercept component that contributed to the overall Intercept score.

Attachment Control Report
Reports on inbound and outbound attachment types that have been blocked. You can generate
per-domain and hosted domain reports with this report.
n

n

n

n
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Blocked Attachment Summary – This table and bar graph displays the Direction,
Number of Messages Blocked and Number of Attachments Blocked in both directions and
the overall totals.
Blocked Attachments by Domain – If per-domain is enabled, this table displays the
domain and number of Inbound and Outbound attachments blocked for the reporting period.
Top Blocked Attachments – Identifies the top blocked attachments for the reporting
period.
All Outbound Attachments Blocked – This table displays information on the number of
all outbound attachments blocked.
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Per-User Attachment Report
The Per-User Attachment Report provides a summary of the number of received and sent
attachments, their size in KB, and total number of attachments and total size in KB. These are
reported for each domain and each user in the domain. This includes information on the file
extension and detected MIME type of all sent and received attachments. You can generate
hosted domain reports with this report.
Pattern / Filter Report
Reports on the Inbound and Outbound messages that have matched a Pattern Filter. Hosted
domain reports can be generated with this report.
n

n

Actioned Message Filter Rate – The bar graph displays the thousands of messages per
hour that were processed and acted on by a Pattern Filter.
All Message Filters – The table displays the Number of Email messages, Filter Number,
Name, Action, Pattern, and Comments for all Pattern Filters triggered during the reporting
period, including those that did not result in an action.

Outbound Content Control Report
Reports on the system’s Content Control features indicating the number of occurrences of
words found in a dictionary file and the corresponding dictionary line number containing the
word. You can generate hosted domain reports with this report.
n

n

n

Inbound Content Control Analysis – The chart displays the breakdown of inbound
messages processed based on Pattern Filters, Attachment Control, Content Rules,
Objectionable Content, Content Scanning, Clean, and Total messages. A graph displays
the thousands of messages per hour for each detected message type.
Outbound Content Control Analysis – The chart displays the breakdown of outbound
messages processed based on Pattern Filters, Attachment Control, Content Rules,
Objectionable Content, Content Scanning, Document Fingerprinting, Clean, and Total
messages. A graph displays the thousands of messages per hour for each detected
message type.
Top Content Control Occurrences – The table displays the Number of Occurrences, the
File Name and Line Number for any content control dictionaries.

Connection Control Report
The Connection Control report provides information and statistics on inbound and outbound
connections for this system. No domain reports are available for this type of report.
n

n
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Connection Control Rate – A table identifies the connecting host IP addresses and
names, the total number of connections from these hosts, and the number of connections
that were blocked (before the connection was established). A graph displays the number of
Connections per hour to this system, classified by which connections were passed,
rejected, and dropped (rejected without notification).
Inbound Connection Control – A table identifies the number of Inbound connections that
were passed or were incomplete (Rejected or Dropped), and the combined total of Inbound
connections.
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n

Outbound Connection Control – A table identifies the number of Outbound connections
that were passed or were incomplete (Rejected or Dropped), and the combined total of
Outbound connections.
Inbound Rejected Connections – Provides statistics on the number and types of
Inbound connections that were rejected.

User/Host Report
Reports on the top sending hosts, top senders, and top recipients. You can generate hosted
domain reports with this report.
n

n

n

Top Sending Hosts – The table displays the Host Name, Host IP, Total Messages, and
Total Message size for hosts sending mail to the system.
Top Senders – This table displays the Sender address, Total Messages and Total Size for
the top senders during the reporting period.
Top Recipients – This table displays the Recipient address, Total Messages, and Total
Size for the top recipients during the reporting period.

Session Summary
The Session Summary report provides a table on WebMail and IMAP logins. No domain reports
are available for this type of report.
n

n

n

WebMail Usage – Displays the total number of connected sessions and failed login
attempts for WebMail. A graph displays the number of WebMail logins per hour.
IMAP Usage – Displays the total number of connected sessions and failed login attempts
for IMAP. A graph displays the number of WebMail logins per hour.
IMAP Data Sent – The amount of IMAP data transferred per hour.

Reputation Domain Report
For each domain processed by this system, this report indicates the amount of Reputation
Enabled Defense rejects (messages rejected because the sending system has a poor
reputation), the total number of messages, and the Reputation Enabled Defense reject
percentage for the domain representing the percentage total of the messages that were rejected
due to reputation. Per-domain and hosted domain reports can be generated with this report.
Rules Report
Indicates the number of inbound and outbound messages acted upon by the Content and
Connection Rules for specific time intervals. A table of the Top Applied Rules lists the most
common triggered rules. This includes information on the rule ID number, name, final action of
the rule, condition, description, and the number of times it was triggered.
System and Resource Summary
Reports on CPU, disk, memory, mail queue, and network traffic statistics. In a cluster,
separate statistics are provided for each system in the cluster. No domain reports are available
for this type of report.
n
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CPU Load – The line graph displays the Average and Peak CPU Load during the reporting
period.
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n

n

n

n

n

Disk Capacity – The table displays the Server, Disk partition, Mount point, KB available,
KB total, KB percentage used, I-nodes available, I-nodes total and I-node percentage used
at the end of the reporting period.
Disk History – The graph displays the time history for Disk Capacity Percentage Used
and I-node Percentage Used for each disk partition over the reporting period.
Swap Usage – The table displays the host name and the Minimum, Average, and
Maximum Swap usage (in MB) over the reporting period. The line graph displays the time
history for this data.
Memory Paging – The graphs displays time histories for Pages Read and Pages Written
over the reporting period.
Mail Queue Sizes – The graphs displays the time histories for Minimum, Average, and
Peak for the Mail Queue and Deferred Queue over the reporting period.
Network Activity – A graph displays for each active network device on the system. Each
graph shows the time history for MB transferred in and out of a specific interface.

Web Analysis Report
Provides a detailed analysis of Web traffic. No domain reports are available for this type of
report.
n

n
n

n

n

n

n

n

n

n

n

n

n
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Web Blocked Content – Displays statistics on each message type that is blocked. This
includes URL Categorization, Viruses, Spyware, Content Control (includes OCF,
Attachment Control, and Content Scanning), URL Block Lists (UBL), Reputation Enabled
Defense, and the Blocked Sites List.
Web Requests – Indicates the total number of web requests (in thousands) per hour.
Web Active Connections Stats – A graph of web connection statistics for the number of
active server connections per hour.
Web Bandwidth Client Side Stats – Indicates the amount of web traffic bandwidth (in
megabytes) sent to clients, including both inbound and outbound traffic.
Web Bandwidth Server Side Stats – Indicates the amount of web traffic bandwidth (in
megabytes) sent to servers, including both inbound and outbound traffic.
Web Cache Efficiency – Displays the efficiency of the web cache based on the number of
cache hits (when content was found in the local disk cache), and the number of web server
requests that did not find the data in the disk cache and had to go to the Internet web server
to fetch the content.
Top Users by Browse Time – Displays the top users with the most browse time. Email
addresses are displayed for users when they have authenticated to the Web Proxy.
Unauthenticated or unknown users are identified by their IP address.
Top Domains by Visits – Displays the top web site domains with the most visits and their
total browse time.
Top Blocked Websites – Displays the top web sites that were blocked for any content
issue. This includes viruses, spyware, Attachment Control, and URL Categorization.
Viruses - Top Blocked Sites by Viruses– Displays the top web sites that were blocked
because the downloaded files contained viruses.
Viruses - Top Blocked Viruses – Displays the top blocked viruses that were detected in
web traffic.
Spyware - Top Blocked Sites by Spyware – Displays the top web sites that were
blocked because the downloaded files contained spyware programs.
Spyware - Top Blocked Spyware – Displays the top spyware programs that were
detected in web traffic.
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n
n

n

Attachments - Top Blocked Sites by Attachment Type – Displays the top web sites
that were blocked because the downloaded content contained forbidden attachment types.
Attachments - Top Blocked Attachment Types – Displays the top blocked attachment
types in web traffic.
URL Categorization - Top Blocked Sites by URL Categorization – Displays the top
web sites that were blocked by URL Categorization. This statistic only appears if URL
Categorization is enabled and licensed.
URL Categorization - Top Blocked URL Categories – Displays the top blocked URL
Categories. This statistic only appears if URL Categorization is enabled and licensed.
Top Blocked Client IP Addresses – Displays the top client IP addresses that had web
content blocked.
Top Blocked Users – Displays the top users that had web content blocked.
Top Browsed Categories – Displays the top browsed categories if URL Categorization is
enabled and licensed.
RED Traffic Classification – Displays the number of web sites with good, neutral, and
bad reputations, and those that bypassed RED scanning.

Web Summary Report
Provides a summary of Web traffic statistics based on the types of messages, connections,
and request information. No domain reports are available for this type of report.
n

n
n

n

n

Web Summary Statistics – Provides a summary of Web traffic. This includes a
breakdown of the count for each type of messages: Total Web Requests, Blocked Viruses,
Blocked Spyware, URL Categorization, Content Control (OCF, Attachment Control, and
Content Scanning), URL Block Lists, HTTP Blocked Sites, and Reputation Enabled
Defense.
Web Requests – Indicates the total number of web requests (in thousands) per hour.
Web Active Connections Stats – A graph of web connection statistics for the number of
active server connections per hour.
Web Bandwidth Client Side Stats – Indicates the amount of web traffic bandwidth (in
megabytes) sent to clients, including both inbound and outbound traffic.
Web Bandwidth Server Side Stats – Indicates the amount of web traffic bandwidth (in
megabytes) sent to servers, including both inbound and outbound traffic.

Web User Summary Report
Reports on the web browsing habits of a specific user. Email addresses are displayed for users
when they have authenticated to the Web Proxy. Unauthenticated or unknown users are
identified by their IP address.
n
n
n
n

n
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Total Browse Time – Displays the total browse time for the user.
Total Domain Visits – Displays the total domain visits and their browse time for the user.
Top Blocked Sites – Displays the top blocked sites for the user.
Top Blocked Categories – Displays the top blocked categories if URL Categorization is
enabled.
Top Browsed Categories – Displays the top browsed categories (by visits) if URL
Categorization is enabled.
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Configure Reports
To configure global report settings:
1. Select Configuration > Miscellaneous > Reports.
The Configure Options page appears.

2. Select the Reporting Enabled check box.
The reporting database is populated with information that is obtained by interpreting the system
log files. If you disable reporting, no new information is saved in the reporting database. This
includes message and system history. We recommend you do not disable reports unless the
device is overloaded, or if you are testing performance levels.
3. In the Message History Days text box, type the maximum number of days (between 1 and 31)
of message history to retain online in the message database.
Data older than this value is deleted as required. The default is 14 days.

4. In the Reporting Summary Days text box, type the maximum number of days (between 1 and
90) of reporting summary information to retain online in the reporting database.
The XCS device automatically adjusts the number of days of reporting data that can be stored
based on current system disk resources and message loads. If the number of reporting days is
changed by the device, an alarm notifies the administrator. The default is 62 days.
Note To report on the previous month in a report definition, the Reporting Summary Days
must be set to 60 days or more to make sure there is enough data to cover the
previous month time period.
5. From the Table Length drop-down list, select the length for each report field.
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For example, in the Top Viruses list, the top 50 viruses are displayed if this field is set to 50. This
value can be changed for specific fields within the report configuration itself. The default is 25.
6. The Hosted Domains option allows you to select a list of domains and hosted domain admin
email addresses hosted by this WatchGuard XCS that are included in the Domain reports.
Domain reports can be emailed to the specified domain administrator address.
These lists are created with the Dictionaries feature. Click Add Dictionary or Edit Dictionary
to manage your hosted domains lists.
Use the List type Domain & Email and use the format domain,email .
For example,
example.com,admin@example.com
example2.com,admin@example2.com
example3.com,admin@example3.com

You can define a maximum of 250 domains. After you select the domain list, domain reports can
be generated when creating a new report definition.
7. From the Months to Retain Reports drop-down list, select the number of months to retain
generated reports. The default is 12 months.
Reports older than the selected time period are deleted.

8. Select the Embed Fonts check box to embed fonts directly into a PDF report.
This option is enabled by default and improves compatibility for different types of PDF viewers,
but significantly increases the size of PDF reports. Disable this option to reduce the size of
PDF reports. Your PDF viewer will download any fonts required to view reports that do not have
embedded fonts.
9. Click Apply.

Spam Logging
The spam logging options modify the behavior of how the reporting engine calculates statistics for
messages that have a Just Log Intercept action applied for the Certainly Spam, Probably Spam,
and Maybe Spam categories.
If you enable this option, for each category where the Intercept action is Just Log (as configured in
Security > Anti-Spam > Anti-Spam), the message is counted as spam for reporting purposes. If you
disable this option, messages that have the Just Log action applied are counted as clean in reports
and the Dashboard statistics.
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Mail Logs
The Mail Logs are the most important and informative logs to monitor because they contain a record of
all mail messages processed by the system.
To access the WatchGuard XCS mail logs:
1. Select Activity > Logs > Mail.
The Mail Logs page appears and displays the end of the log file.

2. Use the slider control to page through the log file, or use the right and left arrow icons.
You can also jump to the start or end of the log file using the arrow icons as required.

The start of a single message log entry begins with a connect message, and ends with the
disconnect message. To make sure that you are looking at the entries for a specific message,
check the message ID
(for example, 7FA528120033BE34) for each log entry.
3. Click Expand All to show a summary of the processing for the message.
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Search the Mail Log
To search the mail log:
1. In the Search text box, type a text string to search for.
2. Click Search.
You can add multiple searches to the original search to further filter the results.

3. Click the Remove button to remove the previous search base, or click Search Base (Original
Log) to start a new search.

By default, the search only applies to the last 24 hours of logs.
4. Click Advanced Search to modify the specific time period for the search.
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System Logs
The System Log contains all system-related messages, for example, file uploads, backup status, virus
pattern file updates, Reputation Enabled Defense service connections, LDAP connection status, and
other types of status messages.
To access the system log files:
1. Select Activity > Logs > System.
The System Log page appears and displays the end of the log file.

2. Use the slider control to page through the log file, or use the right and left arrow icons.
You can also jump to the start or end of the log file using the arrow icons as required.

Search the System Log
To search the system log:
1. In the Search text box, type a text string to search for.
2. Click Search.
You can add multiple searches to the original search to further filter the results.

3. Click the Remove button to remove the previous search base, or click Search Base (Original
Log) to start a new search again.
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By default the search only applies to the last 24 hours of logs.

4. Click Advanced Search to modify the specific time period for the search.
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WatchGuard XCS Logs
Select Activity > Logs > All Logs to access all system log files.

n
n

n
n

n
n

n

n

Mail Logs – A log of all mail processing activity.
System Logs – A log of all system-related messages. This includes LDAP imports, backup
and restore, Anti-virus updates, and others.
Kernel Generated Messages – A log from the system kernel.
Messages From POP/IMAP Logins – Contains messages from POP, IMAP, and WebMail
logins. This includes admin and console logins.
HTTP Access Log – A log of HTTPS access to the web server.
Error Messages From the Web Server – Contains error messages from the internal web
server.
Accesses to the Web Server Made Via SSL – A log of SSL web server access. This log
displays accessed web pages and the connecting IP address.
HTTP Proxy Log – Contains messages generated by the Web Proxy.
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Previous Searches
To see a list of previous log searches that have been performed on the system:
1. Select Activity > Logs > Previous Searches.
The Log Search Tasks page appears.

2. In the list of previous searches, click on a specific search to apply the search query to the most
recent data in the logs and view the results.
This allows you to save your favorite types of searches.

3. In the Search text box, type a text string and click the search icon to filter the search results.
4. To delete specific searches, select the corresponding check box, and then click Remove.

588

WatchGuard XCS

Reports and Logs

Configure Logs
For backup purposes and offline reporting, the WatchGuard XCS can copy log and reporting files to
another system at regular intervals using FTP or SCP file copy utilities. This allows you to backup the
log files to a separate host for analysis and storage. When you enable this option, the offload occurs
each time a log file is rolled over and for the time period specified in the offload date and time. Logs are
saved with a timestamp, for example, “maillog.201301010000”.
Note The Offload (Report) section is used for organizations that require a separate reporting
server to which logs are forwarded.

Explain Log Script
For organizations that offload log files to another server or send logs to a syslog server, WatchGuard
provides a script that examines and parses raw mail log files and displays them using the same format
as displayed in the Mail Logs on the WatchGuard XCS.
The explain.pl script and a technical note describing how to run the script and interpret log files are
available in this knowledge base article.
The Explain Log script (explain.pl) is written for Perl which must be already installed on the system you
are using to analyze the log files. You can download Perl from http://www.perl.org.

Offload (Backup)
To configure your Offload (Backup) settings:
1. Select Configuration > Miscellaneous > Logs.
The Configure Logs page appears.

2.
3.
4.
5.

To enable the offload of rollout log files, select the Offload check box.
From the Offload Days drop-down list, select the days on which to offload log files.
From the Offload Times drop-down list, select the time to offload log files.
From the Copy application drop-down list, select whether to use FTP or SCP for copy offload
log files.
You must enable these applications on the destination host.
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Note When you set up an SCP server, make sure you disable PAM authentication and
enable the built-in authentication. If the WatchGuard XCS is behind a network firewall,
you must open up TCP port 22 to your SCP server.
6. In the Port text box, type the TCP port used by the copy application (FTP or SCP).
If this field is left blank, default port values (FTP: port 21, SCP: port 22) are assumed.

7. In the Host text box, type the IP address or host to which the offload data is copied to using the
specified method.
For example, ftp.example.com .
If you use IPv6, you must type the IP address with square brackets. For example,
[a123:b123::c123] .
8. In the Folder text box, type the folder to which the offload data is copied to.
For clustered systems, use %q to add the name of the clustered system to the folder name.
For example, backups/%q .
9.
10.
11.
12.

In the User text box, type a user name to log in to the destination host.
In the Password text box, type a password for the user.
To enable gzip compression of the rollout file, select the Compress check box.
Click Update when finished to save the configuration.

Offload (Report)
To configure your Offload (Report) settings:
1. To enable the offload of rollout log files to a reporting server, select the Report check box.
2. From the Report Days drop-down list, select the days on which to offload log files to a reporting
server.
3. From the Report Times drop-down list, select the time to offload log files to a reporting server.
4. From the Copy application drop-down list, select whether to use FTP or SCP for copy offload
log files.
You must enable these applications on the destination host.

Note When you set up an SCP server, make sure you disable PAM authentication and
enable the built-in authentication. If the WatchGuard XCS is behind a network firewall,
you must open up TCP port 22 to your SCP server.
5. In the Port text box, type the TCP port used by the copy application (FTP or SCP).
If this field is left blank, default port values (FTP: port 21, SCP: port 22) are assumed.

6. In the Host text box, type the IP address or host to which the offload data is copied to using the
specified method.
For example, ftp.example.com .
If you use IPv6, you must type the IP address with square brackets. For example,
[a123:b123::c123] .
7. In the Folder text box, type the folder to which the offload data is copied to.
For clustered systems, use %q to add the name of the clustered system to the folder name.
For example, backups/%q .
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8.
9.
10.
11.

In the User text box, type a user name to log in to the destination host.
In the Password text box, type a password for the user.
To enable gzip compression of the rollout file, select the Compress check box.
Click Update when finished to save the configuration.

Click Offload now to begin the offload of the files immediately.
Click the Offload Again button to reset the information of offloaded files.
This action forces an offload of all files (even those offloaded before) again. You must click Offload
Now, or wait for the next scheduled offload (when a log file has rolled over, or every hour) to start the
offloading process after you click Offload Again.
Note Logs are not removed from the device when they are offloaded.

Log Search Configuration
These options configure the defaults settings for all log searches:

Page Size
Type the amount of entries in a log file to show on one search page. The default value is 30.
Search Result Limit
Type the default number of entries returned from a search. The default value is 200000.
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20

System Management

Backup
The WatchGuard XCS can back up these data and configuration items:
n
n
n
n
n
n
n
n

System configuration
Reporting data
Quarantined items
Mail queues
User mail directories
Uploaded user lists
SSL certificates
Feature key

These items are not included in a system backup:
n
n
n

Network configuration
Raw system logs
Installed software updates

Backup Methods
The XCS supports three backup methods:
n
n
n

FTP server (recommended for large, full backups)
SCP (Secure Copy) server
Local disk (for small size or partial configuration backups downloaded to a workstation)
WarningWe strongly recommended that you use the FTP backup method for large
backup requirements. You must use Local Disk backups for only small, partial
configuration backups. The XCS device cannot restore a local backup file over
2GB in size.
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Restore from Backup
The restore feature can restore any of the backup items individually. The XCS device must be backed
up before performing any type of software upgrade or update. The restore operation restores the
configuration and reporting data in two separate stages.
n

n

Configuration restore – The XCS configuration is restored first. This process takes only a
short amount of time and you can quickly return to the administrative user interface to start
processing messages again. A critical alarm “Critical Restore: Complete PASSED” is
generated to alert you when this first stage of the restore is complete.
Reporting data restore – The reporting data (if required) is then restored as a background
process. This process is performed while the system is processing messages. When restoring
reporting data, it may take 24 to 72 hours before the restore is fully completed, depending on the
amount of data that is restored. These serious alarms are generated at different points in the
reporting restore process:
o “Serious: RESTORE: Reporting: Recovery Started”: This indicates that the online
reporting restore process has started and data is copying into a temporary database.
o “Serious: RESTORE: Reporting: Migration Started”: This indicates the data has been
fully copied into the temporary database and migrating to the online database.
o “Serious: RESTORE: Reporting: Recovery Complete”: This indicates that the online
reporting restore process is complete.

Message processing performance is negatively affected when restoring reporting data to an XCS
device that is currently processing messages. If you reboot the system during the reporting restore
process, the process continues when the system restarts.
Note In certain cases, large backup files cause the Backup page to time out and the
“Backup Complete” button does not appear. You can still monitor the Backup process
in the logs and the alarms.
The size of the reporting database or quarantined mail area can be very large. If reporting data and
quarantined mail are not required, we recommend that you do not back up this data to provide a
manageable backup file size.
Note Restoring a clustered device requires a different procedure than outlined in the next
section.
See Cluster Management for more information on the backup and restore procedure
for a cluster.

Backup File Name
The naming convention for backup files is:
MG-BCKUP.YYMMDDHHMM

For example,
MG-BCKUP.1002152245
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This indicates that the backup file is from Feb 15th, 2010 at 10:45PM. When you purge old backup
files, make sure that you examine the timestamps before you delete them.
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Start a Backup
To start a backup:
1. Select Administration > Backup/Restore > Backup & Restore.

2. Select the backup destination and click Next >>.

FTP Backup Options
These options are available when you back up to an FTP server:
Note When you configure an FTP server, we recommend that you set the idle timeout value
on the FTP server to a minimum of 1800 to 3600 seconds to make sure the connection
does not timeout while the WatchGuard XCS performs the backup or restore process.

n
n

n

n
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Encrypt Backup – Encrypts the backup file to protect its contents.
Backup System Configuration – Back up all configuration data. This includes mailboxes,
licenses, and feature keys. You must enable this option if you need to restore system
functionality.
Backup Quarantine Mail – Back up all quarantined mail. Backing up quarantined mail may
greatly increase the size of the backup file.
Backup Token Analysis Data – Back up the Token Analysis database.
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n
n
n
n
n

Backup Reporting Data – Back up the entire reporting database. This greatly increases the
size of the backup file.
FTP server – Type the host name or IP address of the destination FTP server.
Username – Type the username for the FTP server.
Password – Type the password for the FTP server.
Directory – Type the directory path where the backup files are located on the FTP server.
Use PASV mode – Set FTP to use passive mode if you experience problems when you
connect to the FTP server.

When you have set your options, click Next >> to continue.

Verify that your options are correct, and then click Create backup now to start the backup.
You can also click Create scheduled backup that takes you to the Daily Backup menu to create a
scheduled FTP backup.

SCP Backup Options
These options are available when you back up to an SCP (Secure Copy) server:

n
n

Encrypt Backup – Encrypts the backup file to protect its contents.
Backup System Configuration – Back up all configuration data. This includes mailboxes,
licenses, and feature keys. You must enable this option if you need to restore system
functionality.
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n

Backup Quarantine Mail – Back up all quarantined mail. Backing up quarantined mail may
greatly increase the size of the backup file.
Backup Token Analysis Data – Back up the Token Analysis database.
Backup Reporting Data – Back up the entire reporting database. This greatly increases the
size of the backup file.
SCP server – Type the host name or IP address of the destination SCP server.
Note When you setup the SCP server, make sure that you disable PAM authentication and
enable the built-in authentication. If the WatchGuard XCS is behind a network firewall,
you must open TCP port 22 to your SCP server.

n
n
n

Username – Type the username for the SCP server.
Password– Type the password for the SCP server.
Directory– Type the directory path where the backup files are located on the SCP server.

When you have set your options, click Next >> to continue.

Verify that your options are correct, and then click Create backup now to start the backup.
You can also click Create scheduled backup that takes you to the Daily Backup menu to create a
scheduled SCP backup.

Local Disk Options
These options are available when you back up to a local disk:
WarningIt is strongly recommended that the FTP backup method be used for large
backup requirements. Local Disk backups must only be used for small, partial
configuration backups. The system cannot restore a local backup file over 2GB
in size.
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n
n

n

n
n

Encrypt Backup – Encrypts the backup file to protect its contents.
Backup System Configuration – Back up all configuration data. This includes mailboxes,
licenses, and feature keys. You must enable this option if you need to restore system
functionality.
Backup Quarantine Mail – Back up all quarantined mail. Backing up quarantined mail may
greatly increase the size of the backup file.
Backup Token Analysis Data – Back up the Token Analysis database.
Backup Reporting Data – Back up the entire reporting database. This greatly increases the
size of the backup file. We recommend that you use the FTP or SCP method for very large
backup files.

When you have set your options, click Next >> to continue.

Verify that your options are correct, and then click Create backup now to start the backup.
You are prompted for a location to download the backup file (backup.gz). The backup file is saved in a
gzip compressed archive.
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Restore from Backup
Before you start a restore operation, make sure that your WatchGuard XCS device is licensed with a
feature key and that you have a network interface configured in your network settings.
Note The backup file to be restored must originate from an XCS device with the same
software version or a previous software version.
To start a restore:

1. Select Administration > Backup/Restore > Backup & Restore.

2. Select the restore method, and then click Next >>.

FTP Restore Options
Enter this information to restore from an FTP server:

n

n
n
n
n

n

FTP server – Type the host name or IP address of the FTP server where the backup file is
stored.
Username – Type the user name for the FTP server.
Password – Type the password for the FTP server.
Directory – Type the directory path where the backup files are located on the FTP server.
Use PASV mode – Set FTP to use passive mode if you experience problems when you
connect to the FTP server.
Click Next >> to connect with the FTP server and restore the backup file.

When you have successfully retrieved the backup file, you can choose which aspects of the XCS
configuration to restore. When you have finished selecting the restore items, click Restore Now.
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Restore from SCP
Enter this information to restore from an SCP server:

n
n
n
n

n

SCP server – Type the host name or IP address of the SCP server.
Username – Type the user name for the SCP server.
Password– Type the password for the SCP server.
Directory/File– Type the full directory path (including the file name) for the backup file on the
SCP server.
Click Next >> to connect with the SCP server and restore the backup file.

When you have successfully retrieved the backup file, you can choose which aspects of the XCS
configuration to restore. When you have finished selecting the restore items, click Restore Now.
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Restore from Local Disk
Type the local filename that contains the backup file, or click Browse to select the file from the local
drive directory listing. Click Next >> to upload and restore the backup file.

Youcanviewthecurrentstatus oftherestoreprocess intheStatussectionoftheAdministration>
Backup/Restore>BackupandRestore
page.
When you have successfully retrieved the backup file, you can choose which aspects of the XCS
configuration to restore. When you have finished selecting the restore items, click Restore Now.
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When the restore is complete, review and edit your network configuration in the Configuration >
Network > Interfaces page as required, and click Apply to reboot. This makes sure that all restored
network settings are applied.

Backup and Restore Alarms and Errors
A critical alarm appears when the configuration restore operation is complete. A serious alarm appears
when the background reporting restore process is complete.
This table describes the errors that can appear in the System Log when you restore a backup file:
Error Code

Description

0

No error

1

Form data missing

2

MIME data missing boundary

3

Invalid form data

4

Unsupported encoding method

5

Unsupported header in MIME data

6

File open error

7

Filename not specified

8

Error writing file

9

Data is incomplete
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Daily Backup
You can schedule FTP and SCP backups to occur each day at a specific time. You must complete the
FTP or SCP configuration first before you enable scheduled daily backups.
You can select Activity > Logs > System to view the results of daily backups.
To configure Daily Backups:
1. Select Administration > Backup/Restore > Daily Backup.

2. Select the FTP Backup check box to use the FTP backup configuration for this scheduled
backup.
3. Select the SCP Backup check box to use the SCP backup configuration for this scheduled
backup.
4. In the Start Time text box, type the start time for the backup in 24-hour format HH:MM.
For example, for 2:00AM, type 02:00 .
Note Because system reporting and log file maintenance starts at 00:00 midnight, we
strongly recommend that you do not schedule daily backups between midnight and
1:00 AM.

Add a Feature Key
A feature key is a license that enables you to activate your purchased feature set on your WatchGuard
XCS. You must register the device serial number on the WatchGuard LiveSecurity web site and
retrieve your feature key before adding it to the WatchGuard XCS.
Note Make sure you can access the Internet if the device is installed behind a network
firewall, or connects through an external proxy server.
To install a new feature key:
1. Select Administration > System > Feature Key.
The Feature Key page appears.
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2. Click Manual Update.
The Update Feature Key page appears.

3. Copy the text of the feature key file and paste it in the text box.
4. Click Update Key.
The Feature Key page appears with the new feature key information.
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Update a Feature Key
If you already have a LiveSecurity login and your WatchGuard device serial number is registered, you
can update your feature key automatically from the LiveSecurity site.
To update a feature key:
1. Select Administration > System > Feature Key.
The Feature Key page appears.

2. Click Download.
Your feature key is downloaded from the LiveSecurity site and automatically updated on your device.

Feature Key Synchronization
Select the Enable automatic feature key synchronization option to always keep your feature key
synchronized with your WatchGuard LiveSecurity account. If you purchase new feature options or
renew your product, your feature key will be automatically updated on the XCS device.

Troubleshoot Feature Key Updates
If you encounter errors when you add your feature key:
For manual update:
n
n
n

Make sure that you cut and paste the entire feature key text.
The first line of the feature key must be “Serial Number: B0Exxxxxxxxxx”.
The last line of the feature key is a long line of characters starting with “Signature: “.
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For automatic download:
n

n
n

Make sure you have a valid LiveSecurity account and you have registered your device serial
number.
You must have an Internet connection to retrieve your feature key.
Make sure communications are not blocked by a network firewall.

Remove a Feature Key
You may need to remove a feature key after an XCS device evaluation or to troubleshoot license
issues.
Note If you remove a feature key, you disable all security features and the system stops
processing messages.
To remove an existing feature key:
1. Select Administration > System > Feature Key.
The Feature Key page appears.

2. Click Remove.
A confirmation dialog box appears.

3. Click OK to confirm.

Feature Key Expiration
The WatchGuard XCS sends notifications to the administrator at 90, 60, 30, 7, 2, and 1 days before a
feature key expires. To make sure your XCS operates with full functionality, update your feature key
before the expiration date.
When a feature key expires on the WatchGuard XCS, the device continues to process and deliver
mail, but expired features do not scan or perform actions on messages. Also, you will not receive
software and Anti-Spam updates from Security Connection.
For example, if the Anti-Virus scanning feature key expires, the WatchGuard XCS continues to
process mail, but the messages are not scanned for viruses.
These features do not have associated expiration periods because they are required for normal system
operations and management:
n
n
n
n
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Reboot and Shutdown
To safely reboot or shut down the system:
1. Select Administration > System > Reboot & Shutdown.

2. To shut down the device and reboot, click Reboot.
To shut down the device completely, click Shutdown.
Note Before you shut down the XCS device, remove any media from the CD-ROM drive.
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Security Connection
Security Connection is a service that polls WatchGuard’s support servers for new updates, security
alerts, and Anti-Spam database updates. The WatchGuard XCS sends a notification to the
administrator when new information and updates are available.
The Security Connection service is enabled by default after you install the WatchGuard XCS to make
sure you automatically receive notifications for the latest software updates. After the initial installation,
Security Connection immediately checks for new available updates. The Security Connection
downloads any available updates for your system, but does not automatically install them.
To install software updates, from the Web UI, select Administration > Software Updates >
Updates. See Software Updates for more detailed information on Software Updates.
Note For security purposes, all Security Connection files are encrypted and contain an
MD5-based digital signature that is verified after the file is decrypted.
To configure Security Connection:
1. Select Administration > Software Updates > Security Connection.

2. Select the Enabled check box.
3. From the Frequency drop-down list, select how often to run the Security Connection service:
daily, weekly, or monthly.
4. To enable software updates to be downloaded automatically, select the Auto Download check
box.
Updates are automatically downloaded, but not automatically installed. You must use Software
Updates to manually install the updates.

5. To enable Security Connection alert messages to appear on the system console, select the
Display Alerts check box.
6. To send an email to the address specified in the Send Emails To text box, select the Send
Email check box.
7. In the Send Emails To text box, type the email address to receive notifications.
8. Click Apply.
9. Click Connect Now to run Security Connection and check for new software updates.
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Software Updates
To make sure your device software is up to date with the latest patches and upgrades, you must install
any updates released for your version of software.
After the installation of the WatchGuard XCS, Security Connection immediately checks for new
software and automatically downloads any available updates. The Security Connection does not
automatically install these updates. You must manually install them on the Software Updates page.
Updates appear in two sections: Available Updates (on the device, but not yet installed) and Installed
Updates (installed and active). You can install an available update, or delete an installed update.
Software updates downloaded from Security Connection appear in the Available Updates section.
You can also perform full system upgrades from the Software Updates page. If you upload a full
system software upgrade, it appears in the System Upgrades section.
Note We recommend that you back up the current system before you perform a software
update. See Backup and Restore from Backup for detailed information on the backup
and restore procedure.

Install a Software Update
To install software updates:
1. Select Administration > Software Updates > Updates.
The Software Updates page appears.

2. If you manually downloaded your software update:
n
n

Click Browse and select the software update.
Click Upload.
The software update appears in the Available Updates section.

3. In the Available Updates section, select the software updates you want to install.
You can install multiple software updates at the same time. The WatchGuard XCS determines
any software dependency issues and installs the updates in the proper order. You will receive a
warning if you are missing a software dependency.
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4. Click Install.
After you install updates, you must restart the device.
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Delete a Software Update
To delete software updates:
1. Select Administration > Software Updates > Updates.
The Software Updates page appears.

2. In the Installed Updates section, select the software updates to delete.
You can delete multiple software updates at the same time. The WatchGuard XCS determines
any software dependency issues and deletes the updates in the proper order.
3. Click Delete.
After you delete updates, you must restart the device.

Install a System Upgrade
You can install a full system upgrade from the Software Updates page. The upgrade is distributed as a
.pf file just like a software update. When you upload a full system software upgrade, it appears in the
System Upgrades section.
WarningIf you install a full system upgrade, your current configuration and data will be
deleted. Make sure you perform a backup of your system before you perform a
full system upgrade. See Backup and Restore from Backup for detailed
information on how to back up and restore your system configuration.
When you perform a system upgrade, the system will retain its original IP address and Feature Key
information. When you system reboots, you can connect to the system using its original IP address.
You can then perform a restore of your configuration from backup.

Upgrade Notes
n

This upgrade method requires that you have at least 2 GB free space in the System Data
Storage disk area. To check your free disk space, select Activity > Dashboard > System
Summary > Disk Usage.

User Guide

613

System Management
n

n

Any network interface specific features that you enabled before the upgrade (for example: Large
MTU, Respond to Ping, Trusted Subnet, Admin & Web User Login, WebMail, SNMP Agent,
Centralized Management, HTTP/HTTPS Proxy, Queue Replication, Bridging etc.) will be reset
to their default value. You must re-enable these options after the upgrade is complete.
Cluster status is preserved, but the system will restart in Standalone mode after the upgrade.
You must manually change the run mode to the system's previous mode, such as Primary,
Secondary, or Client.

To install a full system software upgrade:
1. Select Administration > Backup/Restore > Backup & Restore, and perform a backup of
your system.
2. Select Administration > Software Updates > Updates.
The Software Updates page appears.

3. Click Browse and select the software upgrade.
4. Click Upload.
The software update appears in the System Upgrades section.

5. In the System Upgrades section, select the software upgrade you want to install.
6. Click Upgrade.
The system will prompt you to perform a backup of the current system configuration. After you install
the software upgrade, you must restart the device.

7. Log in to the system as the primary admin user after the device restarts.
8. Select Administration > Backup/Restore > Backup & Restore, and perform a restore of
your configuration.
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Problem Reporting
Problem reporting allows you to send important configuration and log information to WatchGuard
Technical Support for help with troubleshooting device issues. This feature is intended for use in
conjunction with an existing support request with technical support.
The problem report file is saved as a compressed archive called problem_report.tgz.
The report includes these directories and files depending on your configured options:
/var/log
n
n

maillog – The latest hourly mail log file.
messages – The latest hourly system messages log file.

/var/tmp
n
n
n

postfix_mail.cf – The mail configuration file.
mx_stats_snap – A snapshot of the current mail queue statistics.
xcsconfig.xml – A text version of the device configuration.

To configure Problem Reporting:
1. Select Support > Problem Reporting.
The Problem Reporting page appears.

2. In the Send To text box, type an email address to which to send the reports.
The default address is WatchGuard Technical Support, but you can also enter your own email
address so that you can view them before you send them to WatchGuard.

3.
4.
5.
6.
7.
8.
9.
10.
11.

Select the Mail Log check box to send the latest hourly mail log.
Select the HTTP/HTTPS Proxy Log check box to send the latest daily HTTP log.
Select the Mail Configuration check box to send your current mail configuration file.
Select the Mail Queue Stats check box to send a snapshot of the latest current mail queue
statistics.
Select the System Messages check box to send the latest hourly system log.
Select the System Configuration check box to send a text version of the system
configuration.
Click Apply to save the configuration.
Click Download to download a copy of the problem report.
Click Send Now to send the information to the configured email address.
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Performance Tuning
There are several factors that can affect the performance of the WatchGuard XCS system:
n
n
n
n

n

n
n

Network bandwidth
Number of concurrent Mail and Web connections
Number of background processes running, for example, Reporting and WebMail
Internet unpredictability: Mail can often arrive in bursts of activity, with only a few messages
arriving one minute, and several hundred the next. In the event of a network outage, for
example, a failed router, the amount of queued mail that arrives after the router is back online
can be very large
Internet performance: Mail and Web clients can be very slow at connecting, and the connection
may be disconnected before it is complete
The time to process a message is also affected by the size of the email and its attachments
Amount of system resources (Processing power, RAM, and disk space)

You must carefully consider these factors when you tune an XCS device for optimal performance. If
your device is optimized for throughput to handle high mail loads, other aspects of the system may
suffer from increased latency issues, for example, reporting, WebMail access, and the possibility of
dropped connections by clients that cannot connect to a busy system. Similarly, allocating too many
resources to resolve latency issues affects mail throughput performance.
WarningIf you modify certain parameters, this can affect the performance of other
aspects of the system, and we recommend that you only change these
settings to resolve specific performance issues with guidance from
WatchGuard Technical Support. Do not experiment with these settings.

Select Performance settings
To configure performance settings:
1. Select Configuration > Network > Performance.
2. From the Performance Option drop-down list, select the type of performance profile to apply to
the system:
n
n
n
n
n
n

Email Scanning
Email Scanning with WebMail
Web Scanning
Web and Email Scanning
Web and Email Scanning with WebMail
Custom

3. Click Advanced if you need to adjust any of the individual parameters to create a custom
setting.
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Maximum Number of Processes
This parameter specifies the maximum number of concurrent processes that use mail
services. This setting limits the number of connections accepted by smtpd, and the number
of outgoing SMTP connections. If this number is set too large, you can run out of swap
space.
Maximum Number of Parallel Deliveries
This parameter specifies the maximum number of outgoing SMTP connections to the same
destination. This setting helps limit the number of outgoing connections. The value must be
less than the maximum number of processes, or performance is degraded.
Maximum Number of Mail Scanners
This parameter specifies the maximum number of mail scanners that can run
simultaneously.
This setting limits the overall mail processing and memory footprint. Setting this value too
high or too low may result in reduced performance. Valid settings are from 2 - 20.
Raise Priority of Heavy Weight Processes
Increasing the priority of heavyweight processes can increase performance and WebMail
response times, but it can reduce the processing resources for other mail processes if it is
set too high. Valid settings are from a default priority of 0 to a maximum priority of 20.
Number of Heavy Weight Processes
This parameter specifies the maximum number of heavy weight mail scanning processes
that can be run simultaneously. Valid settings are: 1 (Default) to 6 (maximum processes).
Setting a value greater than 2 does not improve performance, and we recommend you do
not change this value from the default setting.
Number of DB Proxies
This parameter specifies the maximum number of database proxies that can be used by the
mail scanning processes. This value is relative to the Maximum Number of Processes
setting, and you must increase this value in conjunction with the number of maximum
processes. Valid settings are from 2 (Default) to 12 (maximum processes), however,
setting this value above 8 results in diminishing performance returns.
SMTP Connect Timeout
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This SMTP parameter specifies the amount of time, in seconds, for an SMTP client to
complete a TCP connection before the connection is dropped. This value defines how long
the system waits for a response before timing out. The default is 0, but there is an overall
system timeout of 5 minutes for SMTP connections. Increase this value to help with sites
that have a slow Internet connection.
SMTP HELO Timeout
This SMTP parameter specifies the amount of time, in seconds, to receive the SMTP
greeting banner before the XCS device drops the connection. The default is 300 seconds,
which means that the system waits 5 minutes to receive the initial SMTP HELO message
before it times out.
Use a lower timeout value to increase performance by freeing up more connections.
Increase this value to help with sites that have a slow Internet connection.
SMTPD Timeout
The amount of time, in seconds, to send an SMTP server response and to receive an
SMTP client request before dropping the connection when the server is not under stress.
Default is 300 seconds. A lower value may increase performance by freeing up
connections. Use higher values if you have a slow Internet connection. This should be a
larger value than the smtpd timeout (stressed) setting.
SMTPD Timeout (Stressed)
The amount of time, in seconds, to send an SMTP server response and to receive an
SMTP client request before dropping the connection when the server is operating under
stress (reached the Maximum Number of Processes limit). Default is 10 seconds. A
lower value may increase performance by freeing up connections. Use higher values if you
have a slow Internet connection. This should be a smaller value than the smtpd timeout
setting.
SMTPD Minimum Receive Rate
The minimum rate, in bytes per second, at which a client must send data. The limit is
enforced after the SMTPD minimum receive rate interval has elapsed. Set this option to a
higher value when excessively slow clients limit device resources. A value of 0 indicates
no minimum rate. Default is 0.
SMTPD Receive Rate Interval
The time interval, in seconds, that must elapse before the SMTPD minimum receive rate
restriction is enforced for a newly connected client. Set this to a higher value to provide
clients more time to establish an acceptable data flow rate. A value of 0 means that the
limit is enforced immediately. Default is 0.
Client connection count limit
The maximum number of simultaneous SMTP connections allowed from a single client IP
address. Set to 0 for no limit. The default value is 50.
SMTP Tarpit Time

618

WatchGuard XCS

System Management

The amount of time, in seconds, to wait before replying to an SMTP client with a 4xx or 5xx
error message (for example, the message content was rejected.) The default is 0 seconds.
The tarpit time must be set to 0 for environments that reject a high number of SMTP
connections. Low values can free up connections to improve performance. Higher values
can deter senders from sending invalid content, for example, spam and viruses.
Service Throttle Time
The amount of time, in seconds, to wait before re-starting a messaging service that exits
unexpectedly. The default is 60 seconds, and must be a minimum of 1 second.
Enable SMTP Connection Cache
Connection caching can improve delivery performance, primarily in deliveries to
destinations with multiple mail servers where some of the servers are not responding. The
system caches the responding servers and use those servers in the next delivery attempt.
This option is disabled by default. If you enable this option, connection caching can
introduce additional processing overhead and reduce performance in certain cases. Disable
this option if performance issues occur.
Number of Concurrent Web Proxies
Increase the number of web proxy processes on the system to increase parallel processing
of web requests and reduce client latency. Too many parallel requests can overload the
scanning engine which results in various user requests blocking each other and contending
for access. The default value is optimized based on the CPU and memory of the hardware
platform. This value can be set from 1 to 4.
Number of Concurrent Web Scanners
Increase the number of concurrent web scanners on the system to increase parallel
processing in the web scanning engine. Too many parallel scanners can overload the
system and use too many resources. We recommend that this value be twice the Number
of Concurrent Web Proxies setting. The default value is optimized based on the CPU
and memory of the hardware platform. This value can be set from 1 to 32.
Maximum Number of Web Content Scanners
Sets the maximum number of web content scanners that can run simultaneously. This
setting limits the overall proxy processing and memory footprint. This value can be set from
1 to 50.
Queue Threshold for Web Requests Per Proxy Instance
This setting limits the number of queued HTTP requests a single instance of the web proxy
can have. In conjunction with the Number of Concurrent Web Proxies value, this setting
determines the maximum number of concurrent web requests that can be handled by the
system. Very high values for thresholds can adversely affect system resources, while low
values may not be sufficient to handle the web traffic load for your environment. Error
messages occur in the logs when a given proxy instance exceeds the configured limit. This
value can be set from 1 to 20000. The default is 1000.
In-Memory Web Cache Size Mark
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These are advanced settings for the web cache and they must be modified with caution.
The In-memory Web Cache sizes represent the thresholds used for cleaning up the
memory cache. The low mark represents the memory level (in MB) after which the process
starts cleaning up its entries. The critical mark represents the memory level (in MB) after
which the process starts aggressively cleaning up its entries. The high mark represents the
maximum memory (in MB) the in-memory web cache utilizes.
Mark

Default Recommended Value

Low

64 MB

Critical

128 MB

High

256 MB
Size of Temporary Files Filesystem
Specify the size of the /tmp file system at system startup. This setting affects the
maximum size of attachments that are scanned, and must only be used if you are having
problems with scanning large files. If you increase this setting beyond the amount of
physical RAM, you can degrade device performance because of excessive swapping. You
must monitor your system performance if you use this setting.
Size of Shared Memory block Allocated to Database
Specify the size of the shared memory block to make available to the database. Increase
this value to increase the speed of database operations at the cost of having less memory
available for other purposes. Increase this value if you are increasing the number of
messages that are stored in the email database. If you change the size of the temp file
system or shared memory block, you must restart the system before these settings take
effect.
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Dashboard
The WatchGuard XCS system Dashboard provides administrators with a brief statistical and graphical
summary of current inbound and outbound email and web activity to enable rapid assessment of the
current status of the WatchGuard XCS. The Dashboard contains links to these components:
n

n

n

n

n

Mail Summary – Displays information on the status of your Mail Security features and your
Mail Resources, for example, current incoming and outgoing connections, and the number of
messages in the Mail, Deferred, and Quarantined queues. This page also provides a traffic
summary of inbound and outbound mail traffic separated by category (for example, Virus,
Spam, and Clean mail).
Web Summary – Displays a web traffic summary separated by category (for example, URL
Categorization and Spyware). The Web Summary page also provides information on the
number of current active web connections, and the web cache efficiency. The Web Statistics
page displays the top browsed categories, top five blocked web sites and users, and top five
browsing users and browsed web sites. A Web User’s page displays web statistics for
individual users.
Recent Mail Activity – Displays the most recent mail messages that have been processed by
the system. This includes the Message ID, Sender and Recipient information, the message
Status, and the final Action taken on the message.
Recent Web Activity – Displays the most recent blocked web messages that have been
processed by the system. This includes the Request ID, Request To and From information, the
message Status, and the final Action taken on the request.
System Summary – Displays the status of critical aspects of your WatchGuard XCS, for
example, its software version and uptime, users logged in, disk/swap/CPU usage, RAID
status, and server status.
Note In a cluster, the Dashboard only shows activity for the local system, and not for the
entire cluster.
For information and statistics for the entire cluster, see the Cluster Activity page.
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To see the Dashboard, go to Activity > Status > Dashboard.

You can set the Dashboard to display its information based on a time period you select (Last 60
Minutes, Last 24 Hours, Last 7 Days, and Last 31 Days). Information on the Dashboard is updated
every 60 seconds when the default, Last 60 Minutes, is selected. The page is updated hourly if set to
Last 24 Hours, and updated every 24 hours if set to Last 7 Days and Last 31 Days.
Note Processed messages are not reflected in the statistics until the required time frame is
summarized, for example, 60 seconds for “Last 60 Minutes”, or one hour for “Last 24
Hours”. The “Last Generated” time indicates when the statistics were last refreshed.

Mail Security Status
The Mail Security section displays information on the status and licensing information for the
WatchGuard XCS security features. You can expand each item to view the status details and the last
connection time for each service.
Note The Mail Security status does not appear on a cluster client device. In addition,
Reputation Enabled Defense status is only available on the Primary cluster device.
n
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Security Connection – Indicates the status of communications with the Security Connection
service:
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Green: (OK status). Indicates that a successful connection has been made to Security
Connection since the previous connection.
o Yellow: (Attention status)
n The system has not made a successful connection to Security Connection since
the last scheduled attempt.
o Red: (Urgent status)
n The system has not made a successful connection to Security Connection in the
last three scheduled attempts.
o Grey: (Disabled). The Security Connection feature is disabled.
Kaspersky Anti-Virus – Indicates the status of the Anti-Virus scanning feature:
o Green: (OK status). The most recent Anti-Virus pattern update is between 0 and 26
hours old.
o Yellow: (Attention status)
n The most recent Anti-Virus pattern update is between 26 and 50 hours old.
o Red: (Urgent status)
n The most recent Anti-Virus pattern update is more than 50 hours old.
n The Anti-Virus feature license is expired.
o Grey: (Disabled or not licensed). Indicates that the Anti-Virus feature is disabled or is
not licensed.
Anti-Spam – Indicates the status of the Intercept Anti-Spam feature:
o Green:(OK status).The mostrecent Anti-Spamdatabase updateis less than amonth old.
n DNS and URL Block List lookup status is OK.
o Yellow: (Attention status)
n The most recent Anti-Spam pattern update is 31 to 62 days old.
n There is an issue with DNS and/or URL Block List primary or alternate server
lookups.
o Red: (Urgent status)
n The most recent Anti-Spam pattern update is more than 62 days old.
n There is an issue with DNS and/or URL Block List primary and alternate server
lookups.
Reputation Enabled Defense – Indicates the status of the RED feature:
o Green: (OK status). Indicates the RED server status is OK.
o Yellow: (Attention status). Indicates there is an issue connecting to a specific RED
server.
o Red: (Urgent status)
n Indicates there is an issue connecting to the RED service.
n The RED license has expired.
o Grey: (Not licensed or disabled).
n The RED feature is not licensed.
n The RED feature is disabled.
McAfee Anti-Virus (If licensed) – Indicates the status of the McAfee Anti-Virus feature:
o Green: (OK status). The most recent McAfee Anti-Virus pattern update is between 0
and 26 hours old.
o Yellow: (Attention status). The most recent McAfee Anti-Virus pattern update is
between 26 and 50 hours old.
o Red: (Urgent status)
n The most recent McAfee Anti-Virus pattern update is more than 50 hours old.
n The Anti-Virus feature license is expired.
o Grey: (Disabled). Indicates that the McAfee Anti-Virus feature is disabled.
o

n

n

n

n
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Brightmail Anti-Spam (if licensed) – Indicates the status of the Brightmail Anti-Spam
feature:
o Green: (OK status). The most recent Brightmail Anti-Spam pattern update is between 0
and 26 hours old.
o Yellow: (Attention status). The most recent Brightmail pattern update is between 26
and 50 hours old.
o Red: (Urgent status)
n The most recent Brightmail Anti-Spam pattern update is greater than 50 hours old.
n The Brightmail Anti-Spam feature license is expired.
o Grey: (Disabled). Indicates that the Brightmail Anti-Spam feature is disabled.

n

SecureMail Encryption (if licensed) – Indicates the status of the SecureMail email encryption
feature:
o Green: (OK status). The SecureMail service is enabled and can connect to SecureMail
servers.
o Red: (Urgent status)
n The SecureMail service is enabled, but cannot connect to SecureMail servers.
n The SecureMail feature license is expired.
o Grey: (Not licensed or disabled).
n The SecureMail feature is disabled
n The SecureMail feature is not licensed.

Mail Summary
The Mail Summary statistics page displays information on mail traffic that passes through the system
and contains statistics on Mail Resources and a Mail Traffic Summary.

Mail Resources
The Mail Resource statistics are updated every 60 seconds. The corresponding activity graphs are
updated every hour.
n

n

n

n

n
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Incoming Connections – Displays the current amount of incoming mail connections to this
system.
Outgoing Connections – Displays the current amount of outgoing mail connections from this
system.
Mail Queue – Indicates how many messages are currently in the Mail Queue waiting to be
delivered. View and manage these messages in Activity > Queue/Quarantine > Mail Queue.
Deferred Queue – Indicates the number of messages that have had their delivery deferred
because of unavailability of the destination mail server. The system tries to deliver these
messages at a later time. You can configure this option in Configuration > Mail > Delivery.
Quarantined Mail – Indicates the number of messages that have been sent to the
administrative quarantine area. View and manage messages in Activity > Queue/Quarantine
> Message Quarantine.

WatchGuard XCS

Monitoring

Mail Traffic Summary
The Traffic Summary section displays a graph that shows how many inbound and outbound email
messages have been processed by the system.
You can customize the Traffic Summary display to show statistics for the last 60 minutes, 24 hours, 7
days, or 31 days with the drop-down list. Information on the Dashboard is updated every 60 seconds
when the default, Last 60 Minutes, is selected. The page is updated hourly if set to Last 24 Hours,
and updated every 24 hours if set to Last 7 Days and Last 31 Days.
These statistics are displayed:
n

n

n

n

n

Reputation Enabled Defense – Indicates the number of messages that were rejected by
Reputation Enabled Defense and other features that reject a message before the SMTP
connection is complete. This category is displayed for inbound mail only. This statistic includes
these connection rejects:
o Reputation Enabled Defense Connection Reject (Reputation, Infection, and Dial-up)
o DNS Block List Reject
o Threat Prevention Reject
o Specific Access Pattern Reject
o Pattern Filter reject
o Connection Rule reject
o Reject on unauthorized SMTP pipelining
o Reject on unknown sender domain
o Reject on missing reverse DNS
o Reject on missing sender MX
o Reject on non FQDN sender
o Reject on Unknown Recipient
o Reject on missing addresses
o Reject if number of recipients exceeds maximum
o Reject if message size exceeds maximum
Virus + Spyware – Indicates the amount of messages that contained viruses, spyware, or
were malformed.
Spam – Indicates the number of messages that have been classified as spam. This includes
Certainly Spam, Probably Spam, Maybe Spam, Brightmail spam, Reputation Enabled Defense
spam, and DNS Block List Spam. This category is displayed for inbound mail only. This
category also depends on the spam logging configuration in Configuration > Miscellaneous >
Reports. The spam action of Just Log is counted in the total if it is enabled in the spam logging
configuration.
Content Control – Indicates the number of messages that have had their content classified by
the Content Control features, for example, Attachment Control, Content Scanning, Pattern
Filters, Content Rules, Document Fingerprinting, and Objectionable Content Filtering.
Clean – Indicates the number of messages processed by the system that have passed all
security, spam, and content checks. This includes messages that have been detected by these
features but have an action of Just Log.
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Recent Mail Activity
The Recent Mail Activity page displays information on the most recent mail messages that have
passed through the system. The data updates every 60 seconds and also updates when you refresh
the page.

n
n
n
n

n

Time – Indicates when the message was processed by the system.
Sender – Indicates the email address of the sender of the mail message.
Recipient – Indicates the email address of the recipient of the mail message.
Status – Indicates which feature acted upon the message if a security or content check was
triggered. For example, OCF indicates that the message was acted on by the Objectionable
Content Filter.
Action – The final action that was taken on the message after it was processed, for example,
Reject.

Each message that passes through the XCS device has a unique message identification number.
Hover over the icon to the left of the message to see the Queue ID for the message. Click the icon to
see the processing details for the message.
To search the recent mail activity:
1. From the Find Email drop-down list, select Sender or Recipient.

2. In the Find Email text box, type a search term that exactly matches the sender or recipient
email address.
For example, user@example.com .
3. Click Search.
The Message History page appears with the search results.

4. Click the message icon to the view the Message Details.
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System Summary
The System Summary page displays the status of critical aspects of your WatchGuard XCS, for
example, its software version and uptime, users logged in, disk/swap/CPU usage, RAID status, and
server status.

System
n

n
n

n

Version – Displays the current software version of the WatchGuard XCS. This includes the
time of installation and any installed software patches.
Uptime – Displays the amount of time since the last restart of the WatchGuard XCS.
Licensee – Displays the licensed user of the WatchGuard XCS. This is the text entered as the
Organization Name during the device installation.
Admin & WebMail Users Online – Displays the number of users who are logged in through
the web admin interface or through a WebMail session. Expand the status to view the login
name, IP address, and idle time.

Hardware
n

n
n

Appliance – Displays information on your hardware device model. Expand the status to view
CPU information, the total amount of RAM memory, and the device serial number.
Disk Usage – Expand the status to view the used and available space for each disk partition.
Swap Space – Displays the current status for the amount of swap space on the system.
Expand the status to view the total swap space and amount of swap space in use.
o Green: (OK status). Indicates that the swap space being used is not greater than half of
the available memory.
o Red: (Urgent status). Indicates that the swap space being used is greater than half of
the available memory.
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n

RAID Status – This displays the RAID status for hardware device models with a RAID disk
system. Expand the status to view the controller, RAID Type, and RAID Size.
o Green: (OK status)
o Yellow: (Attention status). The RAID system is rebuilding.
o Red: (Urgent status). The RAID system is degraded. This indicates a failed disk.

System Activity
You can display the CPU load and swap space statistics for these time periods: Last 24 Hours, Last
7 Days, and Last 31 Days.
Note To display the last 31 days, the Message History Days option must be set to 31 in
Configuration > Miscellaneous > Reports.

n
n

CPU Load – Displays the average and peak CPU load for the specified time period.
Swap Space – Displays the amount of swap space usage (in MB) for the specified time period.

Servers
The Servers section displays the status of your configured NTP and DNS servers.

n
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NTP – Displays the status of your configured NTP (Network Time Protocol) servers. This
includes these statistics:
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NTP Server: Displays the IP address of the NTP server. The local NTP server appears
as “localhost”.
o Stratum: Indicates the number of steps from a primary time source.
o Secs/Poll: Indicates how many seconds between attempts to query the time server.
o Delay: Indicates the round trip time of the time server query.
o Offset: Indicates the difference between the reference time and the system clock.
o Displacement: Indicates the amount of time difference between time server queries.
DNS – Displays the status of your configured DNS (Domain Name Service) servers.
o DNS Server: Displays the IP address of the name server.
o Status: Displays the current connection status to the name server:
n OK: The DNS server is resolving domain names.
n Not OK: The DNS server is not resolving domain names.
o

n

Web Summary
The Web Summary page includes the status of your web security features and displays statistics on
web traffic that passes through the system. This page contains statistics on the types of Blocked
Content, Connections, Bandwidth usage, Web Cache Efficiency, Top 5 Blocked Web Sites and IP
Addresses/Users, and Top 5 Browsed Web Sites and Browsing Users.

Web Security Status
The Web Security section displays information on the status and licensing information for the
WatchGuard XCS web security features. You can expand each item to view the status details and the
last connection time for each service.
Note The Web Security status does not appear on a cluster client device. In addition,
Reputation Enabled Defense status is only available on the Primary cluster device.

n

Security Connection – Indicates the status of communications with the Security Connection
service:
o Green: (OK status). Indicates that a successful connection has been made to Security
Connection since the previous connection.
o Yellow: (Attention status)
n The system has not made a successful connection to Security Connection since
the last scheduled attempt.
o Red: (Urgent status)
n The system has not made a successful connection to Security Connection in the
last three scheduled attempts.
o Grey: (Disabled). The Security Connection feature is disabled.
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n

n

n

Kaspersky Anti-Virus – Indicates the status of the Intercept Anti-Virus feature:
o Green: (OK status). The most recent Anti-Virus pattern update is between 0 and 26
hours old.
o Yellow: (Attention status). The most recent Anti-Virus pattern update is between 26
and 50 hours old.
o Red: (Urgent status)
n The most recent Anti-Virus pattern update is more than 50 hours old.
n The Anti-Virus feature license is expired.
o Grey: (Disabled or not licensed). Indicates that the Anti-Virus feature is disabled or is
not licensed.
Reputation Enabled Defense – Indicates the status of the RED feature:
o Green: (OK status). Indicates the RED server status is OK.
o Red: (Urgent status)
n Indicates there is an issue connecting to the RED service.
n The RED/URL Categorization license has expired.
o Grey: (Not licensed). The RED/URL Categorization feature is not licensed.
URL Categorization – Indicates the status of the URL Categorization feature:
o Green: (OK status). The most recent control list update was successful and is less
than 1 week old.
o Yellow: (Attention status).
n The most recent control list update was successful and is between 1 and 2
weeks old.
n Also indicates a control list download is in progress.
o Red: (Urgent status)
n URL Categorization is waiting for the initial Control List Update.
n The most recent control list update was successful and is greater than 2 weeks old.
n The control list update was not successful and failed to update.
n The URL Categorization license is expired.
o Grey: (Not licensed or disabled).
n Indicates that the URL Categorization feature is not licensed.
n Indicates the URL Categorization feature is disabled.

Web Traffic
The Web Traffic section contains information on the number of web requests and downloaded files that
were blocked because of URL and content issues. This includes the current number of active
connections that use the Web Proxy.
You can customize the Web Traffic display to show statistics for the last 60 minutes, 24 hours,
7 days, or 31 days from the drop-down list. Information on the Dashboard is updated every 60 seconds
when the default, Last 60 Minutes, is selected. The page is updated hourly if set to Last 24 Hours,
and updated every 24 hours if set to Last 7 Days and Last 31 Days.
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Blocked Content
n

n

n

n
n
n

n

Reputation Enabled Defense – Indicates the number of web connections blocked because
the web site URL received a poor reputation score from the Reputation Enabled Defense
service.
URL Block List– Indicates the number of web connections blocked because the web site URL
appeared on a URL Block List.
URL Categorization – Indicates the number of web connections that were blocked because
the URL was in a URL Categorization list of blocked web sites.
Virus – Indicates the number of web downloads and uploads that contained a virus.
Spyware – Indicates the number of web downloads and uploads that contained spyware.
Content Control – Indicates the number of web request uploads and downloads that were
blocked because of content control issues detected by Attachment Control, Content Scanning,
and Objectionable Content Filtering.
Other – Indicates the number of web messages that were blocked because of other reasons
that are not covered in the categories in this list. This includes the HTTP Blocked Sites List.

Connections
Indicates the number of active connections between the Web Proxy and external web servers. This
includes a graph of the number of connections over the selected time period. This statistic is the
average number of connections in the selected report period. For example, when Last 60 Minutes is
selected, this indicates the average number of active connections every minute. If Last 24 Hours is
selected, this indicates the average number of active connections per hour. If Last 7 Days or Last 31
Days is selected, this indicates the average number of active connections per day.
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Bandwidth
Indicates the amount of bandwidth used (in megabytes) for non-cached inbound and outbound web
traffic to web servers.

Web Cache Efficiency
The XCS system contains a web cache that caches data and images from web sites visited by users
of the Web Proxy. This improves performance and reduces bandwidth for subsequent visits to these
web sites, as the data and images are read from the disk cache instead of retrieving data over the
Internet. When a request is received, the system compares its cached data with the requested web
site to make sure it has the latest data, and new web site updates are reflected in the disk cache.
The Web Cache Efficiency counter indicates the percentage success (from 1 to 100) of data retrieval
from the cache (a cache “hit”). Any requests that did not find the object in the web cache are sent out to
the Internet to retrieve the content. The value increases after your system processes requests for at
least 24-48 hours.
When it reaches a baseline level (typically between 15 to 20%), you can recognize changes in
efficiency. If your efficiency gradually decreases, it can indicate your cache is corrupted and must be
flushed (Activity > Status > Utilities). The Web Cache Efficiency percentage reflects information
collected from the previous two weeks.
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Web Statistics
The Web Statistics section contains information on the Top Browsed Categories, Top 5 Blocked Web
Sites, Top 5 Blocked IP/Users, Top 5 Browsed web sites, and Top 5 Browsing Users.
You can customize the Web Statistics display to show statistics for the last 60 minutes, 24 hours, 7
days, or 31 days from the drop-down list. Information on the Dashboard is updated every 60 seconds
when the default, Last 60 Minutes, is selected. The page is updated hourly if set to Last 24 Hours,
and updated every 24 hours if set to Last 7 Days and Last 31 Days.

Top Browsed Categories
This list indicates the top five web site categories that have had been blocked by URL Categorization.
These statistics are only displayed if URL Categorization is enabled. The Other category indicates the
total of all other categories.

Top 5 Blocked Users
This list indicates the top five IP addresses or users (if authentication is enabled) that have been
blocked because of security and content issues, for example, viruses, spyware, content controls, URL
Block Lists, HTTP Blocked Sites, and URL Categorization.

Top 5 Blocked Websites
This list indicates the top five web sites that have had been blocked because of security and content
issues, for example, viruses, spyware, content controls, URL block lists, HTTP blocked sites, and
URL Categorization.
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Top 5 Browsing Users
Indicates the top five users with the most browse time. This value represents the total amount of
browse time for the specific user from all of their browse time sessions. If authentication is enabled,
the email address of the user is displayed. If authentication is disabled, the IP address of the user is
displayed.

Top 5 Browsed Websites
Indicates the top five most browsed web sites. The Browsed Websites value indicates specific web site
visits. This statistic does not count each individual web site hit that results in hit counts for each
retrieved image, and additional files from the same domain or an external domain. A single web site visit
can include several hits to the same domain or external web site domain in a specific period of time.

Web Users
The Web Users section contains information on web browsing statistics for individual users. You can
view Web User statistics for the last 24 hours, or for the last 7 days. The Web User statistics are
updated every hour and reflect information collected up to the previous hour.
From the drop-down list, select an existing user to see their web statistics.
n
n
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Select a user name if authentication is enabled.
Select an IP address if authentication is disabled.
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Total Visits
Indicates the total number of web site visits for the user. A visit is the domain to which the client sends
a request. This statistic does not count each individual web site hit that results in hit counts for each
retrieved image and other files from the same domain or to external domains. A single web site visit
can include several hits to the same web site domain or other domains in a specific period of time.

Blocked Content
n

n

n

n
n
n

n

Reputation Enabled Defense– Indicates the number of web connections blocked because the
web site URL received a poor reputation score from the Reputation Enabled Defense service.
URL Block List– Indicates the number of web connections blocked because the web site URL
appeared on a URL Block List.
URL Categorization – Indicates the number of web connections that were blocked because
the URL visited was listed in a URL Categorization list of blocked web sites.
Virus – Indicates the number of web downloads and uploads that contained a virus.
Spyware – Indicates the number of web downloads and uploads that contained spyware.
Content Control – Indicates the number of web request uploads and downloads that were
blocked because of content control issues detected by Attachment Control, Content Scanning,
and OCF.
Other – Indicates the number of web messages that were blocked because of other reasons
that are not covered in the categories in this list. This includes the HTTP Blocked Sites List.

Top Browsed Categories
This list indicates the top five web site categories that have had been blocked by URL Categorization.
The Other category indicates the total of all other categories. These statistics are only displayed if
URL Categorization is enabled.

Total Browse Time
Indicates the total amount of browse time for the specific user from all of their browse time sessions.
The Total Browse Time is updated every hour and reflects information collected up to the previous hour.
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Top Blocked Sites
This list indicates the top five web sites that have had been blocked because of security and content
issues, for example, viruses, spyware, content controls, URL block lists, HTTP blocked sites, and
URL Categorization. The Top Blocked Sites are updated every 60 seconds, and reflect information
collected from the last 7 days.

Top Browsed Sites
Indicates the top five most browsed web sites. The Browsed Websites value indicates specific web
site visits. This statistic does not count each individual web site hit that results in hit counts for each
retrieved image, subdomain files, and so on. A single web site visit may include several hits to the
same web site domain in a specific period of time. The Top Browsed Sites are updated every hour and
reflect information collected from the last seven days.
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Web User Reporting Configuration
You can modify how the WatchGuard XCS calculates the browse time for a user, and define users,
domains, and categories that are not reported on by the User Reporting feature.
To configure User Reporting:
1. Select Configuration > Web > User Reporting.

2. In the User Session Idle Time text box, type the number of seconds a user session must be
idle before it is considered complete.
When this time has passed, the user's session is written to the log files and considered a unique
browse session. You can set a value from 10 to 3600 seconds. The default value is 180
seconds.
3. In the User Session Read Time text box, type the number of seconds added to a user session
timer after the final activity is recorded.
The read time is added to the user's browse-time to make sure time is allocated for viewing a
web page after the last web page access. The User Session Read Time must be equal to or
less than the User Session Idle Time. The default value is 180 seconds.
4. From the Ignore Users drop-down list, select a dictionary list of users that are not tracked by
the User Reporting feature.
These lists are created in Security > Content Control > Dictionaries. See Dictionaries for
more details on creating user addresses and IP address lists.
The dictionary can contain a list of user names or IP addresses with one entry per line. Use the
dictionary type Email or use IP if you use IP addresses. Use Phrase List if you mix
IP addresses and domain names in the same list.
For example,
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user@example.com
user2@example.com
192.168.1.100

5. From the Ignore Domain Names drop-down list, select a dictionary list of domains that are not
tracked by the User Reporting feature.
These lists are created in Security > Content Control > Dictionaries. See Dictionaries for
more details on creating domain lists.
Use the dictionary type Domain or IP. Use Domain if you mix IP addresses and domain
names in the same list. The dictionary must contain a list of domains or IP addresses with one
entry per line. Use a wildcard character “*” to include subdomains.
For example,
*.example.com
example2.com
example3.com
192.168.1.100

6. In the Ignored Categories section, select the URL Categorization web site categories that are
not tracked by the User Reporting feature.
This option requires that the URL Categorization feature be enabled.
Use the arrow buttons to move categories from the Available Categories list to the Ignored
Categories list.
7. Click Apply.

Recent Web Activity
The Recent Web Activity page displays information on the most recent blocked web requests that
have passed through the system. The data updates every 60 seconds and also updates when the page
is refreshed.
n
n

n

n

n
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Time – Indicates when the request was processed by the system.
Request From – The source of the web request displayed as the user name and the IP address
of the client. If authentication is not enabled, the user name displays unknown user.
Request To – Indicates the destination URL of the web request.
For example: http://www.example.com.
Status – Indicates which feature acted upon the request if a security or content check was
triggered. For example, a status of OCF indicates that the request was acted on by the
Objectionable Content Filtering feature.
Action – Indicates the final action that was taken on the request after it was processed, for
example, Reject.
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Each web request that passes through the system is given a unique Request ID. Hover over the icon
to the left of the request to see the Request ID of the web request. Click the icon to see the processing
details of the web request.
In the default Web Proxy configuration, only rejected requests or requests that are matched in a
content control feature are logged in the Recent Web Activity page. To see the activity of all web
requests, including those that passed all security and content checks, enable Verbose Logging in
Configuration > Web > HTTP/S Proxy advanced settings.
WarningThe Verbose Logging option should only be enabled for troubleshooting
purposes for a short duration of time. Performance is negatively affected when
Verbose Logging is enabled and the system is processing web requests.
To search the recent web activity:
1. From the Find Web Message drop-down list, select to search on the Request From or URL.

2. In the Find Web Message text box, type a search term that exactly matches the Request
From user address or a specific URL.
For example, user@example.com or www.example.com .
3. Click Search.
The Message History page appears with the search results.
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Status and Actions
These tables describe the different types of messages that can appear in the Status and Action
columns on the Recent Mail Activity and Recent Web Activity pages on the Dashboard
Status

Description

TDR

Message was acted upon by the Threat Prevention feature

Very Malformed

Message was considered very malformed

Invalid Sender EHLO

Message sender does not have a valid sender EHLO

Invalid Sender HELO

Message sender does not have a valid sender HELO

Invalid Sender Domain

Message sender domain does not have a valid DNS A or MX
record

Non-FQDN

Message sender is not in correct FQDN (Fully Qualified Domain
Name) form

Missing reverse DNS

Message sender does not have a corresponding PTR record for
reverse lookups

Unknown sender domain

Message sender domain does not have a valid DNS A or MX
record

Missing MX

Message sender domain does not have a valid DNS MX record

Unknown recipient

Message included an unknown recipient

Virus - McAfee

Message was acted upon by McAfee Anti-Virus

Virus - Kaspersky

Message was acted upon by Kaspersky Anti-Virus

PBMF

Message was acted upon by a Pattern Filter

Rules

Message was acted upon by Content/Connection Rules

Malformed

Message was classified as malformed

Threat Outbreak Control

Message was acted upon by the Outbreak Control feature

Mail Access Control

Message was acted upon by Mail Access controls

Attachment Control

Message was acted upon by the Attachment Control feature

OCF

Message was acted upon by the Objectionable Content Filter

Trusted Sender

Message contained a Trusted Sender that bypassed all spam
filters

ACS

Message was acted upon by the Content Scanning feature

DFP

Message was acted upon by Document Fingerprinting

SAP

Message was acted upon by a Specific Access Pattern
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Status

Description

SecureMail Encrypt

Message was encrypted by SecureMail encryption

Certainly Spam

Message was classified as Certainly Spam by Intercept

Probably Spam

Message was classified as Probably Spam by Intercept

Maybe Spam

Message was classified as Maybe Spam by Intercept

User Spam Train

Message was submitted by a user as Spam

User Not Spam Train

Message was submitted by a user as Not Spam

Brightmail Spam

Message was classified as Brightmail spam

Brightmail Suspected

Message was classified as Brightmail suspected spam

HAM

Message was trained as legitimate mail by Token Analysis

DKIM

Message was acted upon by DKIM (DomainKeys Identified Mail)

DomainKeys

Message was acted upon by DomainKeys

SPF

Message was acted upon by Sender Policy Framework (SPF)

Reputation Enabled
Defense Dialup

Message was classified by Reputation Enabled Defense as a
dial-up connection

DNSBL matches above
threshold

Message was acted upon by the DNS Block List feature and
exceeded the DNS Block List threshold

Reputation above threshold

Message was classified by Reputation Enabled Defense as
above the configured reputation threshold

Mail Anomalies

Message was acted upon by the Mail Anomalies feature

Reputation Enabled
Defense Infected

Message was considered to be sent from a recently virus-infected
source by Reputation Enabled Defense

Relay

Message was relayed to another system

UBL

Message was acted upon by the URL Block List feature (Email or
Web)

Clean

Message passed all threat and content checks

Blocked Sender

Message contained senders on a Blocked Sender list

URL Categorization

Web request was acted upon by the URL Categorization feature

HTTP Blocked

Web request was acted upon by the HTTP Blocked Sites list

TLS Failure

Message failed to connect via TLS

TLS Used

Message was delivered via TLS

TLS Refused

Attempt to deliver message via TLS was refused

TLS Not Offered

TLS was not offered when message was delivered
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Status

Description

Attachment Size

Attachment size of a message was greater than the size threshold

Action

Description

Discard

The message was discarded without notification to the sender

Quarantined

The message was sent to the administrative quarantine area

Subject Modified

The message subject was modified before it was delivered

Header Added

A message header was added before it was delivered

Reject

The message was rejected with notification to the sender

Temporary Reject

The message was temporarily rejected and the system attempts
to deliver the message at a later time

Undeliverable

The message is considered permanently undeliverable after
multiple attempts to deliver the message

Bounce

The message has been bounced back to the sender by the
destination mail server and is permanently undeliverable

Incomplete

The SMTP connection to deliver the message was not completed

Failed

The attempted message delivery failed

Release

The message was released from the quarantine

Relay

The message has been relayed to another system

Soft Bounce

The message was bounced back by the destination mail server
before it reached the intended recipient

Sent

The message has been sent but there is not yet confirmation of its
delivery

Forwarded

The message has been forwarded to another recipient

Deferred

The message delivery is deferred and is retried at a later time

Delayed

The message delivery is delayed and is retried at a later time

Redirect

The message has been redirected to another system, for
example, a quarantine or encryption server

BCC

A Blind Carbon Copy was created for the message and sent to the
BCC contact

Bypass

The message bypassed all spam and content controls

SecureMail Encrypt

The message was encrypted by the integrated SecureMail
encryption engine

Trust

The message was considered trusted for scanning purposes
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Action

Description

Accept

The message was accepted for scanning and delivery

Archive Copy

The message was copied to an archive server

Pass

The message passed all threat and content scanners and was
delivered to its destination

Do Not Train

The message is not used as training for Token Analysis

Not Trained

The message was not used as training for Token Analysis

Trained

The message was used for training by Token Analysis

Just Log

The action on the message was only sent to the log files, and the
message delivered to its destination
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System Utilities
The Utilities page (Activity > Status > Utilities) provides the following utilities:
n
n
n
n

Controls to start and stop the message processing
Flush the mail queues, DNS cache, and Web cache
Policy trace
Diagnostic tools, for example, a Hostname Lookup function, SMTP Probe, Ping, and
Traceroute utilities that are useful to resolve message and network problems.

Messaging System Controls
You can control the flow of message processing for inbound and outbound messages.

n

Messaging System Control – To stop or start all email and web messaging services, click on
the Stop or Start Messaging System Control button.
WarningThe Stop and Start messaging controls are replicated in a cluster environment.
When you stop message processing on the Primary, you stop message
processing on all devices in the cluster.

n

n
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Message Receiving – You can enable or disable only the receiving of messages when you
click the Disable Receiving or Enable Receiving button. This is useful if you only want to
stop the processing of inbound messages. For example, you may want to turn off the receiving
of messages to troubleshoot errors with inbound mail, but still send outbound messages.
Message Sending – You can enable or disable only the sending of messages when you click
the Disable Sending or Enable Sending button. This is useful if you only want to stop the
processing of outbound messages. For example, you may want to turn off the sending of
messages to troubleshoot errors with SMTP delivery, but still receive inbound messages.
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Utilities
n

n

n

n

n

Flush Mail Queue – The Flush button is used to reprocess any queued mail in the system.
Only click this button once. If the mail queue does not process, you may have other types of
delivery problems, and additional flushes only add more load on your XCS device.
Flush DNS Cache – Click Flush to remove all entries from the current DNS cache. Use this
option to clear the entries in the DNS cache if you cannot resolve host names because of
cached DNS queries.
Flush Web Cache – Click Flush to manually purge the HTTP Proxy web disk cache.
Administrators may want to purge the entire web cache if there are issues with certain web
pages that do not update with newer content, or issues when you connect to specific web sites.
Flush URL from Web Cache – You can flush a specific URL from the web cache if you have
problems loading or refreshing the URL. The URL must be specified exactly the way it is typed
including the protocol, for example, http://www.example.com/index.html. When you have
entered the URL, click Flush.
Policy Trace – Click Enable Policy Trace to enable more detailed log messages for policy
resolution in the messaging logs. The additional logging fields provide information on the
features enabled for each level of policy (domain, group, user, default, etc.), and the policy user
and recipient address.
For example, policy_recipient=<testuser@example.com>, policy_
user=<testuser@example.com> (remote=F), domain_policy=<2:Antispam enabled>,
group_policy=<0:>, group_name=<>, user_policy=<4:OCF enabled> default_
policy=<1:Default>

n

Flush Web Single Sign-on Sessions – Flushes all Web Proxy authenticated single sign-on
sessions for both Proxy and Portal IP address-based authenticated users. Current Web Proxy
users must re-authenticate before they can get access through the Web Proxy.

Diagnostics
The Diagnostics section contains networking and SMTP utilities to help troubleshoot network and
message delivery issues.

n
n
n
n

n

Hostname Lookup – Verifies host name resolution with a query to a DNS name server.
SMTP Probe – Sends a test email to a remote SMTP server.
Ping – Test network connectivity with ICMP ping.
Traceroute – Traces the routes of network data from the source to the destination server to test
connectivity.
Web RED URL Lookups – Lookup the web reputation of a specific URL.

User Guide

645

Monitoring

Mail Queue
The Mail Queue page contains information on mail waiting to be delivered. Mail may be deferred
because the destination mail system cannot be contacted.
If a message is deferred, this schedule is used to try another mail delivery:
n
n
n

1000 seconds (first retry)
2000 seconds (second retry)
4000 seconds (third and subsequent retries until the message is delivered or the message
expires in the queue)
Note The Maximum Time in Mail Queue setting is configured via Configuration > Mail >
Delivery.
The default is 5 days. You can enable mail queue monitoring in the advanced settings.

To see and manage the mail queue:
1. Select Activity > Queue/Quarantine > Mail Queue.
2. You can take these actions:
n
n
n
n

Use the Search field to search for a specific mail message.
To remove undeliverable messages, select the message and click Remove.
Select Remove All to remove all messages in the queue.
To process messages out of the queue, click Flush Mail Queue. Only click this button
once. If the mail queue does not process, you may have other types of delivery problems
and reprocessing the mail queue only adds additional load to the system.

Display Options
You can append these options to the URL of the Mail Queue page:
n
n
n

?limit=n — Sets the total number of mail queue items in the list. The default is 2000.
?ipp=n — Sets the number of items per page.
?order=asc — Sorts items by oldest date first to the most recent.

For example, to set the total number of displayed items to 100, use this URL:
https://hostname.example.com/ADMIN/mailqueue.spl?limit=100

Use the “&" symbol instead if an “?” option already exists:
https://hostname.example.com/ADMIN/mailqueue.spl?action=submit&limit=100
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Message Quarantine
The Message Quarantine contains messages that have been quarantined by these message security
features:
n
n
n
n
n
n
n
n
n

Anti-Spam
Anti-Virus and Spyware
Outbreak Control
Attachment Control
Attachment Size Limits
Malformed Mail
Objectionable Content Filter
Document Fingerprinting
Data Loss Prevention (DLP) compliance rules

In addition to the primary system quarantine, you can view and manage messages in Custom
Quarantines.

Manage the Message Quarantine
To view and manage the message quarantine:
1. Select Activity > Queue/Quarantine > Message Quarantine.

2. You can take these actions:
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n

n

From the Filters drop-down list, select the name of a specific quarantine to view. Select All
to show all quarantined messages. Select System to display the primary system
quarantine.
Click a message subject link to view a message preview.
WarningThe message may contain malicious code such as a virus. Do not click on any
message links or open any message attachments within the quarantine
message preview.

n
n

n

n

n

n

Select a message and click Delete to delete the message from the quarantine.
Select a message and click Release to release the message from the quarantine and
deliver it to its original destination.
Select a message and click Move to Quarantine to move the quarantined message to the
selected quarantine area.
Select a message and click Rescan and Release to perform an anti-virus scan of the
quarantined message and release the message if no viruses are detected, or drop the
message if viruses are detected. Kaspersky Anti-Virus must be licensed and enabled to
scan a quarantined message.
Select a message and click SecureMail Encrypt and Release to encrypt the quarantined
message with SecureMail Email Encryption and release the message to the original
recipient. SecureMail Email Encryption must be licensed and enabled to encrypt the
message.
Select a message and click Encrypt and Release to encrypt the quarantined message
with the configured External Email Encryption server and release the message to the
original recipient. External Email Encryption must be enabled to encrypt the message.

3. Use the Search field to look for specific messages in the quarantine.
For example, you could search for the name of a specific virus so that any quarantined
messages infected with that specific virus are displayed.
You can search these message fields:
n
n

n
n
n
n
n

Sender, Recipient, or QueueID
Type (for example, attachment, attachment size, malformed, virus, spyware,
objectionable, compliancy, antispam, pbmf, content rules, dfp, or possible virus to restrict
the search to those types of messages.). You can combine the specified message type
and include an attachment, virus, or spyware name, for example, attachment file.exe )
Subject
Date and time (for example, 2013-01-14, 20:27:34, or both 2013-01-14 20:27:34)
Filename
Virus or spyware name
File Size

Note The Delete All,, Release All, Move to Quarantine, Rescan and Release All,
SecureMail Encrypt All, and Encrypt All buttons are used specifically with the
search function. You must enter a specific search pattern before you use these
controls.
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Cluster Quarantine Management
You can manage the quarantine from any host in a cluster. Within the message quarantine, each
message indicates the host in the cluster where the quarantined message is located. You can preview,
release, move, rescan and release, SecureMail encrypt, encrypt, or delete any quarantined message in
the cluster from any cluster host.
Note The system can only display a maximum of 1000 cluster quarantined messages.
Refine your search to filter the results.

Custom Quarantines
You can create your own custom quarantine areas for specific types of quarantined messages. For
example, you can create a quarantine specifically for messages quarantined because of a virus, or
messages quarantined because they violate a Data Loss Prevention (DLP) policy rule.
Custom quarantines can be managed by a Tiered Administrator with the appropriate permissions. This
allows you to assign administrators for specific quarantine areas. For example, for compliance
purposes, you can assign a user the role of administrator for the DLP quarantine.
You can also configure independent message expiry options for each custom quarantines.
To view items in the system quarantine and custom quarantines, select Activity > Queue/Quarantine
> Message Quarantine.

Custom Quarantine Action
When you create a custom quarantine, each message security feature that supports the quarantine
option will provide a quarantine action for the system quarantine and any custom quarantines. For
example, you can create a custom quarantine called "Anti-Virus", and then set the Anti-Virus feature
action to use that quarantine action. All messages quarantined by the Anti-Virus feature will appear in
the "Quarantine: Anti-Virus" quarantine area.

User Guide

649

Monitoring

Manage Custom Quarantines
To manage custom quarantines, select Activity > Queue/Quarantine > Custom Quarantines.
The Custom Quarantine page displays this information:
n

n

n
n

ID – The ID number for the quarantine. This ID number appears in the message details log of a
quarantined message.
Name – The name of the quarantine. This name appears in the quarantine actions for all
message security features.
Expiry Mode – Indicates the current expiry mode for the quarantine.
Quarantined Emails – Indicates how many email messages are stored in the quarantine.

There are two default pre-defined quarantines:
n

n

System – The primary system quarantine. All quarantined messages are stored here except
messages stored in a custom quarantine.
DLP – You can use the DLP quarantine to quarantine messages for Data Loss Prevention
features.

You can perform these actions from the Custom Quarantine Management page:
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n

Click an existing custom quarantine to edit its settings.
Click Add to add a new custom quarantine.
Click Delete to delete the selected custom quarantine. You cannot delete a quarantine that is
currently in use with a message security feature action or is not empty.
Click any column heading to switch the sort order between ascending or descending.
Use the Search field to search for a specific quarantine.

Add or Edit a Custom Quarantine
To add a custom quarantine, or edit the details of an existing custom quarantine:
1. Click Add.

2. In the Quarantine Name text box, type a descriptive name for the custom quarantine.
3. In the Quarantine Comment text box, type a comment to describe the custom quarantine.
4. From the Expiry Mode drop-down list, select the type of expiry to use for the custom
quarantine. An expiry term can be set so that quarantined messages will be deleted after a
certain period of time or if disk space is limited.
n

n

Disk Full – Expire messages from the quarantine when the disk is 90% full. Messages are
expired starting with the oldest message until the percentage is below the limit.
Per Settings – Expire messages based on the configured settings:
n Expiry Days – Enter how many days to keep a quarantined message before it
expires. The default is 7 days.
n Disk Usage (Percentage) – Enter a percentage of disk usage that is used by the
quarantine storage area. Valid values are between 10% and 90%. The default is
50%. The disk partition used by the quarantine is the System Data Storage Area
partition. If the usage for this disk partition grows beyond the specified size,
messages are expired starting with the oldest message until the percentage is below
the limit. You can view the size of disk partitions on the main Dashboard page.

5. Click Apply to save the configuration.

Custom Quarantine Logs
In the Message Logs, the ID number of the custom quarantine is indicated by the Action Data field.
For example:
Jan 25 13:00:18 xcs postfix/cleanup[14531]: 341235278AB9CDDC:
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User Policy: 0, Group Policy: 0, Domain Policy: 0, System: Intercept
Source (Reason): Attachment Control, Action: quarantine
Recipient: user@example.com, Is Inbound: yes, Intercept score: 0
Action Data: 110, Rule Number: 0, User Time Policy: 0, IP Time Policy: 0
IP Policy: 0, Group Time Policy: 0, Domain Time Policy: 0
Default Time Policy: 0
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Message History
Every message that passes through the system generates a database entry that records information
about how it was processed, filtered, and delivered. To see how the message was processed, you can
examine the message history database to see the disposition of the message.
Messages are searched and displayed based on the type of message (email and web) and the
message part. For example, you can search for partial or specific text in the subject header of all email
messages in the database.
To search the message history:
1. Select Activity > History > Message History.
2. In the Search Name text box, type an optional descriptive name for the search if you want to
save it or schedule a report.
3. Configure your search parameters and start the search.
4. Examine the Status column for full information on how a message was processed and its final
disposition.
5. Use the search fields to filter the message history results.
All simple search fields default to exact matches, except for Subject, which accepts partial
matches, and Domain part, which matches the ending of a domain part. For more detailed and
flexible searches, use the Advanced Search option.
Note A maximum of 10,000 search results are displayed. Use the search parameters to
narrow your search and improve the search results, or download the results file to see
all search results. See Message History for more details.
You can also take these actions:
n

n
n
n

n
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Click the Download these results link to save the search results as a local file. You can
search this file offline for more efficient results.
Click on a Message ID to see the Message Details.
Click Show Log to see the corresponding log entry for this message.
Click Save Search to save a message history search. To see saved searches, select
Activity > History -> Saved Searches.
Click Schedule as Report to create a scheduled message history report for this search.
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Email History Search
You can search for email messages with these message fields:
n
n
n
n

n

n

n
n

n

n
n

n
n
n
n

FROM/Sender – When you search on FROM/Sender, it includes these message fields:
Envelope Address – The Envelope From address in the SMTP envelope.
Header Address – The From address in the message header.
TO/CC/BCC/Recipients – When you search on TO/CC/BCC/Recipients, it includes these
message fields:
o Account/Mailbox Part (for example, user1 in the email address user1@example.com )
o Domain Part (for example, example.com )
Subject – Searches the subject field of a message. The subject field search additionally checks
for variations on the subject specified in any part of the subject. For example, if you search on
spam message , the system matches on spam message , message spam , this message is
spam and also plurals, for example, spam messages .
SMTP HELO message – Searches on text in the SMTP HELO message that identifies the
SMTP client to the server.
Client IP – Searches on the client IP address, for example, 10.0.l.100 .
Client Host – Searches on the client hostname, for example, hostname in the fully qualified
domain name hostname.example.com .
Message ID – Searches on the Message ID that is added by a mail server, for example,
8290352619373D0@server.example.com .
Queue ID – Searches on the Queue ID of a message, for example, CE9D0C23183D8E2B .
Prior Queue ID – Searches on the prior Queue ID of a message. If a message is forwarded
because of alias expansion, vacation notification, or because it was bounced, a new message
is created in the queue.
Virus – Searches for messages that contained a specific virus.
Spyware – Searches for messages that contained a specific type of spyware.
Attachment Type – Searches messages for specific attachment types.
Authentication – Searches messages based on their SMTP authentication status.

HTTP History Search
You can search for web requests and sessions with these fields:
Note There are no message details for successful web sessions. The browse time for
successful sessions is indicated in the status column of the search results.
n

n

n

n

n

Client IP – Searches web requests and sessions based on the IP address of the web client, for
example, 10.0.1.100 .
Request ID – Searches on the Request ID added to the request by the system, for example,
8290352619373D0 . This field can also be used to search web sessions.
URL – Searches on the URL of the HTTP request, for example, www.example.com . This field
can also be used to search web sessions.
Request From – Searches on the user name of the originating client request if authentication is
enabled for the Web Proxy. If authentication is not enabled, use the Client IP option to search
requests for specific client IP addresses. This field can also be used to search web sessions.
Virus – Searches for messages that contain the specified virus.
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Spyware – Searches for messages that contain the specified spyware name.
Attachment Type – Searches on the attachment type of any attachments filtered by the
Attachment Control and Content Scanning features. The specified search term must match the
Content-type for the attachment, as displayed in the HTTP log. For example, to match a .exe
attachment, you must enter a partial or exact search on the Content-Type name of
application/x-msdos-program .

Advanced Search
Click the Advanced Search link to expand the number of options to use to search the database. The
advanced search includes additional parameters, for example, advanced date ranges, message
direction, TLS status, and the final action taken on messages.

Message History Search Tips
The message history search methods have been optimized to work most efficiently when used to
locate messages using specific criteria in a narrow time period. Try to narrow your searches to the
smallest time period possible, and avoid searches for all time periods (Anytime). This is especially
important for systems that process a large volume of messages,. The most efficient way to retrieve
results is to narrow your search to a single daily time period.
On the Simple Search page, the default search criteria option is exactly matches (case sensitive) for
all search items except for these fields:
n
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Subject – Defaults to contains. Subject searches with the contains option use substring
matching. Use the contains keywords option for full text search of subject fields for fast
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n

searches of space-delimited languages.
Recipient Domain Part – Defaults to ends with.

For all other search items, the contains option is the least-efficient possible search method. If
possible, narrow your search using the options exactly matches, starts with or ends with, which are
more efficient for message searches. For more detailed and flexible searches, use the Advanced
Search page.
Specify these search fields in your query for the most efficient searches:
n
n
n
n
n
n
n

Queue ID
Sender Envelope Address
Sender Header Address
Sender Display Name
Recipient Account/Mailbox Part
Recipient Domain Part
Subject
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Saved Searches
When you perform a message history search, you can save the search parameters as a saved search.
This option is useful to store message history searches that you perform on a regular basis, and
enables you to schedule a saved message history search as a report.
To manage saved searches, select Activity > History > Saved Searches.

Any message history searches that you have saved previously are displayed.
You can perform these actions:
n
n
n
n
n

Click a specific search name to run and view the results of the search.
Click Edit Search to make changes to the saved search.
Click Schedule as Report to create a scheduled message history report for this search.
Click Add to add a new message history search.
To delete a saved search, select a saved search, then click Delete.
Note If the saved search has a report connected to the search, you must delete the report
first before you can delete the saved search.

658

WatchGuard XCS

Monitoring

Message Details
From the Message History search and Recent Mail Activity page on the Dashboard, you can click a
message to view the processing details for a message.
The Scan Results section provides the scan results of each scanner, and identifies any specific
scanning features that performed an action on the message. The final message disposition and the
actions performed on the message are displayed in the Message Dispositions section.
Any follow-up messages such as notifications are displayed in the Follow-Up Messages section.

n

n
n
n
n

n
n

From – The Envelope From field of the message. If the Envelope From is different than the
header From field, both values are displayed.
Date – The time and date the message was accepted by the WatchGuard XCS.
Subject – The subject field of the message.
Recipients – The total number of recipients for the message.
Sending Host – The sending host and IP address. If there is no host information, the IP
address is displayed.
Size – The size of the message in bytes.
TLS – Indicates if TLS encryption was used during the delivery of the message.
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n

Message ID – The unique ID number for the message.
Queue ID – The message queue ID assigned to the message by the WatchGuard XCS for
message processing.
Prior Message – Provides a link to any prior messages for this message.

From the message details, you can perform the following administrative functions:
n

n

n

n

Allow Sender – Creates a pattern filter set to "Accept" for the sender Envelope From address.
Any future messages from the same sender are accepted and delivered regardless if the
message is classified as spam.
Block Sender – Creates a pattern filter set to "Reject" for the sender Envelope From address.
Any future messages from the same sender are rejected.
Allow Domain – Creates a pattern filter to "Accept" the domain part of the sender Envelope
From. Any future messages from the same sender domain are accepted and delivered
regardless if the message is classified as spam.
Block Domain – Creates a pattern filter to "Reject" any messages from the domain part of the
sender Envelope From. Any future messages from the same sending domain are rejected.
Note Tiered administrators cannot perform these actions on the message details page.
They must be performed by the primary administrator account.
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System History
The System History is a record of system-related information and events, for example, processes,
message queue sizes, administrative and log in activity, network/disk space use, swap file, and disk
paging statistics.
To get access to the system history:
1. Select Activity > History > System History.

2. Set the Search Criteria to restrict the search to a specific range of dates or number of days.
3. Click Search.
Search results are filtered based on the type of system activity/process, or a specific hardware
device.
This table provides a description of the search fields.
System Activity

Description

Admin Actions

Displays a list of actions taken by an administrative user.
This includes commands and logins.

Avg. Waiting Processes

The average number of waiting CPU processes for the past 1, 5, and
15 minutes.

DNS Lookup Performance

Displays performance information for DNS lookups.

Disk Loading (Other)

Displays the MB per second, KB per transfer, and transfer per
second, for each non-SCSI disk.

Disk Loading (SCSI)

Displays the MB per second, KB per transfer, and transfer per
second, for each SCSI disk.

Disk Usage

Amount (in KB) of used disk space, total available disk space, and
percentage used for each disk slice.

Disk Usage Inodes

Amount of used inodes, available inodes, and percentage inodes
used for each disk slice.
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System Activity

Description

Login Failures

Displays information on failed web admin or WebMail logins to the
system.

Login Success

Displays information on successful web admin or WebMail logins to
the system.

Logout

Displays information on web admin or WebMail logouts from the
system.

Logout Expiry

Displays information on logins that expired and were automatically
logged out of the system.

Network Usage

Amount of data inbound and outbound (in bytes) on the network
interface.

Paging

The number of disk pages in and out.

Pattern File Download

Status of Anti-Virus pattern file downloads.

Queue size

Amount of mail waiting in the Mail or Deferred Queue.

Swap

Used and available swap space in megabytes.
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Connection History
The Connection History is a log history of connections to the system from other systems. The history
shows the time of the connection, the server name and IP address, the action taken on the connection
and its source, properties (trusted or untrusted), and the reject details if the message was rejected.
To see the connection history:
1. Select Activity > History > Connection History.

2. Set the Search Criteria to restrict the search to a specific range of dates or number of days.
3. Click Search.
Search results are filtered based on the actions taken on that connection and the action source,
for example, a connection refused because of a low reputation score by Reputation Enabled
Defense.
This table provides a description of the search fields.
Note The Sender and Recipient fields are empty for connections that are rejected before
that information is received, for example, in the case of an IP address that was
blocked.

Action

Description

Accept

Connection passed the initial connection checks and was
accepted by the system.

Just Log

Connection and its processing was recorded in the log file
only.

Pass

Connection was accepted by the system and the messages
passed all content and security checks.

Reject

Connection was rejected with notification to the connecting
system.

Relay

Connection was relayed through this system.

Temporary Reject

Connection was temporarily rejected. The connection is
retried at a later time.
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Source

Description

Reputation Dialup

Connection was detected as a dialup source by the
Reputation Enabled Defense service.

Reputation Infected

Connection was considered to be a source of virus
infections by the Reputation Enabled Defense
service.

RED

The connection’s Reputation Enabled Defense
reputation score exceeded the reputation reject
threshold.

Blocked Sender

Sender of a message in the connection was on the
Blocked Senders List.

Clean

Connection was allowed and messages were
processed as clean.

DNSBL matches above
threshold

Connection was rejected by a DNS Block List
because the number of DNSBL matches exceeded
the threshold.

Invalid Sender Domain

Connection contained an invalid sender domain
address.

Mail Access Control

Connection violated a threshold in the Mail Access
settings (for example, message too large).

PBMF

Connection matched a Pattern Filter rule.

Relay

Connection was allowed to Relay through this
system.

SAP

Connection matched a Specific Access Pattern.

TDR

Connection was acted on by the Threat Prevention
feature.

Trusted Sender

Sender of a message in the connection was on a
Trusted Senders List.

UBL

Connection (Email or Web) contained a URL that
matched on a URL Block List.

Very Malformed

Connection contained very malformed messages.

Rule Match

Connection information was matched in a Connection
Rule.
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Syslog Host
You can forward all of the system’s log files to a syslog server that collects and stores log files from
many sources. The syslog files can then be analyzed by a separate logging and reporting program.
Syslog includes these system logs: Mail log, System log, Auth log, and cron messages.
To define a syslog host:
1. Select Configuration > Network > Interfaces.
2. Type the IP address or host name of the syslog server in the Syslog Server field.

3. Click Apply.
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SNMP (Simple Network Management Protocol)
Simple Network Management Protocol (SNMP) is the standard protocol for network management.
When enabled on the WatchGuard XCS, this feature gives standard SNMP monitoring tools the ability
to connect to the SNMP agent that runs on the XCS system and extract real-time system information.
The information available from the SNMP agent is organized into objects that are described by the MIB
(Management Information Base) files. The information available includes disk, memory, and CPU
statistics, mail queue information, and statistics on the number of spam or virus-infected emails. An
SNMP trap is sent when the system reboots.
Note The SNMP MIB files are based on SNMP version 2 and are backwards compatible
with version 1.
The SNMP agent service is installed and running by default, but it must be enabled specifically to
monitor a network interface as required.
To add SNMP access to a network interface:
1. Select Configuration > Network > Interfaces.
2. Select the SNMP Agent check box on the required interface.
We strongly recommend that the agent only be configured for the internal (trusted) network.
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3. Click Apply.
You must restart the device.
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Configure SNMP
To configure SNMP:
1. Select Configuration > Network > SNMP.

2. Select the Send Trap on Reboot check box to send a trap message to your SNMP trap host
when the system reboots.
A trap is sent when the system shuts down, and another trap is sent when the system restarts.

3. Enter the email address of the System Contact for this device.
4. Enter the System Location for this device.
5. Enter the Read-Only Community string (case-sensitive) for this device.
By default, the system does not allow read/write access to the SNMP agent. For read access,
you must set up a read-only community string on both the agent and your SNMP management
application for authentication. We recommend that you change the default community string
“public” to a more secure value.
6. Click Apply.

Permitted Clients
To enable access to the system’s SNMP agent, you must specifically add the client system to the list
of SNMP permitted clients.
To add permitted clients:
1. Enter the address of your SNMP management station.
The clients are specified with a host name, IP address, or CIDR network address (192.168.128.0/24
or a123:b123::/64.

2. Click Add to add the permitted client.
3. Click Apply.
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Trap Hosts
A trap host is an SNMP management station that receives system traps from the WatchGuard XCS.
The system sends an SNMP trap when the system is shut down or restarts.
To add trap hosts:
1. Enter a list of hosts that receive trap messages.
The hosts are specified with a host name or IP address.

2. Click Add to add the trap host.
3. Click Apply.

MIB Files
To download the SNMP MIB files, click Download MIBs. You must import these files to your SNMP
management program. The MIB file contains a list of objects that represent the information that is
extracted from the XCS SNMP agent.
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Alarms
The WatchGuard XCS implements a variety of system alarms to notify the administrator of exceptional
system conditions. Alarms are generated from the Queue Replication, LDAP, DNS Intercept queries,
and Backup subsystems. For example, you can receive an alarm notification if the daily FTP backup
fails, or if queue replication fails. Errors with LDAP user imports also trigger an alarm.
You can select the type of alarm notifications to receive, for example, Critical, Serious, and Warning
events.
The notifications are sent with these methods:
n
n
n

Alarms Indicator
Email notification
Console Alert

This example shows the Alarms Indicator that appear on the administrative user interface page.

The indicator displays how many new alarms have occurred. Click the Alarms Indicator to see a
summary of the most recent alarms.

Click View all alarms in the alarms indicator, or select Activity > Status > Alarms to go to the local
alarms page where you can see and acknowledge all alarms.
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Click Acknowledge to acknowledge and remove the alarm notification. Click Acknowledge All to
remove all alarm notifications.
Note Tiered administrators only have a read-only view of the Alarms indicator if the “View
Alarms” permission is assigned. Tiered administrators can see alarms, but they
cannot acknowledge an alarm. Delegated Domain administrators do not have access
to the alarms.

Alarms in a Cluster
You can see and acknowledge local alarms on each individual system in the cluster (Primary,
Secondary, or Client). The alarms indicator on any cluster system only shows local alarms for the
specific system, and acknowledgement of a local alarm does not clear its status for the cluster.
Alarms generated by the cluster are only available on the Cluster Primary system at Activity > Status
> Cluster Alarms. The Cluster Alarms page indicates alarms that appear on individual systems in the
cluster and you can see and acknowledge them on the Primary system. The alarm indicates the
specific host in the cluster from where the alarm generated.
Note In certain cases, a cluster alarm appears on a Primary, Secondary, and Client. The
alarms must be acknowledged on all systems before the cluster alarm is cleared on
the Primary.

User Guide

671

Monitoring

Configure Alarms
To configure alarms and notifications:
1. Select Configuration > Miscellaneous > Alarms.

2. In the Send Escalation Mail section, select the types of alarms that send an email to the
specified Escalation Mail Address.
3. In the Send Alarm Mail section, select the types of alarms that send and email to the specified
Alarm Mail Address.
The alarm only triggers once for a specific alarm. You do not receive another email alert for the alarm
unless you acknowledge the alarm on the Dashboard and it occurs again.

Note You must have a valid address specified in the Email Addresses section for the alarm
email notification to be sent.
4. In the Alert to Console section, select the types of alarms that display an alert on the system
console screen.
5. In the Alert to Alarms Indicator section, select the types of alarms that display an alert on the
main administrative user interface page in the alarms indicator.
6. Type the Escalation Mail Address to send escalation messages to.
7. Type an Alarm Mail Address to send alarm messages to.
Note You should use SNMP for monitoring of system resources, for example, disk space
and memory usage. See SNMP (Simple Network Management Protocol) for more
information.

Alarms List
This table describes the types of alarms that can occur.
Severity

Alarm

Critical

LDAP Lookup: LDAP lookup failed during delivery

Critical

LDAP Lookup: LDAP lookup: Unable to bind to server
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Severity

Alarm

Critical

LDAP Lookup: LDAP lookup: Search error 81: Can't contact LDAP server

Critical

Queue Replication: Cannot connect to mirror

Critical

kav_pattern_update: No available Kaspersky Anti-Virus update servers

Critical

Deferred mail queue threshold exceeded.

Critical

QueueMonitor: Incoming queue size exceeded the “Significant” limit.
SMTPDs reject new requests temporarily.

Serious

QueueMonitor: Incoming queue size exceeded the “Medium” limit. The
system significantly increases priority of mail delivery over mail receiving.

Critical

Restore: Finished: (indicates if restore successfully PASSED)

Serious

DNS status check (DNSBL, UBL, Reputation)

Serious

Restore: Reporting: Finished: (indicates if reporting restore was completed)

Serious

FTP Backup: FTP Backup Failed

Serious

SCP Backup: SCP Backup Failed

Serious

LDAP Import: LDAP import, Import of groups failed

Serious

LDAP Import: LDAP import, Import of users failed

Serious

LDAP Import: LDAP failed to download users, groups

Serious

mxlogging: could not rollover/offload some files. Please see details in
Systems Log (messages).

Serious

mxlogging: [error message]

Serious

Web Proxy SSO: Lost connection to SSO Agent

Warning

Content Rules: Uploaded rules processing completed

Warning

QueueMonitor: Incoming queue size exceeded the “Minor” limit. The system
slightly increases the priority of mail delivery over mail receiving.

Warning

kav_pattern_update: Indicates that the pattern update could not be
completed because there was no connection to the Kaspersky Anti-Virus
update server. This can be caused by a timed-out or blocked connection.
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Troubleshooting

Troubleshoot Message Delivery
When message delivery problems occur, the first step to troubleshoot the issue is to examine if the
problem is affecting only incoming messages, outgoing, or both. For example, if you receive
messages, but cannot send outgoing messages, it is certain that your Internet connection is working
properly, or you would not be able to receive messages. In this scenario, you may have issues with a
network firewall blocking your outbound connections, or some other issue that prevents message
delivery.
Problems that affect both inbound and outbound delivery include these scenarios:
n

n

n

Network Infrastructure and Communications – The most common scenario in which you
cannot send or receive messages is if your Internet connection is down. This can include
upstream communications with your ISP, your connection to the Internet, or your external
router. You must also check your internal network infrastructure to make sure you can contact
the WatchGuard XCS from your router or firewall.
DNS – If your DNS is not working or configured properly, messages are not forwarded to your
WatchGuard XCS and you cannot lookup external messaging or web servers. Make sure the
DNS service is running, and check your DNS records for any misconfiguration for your
messaging services. Make sure that your MX mail records are set up properly to direct
messages to the WatchGuard XCS.
Firewall – If you have issues with your firewall, or if it is misconfigured, it may inadvertently
block message access to and from the WatchGuard XCS. For example, SMTP port 25 access
must be open between the Internet and the WatchGuard XCS, and between the WatchGuard
XCS and internal servers to allow inbound and outbound message connections. TCP port 80
access is required for HTTP web communications between the WatchGuard XCS and external
web servers.
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Internal Messaging Systems – You can experience problems where you receive incoming
messages to the WatchGuard XCS, but the messages are not forwarded to the appropriate
internal servers. Also, outgoing messages from the internal servers are not forwarded to the
WatchGuard XCS for delivery. In these scenarios, examine your internal messaging server to
make sure it is working properly. Check communications between the two systems to make
sure there are no network, DNS, or routing issues. Also check that your internal servers and
web clients are configured to send outgoing messages and requests to the WatchGuard XCS.
External Messaging and Web Servers – If you have a large amount of messages or requests
to a particular destination, and that server is currently down, the messages queue up in the
deferred queue and delivery is retried after a period of time. You can view the log files to see the
relevant messages that can indicate why you cannot connect to that particular server. The
server could be down, too busy, or not currently accepting connections.
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Troubleshooting Tools
These sections describe the built-in tools that you can use on the XCS device to help troubleshoot
message and web request issues.

Monitor the Dashboard
The Dashboard provides a summary view that allows you to examine critical statistics for email and
web traffic all on one page. When you check email and web activity, examine these items:

Check the Mail Security section to verify the status of your mail security services.
Check the Mail Resources section to view the number of messages in the Mail Queue and Deferred
queue.
This is a quick indicator of how your email messages are processing.
Make sure that the queues are not building up too high. This can indicate a message delivery issue.
Also, check the number of incoming and outgoing connections, because you can experience system
processing latency when a large number of concurrent connections are active.
In the Recent Mail Activity and Recent Web Activity portions of the Dashboard, check the timestamps
of your most recent incoming and outgoing messages or web requests. If no messages or requests are
processed in a specific period of time, this indicates that the inbound, outbound, or both directions are
not working.
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Check the mail and web traffic summaries regularly, because you may notice messaging system
latency if you receive a lot of viruses, spam, or message rejects.
In the Web Summary, examine the web cache efficiency to make sure it is not at a low level compared
to your typical cache efficiency baseline. Also, check the number of web connections, because you
may experience system processing latency when a large number of connections are active.
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Network Utilities
Select Activity > Status > Utilities to access diagnostic tools that help you troubleshoot networking
problems and connectivity issues with other messaging servers. Examples of messaging tools include
Hostname Lookups, SMTP Probe, Ping, and Traceroute.

Utilities
From the Utilities section, you can control these system services:

Flush Mail Queue
Use the Flush Mail Queue option to flush and reprocess all queued email. You must only use this utility
if you have a high amount of deferred mail that you need to deliver. This process can take a very long
time in environments with a high amount of deferred mail.
If the deferred mail queue continues to grow, there are other problems that prevent the delivery of mail,
and you should not click Flush again.
Note You must only click this button once because it reprocesses all queued mail.

Flush DNS Cache
Click the Flush button to remote all entries from the current DNS cache. Use this option to clear the
entries in the DNS cache if you experience issues resolving host names because of cached DNS
queries.
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Flush Web Cache
Click the Flush button to manually purge the Web Proxy disk cache. You should purge the entire web
cache if you have issues with specific web pages not updating with newer content, or issues
connecting to specific web sites.

Flush URL from Web Cache
You can flush a specific URL from the web cache if you have problems loading or refreshing the URL.
The URL must be specified exactly the way it is typed including the protocol, for example,
http://www.example.com/index.html. When you have entered the URL, click Flush.

Policy Trace
Click Policy Trace to enable more detailed logging of policy resolution in the message logs. The
additional logging fields provide information on the features enabled for each level of policy (domain,
group, user, default, etc.), and the policy user and recipient address.
The log entry contains information similar to this output:
policy_recipient=<testuser@example.com>,
policy_user=<testuser@example.com> (remote=F), domain_policy=<2:Antispam enabled>,
group_policy=<0:>, group_name=<>, user_policy=<4:OCF enabled> default_
policy=<1:Default>

Flush Web Single Sign On Sessions
Use this utility to flush all Web Proxy authenticated single sign-on sessions for both Proxy and Portal
IP address-based authenticated users. After you flush the sessions, current Web Proxy users must
authenticate to the Web Proxy again before they are allowed to browse web sites.
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Hostname Lookup
Use the Hostname Lookup utility to perform DNS host lookups and make sure that hostnames are
properly resolved by the DNS server.
To perform a hostname lookup:
1. In the Name text box, type the FQDN (Fully Qualified Domain Name) of the host to lookup on
the name server.
For example, host.example.com .
2. From the Query type drop-down list, select the type of DNS record to lookup.
For example, select A for a typical name host record or select MX for a mail server lookup.
n
n
n
n
n
n
n
n

A = Address
MX = Mail Exchanger
ANY = All records
NS = Name Server
SOA = Start of Authority
HINFO = Host Information
TXT = Text
AAAA = IPv6 Address

9. Click Lookup.
The name server displays the IP address for the host name. If “Unknown host” is displayed,
then the host name is not listed in the DNS records.

If the XCS device cannot contact the name server, select Configuration > Network >
Interfaces and check your DNS configuration.
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To make sure you have network connectivity, use the ping and traceroute commands on the
Utilities page to check if you have a connection to the network and to the DNS server.
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Ping Utility
The ping utility sends ICMP packets to a host and then listens for a return packet. Use this utility to
ping hosts both on the internal and external networks from the WatchGuard XCS. Ping the firewall,
DNS server, and external router, as well as the WatchGuard XCS from these locations to make sure
you have connectivity.
For more detailed information on routing connectivity between the two hosts, use the traceroute utility.
To test connectivity using ping:
1. In the Ping host text box, type the IP address or host name of the host you want to ping.
2. Select the IP Type: IPv4 or IPv6.
3. Click Ping.
The response displays the time for each successful ping. A “Request timed out” response
indicates you cannot contact the specified host.
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Traceroute Utility
Use the Traceroute utility to see the routing steps between two hosts. If you lose connectivity
somewhere between the XCS device and a receiving host, you can use traceroute to see where
exactly the packet is dropped.
The traceroute utility displays each network hop as it passes through each router to the destination. If
you experience routing issues, you can see in the trace output where exactly the communication fails.
To test connectivity using traceroute:
1. In the Traceroute host text box, type the IP address or host name of the system to test.
2. In the Protocol drop-down list, select the protocol to use (UDP, TCP, GRE, ICMP).
This option is for IPv4 only.

3. Select the IP Type: IPv4 or IPv6.
4. Click Traceroute.
The response indicates the traceroute to the destination. A series of “*” characters indicates the
connection is lost.
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SMTP Probe
Use the SMTP (Simple Mail Transport Protocol) Probe to test email connectivity with a remote SMTP
server.
This allows you to verify that the SMTP server responds to connection requests and returns a valid
response.
To perform an SMTP probe:
1. In the SMTP Server text box, type the domain name or IP address of the destination SMTP
server to test.

2. In the envelope-from (MAIL FROM) text box, type the address to identify the sender of the
email message.
3. In the envelope-to (RCPT TO) text box, type the address to identify the recipient of the email
message.
4. In the HELO text box, type text that identifies the SMTP Client to the SMTP Server.
You can enter any value here, but typically you specify the sending server’s domain name.

5. In the Message to Send (DATA command) text box, type the text to include in the test email
message.
You can enter an optional subject to make sure you do not send a message with a blank subject.

6. Click Send Message.
The response displays the result of the SMTP diagnostic probe, and includes the response for each
SMTP command:
Sending mail... <<< 220 ESMTP Postfix (2.1.0) HELO example.com <<< 250
mail.example.com MAIL FROM:user1@example.com
<<< 250 Ok
RCPT TO:user2@example.com
<<< 250 Ok
DATA
<<< 354 End data with <CR><LF>.<CR><LF>sending /tmp/smtpdata.
<<< 250 Ok: queued as F130F33EA6QUIT
<<< 221 Bye
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Examine Log Files
Select Activity > Logs to access logs files for each messaging protocol (Email and HTTP). These
logs are the most important logs to monitor for message processing as they provide a detailed
description of each message that passes through the XCS device.

The start of a single message log entry begins with a “connect” message, and ends with the “disconnect”
message. To make sure that you are looking at the entries for a specific message, check the Request ID
(for web) or Message ID (for mail, for example, 7FA528120033BE34) for each log entry.
Click [+] or [-] to expand or collapse the log details for the specific Message or Request ID.
Note When there is more than one recipient for a message, only the first recipient is
included in the log for the overall message summary.

Feature Abbreviations
Many XCS features use special acronyms or abbreviations in the message logs. The following table
contains a list of the most common features and their abbreviations or alternate names that can appear
in the logs:
Item

Description

acs

Content Scanning (also known as Attachment
Content Scanning)

brightmail

Brightmail Anti-Spam

bs

Blocked Senders List

bsctr

Backscatter Detection
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Item

Description

bsn

Reputation Enabled Defense (RED) reputation

dfp

Document Fingerprinting

dk

DomainKeys

dnsbl

DNS Block List

ipr

Mail Anomalies

ocf

Objectionable Content Filter

pbmf

Pattern Filters (also known as Pattern Based
Message Filters)

spamrules

Spam Rules

spf

Sender Policy Framework

sta

Token Analysis (also known as Statistical Token
Analysis)

sw

Spam Words

ts

Trusted Senders List

ubl

URL Block List
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Troubleshoot Connection Issues
In many cases, a connection is blocked by the XCS device before the sending mail server transfers
any messages. These features can trigger a connection-level reject:
n
n
n
n
n
n
n
n

Reputation Enabled Defense
DNS Block Lists
Specific Access Patterns
Pattern Filters
Threat Prevention
URL Block Lists
Very Malformed messages
Trusted/Blocked Senders Lists

To view a history of connections to the WatchGuard XCS:
1. Select Activity > History > Connection History.
2. Set the Search Criteria to limit the search to a specific range of dates or number of days.
You can filter search results based on the actions taken on the connection and the action
source, for example, a connection refused because of a low reputation by the Reputation
Enabled Defense service.
See Connection History for more information on searching the connection history database.
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Troubleshoot Content Issues
If a message is successfully delivered to the WatchGuard XCS, it undergoes security processing
before it is delivered to its final destination. Many of the security tools used by the XCS device, for
example, Intercept Anti-Spam, Content Filtering, Anti-Virus scanning, and Attachment Control, can
reject, discard, or quarantine the message before it is delivered to the recipient. These tools can be
misconfigured which allows legitimate messages and requests to be incorrectly rejected or
quarantined. If specific messages are blocked when they should be allowed, check these items:
n
n
n
n

n
n

Is there a Specific Access Pattern, Pattern Filter, or Content rule that applies to the message?
Is the attachment type or content filtered by Attachment Control or Content Scanning?
Do any of the Intercept Anti-Spam features block the message?
Do words from the Objectionable Content Filter (OCF) or Spam Dictionaries appear in the
message?
Is the message or its attachments over the maximum size limit?
Does the user belong to a policy that blocks the message?

Message History
Every email message and web request that passes through the WatchGuard XCS generates a
database entry that records information about how it was processed, filtered, and delivered. To see
how the message was processed, you can check the message history to see the disposition of the
message. Use this information to find out which security process blocks the message, and then check
the configuration and rules to make sure that they are set properly.
To view the Message History:
1. Select Activity > History > Message History.
2. Examine the Status column for full information on how a message was processed and its final
disposition.

3. Click the message icon to view the processing details of a message.

User Guide

689

Troubleshooting

Dispositions and the final Intercept score, if any, are listed below the details table in the
Message Dispositions section.
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